Subject: RE: requirement: agent initiated session support

From: "Sharon Chisholm" <[email-masked]>
Date: Mon, 3 Apr 2006 11:38:59 -0400

hi

There is no mechanism for replay in the current draft.

Sharon

-----Original Message-----
From: Andy Bierman [mailto:[email-masked]] 
Sent: Monday, April 03, 2006 11:37 AM
To: Chisholm, Sharon [CAR:ZZ00:EXCH]
Cc: Netconf (E-mail)
Subject: Re: requirement: agent initiated session support

Sharon Chisholm wrote:
> hi
> 
> This is similar to the event replay work we have done. Our method 
> works fine without persistent subscriptions. The user creates a new 
> subscription with a timestamp that indicates the start of the replay 
> window and the other parameters it sends when it creates a normal 
> subscription.
> 
> We didn't include it in the draft since we felt it could be done later

> as an optional capability.
> 
> Is there interest in including replay in release one?

I'm interested in implementing what Phil is suggesting,
not the mechanisms in the current draft.

> Sharon

Andy

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Andy Bierman <[email-masked]>
Date: Mon, 03 Apr 2006 09:21:34 -0700

> There is no mechanism for replay in the current draft.

I meant the whole thing.
Phil is suggesting an endless-RPC if the <realtime/>
parameter is included.  IMO this is a nice simple approach.
The manager connects and gets new and 'old-since-time-X'
in the same RPC.  It can fill the data gap and keep going
in 1 easy step.

Andy