Subject: Confirmation of configuration

From: Balazs Lengyel <[email-masked]>
Date: Wed, 31 May 2006 17:21:54 +0200

Hello,
During configuration if I do something risky (like restarting the node or switching of an 
interface I might get a back a question do I really want to do this? A sort of confirmation.

1) TO NODE: configure-interface
2) FROM NODE: Confirm action
3) TO NODE: yes do it
4) FROM NODE: OK, done

Is it our aim to support such a configuration flow in netconf or is this the only for 
CLI/GUI interfaces?

Balazs

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Andy Bierman <[email-masked]>
Date: Wed, 31 May 2006 08:43:42 -0700

Balazs Lengyel wrote:
> Hello,
> During configuration if I do something risky (like restarting the node 
> or switching of an interface I might get a back a question do I really 
> want to do this? A sort of confirmation.
> 
> Is it our aim to support such a configuration flow in netconf or is this 
> the only for CLI/GUI interfaces?

No.
This is what we call "screen-scraping".
NETCONF is intended to replace screen-scraping.
You could do this with a state variable
and 2 RPC calls, if you really thought it was important.

> Balazs

Andy

---

From: "Margaret Wasserman" <[email-masked]>
Date: Wed, 31 May 2006 12:21:59 -0400

You could also do this in your end-user application as a front-end to
NETCONF.  If, for instance, your application presents a "delete interface"
button to the end-user, it could confirm that the end-user really wants to
delete the interface before sending the corresponding command via NETCONF.  

On the other hand, if your application doesn't have a user interface and is
running unattended, there is no reason to ask for a confirmation, as the
unattended program will have no one to ask and no reason to change its mind.

Margaret

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Andy Bierman
> Sent: Wednesday, May 31, 2006 11:44 AM
> To: Balazs Lengyel
> Cc: Netconf (E-mail)
> Subject: Re: Confirmation of configuration
> 
> Balazs Lengyel wrote:
> > Hello,
> > Is it our aim to support such a configuration flow in netconf or is 
> > this the only for CLI/GUI interfaces?
> 
> No.
> to unsubscribe send a message to [email-masked] 
> with the word 'unsubscribe' in a single line as the message text body.