Subject: Scalability as requirement

From: Balazs Lengyel <[email-masked]>
Date: Thu, 18 May 2006 13:45:18 +0200

Jurgen,
Could you please add scalability to your requirements page. After the discussions I 
believe we require that the protocol should allow 30.000 to 100.000 nodes to send 
notifications to a management station and the station should be able to order the 100.000 
nodes to send the notifications.
Balazs

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 18 May 2006 15:19:09 +0200

On Thu, May 18, 2006 at 01:45:18PM +0200, Balazs Lengyel wrote:
> Jurgen,
> Could you please add scalability to your requirements page. After the 
> discussions I believe we require that the protocol should allow 30.000 to 
> 100.000 nodes to send notifications to a management station and the station 
> should be able to order the 100.000 nodes to send the notifications.

Added to the list.

/js

-- 
Juergen Schoenwaelder		    International University Bremen
<http://www.eecs.iu-bremen.de/>	    P.O. Box 750 561, 28725 Bremen, Germany

---

From: Andy Bierman <[email-masked]>
Date: Thu, 18 May 2006 06:48:32 -0700

>> should be able to order the 100.000 nodes to send the notifications.

This is a really poorly worded requirement.
A million nodes could send notifications.
The protocol does not actually constrain the number
of nodes that can participate in netconf sessions.
Nor would it.

Operational scalability is hard to quantify, and it
of course depends on your acceptable failure response time
and security requirements.  I don't want to specify maximum
event-to-delivery latency times in the netconf standard.
I don't know how to write this requirement in a meaningful
and acceptable way.

IMO, Callhome could sufficiently address the scalability problem
wrt/ manager-subscribe based delays, if it was fully specified.
The relative overhead of establishing a netconf session to send
secure notifications is debatable I guess, about the same any
way you do it (if you decide up front you want to use sessions).

> /js

Andy