Subject: RE: Verbiage

From: "Sharon Chisholm" <[email-masked]>
Date: Tue, 16 May 2006 15:15:48 -0400

hi

Note that named profiles are not filters in the latest draft. While in
earlier drafts they were holders for proprietary filtering methods, now
they are only a mechanism to save a favourite set of filters. So,
really, there is only one mechanisms.

Sharon

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Balazs Lengyel
Sent: Tuesday, May 16, 2006 8:30 AM
To: Netconf (E-mail)
Subject: Re: Verbiage

Hello,
I am more disturbed by the fact that we have two filter mechanism -
named profile and 
filter in the draft. These seem really to do the same thing one using a
data model while 
the other trying to conform to a verb type solution.

Please merge the two! You could kill the filter or say that it updates
the stored 
filter/named profile.

Myself I am more on the data model side but can we settle for Andy's
compromise: Set up what to do using a data model then start/stop
subscription using a very simple 
verb/operation?

regards Balazs

Sharon Chisholm wrote:
> hi
> 
> <Andy>
> 
> I think you missed a key point in this thread.
> New RPCs are appropriate when they don't
> replicate the existing RPCs.  Several WG members
> are not convinced at all that subscription data
> is anything other than config data.
> 
> </Andy>
> 
> No, I don't think I did.  I thought people raised some very good 
> points to consider when deciding whether or not to add new verbs. Just

> whether existing verbs and a chunk of data model *could* be used 
> obviously isn't the only criteria or we wouldn't have a made some of 
> the decisions we made in the base protocol.
> 
> Usability by the client and ease of integration into the network 
> itself need to also be considered.
> 
> Sharon
> 
> --
> to unsubscribe send a message to [email-masked] with the

> word 'unsubscribe' in a single line as the message text body.
> archive: <http://ops.ietf.org/lists/netconf/>

-- 
Balazs Lengyel                       Ericsson Hungary Ltd.
TSP System Manager
ECN: 831 7320                        Fax: +36 1 4377792
Tel: +36-1-437-7320     email: [email-masked]

--
to unsubscribe send a message to [email-masked] with the
word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Balazs Lengyel <[email-masked]>
Date: Wed, 17 May 2006 09:55:45 +0200

Hello,
But if we can point out a stored filter then why do we need to define a second filter 
inline in the subscription/modify-subscription request ? Why don't we just define the 
filter referenced by the named profile and use it in the subscription request ? It would 
make the world simpler. Do we really so strongly need filters that are alive only for a 
session that we need to complicate the operation ?
Balazs