Subject: RE: manager subscription model for notifications: usage survey

From: "Sharon Chisholm" <[email-masked]>
Date: Mon, 1 May 2006 08:57:08 -0400

<Andy> 
> By the way, the update, which was sent to the Internet Draft folks but

> hasn't shown up yet, does include an optional capability with 
> different behaviour meant to handle the call-home cases. I don't 
> expect this to be the method generally used since the normal 
> subscription is much more predictable and reliable, but as people have

> indicated there are cases when you need to reverse roles.

There is a simple established way to do this,
without adding massive amounts of complexity.
Just define a notification target data model and use the existing RPC
operations like edit-config to fill it in.

</Andy>

That's the easy part. The complexity is around managing your
subscriptions (determining if they already exist, pushing them out to
all the devices you are managing and trying to determining if things are
running as expected), but as people have said, in some use cases the
tradeoffs for the call-home approach make sense. They don't want the
simplicity of long-lived connections that self-clean in these cases.

Sharon

> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Andy Bierman
> Sent: Friday, April 28, 2006 10:21 AM
> To: Netconf (E-mail)
> Subject: manager subscription model for notifications: usage survey
> 
> 
> Hi,
> 
> I am having a hard time understanding how the
> peer-to-peer manager subscribe model defined
> in the notifications draft fits with syslog and
> SNMP notifications already in use.
> 
> Who is using this model today?
> What products work this way today?
> 
> IMO, this is much different than the Tibco model.
> That is a publish/subscribe model with a virtual bus.
> The netconf proposal uses multiple point-to-point manager-initiated 
> subscriptions instead.
> 
> I think it would be wise to understand how the entire
> managed system is going to work when netconf notifications
> are added to the mix.   How will a network of 100 - 10000 devics
> behave in various common failure scenarios?
> 
> If this subscribe-only model is not being used in a meaningful way in 
> the real world, then I don't understand why we need to standardize it 
> at all.
> 
> 
> Andy
> 
> 
> 
> 
> --
> to unsubscribe send a message to [email-masked] with the

> word 'unsubscribe' in a single line as the message text body.
> archive: <http://ops.ietf.org/lists/netconf/>
> 
> 
> --
> to unsubscribe send a message to [email-masked] with the

> word 'unsubscribe' in a single line as the message text body.
> archive: <http://ops.ietf.org/lists/netconf/>
> 
> 

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Balazs Lengyel <[email-masked]>
Date: Tue, 02 May 2006 09:12:15 +0200

Hi
Could you please give some examples when does this happen that "the interest of the 
manager changes".
Balazs

Sharon Chisholm wrote:
> The manager starts to manage
> a network element and then subscribes for the information that is of
> interest to it. If its interests change, it modifies the subscription.

---

From: "Sharon Chisholm" <[email-masked]>
Date: Wed, 3 May 2006 07:18:30 -0400

hi

One example would be that in order to debug a particular problem it
wants to start receiving notifications that before were considered not
sufficiently interesting.  Or alternatively, if the subscribing to a
particular class of events proves to be more noisy then expected, the
manager may wish to stop subscribing to this class of events.

Sharon

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Balazs Lengyel
Sent: Tuesday, May 02, 2006 3:12 AM
To: Netconf (E-mail)
Subject: Re: manager subscription model for notifications: usage survey

Hi
Could you please give some examples when does this happen that "the
interest of the 
manager changes".
Balazs