Subject: Netconf WG IETF 66 and Montreal Interim Meeting Agenda (draft)

From: Andy Bierman <[email-masked]>
Date: Tue, 30 May 2006 12:40:14 -0700

Hi,

Here is the first draft of the interim agenda for comment:
[resend]

---------------

The NETCONF WG will meet at IETF #66, and the Montreal interim meeting
following, to work on NETCONF Notifications work item.

- Interim Meeting Location
   IETF Headquarter Hotel: Delta Centre-Ville
   777 University Street
   Montreal, Quebec, Canada, H3C 3Z7
   Hotel WEB site:
   http://www.deltahotels.com/hotels/hotels.php?hotelId=35

- Interim Meeting Times
   Friday, July 14, 2006 (1:30 PM - 6:00 PM)
   Saturday, July 15, 2006 (9:00 AM - 6:00 PM)

- Required Reading
   NETCONF Event Notifications

http://www.ietf.org/internet-drafts/draft-ietf-netconf-notification-01.txt

The following is a proposed issues list.  The discussion sequence at the
meetings will generally follow this list, but issues that are inter-related
may affect the order.  The official WG meeting on July 14, 9:00 - 11:30 AM
will be used to discuss and prioritize functional requirements.

- Functional Requirements
   - determine WG consensus on need and priority of Juergen's list
     http://www.eecs.iu-bremen.de/wiki/index.php/Netconf_notifications

- Architecture

   - role of notifications within netconf
   - relationship to syslog and snmp notifications
   - scaling issues
   - security issues (session vs. signed msg, etc.)
   - standard RPC methods vs. new RPC methods
   - agent resource vs. NMS resource issues

- Use within Sessions

   - endless RPC
   - mixed-mode (rpc operations and notifications)
   - single vs. multiple subscriptions within a single session

- Transport Specific Support

   - use of channels (ssh, beep, what about soap?)
   - callhome support for agent initiated sessions

- Agent Notification Configuration and Control Mechanism

   - config-data vs. subscription-data
   - RPCs used to configure and control agent notification generation

- Notification Event Classes

   - WG consensus on specific list
   - Guidelines for selecting classifications

- Notification Filtering

   - Configuration mechanism(s)
   - Agent processing model

- Notification Header Content

   - Syntax and semantics of data included in all notifications

- Standard Notification Content

   - WG consensus on 0 or more fully-specified standard notifications
   - Full syntax and semantics of each standard notification

- Read-only (monitoring) data for agent notification activity

- Access Control Issues

- Data Model and XSD Issues

   - Data model design
   - XSD correctness
   - Need for 'min-access' and 'max-access'

- Documentation Issues

   - Terminology
   - Inclusion of non-normative text
   - Document section order
   - Document clarity
   - Choice of examples
   - Example correctness (need to validate against the XSD)

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Balazs Lengyel <[email-masked]>
Date: Wed, 31 May 2006 16:24:58 +0200

I thought (I hoped) that Sharon aims to update the draft before the meeting.
Balazs

-- 
Balazs Lengyel                       Ericsson Hungary Ltd.
TSP System Manager
ECN: 831 7320                        Fax: +36 1 4377792
Tel: +36-1-437-7320     email: [email-masked]

---

From: Andy Bierman <[email-masked]>
Date: Wed, 31 May 2006 07:35:42 -0700

> I thought (I hoped) that Sharon aims to update the draft before the 

Good idea.
We will try to reach consensus on some issues
so there are edits to make.  The authors can
always do bug-fixes as they find them as well.

> Balazs

Andy

---

From: "Sharon Chisholm" <[email-masked]>
Date: Wed, 31 May 2006 11:01:32 -0400

hi

I think we have already identified a number of smaller changes and
corrections. I plan on proposing a modification to Balazs' event class
text which I think we can all agree to incorporate as well. If we get
consensus on other changes, that would be great. 

Should we aim for mid-June?

Sharon

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Andy Bierman
Sent: Wednesday, May 31, 2006 10:36 AM
To: Balazs Lengyel
Cc: Netconf (E-mail)
Subject: Re: Netconf WG IETF 66 and Montreal Interim Meeting Agenda
(draft)

Good idea.

Andy

> 
> Andy Bierman wrote:
>> Hi,
>>
>> Here is the first draft of the interim agenda for comment: [resend]
>>
>> ---------------
>>
>> The NETCONF WG will meet at IETF #66, and the Montreal interim 
>> meeting following, to work on NETCONF Notifications work item.
>>
>> The following is a proposed issues list.  The discussion sequence at 
>> the meetings will generally follow this list, but issues that are 
>> inter-related may affect the order.  The official WG meeting on July 
>> 14, 9:00 - 11:30 AM

---

From: Andy Bierman <[email-masked]>
Date: Wed, 31 May 2006 08:31:44 -0700

> consensus on other changes, that would be great. 

Good.
I was hoping we could finish up event classes before the meeting.
The other issue that seems to be finishing up is the use of existing
configuration RPCs instead of new subscription RPCs for conveying
notification generation parameters.

> Should we aim for mid-June?

Mid-June-ish.
How about 9:00 AM EDT, June 19, 2006?

Andy