Subject: Event type

From: Balazs Lengyel <[email-masked]>
Date: Fri, 19 May 2006 16:19:12 +0200

Hello,
In SNMP every trap/notification has a Object Identifier which can be used as a detailed 
event type. As far as I know this is quite often used as a branching condition in manager 
programs. I feel we are missing this in the notification draft. As I see this bit of 
information quite important, I would make it a mandatory part of every notification.
I propose a short textual identifier for the event type.
Balazs

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Andy Bierman <[email-masked]>
Date: Fri, 19 May 2006 10:56:30 -0700

Balazs Lengyel wrote:
> Hello,
> In SNMP every trap/notification has a Object Identifier which can be 
> used as a detailed event type. As far as I know this is quite often used 
> as a branching condition in manager programs. I feel we are missing this 
> in the notification draft. As I see this bit of information quite 
> important, I would make it a mandatory part of every notification.

I agree.

I think a QName is used for this purpose.
We need <element name="notification-id" type="xs:QName"/>
in the <notification> element.

The owner of the namespace must manage notification
name uniqueness, and notifications cannot be nested
like data types (makes no sense).  This is the same as SNMP.

> Balazs

Andy