Subject: Re: Event classes

From: "Randy Presuhn" <[email-masked]>
Date: Fri, 2 Jun 2006 13:11:18 -0700

Hi -

> From: "Balazs Lengyel" <[email-masked]>
> To: "Andy Bierman" <[email-masked]>
> Cc: "Netconf (E-mail)" <[email-masked]>
> Sent: Monday, May 29, 2006 1:34 AM
> Subject: Re: Event classes
...
> State is a good choice but there is a more general issue hidden here.
> 
> State events can also represent a fault. E.g. For threshold-crossing: memory-usage more 
> then 20% is just a state event. Memory usage more then 99.9% is a critical fault/alarm as 
> at this point we can easily have a crash. Where do we put such events? Shall we
> - allow such events to jump from state to fault depending on the seriousness of the situation
> - allow some notifications to belong to more then one event class
> - leave it to the application developer
...

I think that syntactic needs, rather than semantic distinctions,
will be most useful in characterizing event classes at the level
of a data model.   Decisions about "seriousness" are in the
eye of the beholder, and may depend on the context in which
they occur.

Randy

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: "McDonald, Ira" <[email-masked]>
Date: Sat, 3 Jun 2006 09:28:44 -0700

Hi,

It's important to separate atomic event names from their
associated event metadata (e.g., severity of informational,
warning, critical) - one event, multiple contexts.

FWIW, the Printer MIB (RFC 1759/3805) defined 'prtAlertCode'
(of type 'PrtAlertCodeTC') with the following event metadata:

prtAlertSeverityLevel       PrtAlertSeverityLevelTC,
prtAlertTrainingLevel       PrtAlertTrainingLevelTC,
prtAlertGroup               PrtAlertGroupTC,
prtAlertGroupIndex          Integer32,
prtAlertLocation            Integer32,
prtAlertDescription         PrtLocalizedDescriptionStringTC,
prtAlertTime                TimeTicks

'prtAlertTrainingLevel' describes the necessary training to
handle the event (fieldService, trained, untrained, etc.).

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Randy Presuhn
> Sent: Friday, June 02, 2006 4:11 PM
> To: Netconf (E-mail)
> No virus found in this incoming message.
> Checked by AVG Free Edition.
> Version: 7.1.394 / Virus Database: 268.8.1/355 - Release 
> Date: 6/2/2006
>  
> 

-- 
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.394 / Virus Database: 268.8.1/355 - Release Date: 6/2/2006