Subject: Re: our first CLR

From: Balazs Lengyel <[email-masked]>
Date: Wed, 05 Jul 2006 20:14:52 +0200

I am fighting to be able to send late replies to operations. The most likely method to do 
this will be a notification that refers to the original operation. To be able to refer to 
it we need the sessionId and the messageId. So Ericsson is in an immediate need of the 
messageId.
Balazs

Andy Bierman wrote:
> Hi,
> 
> Didn't anybody notice that the protocol spec makes a big
> deal about a mandatory message-id (and I made a big deal
> about limiting its length), but it isn't used anywhere
> in the document in a normative manner?
> 
> Nope.  We took out the only operation that depended on
> the message-id attribute a couple years ago.
> The agent totally ignores this attribute except to
> check if needs to generate an error if it is missing.
> 
> If that isn't the essence of a Crappy Little Rule,
> I don't know what is.  (I know, we may need the
> message-id someday, but not now.)
> 
> 
> Andy
> 
> 
> -- 
> to unsubscribe send a message to [email-masked] with
> the word 'unsubscribe' in a single line as the message text body.
> archive: <http://ops.ietf.org/lists/netconf/>

-- 
Balazs Lengyel                       Ericsson Hungary Ltd.
TSP System Manager
ECN: 831 7320                        Fax: +36 1 4377792
Tel: +36-1-437-7320     email: [email-masked]

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Phil Shafer <[email-masked]>
Date: Wed, 05 Jul 2006 15:29:23 -0400

The "echo all attributes back to the client" rule turns this from
a CLR into an SLR (simple little rule) with a hundred and one uses.

We've used it to record RPC name, hostname, timestamps, and other
information so that any information we need to handle the rpc-reply
is contained inside the rpc-reply.  I can hand the rpc-reply to a
transformation that uses this information without having to feed
it in out of band.

Thanks,
 Phil

---

From: Andy Bierman <[email-masked]>
Date: Wed, 05 Jul 2006 12:30:26 -0700

Balazs Lengyel wrote:
> I am fighting to be able to send late replies to operations. The most 
> likely method to do this will be a notification that refers to the 
> original operation. To be able to refer to it we need the sessionId and 
> the messageId. So Ericsson is in an immediate need of the messageId.

But you can put any attribute you want in the <rpc> header and it
will get returned to you.  There's no point in the agent blindly
rejecting a PDU just because this 'message-id' attribute is missing.

Andy

---

From: Andy Bierman <[email-masked]>
Date: Wed, 05 Jul 2006 12:33:07 -0700

> transformation that uses this information without having to feed

You missed my point.
Echoing all attributes is fine -- good stuff.

Making a special check that the manager included an
attribute named 'message-id', and rejecting the PDU
if not, is the CLR.

Andy

---

From: Phil Shafer <[email-masked]>
Date: Wed, 05 Jul 2006 15:48:06 -0400

>You missed my point.

Nope, I'm completely agreeing with you.  Nuke the CLR and just
go with the SLR, which completely covers it.

Thanks,
 Phil