Subject: RE: sylsog in NETCONF notifications

From: "Hector Trevino \(htrevino\)" <[email-masked]>
Date: Thu, 6 Jul 2006 09:43:23 -0700

> Rainer Gerhards writes: 
> WG,
> 
> I suggest that the mapping of syslog to netconf notifications 
> as well as the "syslogTunnel" event type be left out of the 
> netconf notifications I-D. The reason is that I think the 
> syslog community should provide a data model for syslog 
> notifications as well as a mapping. The same should probably 
> be done for SMTP traps.

HT: I tend to disagree with this. First, the "syslogTunnel" is just a
way to 
    indicate that the payload of the NETCONF notification is a syslog
PDU. Why would this be the
    responsibility of the syslog WG/community. Second, the mapping was
an attempt to "re-use" existing
    syslog field definitions.  
> 
> Having syslog mappings in a basic netconf document forces the 
> netconf document to be changed/obsoleted whenever there is 
> change on the syslog side. I think this dependency should be avoided.

HT: I don't think this is necessarily true given the purpose of the
"mappings" but we'll look at it. 

> 
> There is some growing interest in the syslog community to 
> define event data models. This effort could play nicely 
> together with netconf.

HT: IMO this work is necessary but should be done independently of
syslog. Syslog can be a delivery mechanism but there is no reason for
syslog to be the only one. 
> 
> Rainer
> 
> --
> to unsubscribe send a message to [email-masked] 
> with the word 'unsubscribe' in a single line as the message text body.
> archive: <http://ops.ietf.org/lists/netconf/>
> 

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Martin Bjorklund <[email-masked]>
Date: Thu, 06 Jul 2006 21:45:06 +0200 (CEST)

"Hector Trevino (htrevino)" <[email-masked]> wrote:
> HT: I tend to disagree with this. First, the "syslogTunnel" is just
> a way to indicate that the payload of the NETCONF notification is a
> syslog PDU.

The current draft specifies in B.1 a mapping from the syslog fields to
something called NETCONF event fields.  But these event fields are not
defined anywhere.  Is this part still correct, or are you saying that
the syslog message is tunnelled "as-is"?

/martin