Subject: Re: What about the OAM in OAM&P

From: Andy Bierman <[email-masked]>
Date: Wed, 05 Jul 2006 13:44:32 -0700

Hare, Michael wrote:
> Anyone explore the DMTF (http://www.dmtf.org/home)?
> 
> It was our opinion they were making all the same mistakes the IETF made with the MIBs, i.e. we would need to restructure our data model to fit into the DMTF framework.
> 
> NETCONF is allowing us to keep our internal data model intact and while the payloads may be less standard across vendors, we will be able to implement the embedded much quicker since we can reuse much of what we had before.
> 

This is fine to get started, but in order to have
a workable standards based solution, there needs to be
a transition to standard data models somehow.

IMO NETCONF is already on the right track by recognizing
that an NE device has native NV-storage behavior,
and an "advertised capabilities" extensibility mechanism.

I agree with Phil that a real solution is not going to
be able to ignore the native interface, but instead will need
to use it effectively to "fill the gaps".

(I have been researching this topic for a few years now.
This is what I call the "near model".  Mapping the near model
to the real model semi-automatically is non-trivial.)

> - m

Andy

> 
> -----Original Message-----
> From: Phil Shafer [mailto:[email-masked]]
> Sent: Wednesday, July 05, 2006 2:37 PM
> To: Andy Bierman
> Cc: Hare, Michael; Netconf Mailing List (E-mail)
> Subject: Re: What about the OAM in OAM&P 
> 
> 
> Andy Bierman writes:
>> Our focus is standards based configuration, a subject some
>> vendors seem to want to leave as "TBD".
> 
> I'm not in the TBD crowd, I just don't think this is a simple
> problem.  You can't just define a simple schema and force all
> the world onto it.  If this worked, folks would have rewritten
> their implementations to follow MIBs.
> 
>> Unfortunately, the current process and mindset for IETF data models (MIBs)
>> is never going to work for configuration.
> 
> What we need is an understanding that it's not a simple problem and
> a plan to simplify it, to allow for incompatibilities, conversions,
> etc without losing the ability to cover the 50-80% of use cases
> that are the most beneficial.
> 
> Thanks,
>  Phil
> 
> --
> to unsubscribe send a message to [email-masked] with
> the word 'unsubscribe' in a single line as the message text body.
> archive: <http://ops.ietf.org/lists/netconf/>
> 
> 

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: "Hare, Michael" <[email-masked]>
Date: Wed, 5 Jul 2006 15:04:30 -0500

- m

-----Original Message-----
From: Phil Shafer [mailto:[email-masked]]
Sent: Wednesday, July 05, 2006 2:37 PM
To: Andy Bierman
Cc: Hare, Michael; Netconf Mailing List (E-mail)
Subject: Re: What about the OAM in OAM&P 

Thanks,
 Phil