Subject: Re: What about the OAM in OAM&P

From: Andy Bierman <[email-masked]>
Date: Mon, 03 Jul 2006 09:29:21 -0700

Hare, Michael wrote:
> Hi,
> 
> Please forgive me if this was covered.
> 
> Netconf is doing a good job of covereing the 'P' and maybe some of the 
> 'A' and 'M', but what about the 'O'?
> 
> Things like:
> 
> Software Download (not really a <copy-config>, maybe just <copy>?)
> Operating and Releasing Loopbacks/Test Signals (not really editing the 
> configuration, new verb-set?)
> Initializing PM Registers (again, not really editing the configuration)
> Protection Switching
> 
> 
> This may be outside the Netconf charter, but it seems the rpc framework 
> being used for netconf could be re-used to the other parts of network 
> management.

My position on NETCONF extensions is clear:

Vendors should develop extensions on their own, in running code,
and get some operators to use them.  When you have some
deployment experience with the extension, then propose it
as a standard.  In my experience, if a "feature" is important
enough, vendors will provide it to customers, regardless of any standard.

<config-rant>

Notifications got grandfathered in because they were in the original charter.
After that, we will be working on standards based configuration
or nothing at all.

Our focus is standards based configuration, a subject some
vendors seem to want to leave as "TBD".  Anybody who understands
embedded agent design knows why --  it is a non-trivial matter
to support multiple incompatible configuration APIs
(e.g., proprietary and standard), unlike multiple incompatible
monitoring APIs.  The problem is not "special RPC" vs. "data model" at all.

Unfortunately, the current process and mindset for IETF data models (MIBs)
is never going to work for configuration.  Somebody is
going to have to figure out how to remove 1 of the 2 adjectives
('multiple' or 'incompatible').  Maybe this is a topic for the NMRG.

</config-rant>

> 
> 
> ---------------------------------
> Michael Hare
> NMI Engineering

Andy

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Phil Shafer <[email-masked]>
Date: Wed, 05 Jul 2006 15:36:43 -0400

Andy Bierman writes:
>vendors seem to want to leave as "TBD".

I'm not in the TBD crowd, I just don't think this is a simple
problem.  You can't just define a simple schema and force all
the world onto it.  If this worked, folks would have rewritten
their implementations to follow MIBs.

>is never going to work for configuration.

What we need is an understanding that it's not a simple problem and
a plan to simplify it, to allow for incompatibilities, conversions,
etc without losing the ability to cover the 50-80% of use cases
that are the most beneficial.

Thanks,
 Phil