Subject: RE: Relax NG use in RAI

From: "McDonald, Ira" <[email-masked]>
Date: Fri, 4 Aug 2006 10:10:49 -0700

Hi folks,

In support of the proposal below to recommend Relax NG as
preferred RAI schema language at present, note the following
quote from the latest W3C XHTML 2.0 working draft in the
'Status of This Document' section:

  "This version includes an early implementation of XHTML 2.0
  in RELAX NG [RELAXNG [p.247] ], but does not include the 
  implementations in DTD or XML Schema form.  Those will be 
  included in subsequent versions, once the content of this 
  language stabilizes."

This working draft is posted at:

  http://www.w3.org/TR/2006/WD-xhtml2-20060726

Notice in particular that the W3C HTML WG is using Relax NG
until their specification content stabilizes.  This approach
coheres well with rapidly evolving IETF specifications.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Romascanu, Dan (Dan)
> Sent: Friday, August 04, 2006 3:17 AM
> To: Netconf Data Model Discussion; Netconf Mailing List (E-mail)
> Cc: Cullen Jennings; Lisa Dusseault
> Subject: FW: Relax NG use in RAI
> 
> 
>  
> I believe that this may be of interest for the Netconf and 
> Netmod folks.
> 
> 
> Dan
> 
> 
>  
> 
> -----Original Message-----
> From: Cullen Jennings [mailto:[email-masked]] 
> Sent: Thursday, August 03, 2006 9:18 PM
> To: Lisa Dusseault; XML Directorate; Jon Peterson
> Cc: IESG IESG; Henning Schulzrinne
> Subject: Relax NG use in RAI
> 
> 
> Hi all - I'm looking for some advice here.
> 
> The RAI area uses XML all over the place and every time we 
> get to have a
> discussion about DTD/Scheme/Relax NG. More than one person 
> has suggested
> we could make life easier and stop the same discussion from happening
> over and over again. I am considering sending an email that says
> something like the following and I would like to get some input on how
> to word this or if I should send it at all. Thanks, Cullen
> 
> In the RAI area, when working with XML, many folks have come to the  
> conclusion that Relax NG is currently the preferred schema 
> language.   
> Authors are encouraged to use Relax NG unless there is a good 
> reason to
> use something else. Ease of reuse of previous work could 
> certainly be a
> good reason to choose something else. In the future,  other things may
> come along and this is not meant to block usage of better 
> tools when and
> where they are more appropriate.
> 
> 
> 
> 
> --
> to unsubscribe send a message to [email-masked] with
> the word 'unsubscribe' in a single line as the message text body.
> archive: <http://ops.ietf.org/lists/netconf/>
> 

-- 
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.394 / Virus Database: 268.10.5/407 - Release Date: 8/3/2006

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: "Joel M. Halpern" <[email-masked]>
Date: Fri, 04 Aug 2006 13:18:33 -0400

I don't object to letting working groups try using relaxNG.  It 
appears to have a number of useful properties.
However, given the weak tool support available, as compared with XML 
Schema, I would be reluctant to see us require working groups to work that way.
I realize that this means that for now each working group has to have 
the debate, but I do not see a practical alternative.

Yours,
Joel M. Halpern

---

From: Andy Bierman <[email-masked]>
Date: Fri, 04 Aug 2006 15:23:14 -0700

Joel M. Halpern wrote:
> I don't object to letting working groups try using relaxNG.  It appears 
> to have a number of useful properties.

This has been the rationale all along,
and I'm not trying to go against it, but
RelaxNG can be converted to XSD with free tools.

IMO, none of the "XML languages" -- even RelaxNG Compact -- has
the right mix of data modeling constructs and user-friendliness.
SML is even harder to read than XSD -- a step backward in that
dept., but a step forward in others.

A workable solution is probably going to mean a powerful new
DM language that has nested indexed tables and other powerful
DM mechanisms, but is super easy to read and write by humans.
This high level language can then be automatically translated
to XSD using free tools. RelaxNG-NG.  (But I call it NCX.)

> Joel M. Halpern

Andy