Subject: RE: I-D ACTION:draft-kulkarni-netconf-subagent-prot-00.txt

From: "Romascanu, Dan \(Dan\)" <[email-masked]>
Date: Fri, 6 Oct 2006 13:56:00 +0200

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Andy Bierman
> Sent: Thursday, October 05, 2006 9:25 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: I-D ACTION:draft-kulkarni-netconf-subagent-prot-00.txt
> 
> [email-masked] wrote:
> > Thanks for all the comments on the draft.
> > 
> > I note following problems that need to be updated in the draft:
> > 
> > - problems with edit-config operation esp like locking mechanisms, 
> > error-options, confirmed-commit etc
> > 
> > - complexities in Xpath filtering
> > 
> > - capability variations between agents
> > 
> > - data model sharing between sub-agent and master-agent
> > 
> > - dealing with vendor specific operations and extra 
> parameters in the 
> > standard operations
> > 
> > - passing on security identity to sub-agents
> > 
> > I believe there will be cases for master agent-subagent 
> > implementation, because in a multi-vendor unit with FRUs 
> coming from 
> > various vendors or various business units with in a organisation, 
> > using a standard protocol is the only way for the 
> controller card to interact with the line cards.
> > 
> 
> I think it would be a good idea (if you do update the draft) 
> to start another mailing list for discussion of this topic.
> I suggest asking the AD for a "pre-BOF" mailing list for this purpose.
> 

It would be good indeed to let the netconf list focus on discussions
about or closely related to the netconf WG chartered items. If there is
a demand we can create a separate list for proposals on possible
extensions of netconf. Note that a list (netmod) for data modeling
issues already exists. 

Dan

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Andy Bierman <[email-masked]>
Date: Fri, 06 Oct 2006 06:53:19 -0700

>...

I am sorry for not politely suggesting from the start that
discussion of non-chartered work items be taken to a different
mailing list.

So to be clear, this mailing list is only for discussion of issues
related to WG documents or the NETCONF Notifications work item.

> Dan

Andy