Subject: RE: I-D ACTION:draft-kulkarni-netconf-subagent-prot-00.txt

From: <[email-masked]>
Date: Fri, 6 Oct 2006 00:41:02 +0530

Thanks for all the comments on the draft.

I note following problems that need to be updated in the draft:

- problems with edit-config operation esp like locking mechanisms, error-options, confirmed-commit etc 

- complexities in Xpath filtering

- capability variations between agents

- data model sharing between sub-agent and master-agent

- dealing with vendor specific operations and extra parameters in the standard operations

- passing on security identity to sub-agents

I believe there will be cases for master agent-subagent implementation, because in a multi-vendor unit with FRUs coming from various vendors or various business units with in a organisation, using a standard protocol is the only way for the controller card to interact with the line cards.

Regards

Jayaprakash

-----Original Message-----

From: [email-masked] [mailto:[email-masked] <mailto:[email-masked]> ] On Behalf Of ext Romascanu, Dan (Dan)

Sent: Tuesday, 03 October, 2006 05:40

To: [email-masked]

Subject: FW: I-D ACTION:draft-kulkarni-netconf-subagent-prot-00.txt 

In case some of you are not subscribed to i-d-announce. 

Dan

-----Original Message-----

From: [email-masked] [mailto:[email-masked] <mailto:[email-masked]> ]

Sent: Monday, October 02, 2006 4:50 PM

To: [email-masked]

Subject: I-D ACTION:draft-kulkarni-netconf-subagent-prot-00.txt 

A New Internet-Draft is available from the on-line Internet-Drafts directories.

Title : NETCONF Master-agent Sub-agent Communication

Protocol

Author(s) : J. Kulkarni

Filename : draft-kulkarni-netconf-subagent-prot-00.txt

Pages : 16

Date : 2006-10-2

This memo contains a mechanism by which NETCONF server and client can extended to operate in a master-agent sub-agent scheme. It extends the base NETCONF protocol with additional NETCONF operations, describes the protocol for this interaction and provides error messages exchanged during this interaction.

A URL for this Internet-Draft is:

http://www.ietf.org/internet-drafts/draft-kulkarni-netconf-subagent-prot <http://www.ietf.org/internet-drafts/draft-kulkarni-netconf-subagent-prot> 

-00.txt

To remove yourself from the I-D Announcement list, send a message to [email-masked] with the word unsubscribe in the body of the message. 

You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce <https://www1.ietf.org/mailman/listinfo/I-D-announce> 

to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the username "anonymous" and a password of your e-mail address. After logging in, type "cd internet-drafts" and then "get draft-kulkarni-netconf-subagent-prot-00.txt".

A list of Internet-Drafts directories can be found in http://www.ietf.org/shadow.html <http://www.ietf.org/shadow.html>  or ftp://ftp.ietf.org/ietf/1shadow-sites.txt <ftp://ftp.ietf.org/ietf/1shadow-sites.txt> 

Internet-Drafts can also be obtained by e-mail.

Send a message to:

[email-masked].

In the body type:

"FILE

/internet-drafts/draft-kulkarni-netconf-subagent-prot-00.txt".

NOTE: The mail server at ietf.org can return the document in

MIME-encoded form by using the "mpack" utility. To use this

feature, insert the command "ENCODING mime" before the "FILE"

command. To decode the response(s), you will need "munpack" or

a MIME-compliant mail reader. Different MIME-compliant mail readers

exhibit different behavior, especially when dealing with

"multipart" MIME messages (i.e. documents which have been split

up into multiple messages), so check your local documentation on

how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader implementation to automatically retrieve the ASCII version of the Internet-Draft.

---

From: Andy Bierman <[email-masked]>
Date: Thu, 05 Oct 2006 12:24:53 -0700

[email-masked] wrote:
> I believe there will be cases for master agent-subagent implementation, 
> because in a multi-vendor unit with FRUs coming from various vendors or 
> various business units with in a organisation, using a standard protocol 
> is the only way for the controller card to interact with the line cards.
> 

I think it would be a good idea (if you do update the draft)
to start another mailing list for discussion of this topic.
I suggest asking the AD for a "pre-BOF" mailing list for this purpose.

> Jayaprakash

Andy

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>