Subject: RE: RelaxNG examples

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Thu, 9 Nov 2006 00:00:59 +0100

And so what tools (cheap and with very small footprint I hope) do
end-users/operators have to view the XSD in a readable fashion?

Remember that we will have MANY MANY novice readers of our
data models than we have data-model developers or data-model
implemneters.

Bert

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Hideki Okita
> Sent: Wednesday, November 08, 2006 14:35
> To: [email-masked]
> Subject: Re: RelaxNG examples
> 
> 
> Andy,
> 
> 
> Thanks for your comment.
> 
> 
> As I said in the first mail, I agree that XSD is difficult
> to read "directly".
> 
> 
> Normally, to develop applications using XML data, developers
> at first construct classes and generate XSD description from
> these classes by some XSD generation tool.
> In addition, they use GUI to draw classes and XSDs.
> 
> And, when they include and validate the XML schema like the
> NETCONF protocol schema, they use integrated development
> environment (IDE). They do not read directly the XML schema.
> 
> Which expression is best for the WG documents?
> Do not we need to write drafts more visually?
> 
> 
> Best regards,
> 
> Hideki Okita
> 
> 
> 
> Andy Bierman wrote:
> > I do not rate XSD ease-of-understanding as good.
> > I rate it as awful, even unacceptable.
> > Human factors are very important here because humans, not machines,
> > need to understand the data models that are being proposed and
> > developed for standardization in IETF WGs.
> > 
> > IMO, most of the humans working in the NETCONF WG do not 
> understand XSD
> > well enough to throw down hill 5 feet.  This is a significant
> > process problem, since it is difficult to reach consensus
> > on complex technical details if very few people actually
> > understand what they are reading.
> > 
> > A comment was made at the data modeling meeting that W3C is now
> > doing development in RelaxNGc, and converting it to XSD for 
> normative
> > reference in the final standard.  How clueful.  How about if we do
> > the same thing?  We don't care if the conversion isn't pretty.
> > (Nothing about XSD is pretty, so it's a non-issue. ;-)
> > 
> > Note that there is no guarantee that people will understand
> > RelaxNG either, but most people find it more readable and writable
> > than XSD.
> > 
> > 
> > Andy
> > 
> > 
> > 
> >> So I think we choice "xsd", for operator who can make 
> netconf tools and
> >> NMS programmers.
> >> -------
> >>    Yoshifumi Atarashi
> >>
> >> Hideki Okita wrote:
> >>> From implementors' viewpoint,
> >>> RelaxNG as the schema is not a good choice.
> >>>
> >>>
> >>> Major development environments such as Java (Apache),
> >>> Visual Studio and others has no support for RelaxNG.
> >>>
> >>> Surely RelaxNG make it easy to read "directly" the NETCONF schema.
> >>> However, finally, it can decrease the development efficiency.
> >>>
> >>>
> >>> I do not object to use RelaxNG as the optional means.
> >>> However, XSD should remain as the default schema in 
> NETCONF drafts.
> >>>
> >>>
> >>> Best regards,
> >>>
> >>> Hideki Okita
> >>> Hitachi, Ltd.
> >>>
> >>>
> >>> References:
> >>>
> >>> RelaxNG Homepage:
> >>> 
http://www.oasis-open.org/committees/tc_home.php?wg_abbrev=relax-ng
>>>
>>> Apache Xerces2 Java Parser Homepage:
>>> http://xerces.apache.org/xerces2-j/
>>>
>>>
>>> Simon Leinen wrote:
>>>> On the ad-hoc meeting on data modeling issues, the possibility of
>>>> using RelaxNG for data modeling work was raised, and some people asked
>>>> for examples.  Here are some that are somehow related to network
>>>> management.
>>>>
>>>> The Compact RelaxNG Schema for NETCONF's protocol operations (at the
>>>> time) that Rob Enns posted to the list in November 2004:
>>>>
>>>>   http://ops.ietf.org/lists/netconf/netconf.2004/msg00597.html
>>>>
>>>> The (Expired) draft-schoenw-nmrg-snmp-measure-01.txt contains a
>>>> RelaxNG schema for a set of information from SNMP packet traces:
>>>>
>>>>  
>>>> http://bgp.potaroo.net/ietf/all-ids/draft-schoenw-nrmg-snmp-measure-01.txt 

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Hideki Okita <[email-masked]>
Date: Thu, 09 Nov 2006 08:51:08 +0900

Bert,

Thanks you for your comment.
It is difficult for me to list all of the XML related tools...
Following are famous tools.

- oXygen
- Eclipse Web Tools Platform (WTP)
- NetBeans Schema support function
- Visual Studio XML editor

Various W3C XML Schema related tools are listed in following page.

W3C - XML Schema - Tools
http://www.w3.org/XML/Schema#Tools

As the reference,
RelaxNG related tools:
http://relaxng.org/#editors

Regards,

Hideki Okita