Subject: RE: RelaxNG examples

From: "McDonald, Ira" <[email-masked]>
Date: Wed, 8 Nov 2006 17:50:12 -0800

Hi Bert,

I handwrite XSD for IEEE-ISTO PWG standards (and I don't like
doing it, but the graphical tools are awful bloatware IMHO).
The PWG's seriously considering following the lead of many W3C,
OASIS, and DMTF working groups and using RelaxNGc (compact)
for development and machine-generating XSD when we're done.

The readability of XSD without tools has been a major hurdle
for specification review by PWG members in recent years.
The browseability of a set of XSD schemas is a real problem.

FWIW, two free Win32 tools do nice color highlighting of XSD:

  Notepad++ (all Win32 platforms - I love this tool)
    http://notepad-plus.sourceforge.net/uk/site.htm

  XRay (all Win32 platforms - pretty smart XML editor)
    http://architag.com/xray/

Cheers,
- Ira
      
Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of Wijnen, Bert (Bert)
Sent: Wednesday, November 08, 2006 6:01 PM
To: Hideki Okita; [email-masked]
Subject: RE: RelaxNG examples

And so what tools (cheap and with very small footprint I hope) do
end-users/operators have to view the XSD in a readable fashion?

Remember that we will have MANY MANY novice readers of our
data models than we have data-model developers or data-model
implemneters.

Bert

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Hideki Okita
> Sent: Wednesday, November 08, 2006 14:35
> To: [email-masked]
> Subject: Re: RelaxNG examples
> 
> 
> Andy,
> 
> 
> Thanks for your comment.
> 
> 
> As I said in the first mail, I agree that XSD is difficult
> to read "directly".
> 
> 
> Normally, to develop applications using XML data, developers
> at first construct classes and generate XSD description from
> these classes by some XSD generation tool.
> In addition, they use GUI to draw classes and XSDs.
> 
> And, when they include and validate the XML schema like the
> NETCONF protocol schema, they use integrated development
> environment (IDE). They do not read directly the XML schema.
> 
> Which expression is best for the WG documents?
> Do not we need to write drafts more visually?
> 
> 
> Best regards,
> 
> Hideki Okita
> 
> 
> 
> Andy Bierman wrote:
> > I do not rate XSD ease-of-understanding as good.
> > I rate it as awful, even unacceptable.
> > Human factors are very important here because humans, not machines,
> > need to understand the data models that are being proposed and
> > developed for standardization in IETF WGs.
> > 
> > IMO, most of the humans working in the NETCONF WG do not 
> understand XSD
> > well enough to throw down hill 5 feet.  This is a significant
> > process problem, since it is difficult to reach consensus
> > on complex technical details if very few people actually
> > understand what they are reading.
> > 
> > A comment was made at the data modeling meeting that W3C is now
> > doing development in RelaxNGc, and converting it to XSD for 
> normative
> > reference in the final standard.  How clueful.  How about if we do
> > the same thing?  We don't care if the conversion isn't pretty.
> > (Nothing about XSD is pretty, so it's a non-issue. ;-)
> > 
> > Note that there is no guarantee that people will understand
> > RelaxNG either, but most people find it more readable and writable
> > than XSD.
> > 
> > 
> > Andy
> > 
> > 
> > 
> >> So I think we choice "xsd", for operator who can make 
> netconf tools and
> >> NMS programmers.
> >> -------
> >>    Yoshifumi Atarashi
> >>
> >> Hideki Okita wrote:
> >>> From implementors' viewpoint,
> >>> RelaxNG as the schema is not a good choice.
> >>>
> >>>
> >>> Major development environments such as Java (Apache),
> >>> Visual Studio and others has no support for RelaxNG.
> >>>
> >>> Surely RelaxNG make it easy to read "directly" the NETCONF schema.
> >>> However, finally, it can decrease the development efficiency.
> >>>
> >>>
> >>> I do not object to use RelaxNG as the optional means.
> >>> However, XSD should remain as the default schema in 
> NETCONF drafts.
> >>>
> >>>
> >>> Best regards,
> >>>
> >>> Hideki Okita
> >>> Hitachi, Ltd.
> >>>
> >>>
> >>> References:
> >>>
> >>> RelaxNG Homepage:
> >>> 
http://www.oasis-open.org/committees/tc_home.php?wg_abbrev=relax-ng
>>>
>>> Apache Xerces2 Java Parser Homepage:
>>> http://xerces.apache.org/xerces2-j/
>>>
>>>
>>> Simon Leinen wrote:
>>>> On the ad-hoc meeting on data modeling issues, the possibility of
>>>> using RelaxNG for data modeling work was raised, and some people asked
>>>> for examples.  Here are some that are somehow related to network
>>>> management.
>>>>
>>>> The Compact RelaxNG Schema for NETCONF's protocol operations (at the
>>>> time) that Rob Enns posted to the list in November 2004:
>>>>
>>>>   http://ops.ietf.org/lists/netconf/netconf.2004/msg00597.html
>>>>
>>>> The (Expired) draft-schoenw-nmrg-snmp-measure-01.txt contains a
>>>> RelaxNG schema for a set of information from SNMP packet traces:
>>>>
>>>>  
>>>>
http://bgp.potaroo.net/ietf/all-ids/draft-schoenw-nrmg-snmp-measure-01.txt 

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

-- 
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.409 / Virus Database: 268.14.0/524 - Release Date: 11/8/2006

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: "McDonald, Ira" <[email-masked]>
Date: Thu, 9 Nov 2006 07:58:42 -0800

Hi Tom,

Several, but the most trustworthy IMHO is XSV, co-authored
by Henry Thompson (co-editor of W3C XML Schema standards).

  http://www.w3.org/XML/Schema#XSV

Available for online web form access, Win32 self-installer,
and Python source for any platform - see

  http://www.ltg.ed.ac.uk/~ht/xsv-status.html

Cheers,
- Ira

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of tom.petch
Sent: Thursday, November 09, 2006 8:38 AM
To: [email-masked]
Cc: [email-masked]
Subject: Re: RelaxNG examples

----- Original Message ----- 
From: "Juergen Schoenwaelder" <[email-masked]>
To: "Yoshifumi Atarashi" <[email-masked]>
Cc: <[email-masked]>; "Hideki Okita" <[email-masked]>
Sent: Wednesday, November 08, 2006 8:55 PM
Subject: Re: RelaxNG examples

> On Thu, Nov 09, 2006 at 02:25:05AM +0900, Yoshifumi Atarashi wrote:
> > I think there are a few style decision points.
> > 
> > 1) expression ability
> > 2) easy to understanding
> > 3) programming language/tool/library support
> > 4) capability
> > 
> > In my understanding,
> > RelaxNG
> > 1) good
> > 2) good
> > 3) not good
> > 4) not good, because RelaxNG is not mainstream in XML tool developer.
> >    (Our XML expert told us.)
> > 
> > xsd
> > 1) good (a little limited)
> > 2) good (a little limited)
> > 3) very good
> > 4) good
> > 
> > So I think we choice "xsd", for operator who can make netconf tools and
> > NMS programmers.
> 
> I assume that all sensible developers will use some other input format
> to generate the XSD. And I doubt the IETF has enough people who can
> really read and judge the correctness of XSDs - at least this WG seems
> to have proven that bugs in the XSD usually stay around for a long
> time undetected (even though there are all these great tools out
> there).
> 
Is there a publicly available tool for XSD like
  [email-masked]
or its successor is for SMIv2?

Tom Petch
> /js
> 
> -- 
> Juergen Schoenwaelder     International University Bremen
> <http://www.eecs.iu-bremen.de/>     P.O. Box 750 561, 28725 Bremen,
Germany

-- 
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.409 / Virus Database: 268.14.0/525 - Release Date: 11/9/2006