Subject: RE: Please review new Notifications draft!!!

From: "Romascanu, Dan \(Dan\)" <[email-masked]>
Date: Mon, 8 Jan 2007 15:25:47 +0200

I believe that the document can be sent to the WGLC. There have been
comments from Andy and Martin, can we consider them as initial WGLC
comments? 

Dan

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Andy Bierman
> Sent: Tuesday, December 26, 2006 9:17 PM
> To: Netconf (E-mail)
> Subject: Please review new Notifications draft!!!
> 
> Hi,
> 
> The new notifications draft has been out for about a week and 
> so far, no comments.  Not surprising, given the holidays, and 
> lots of people on vacation.
> 
> In case you missed the I-D announcement:
> 
> http://www.ietf.org/internet-drafts/draft-ietf-netconf-notific
> ation-05.txt
> 
> Please try to read it in the next 2 weeks, and send comments 
> to the WG mailing list.  We need to know if you think this 
> document is done and ready for WG Last Call.
> 
> thanks,
> Andy
> 
> 
> --
> to unsubscribe send a message to [email-masked] 
> with the word 'unsubscribe' in a single line as the message text body.
> archive: <http://ops.ietf.org/lists/netconf/>
> 

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Balazs Lengyel <[email-masked]>
Date: Tue, 09 Jan 2007 12:46:36 +0100

Hello,
Some more comments:

General:
I thought we agreed on having just one schema instead of many small ones, but if must I can 
live with this.

Chapter 1.2)
Please describe that any RPC requests received on a notification session may be discarded 
silently, without any response message.

Chapter 2.3)
Mention termination due to closing the transport session or stop-time.

Chapter 3.2.5.2 Here in the nm:Name element we have NetconfNotificationSchema which is not 
describing the content of this specific schema.

Chapter 3.3) "While it is possible ..."
We do not provide a schema to retrieve this information, so I would formulate this as "While it 
might be possible ..."

Chapter 6.2)
Start and stop times should relate to generation time "whenever possible".
Shouldn't we send back in the error info the date/time of the earliest available notification.

Chapter 6.3)
Please indicate what happens with the session after the replayComplete notification is sent. Is 
it terminated on transport level? Does it become a normal session? Is it some kind of stale/ 
useless session? What options might a device choose? I feel terminate SSH/SOAP/BEEP is the best.

After updating according to Martin's Andy's etc. comments I agree with the last call.

Balazs

-- 
Balazs Lengyel                       Ericsson Hungary Ltd.
TSP System Manager
ECN: 831 7320                        Fax: +36 1 4377792
Tel: +36-1-437-7320     email: [email-masked]