Subject: netconf update

From: Andy Bierman <[email-masked]>
Date: Fri, 09 Feb 2007 15:31:42 -0800

Hi,

The NETCONF WG is scheduled to meet on Monday evening at
the next IETF.  The primary goal of the meeting is to get
the NETCONF Notifications draft approved by the WG and passed
to the IESG for publication consideration.

 1) The authors are working on a new version of the Notifications draft.
 2) A 3 week WG Last Call will be started when this draft is published.
 3) Depending on the new draft and the comments we receive in WGLC, there
    may be time available at the end of the meeting slot to discuss other
    drafts besides this one.

thanks,
Andy

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Phil Shafer <[email-masked]>
Date: Thu, 15 Feb 2007 11:23:00 -0500

> 1) The authors are working on a new version of the Notifications draft.

Any estimate on when the new version will be out?

Thanks,
 Phil

---

From: "Sharon Chisholm" <[email-masked]>
Date: Fri, 16 Feb 2007 09:54:56 -0500

Hi

The edit is basically ready. I just want to give the issue list a chance
to air and verify that there are not any new comments that need to be
addressed. We'll probably send it in on Monday.

Sharon

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Phil Shafer
Sent: Thursday, February 15, 2007 11:23 AM
To: Andy Bierman
Cc: Netconf (E-mail)
Subject: Re: netconf update

Thanks,
 Phil

--
to unsubscribe send a message to [email-masked] with the
word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: "tom.petch" <[email-masked]>
Date: Fri, 16 Feb 2007 21:27:15 +0100

Sharon

MUST the event be properly formed XML?  I imagine it must but do not see that
explicitly spelt out in the I-D.  Equally, MUST there be a DTD or Schema for an
event?

Tom Petch

----- Original Message -----
From: "Sharon Chisholm" <[email-masked]>
To: "Netconf (E-mail)" <[email-masked]>
Sent: Friday, February 16, 2007 3:54 PM
Subject: RE: netconf update

Hi

Sharon

-----Original Message-----

Thanks,
 Phil

---

From: "Sharon Chisholm" <[email-masked]>
Date: Tue, 20 Feb 2007 13:24:57 -0500

Hi

It must be well-formed XML. I had been thinking that this was covered,
but since we are not re-using rpc messaging for Notifications anymore, I
guess we need to explicitly state it. I don't think we can make any more
specific claims in this document, but certain can in data model related
ones.

Sharon 

-----Original Message-----
From: tom.petch [mailto:[email-masked]] 
Sent: Friday, February 16, 2007 3:27 PM
To: Chisholm, Sharon (CAR:ZZ00); Netconf (E-mail)
Subject: Re: netconf update

Sharon

MUST the event be properly formed XML?  I imagine it must but do not see
that explicitly spelt out in the I-D.  Equally, MUST there be a DTD or
Schema for an event?

Tom Petch

----- Original Message -----
From: "Sharon Chisholm" <[email-masked]>
To: "Netconf (E-mail)" <[email-masked]>
Sent: Friday, February 16, 2007 3:54 PM
Subject: RE: netconf update

Hi

Sharon

-----Original Message-----

Thanks,
 Phil

---

From: "tom.petch" <[email-masked]>
Date: Wed, 21 Feb 2007 11:26:57 +0100

<inline>
Tom Petch

----- Original Message -----
From: "Sharon Chisholm" <[email-masked]>
To: "Netconf (E-mail)" <[email-masked]>
Sent: Tuesday, February 20, 2007 7:24 PM
Subject: RE: netconf updatei

Sharon

<tp>

What I am wrestling with, after reading the SIP RFC you pointed us at, is the
idea that the document must be well-formed XML, that filters may have removed
mandatory elements and that the 'principal' may not be authorised to view a
mandatory element.  I am not sure how this can be resolved.

eg suppose <user> has minoccurs="1" maxoccurs="1" for each of the elements
<name>
<department>
<securityCredentialType>
of which the last has very restricted access.  I can envisage either access
restrictions forcing a document not to conform to its Schema or multiple
document definitions to allow for different combinations of access rights to
different combinations of the elements, both of which seem unattractive.

I think that this is a generic consideration, not one that should be left to
individual data models, even if all we can say is that the data models should
consider it.

In SNMP, I do not see the issue arising because access rights win and there is
no concept of a well-formed document to be in conflict with.  Ditto syslog.

Tom Petch

-----Original Message-----
From: tom.petch [mailto:[email-masked]]
Sent: Friday, February 16, 2007 3:27 PM
To: Chisholm, Sharon (CAR:ZZ00); Netconf (E-mail)
Subject: Re: netconf update

Sharon

Tom Petch

----- Original Message -----
From: "Sharon Chisholm" <[email-masked]>
To: "Netconf (E-mail)" <[email-masked]>
Sent: Friday, February 16, 2007 3:54 PM
Subject: RE: netconf update

Hi

Sharon

-----Original Message-----

Thanks,
 Phil

---

From: Balazs Lengyel <[email-masked]>
Date: Wed, 21 Feb 2007 17:33:14 +0100

Hello,
You can just leave out the restricted elements (and their children). The XML will still be well 
formed, although it might not comply with some schema defining the content of the notification. 
However as Sharon's draft does not deal with the content of notifications, I thinks this issue 
is not Sharon's problem.
regards Balazs

-- 
Balazs Lengyel                       Ericsson Hungary Ltd.
TSP System Manager
ECN: 831 7320                        Fax: +36 1 4377792
Tel: +36-1-437-7320     email: [email-masked]

---

From: Andy Bierman <[email-masked]>
Date: Wed, 21 Feb 2007 09:12:53 -0800

Balazs Lengyel wrote:
> Hello,
> You can just leave out the restricted elements (and their children). The 
> XML will still be well formed, although it might not comply with some 
> schema defining the content of the notification. However as Sharon's 
> draft does not deal with the content of notifications, I thinks this 
> issue is not Sharon's problem.

To be even more clear:

An agent is required to process the subtree filter regardless
of its contents -- there is no schema to validate here.
Any error (invalid namespace, attribute, simple or complex content)
is just a "no match" condition, not any error.

Andy