Subject: One comment on netconf-notification-transport-01

From: Ma Yuzhi <[email-masked]>
Date: Fri, 09 Mar 2007 15:07:39 +0800

The exmple in section 2.1 have some redundant tags, such as </config>,
</data> and </event>.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> Sent: Thursday, March 01, 2007 7:50 AM
> To: [email-masked]
> Subject: I-D 
> ACTION:draft-trevino-netconf-notification-transport-01.txt
> 
> A New Internet-Draft is available from the on-line 
> Internet-Drafts directories.
> 
> 
> 	Title		: NETCONF Notification Transport Mappings
> 	Author(s)	: S. Chisholm, H. Trevino
> 	Filename	: 
> draft-trevino-netconf-notification-transport-01.txt
> 	Pages		: 14
> 	Date		: 2007-2-28
> 	
> This document defines the transport mappings for NETCONF event
>    notifications.  This is an optional capability built on top of the
>    base NETCONF protocol.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-trevino-netconf-noti
> fication-transport-01.txt
> 
> To remove yourself from the I-D Announcement list, send a message to 
> [email-masked] with the word unsubscribe in 
> the body of 
> the message. 
> You can also visit 
> https://www1.ietf.org/mailman/listinfo/I-D-announce 
> to change your subscription settings.
> 
> Internet-Drafts are also available by anonymous FTP. Login with the 
> username "anonymous" and a password of your e-mail address. After 
> logging in, type "cd internet-drafts" and then 
> "get draft-trevino-netconf-notification-transport-01.txt".
> 
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html 
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE 
> /internet-drafts/draft-trevino-netconf-notification-transport-01.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant 
> mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
> 
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> 

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Andy Bierman <[email-masked]>
Date: Fri, 09 Mar 2007 06:54:33 -0800

> The exmple in section 2.1 have some redundant tags, such as </config>,

Please note that this is not a WG document.
We have an open issue wrt/ the transport mappings.
Only SSH is supported for notifications at this time.

The BEEP profile for Notification support does not exist.
The detailed document describing how the SOAP transport works,
including how the SOAP transport makes the Notification system
work exactly the same for higher layer protocols as SSH does,
does not exist.

The document you cite does not contain any normative text
relevant to the title of the document.  It contains
non-normative examples mostly taken from other documents.

The WG must decide what to do (if anything) about supporting
BEEP and SOAP for Notifications.  I am most concerned about
getting the Notifications draft completed, and do not want to
block that document to wait for normative BEEP and SOAP transport mappings.
There does appear to be enough interest in the WG to work
on this aspect of the new protocol feature.

Andy

---

From: "David B Harrington" <[email-masked]>
Date: Fri, 9 Mar 2007 10:23:29 -0500

Should the abstract be changed from "This document defines the
transport mappings" to "This document defines optional transport
mappings"?

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Andy Bierman
> 
[...]
> The document [] does not contain any normative text
[...]

---

From: "Sharon Chisholm" <[email-masked]>
Date: Fri, 9 Mar 2007 12:32:26 -0500

Hi

This document is a holding place for the issue of transport mapping for
notifications. My hope is that any gaps we identify in the existing
transport mappings will result in a bis of those documents to properly
cover notifications. Hector and I want to make sure the issue didn't get
lost - hence the draft.

If it does continue in its current form, I don't think throwing the word
optional in is helpful. Either it is defining the mapping for the
various transports or it isn't.

I sent some private emails to ping the authors of the various transport
mappings on the topic. We received some good feedback so far on SOAP
(what we have in the document isn't what is needed) and a promise for a
review on BEEP.

Sharon 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of David B Harrington
Sent: Friday, March 09, 2007 10:23 AM
To: 'Andy Bierman'; 'Ma Yuzhi'
Cc: [email-masked]
Subject: netconf-notification-transport-01

Should the abstract be changed from "This document defines the transport
mappings" to "This document defines optional transport mappings"?

[...]
> The document [] does not contain any normative text relevant to the 
> title of the document.  It contains non-normative examples mostly 
> taken from other documents.
[...]
> >> A New Internet-Draft is available from the on-line Internet-Drafts 
> >> directories.
> >>
> >>
> >> [email-masked] with the word unsubscribe in the body

> >> of the message.

---

From: "Hector Trevino \(htrevino\)" <[email-masked]>
Date: Fri, 9 Mar 2007 09:58:41 -0800

And just to emphasize what Sharon says about the bis of the transport
mapping documents, the following is included in the introduction:

"Editor's Note: Inclusion of Notification transport mappings
   into bis versions of the SSH, SOAP and HTTP transport mappings RFCs
   should be considered instead of publishing a Notification-specific
   transport mapping document."

Hector

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Sharon Chisholm
Sent: Friday, March 09, 2007 10:32 AM
To: [email-masked]
Subject: RE: netconf-notification-transport-01

Hi

Sharon 

-----Original Message-----

[...]
[...]

> >> logging in, type "cd internet-drafts" and then "get 
> >> draft-trevino-netconf-notification-transport-01.txt".
> >>
> >> http://www.ietf.org/shadow.html or 
> >> ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> >>
> >> 	a MIME-compliant mail reader.  Different MIME-compliant mail 
> >> readers
> to unsubscribe send a message to [email-masked] with the

> word 'unsubscribe' in a single line as the message text body.

--
to unsubscribe send a message to [email-masked] with the
word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

--
to unsubscribe send a message to [email-masked] with the
word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>