Subject: [Netconf] #1: message-id attribute not used

From: "Netconf" <[email-masked]>
Date: Thu, 26 Jul 2007 22:11:42 -0000

#1: message-id attribute not used
----------------------------------+-----------------------------------------
 Reporter:  [email-masked]  |       Owner:            
     Type:  defect                |      Status:  new       
 Priority:  minor                 |   Milestone:  milestone1
Component:  RFC4741               |     Version:  1.0       
 Keywords:  message-id            |  
----------------------------------+-----------------------------------------
 The message-id attribute is required to be present in
 an <rpc> request on the agent must return an error.
 However, this attribute is not actually used in NETCONF,
 and there is no reason to return an error if this
 attribute is missing.

-- 
Ticket URL: <http://tools.ietf.org/wg/netconf/trac/ticket/1>
Netconf <http://tools.ietf.org/wg/netconf/trac/>
Issue tracker for the NETCONF Working Group������r��zǧu���Ơz�'z�(��ު笶�l��_��0��m��(�ۧ���r��z)ڲ)���b�欶�z���^���w&�r�zm���Ȟ��+��b��?��\�w�

---

From: "Netconf" <[email-masked]>
Date: Mon, 30 Jul 2007 16:04:10 -0000

#1: message-id attribute not used
-----------------------------------+----------------------------------------
  Reporter:  [email-masked]  |       Owner:            
      Type:  defect                |      Status:  new       
  Priority:  minor                 |   Milestone:  milestone1
 Component:  RFC4741               |     Version:  1.0       
Resolution:                        |    Keywords:  message-id
-----------------------------------+----------------------------------------
Comment (by [email-masked]):

 We do want to use it. We want to send notifications about long running
 operations like backup. We will identify the original operation using the
 message-id.
 It could also be useful for logging, to pair the request and the answer.
 [[BR]]
 Please do not remove it.
 [[BR]]
 Balazs Lengyel

-- 
Ticket URL: <http://tools.ietf.org/wg/netconf/trac/ticket/1#comment:1>
Netconf <http://tools.ietf.org/wg/netconf/trac/>
Issue tracker for the NETCONF Working Group������r��zǧu���Ơz�'z�(��ު笶�l��_��0��m��(�ۧ���r��z)ڲ)���b�欶�z���^���w&�r�zm���Ȟ��+��b��?��\�w�

---

From: Andy Bierman <[email-masked]>
Date: Mon, 30 Jul 2007 11:58:39 -0700

> #1: message-id attribute not used

You misunderstand. I did not make the ticket clear enough.
The 'message-id' attribute is not being removed.  The requirement
to generate an error and reject the <rpc> request if it is missing
is being removed.

The agent is already required to return every attribute in <rpc>
unchanged in the <rpc-reply> anyway.  The message-id rule is redundant.
(Phil already explained it all to us, remember?)

>  Balazs Lengyel

Andy

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>