Subject: Conclusion: notification-09 consensus points

From: Andy Bierman <[email-masked]>
Date: Thu, 04 Oct 2007 10:28:11 -0700

Hi,

There seems to be no objection to adding the interleave capability
and leaving the eventTime as a sibling of notificationContent.

The pre-10 draft does not need any changes related to these issues.
There are no other open issues, so notification-10 should be
published ASAP.  After that, a final 3 week WGLC will be held
to identify any new issues only.

Andy

> Hi,
> 
> I have reviewed the latest notification draft, and it is very
> close to done!
> 
> There are clarifications and small bug fixes already pointed
> out in review comments.  In addition, the comments below
> require that the WG make a couple of decisions.
> 
> 
> 
> ==============================================
> 
> sec 1.3, para 2, last sentence
> 
> [Andy]
> 
> Current:
> 
>   An example of when other commands would be processed is if a separate
>   capability was advertised indicating support of this functionality.
> 
> Proposed:
> 
>   [some text defining the :interleave capability]
> 
>  *** WG consensus point *************************************
>  * Add :interleave capability to indicate agent will accept *
>  * other RPC methods besides close-session while delivering *
>  * notifications.  Yes/No?                                  *
>  ************************************************************
> 
> 
> ==============================================
> 
> sec 2.3
> 
> [Martin]
> 
> Add sentence about <close-session> as the primary method
> to terminate the session.
> [Andy] IMO the <kill-session> and drop connection text
> should be removed.
> 
> ==============================================
> 
> sec 4. and 5: eventTime element
> 
> The XSD and examples show the eventTime as a sibling
> of the notificationContent node, not a child of the
> notification content:
> 
> [A] Current:
> 
>   <notification
>      xmlns="urn:ietf:params:netconf:capability:notification:1.0">
>      <eventTime>2007-07-08T00:01:00Z</eventTime>
>      <event xmlns="http://example.com/event/1.0">
>         <eventClass>fault</eventClass>
>         <reportingEntity>
>             <card>Ethernet0</card>
>         </reportingEntity>
>         <severity>major</severity>
>       </event>
>   </notification>
> 
> 
> [B] Discussed on mailing list:
> 
>   <not:notification
>      xmlns:not="urn:ietf:params:netconf:capability:notification:1.0">
>      <event xmlns="http://example.com/event/1.0">
>         <not:eventTime>2007-07-08T00:01:00Z</not:eventTime>
>         <eventClass>fault</eventClass>
>         <reportingEntity>
>             <card>Ethernet0</card>
>         </reportingEntity>
>         <severity>major</severity>
>       </event>
>   </not:notification>
> 
> 
>  *** WG consensus point ****************************************
>  * [A] == Keep 'eventTime' as a sibling of notificationContent *
>  * [B] == Make 'eventTime' a child of notificationContent      *
>  *                [A] or [B]?                                  *
>  ***************************************************************
> 
> 
> 
> 
> -- 
> to unsubscribe send a message to [email-masked] with
> the word 'unsubscribe' in a single line as the message text body.
> archive: <http://ops.ietf.org/lists/netconf/>
> 
> 

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 8 Oct 2007 18:56:49 +0200

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Andy Bierman
> Sent: Thursday, October 04, 2007 7:28 PM
> After that, a final 3 week WGLC will be held 

I suggest that you make clear in the Last Call announcement that the
focus o the review should be on changes since the version of the I-D
that was last-called, and also help the readers and reviewers with a log
section in the document detailing these changes. 

Dan