Subject: Re: Last Call: draft-levin-mmusic-xml-media-control (XML Schema for Media Control) to Informational RFC

From: "tom.petch" <[email-masked]>
Date: Tue, 20 Nov 2007 17:40:18 +0100

----- Original Message -----
From: "Romascanu, Dan (Dan)" <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Sent: Monday, October 08, 2007 2:50 PM
Subject: FW: Last Call: draft-levin-mmusic-xml-media-control (XML Schema for
Media Control) to Informational RFC

I think that folks in the OPS Area and NECONF may want to have a look at
this proposal and comment if necessary.

Dan

OK, I'll bite.

Why do you think that this might be of interest to NETCONF?  It looks quite
straightforward (apart from a few typos).  I note that there is now -12 which
has altered the substance of the XML and in doing so made it invalid (as has
already been pointed out).

Tom Petch

-----Original Message-----
From: The IESG [mailto:[email-masked]]
Sent: Monday, October 08, 2007 3:30 PM
To: IETF-Announce
Subject: Last Call: draft-levin-mmusic-xml-media-control (XML Schema for
Media Control) to Informational RFC

The IESG has received a request from an individual submitter to consider
the following document:

- 'XML Schema for Media Control '
   <draft-levin-mmusic-xml-media-control-11.txt> as an Informational RFC

The IESG plans to make a decision in the next few weeks, and solicits
final comments on this action.  Please send substantive comments to the
[email-masked] mailing lists by 2007-11-05. Exceptionally, comments may
be sent to [email-masked] instead. In either case, please retain the
beginning of the Subject line to allow automated sorting.

The file can be obtained via
http://www.ietf.org/internet-drafts/draft-levin-mmusic-xml-media-control
-11.txt

IESG discussion can be tracked via
https://datatracker.ietf.org/public/pidtracker.cgi?command=view_id&dTag=
9391&rfc_flag=0

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 20 Nov 2007 23:29:07 +0100

Hi Tom,

The original call for comments was for draft-11, which was in IETF LC a
while ago. Right now draft-12 is in LC, and in case you have any
consistent comments you may want to forward them to the ietf list or to
the authors. 

To answer your question besides the fact that cross-area reviews are a
good thing, I believe that it's useful for the NETCONF community to see
how other protocols are using XML for management operations in different
environments. 

Dan

> From: tom.petch [mailto:[email-masked]] 
> Sent: Tuesday, November 20, 2007 6:40 PM
> To: Romascanu, Dan (Dan); [email-masked]
> Subject: Re: Last Call: draft-levin-mmusic-xml-media-control 
> (XML Schema for Media Control) to Informational RFC 
> 
> Subject: FW: Last Call: draft-levin-mmusic-xml-media-control 
> (XML Schema for Media Control) to Informational RFC
> 
> I think that folks in the OPS Area and NECONF may want to 
> have a look at this proposal and comment if necessary.
> 
> Dan
> 
> OK, I'll bite.
> 
> Why do you think that this might be of interest to NETCONF?  
> It looks quite straightforward (apart from a few typos).  I 
> note that there is now -12 which has altered the substance of 
> the XML and in doing so made it invalid (as has already been 
> pointed out).
> 
> Tom Petch
> 
> Subject: Last Call: draft-levin-mmusic-xml-media-control (XML 
> Schema for Media Control) to Informational RFC
> 
> The IESG has received a request from an individual submitter 
> to consider the following document:
> 
> The IESG plans to make a decision in the next few weeks, and 
> solicits final comments on this action.  Please send 
> substantive comments to the [email-masked] mailing lists by 
> 2007-11-05. Exceptionally, comments may be sent to 
> [email-masked] instead. In either case, please retain the 
-11.txt

--
to unsubscribe send a message to [email-masked] with the
word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 21 Nov 2007 00:22:40 +0100

> how other protocols are using XML for management operations in different

Not sure this is such a great example (for whatever it is meant to
be an example). Let me quote from the abstract:

   [...] New implementations are discouraged from using the described
   method described except for backward compatibility purposes. [...]

I understand the problem here does not seem to be the XML fragment but
the usage of the signaling path - but then I am again not sure what
particular NETCONF lesson I am supposed to learn from this.

And since you specifically point to this document (and not at other
IDs that contain XML fragments where they sometimes also talk about
configuration), I am seriously concerned that people looking at
examples of the following instance XML document complexity

   <media_control>
      <vc_primitive>
       <to_encoder>
         <picture_fast_update/>
       </to_encoder>
     </vc_primitive>
   </media_control>

(yes that is all there is!) may draw wrong conclusions. My
understanding is that NETCONF is intended to deal with things as
complex as whole router configurations, different data stores, locking
semantics, commit mechanisms, failure handling mechanisms, validation
features, ... and from that perspective, I guess I should not have
looked at this document (and clearly not spent time writing this
email).

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "tom.petch" <[email-masked]>
Date: Fri, 23 Nov 2007 10:45:26 +0100

---- Original Message -----
From: "Romascanu, Dan (Dan)" <[email-masked]>
To: "tom.petch" <[email-masked]>; <[email-masked]>
Sent: Tuesday, November 20, 2007 11:29 PM
Subject: RE: Last Call: draft-levin-mmusic-xml-media-control (XML Schema for

Hi Tom,

Dan

Dan,

Understand.  I do now keep an eye on XML arising from other working groups but
did not see this one as particularly insightful.  I do see the simple ones - eg
draft-ietf-simple-xml-patch-ops-03 - and ippm - eg
draft-ietf-ippm-storetraceroutes-05 with its definition of  inetAddressType:-) -
as more thought provoking

Tom Petch