Subject: Question on <draft-bierman-ncx-smi-00.txt>

From: Bharadwaj Kalahasti <[email-masked]>
Date: Fri, 9 Nov 2007 22:17:00 -0800 (PST)

Andy,
  On page 8 of section 1.2, you have written:
"
   Although it is possible to arbitrarily extend the <appinfo> element,
   this XSD mechanism is by definition non-standard, and 'off-the-shelf'
   XSD-based applications will not be able to do anything useful with
   information encoded in this manner.
"
  The stated flaws in XSD such as lack of conditional presence test for referential
integrity could be fixed with changes to the XSD language by creating new elements
that are test-only or such. Has there been effort in seeking such a solution from
W3C forum so far?  Reason being an attempt to create a modeling language that is
compliant with both SMIv2 and XSD seems to be an overkill. 
  Please enlighten me if I have missed any concepts here. 
Thanks,
Kalahasti

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Andy Bierman <[email-masked]>
Date: Fri, 09 Nov 2007 23:04:53 -0800

> compliant with both SMIv2 and XSD seems to be an overkill. 

I think the 'must' and 'when' clauses in the YANG language address
the needs of NETCONF very well in this area.  They leverage Xpath
in the simplest possible way.

I don't know about a NETCONF DML that is backwards-compatible
with SMIv2.  I think YANG can represent just about any SMIv2
data model.  The reverse is obviously never going to be true.

>   Please enlighten me if I have missed any concepts here. 

Andy