Subject: RE: Comments on Partial Locking -01

From: Mehmet Ersue <[email-masked]>
Date: Thu, 13 Dec 2007 10:52:38 +0000 (GMT)

> > > a) A partial lock after a global lock MUST fail.
> > > b) A global lock after a partial lock SHOULD be allowed.
> > 
> > I don't agree with the point a). In the case when a session A wants to
> > lock (partial lock) /foo/bar and /foo/baz, it can execute the global
> > lock first to protect against the situation, when during partial
> > locking /foo/bar another session (B) would lock partially /foo/baz. It
> > means that after the following steps:
> > 1) global lock
> > 2) partial lock of /foo/bar
> > 3) partial lock of /foo/baz
> > 4) global unlock
> > session A keeps lock on /foo/bar and /foo/baz.
> 
> This particular use case is actually handled in the current draft by
> doing a single operation:
>    
>   partial-lock(/foo/bar, /foo/baz)

I agree, this is the atomic way to partial lock two areas at once. Three 
lock operations before we can be sure the session can start working 
(global lock, partial lock of /foo/bar, partial lock of /foo/baz) wouldn't be efficient.

Mehmet

> /martin

      Heute schon einen Blick in die Zukunft von E-Mails wagen? www.yahoo.de/mail

---

From: "Tomasz Mikolajczyk" <[email-masked]>
Date: Mon, 17 Dec 2007 09:13:29 +0100

> (global lock, partial lock of /foo/bar, partial lock of /foo/baz) wouldn't

Assuming that partial locks on a few resources is an atomic operation,
we don't have to worry about situation described by me.

Regards
Tomasz

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>