Subject: comments on draft-ietf-netconf-partial-lock-00

From: "Bert Wijnen" <[email-masked]>
Date: Fri, 25 Jan 2008 00:41:38 +0100

Commenting as a technical contributor.
These are however mainly/initial editorial comments
that you can consider for the next revision.

- sect 1
    Partial locking will be introduced as a capability to NETCONF.
  I think I would prefer
    Partial locking is defined as a capability to NETCONF.
  or some such. So do not speak in the future

- Sect 1.1
  Need to add a citation to RFC2119, and then add RFC2119 to the
  normative references.
 
- sect 2.1
    The system will ensure that configuration resources covered by the
    lock will not be modified by other NETCONF or non-NETCONF management
    operations such as SNMP and the CLI.

  I think it would be better to not speak in the future.
  So I would do 
    The system ensures... 
    lock can not be modified ,,,
  Or some such

- Sect 2.2

    If the :xpath capability is supported, the filter expressions can be
    full XPath 1.0 expressions.

  This may be a good place to also add some text on how the filter
  experssions are limited if :xpath capability is not supported.
    
- page 12

    target:  Name of the configuration datastore of which a part will be
       locked.  URIs are not accepted.

  Did you mean "url" instead of URI?
  In rfc4741 in sect 8.8 we speak of "URL capability" that allows urls 
  to be used for target. We should try to be consistent in our usage of
  terms.

- section 4, IANA considerations.

     The capability's URI should be registered by IANA.

  I would make this somewhat more explicit. Something aka

   This document registers a URN for the the following NETCONF
   capability in the netconf registry (RFC4741], sect 10.3):

   +--------------------+----------------------------------------------+
   | Index              | Capability Identifier                        |
   +--------------------+----------------------------------------------+
   | :partial-lock      | urn:ietf:params:netconf:capability:partial-  |
   |                    | lock:1.0                                     |
   +--------------------+----------------------------------------------+

- Overall

Bert Wijnen 

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Balazs Lengyel <[email-masked]>
Date: Fri, 25 Jan 2008 17:58:33 +0100

Hello Bert,
Thanks for the comments. I mostly agree (see below).
Balazs

>   or some such. So do not speak in the future
OK
>   Need to add a citation to RFC2119, and then add RFC2119 to the
OK
>     lock can not be modified ,,,
OK
>   experssions are limited if :xpath capability is not supported.
It is described in chapter 2.4.1. <partial-lock>. Do you find that description insufficient or 
do you think we should bring it forward here?
>   to be used for target. We should try to be consistent in our usage of
OK
>    capability in the netconf registry (RFC4741], sect 10.3):
OK

-- 
Balazs Lengyel                       Ericsson Hungary Ltd.
TSP System Manager
ECN: 831 7320                        Fax: +36 1 4377792
Tel: +36-1-437-7320     email: [email-masked]

---

From: "Bert Wijnen" <[email-masked]>
Date: Fri, 25 Jan 2008 18:08:34 +0100

W.r.t.
> It is described in chapter 2.4.1. <partial-lock>. Do you find
> that description insufficient or do you think we should bring it forward
here?

Yes I had seen that.
At least you might want to add a forward reference.
But 2.4.1 has a lot more than just the filter expression and the
limitations if one does not support :xpath. So you may want to
add some specific text here in Sect 2.2 that explains the
limitations.

My comment of course is not a show stopper. But when I was reading
the draft I sort of wondered and had to a read lot more before it
started to make any sense.

Bert