Subject: Agenda for NETCONF WG session at IETF #71

From: "Ersue, Mehmet (NSN - DE/Muenich)" <[email-masked]>
Date: Thu, 28 Feb 2008 10:40:51 +0100

Dear NETCONF WG,

below is an update for the agenda of the NETCONF WG session 
at the IETF #71. 

Our main focus in the session will be on open issue discussion.
Please let us know before hand about your implementation.
Please let us also know whether you have a concrete topic for 
the open mic session.

We still need volunteers as scribe and minute taker. As you 
know the session will not start before we have them ;-). 

Bert & Mehmet

_____________________________________________

NETCONF WG
IETF 71, Philadelphia, PA, USA

MONDAY, March 10, 2008 1740-1950

  Scribes (needs to be organized before the session),
  Agenda bashing (2 minutes)

  Use of mailing lists,
  WG status review (10 minutes)

  Current charter items:

    1. NETCONF over TLS (20 minutes)

       draft-ietf-netconf-tls-01.txt

    2. Fine-grained locking (20 minutes)

       draft-ietf-netconf-partial-lock-00.txt

    3. Netconf monitoring (20 minutes)

       draft-ietf-netconf-monitoring-00.txt

  Discussion on ongoing implementations (10 minutes)

      Who is implementing what?
      Should we plan an interop-event for testing of
      RFC 4141-4144 to get them to DS? 

  AOB

  Open mike 

      One hot topic is e.g. the NETCONF-related requirements on DML. 
      Any other hot topics to discuss? 

Note (this is not part of the agenda): 
We are not going to discuss solutions in open mic slot. 
This is just because we have some time and want to give 
you the opportunity to sort out the NETCONF-related 
requirements as a preparation for the Canmod BoF.

---

From: Phil Shafer <[email-masked]>
Date: Thu, 28 Feb 2008 09:57:02 -0500

>Please let us also know whether you have a concrete topic for

I posted a list of question for discussion at the last ietf,
but nothing really came of it.  Is it worth repeating?

>Another thought is to come up with a list of the five biggest
>impediments to NETCONF's complete domination of the configuration
>space.  Do we know the answers to questions like:
> 
> - Why aren't/won't device folks shipping netconf implementations?
> - Why aren't/won't application writers moving to NETCONF?
> - Why isn't NETCONF becoming the answer to configuration problems?
> - What's stopping it?
> - Where's the chicken?
> - What's the egg?
> - What's the key to moving forward from here?
> - Where should we be concentrating our (precious and few) resources?

The first issue (YANG) is clearly the (YANG) lack of a workable
DML, and (YANG) I think we are making (YANG) great progress
in that (YANG) area.

But I don't know what the other four top-five issues are.  What
stands between us and Complete World Domination (CWD)?

Thanks,
 Phil (the (YANG) subtle one ;^)

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Andy Bierman <[email-masked]>
Date: Fri, 29 Feb 2008 09:48:38 -0800

> but nothing really came of it.  Is it worth repeating?

I don't think this is really fair to the new co-Chairs.
Except for NETCONF over TLS, all of the current charter
features have been 'on the list' for a long time.

I hope a NETMOD WG start up ASAP to do the DML work in parallel.
(IMO the schema-discovery data model for <get/> retrieval
is a critical new feature for NETMOD -- even if it is a 1 page
data model that can be implemented in an hour ;-)

Andy

---

From: Phil Shafer <[email-masked]>
Date: Fri, 29 Feb 2008 15:12:02 -0500

>I don't think this is really fair to the new co-Chairs.

Don't mean to be unfair to anyone, I'm just looking
to see if we can get an idea of what our obstacles
are and if we know what we should be doing about them.

My top-five goes:
a) DML
b) open source toolkits in common development languages
c) evangelism/training/documentation/tutorials
d) blank
e) blanker

I'd love to know what (d) and (e) should be, but, well
I don't see it.  Do folks feel that the charter items
are really seen as obstacles to using netconf?

Thanks,
 Phil

---

From: Andy Bierman <[email-masked]>
Date: Fri, 29 Feb 2008 15:09:06 -0800

> c) evangelism/training/documentation/tutorials

gosh, me too! ;-)

> are really seen as obstacles to using netconf?

We already had this debate and the charter is what it is.
We also need to limit the scope of this discussion to
what should be done in the IETF, i.e, new or updated standards.

My top 3 issues (also nowhere on the radar):

  1) A NETCONF DML for non-modeling-experts, so operators, engineers,
     and IETFers can use NETCONF with ease
  2) An access control model
  3) A robust, extensible, multi-protocol NM architecture, that pulls
     together NETCONF, CLI, SNMP, SYSLOG, existing MIBs, new next-gen MIBs,
     into a secure and standard API framework.

(Yeah, right. I'll put them on my Xmas list, along with the new train set :-)

Andy