Subject: Status of Schema advertisement drafts WAS: FW: Status of netconf-schema-query

From: Mehmet Ersue <[email-masked]>
Date: Wed, 20 Feb 2008 16:48:19 +0000 (GMT)

Dear Mark, Hideki, Sharon, 

we sent you a request on the issue in the subject mid of January (see 
the mail below) and asked whether you want to: 

a) submit one WG netconf-monitoring draft that incorporates the best 
    ideas from the 3 of your drafts including the schema advertisement, or 
b) prepare a separate schema-advertisment related document. 
  
Did you already have a discussion on how you want to proceed with 
the Schema advertisement drafts? 

We have provisionally included a time slot for this in the draft agenda 
(see parallel mail). 
But the prerequisite for the discussion on the topic in the WG session is 
your agreement on how you want to proceed and the submission of a 
new draft before the IETF #71 meeting (we are going to be gracious if 
it's a joint -00 draft). One possibility we discussed is also to merge with 
the monitoring draft. 

So please get together and force the agreement for further proceeding. 
We would like to encourage you to submit a joint draft before the IETF #71 
meeting to be able to discuss it in the session and to get it one step further. 
If something is not clear or not easy to decide please involve the WG 
co-chairs or discuss on the WG maillist. 

Regards, 
Bert & Mehmet 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of ext Bert 
> Wijnen - IETF
> Sent: Tuesday, January 15, 2008 4:56 PM
> To: [email-masked]; [email-masked]
> Cc: Sharon Chisholm; [email-masked]
> Subject: FW: Status of netconf-schema-query
> 
> Mark, Hideki, Sharon,
> 
> From the last IETF71 Netconf Minutes, we see that our AD (Dan) has
> recommended that the authors of
> 
>       draft-okita-netconf-advertisement-00.txt
>    and
>       draft-scott-netconf-schema-query-00.txt
>    would get together and try to come up with a common proposal.
> 
> Both documents were read by about the same amount of people (10-11)
> and when asked who would like adopt each of the documents, they
> both got some 5-7 or so supporters. So it is best to see if we
> can merge the best from the two.
> 
> So, can the two of you (with your co-authors/co-editors) work together
> to create a new (or merge your existing) document(s) that we can
> put on the WG agenda for the upcoming IETF. The goal should be
> to try and address the WG charter item that says:
> 
>       3. Schema advertisement: Currently the NETCONF protocol 
> is able to
>           advertise which protocol features are supported on 
> a particular
>           netconf-capable device. However, there is currently 
> no way to
> discover
>           which XML Schema are supported on the device. The 
> NETCONF working
>           group will produce a standards-track RFC with 
> mechanisms making
> this
>           discovery possible.
> 
> Note that the charter also says:
> 
>    This item may be merged with "NETCONF monitoring" into a 
> single document.
> 
> That is why we also copied Sharon.
> 
> We as WG chairs would like to know what the 3 of you want to do:
> a) submit one WG netconf-monitoring draft that incorporates the best
>    ideas from the 3 of your drafts including the schema 
> advertisement, or
> b) submit monitoring document based on existing monitoring
>    document and do a separate schema-advertisment related document.
> 
> In any case, we would like the documents to be submitted asap/timely,
> so that they meet the -00 cutof date of 11 feb 2008. This so that we
> have ample time to study and review and so that we can have a fruitful
> discussion at IETF71.
> 
> Bert and Mehmet
> 
> 

      Lesen Sie Ihre E-Mails auf dem Handy.
www.yahoo.de/go

---

From: Martin Bjorklund <[email-masked]>
Date: Wed, 20 Feb 2008 21:11:29 +0100 (CET)

Hi,

AFAICT, the method defined in draft-okita-netconf-advertisement-00.txt
works for NETCONF over SOAP, but not for the other transports (SSH and
BEEP).  The methods listed in draft-scott-netconf-schema-query-00
works for any transport.  I would prefer a generic transport agnostic
method for this problem.

I proposed one solution in
http://ops.ietf.org/lists/netconf/netconf.2007/msg00698.html.  I would
be happy to work with Mark Scott on a schema discovery document.

/martin

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: OKITA Hideki <[email-masked]>
Date: Mon, 25 Feb 2008 09:45:41 +0900 (JST)

Dear Mehmet and Bert,

Sorry for late reply.
We do not have aggreement for the schema-advertisement draft yet.

> b) prepare a separate schema-advertisment related document. 

I prefer the second choice for the document makeup since monitoring is
for dynamic status (NETCONF sessions and notification subscriptions) 
and schema-advertisement is for static feature (supported datamodel).

I try to arrange discussion point and make a joint -00 draft.

Regards,

Hideki Okita

From: Mehmet Ersue <[email-masked]>
Subject: Status of Schema advertisement drafts WAS: FW: Status of netconf-schema-query
Date: Wed, 20 Feb 2008 16:48:19 +0000 (GMT)

>       Lesen Sie Ihre E-Mails auf dem Handy.
h�{.n�+���zwZ��,j��w�r�߭�z�h�Ȟ��+����^ݺ{.n�+�����"�	^�)�j�azg�����mn�rj�!�������l��_��?�+-��޵�'

---

From: OKITA Hideki <[email-masked]>
Date: Mon, 25 Feb 2008 10:46:52 +0900 (JST)

Martin,

Thank you for your comment.

> I would prefer a generic transport agnostic method for this problem.

How about to use each transport for each mapping?

I can aggree with you if we limit the usecase into post-deployment phase
which has active NETCONF sessions. However, in pre-deployment phase like
NMS development, all development environment does not have ability to
talk NETCONF sessions. Most of environment that we presume support HTTP to
take service advertisement information written in WSDL.

IMO, transport selection is not a main issue.
The main issue is how to describe/summarize schema information.

> http://ops.ietf.org/lists/netconf/netconf.2007/msg00698.html.

In this mail you proposed "a mechanism to retrieve the actual schema 
over NETCONF." I prefer this approach. WSDL approach also realizes this. 
It can contain actual schema definitions in <wsdl:types> element.

Example WSDL structure:

<wsdl:definitions
  xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/"
  xmlns:xsd="http://www.w3.org/2001/XMLSchema">

  <wsdl:types>
    <xsd:schema>
      (Schema Definitions)
    </xsd:schema>
  </wsdl:types>

  ...
</wsdl:definitions>

IMO, Using WSDL to describe/summarize schema information is 
a transport agnostic and well standardized method.
It works for any transport.

Regards,

Hideki Okita

From: Martin Bjorklund <[email-masked]>
Subject: Re: Status of Schema advertisement drafts WAS: FW: Status of netconf-schema-query
Date: Wed, 20 Feb 2008 21:11:29 +0100 (CET)

---

From: Balazs Lengyel <[email-masked]>
Date: Mon, 25 Feb 2008 12:07:25 +0100

Hello Okita,
How will your solution support people that do not use SOAP or SSH?

I feel it does not. I think saying that if you want to query the schemas you MUST support SOAP 
is not something I would like.

Martin's solution does not require any new NETCONF infrastructure.
regards Balazs

-- 
Balazs Lengyel                       Ericsson Hungary Ltd.
TSP System Manager
ECN: 831 7320                        Fax: +36 1 4377792
Tel: +36-1-437-7320     email: [email-masked]

---

From: OKITA Hideki <[email-masked]>
Date: Tue, 26 Feb 2008 00:28:14 +0900 (JST)

Balazs,

> How will your solution support people that do not use SOAP or SSH?

Are you saying about BEEP people? I cannot deeply talk about BEEP.
However, I believe they could transfer schema information 
described/summarized in a WSDL document on a BEEP channel.

> I feel it does not. I think saying that if you want to query the schemas 
> you MUST support SOAP is not something I would like.

Althoulgh as the start of discussion I proposed HTTP to transfer a WSDL file ,
you are free to adopt your favorite transport that can transfer a WSDL file.
Of course, I prefer HTTP.

I talked mainly how to describe/summarize supported schema information
in a XML document. It does not constrain your transport choice.

Regards,

Hideki Okita

From: Balazs Lengyel <[email-masked]>
Subject: Re: Status of Schema advertisement drafts WAS: FW: Status of netconf-schema-query
Date: Mon, 25 Feb 2008 12:07:25 +0100

> I feel it does not. I think saying that if you want to query the schemas 
> you MUST support SOAP is not something I would like.
>

---

From: Phil Shafer <[email-masked]>
Date: Mon, 25 Feb 2008 10:45:26 -0500

>Of course, I prefer HTTP.

Are you seeing this as a mechanism that isn't fully supported by
NETCONF proper, so you'll need to explicitly add transport bindings
for each current transport?  And emerging transports (like TLS)
will need to add language for this mechanism?  I don't see this
working well.  We're better off placing this transfer mechanism
inside NETCONF and allowing it to work over any current or future
transport.

Thanks,
 Phil