Subject: bug in notification-11 XSD

From: Andy Bierman <[email-masked]>
Date: Thu, 14 Feb 2008 10:55:26 -0800

Hi,

I just noticed that the targetNamespace is wrong in
the first XSD in this draft.  It is missing the ':1.0' suffix
that is present in the 'ncEvent' URI.

(Not that this reaffirms my belief that XSD is a mistake factory ;-)

Andy

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Andy Bierman <[email-masked]>
Date: Thu, 14 Feb 2008 11:16:34 -0800

> (Not that this reaffirms my belief that XSD is a mistake factory ;-)

oops -- I was looking at ncEvent but I should have been looking
at manageEvent.  The XSD is okay but I think the WG should pick
a URI style (with or without version numbers) and stick with it.

Andy

---

From: "Bert Wijnen - IETF" <[email-masked]>
Date: Wed, 20 Feb 2008 15:44:30 +0100

Sharon (or Hector), I have not seen you react to this
at all. What is the story here? 

Andy, is this about these 2 lines on pages 17/18

    xmlns:manageEvent="urn:ietf:params:xml:ns:netmod:notification"
    targetNamespace="urn:ietf:params:xml:ns:netmod:notification"

and the corresponding line in IANA considerations:

   URI: urn:ietf:params:xml:ns:netmod:notification

I'd like to understand from the authors what their reason is
to not be consistent as Andy suggests.

If that gets changed, then I suspect that the otehr occurences in
the rpc messages need to be changed too, no?

Bert Wijnen 

> -----Oorspronkelijk bericht-----
> Van: [email-masked]
> [mailto:[email-masked]]Namens Andy Bierman
> Verzonden: donderdag 14 februari 2008 20:17
> Aan: Netconf (E-mail); Bert Wijnen - IETF; Sharon Chisholm
> Onderwerp: Re: bug in notification-11 XSD
> 
> 
> Andy Bierman wrote:
> > Hi,
> >

---

From: "Sharon Chisholm" <[email-masked]>
Date: Wed, 20 Feb 2008 09:50:33 -0500

Hi

I believe this was discussed previously. Version numbers are included
for protocol definitions, not for the content definitions.

Sharon 

-----Original Message-----
From: Bert Wijnen - IETF [mailto:[email-masked]] 
Sent: Wednesday, February 20, 2008 9:45 AM
To: Chisholm, Sharon (CAR:ZZ00); Hector Trevino (htrevino); Andy Bierman
Cc: Netconf (E-mail)
Subject: RE: bug in notification-11 XSD

Sharon (or Hector), I have not seen you react to this at all. What is
the story here? 

I'd like to understand from the authors what their reason is to not be
consistent as Andy suggests.

If that gets changed, then I suspect that the otehr occurences in the
rpc messages need to be changed too, no?

Bert Wijnen 

> > I just noticed that the targetNamespace is wrong in the first XSD in

> > this draft.  It is missing the ':1.0' suffix that is present in the 
> > 'ncEvent' URI.
> > 
> oops -- I was looking at ncEvent but I should have been looking at 
> manageEvent.  The XSD is okay but I think the WG should pick a URI 
> style (with or without version numbers) and stick with it.
> 
> 
> > Andy
> 
> Andy
> 
> --
> to unsubscribe send a message to [email-masked] with the

> word 'unsubscribe' in a single line as the message text body.

---

From: Phil Shafer <[email-masked]>
Date: Wed, 20 Feb 2008 10:06:48 -0500

>for protocol definitions, not for the content definitions.

Can you repeat the theory behind this?  Why are they good
for one and not good for the other?  Does content never
change?

Thanks,
 Phil

---

From: Andy Bierman <[email-masked]>
Date: Wed, 20 Feb 2008 07:19:39 -0800

> for one and not good for the other?  Does content never

The theory is that change control rules will be in place for content,
so backward compatibility will be provided.

I agree with you that backward compatibility applies just as much
to protocol features as content.

Andy

---

From: "Hector Trevino (htrevino)" <[email-masked]>
Date: Wed, 20 Feb 2008 08:06:45 -0800

Hi, I don't recall why the version numbers are not in but I went back to
check and they used to be present in the earlier releases of the doc. I
agree they should be included if nothing else for style purposes. 

Hector

-----Original Message-----
From: Sharon Chisholm [mailto:[email-masked]] 
Sent: Wednesday, February 20, 2008 7:51 AM
To: Bert Wijnen - IETF; Hector Trevino (htrevino); Andy Bierman
Cc: Netconf (E-mail)
Subject: RE: bug in notification-11 XSD

Hi

Sharon 

-----Original Message-----
From: Bert Wijnen - IETF [mailto:[email-masked]]
Sent: Wednesday, February 20, 2008 9:45 AM
To: Chisholm, Sharon (CAR:ZZ00); Hector Trevino (htrevino); Andy Bierman
Cc: Netconf (E-mail)
Subject: RE: bug in notification-11 XSD

Bert Wijnen