Subject: Notification Pre-release of -12 (take 2)

From: "Bert Wijnen - IETF" <[email-masked]>
Date: Wed, 20 Feb 2008 16:27:14 +0100

Can you also explain why in section 4 I cannot find the string
    notification.xsd  ???

Why is it that such needs to be learned by looking at the IANA
considerations section?

I admit that for the netconf.xsd (appendix B of RFC4741) the
situation is the same (or maybe even worse, because the string
netconf.xsd does not occur in RFC4741 at all; only schema:netconf
exists, but only in the IANA considerations section, nowhere else.)

I find it a bit strange if this is the way to find out where an
an XSD of a specific name is defined.

I also note that I do not find the string schema:notification in
the ntotications draft....

I guess I am just totally lost/confused ... sure it shows how
bad my XML/XSD skills are. Sorry for that.

Bert Wijnen

> -----Oorspronkelijk bericht-----
> Van: Bert Wijnen - IETF [mailto:[email-masked]]
> Verzonden: woensdag 20 februari 2008 15:46
> Aan: Sharon Chisholm; Hector Trevino (htrevino)
> CC: Mehmet Ersue (NSN - DE/Muenich); Dan Romascanu
> Onderwerp: RE: Notification Pre-release of -12 (take 2)
>
>
> OK, here are my nits:
>
> - sect 2.2.1 page 10
>
>       eventTime
>
>          The time the event was generated by the event source.This
>          parameter is of type dateTime.
>
>   Put a space (or maybe 2) in front of "This"
>
> - Section 8, page 37
>
>    -- Editor note to IANA/RFC-Editor: we request that you make these
>    assignments, in which case it is top be documented as below
>
>   s/top be/to be/
>
> - Section 8
>
>   I do not understand why we would not use the same format for
>   capabilities as in sect 10.3 of RFC4741. That makes it so much
>   more consistent. So instead of:
>
>    URI: urn:ietf:params:netconf:capability:notification:1.0
>
>    URI: urn:ietf:params:netconf:capability:interleave:1.0
>
>   I would do:
>
>    +--------------------+----------------------------------------------+
>    | Index              | Capability Identifier                        |
>    +--------------------+----------------------------------------------+
>    | :notification      | urn:ietf:params:netconf:capability:          |
>    |                    | notification:1.0                             |
>    |                    |                                              |
>    | :interleave        | urn:ietf:params:netconf:capability:          |
>    |                    | interleave:1.0                               |
>    +--------------------+----------------------------------------------+
>
>   It seems like you more or less completely ignored my comment that I
>   posted to the netconf list on 24th of January. I have attached that
>   posting to this email.
>   Pls check and review and let me know what you think about that.
>
> Pls also see my other email w.r.t. Andy Biermans comment "BUG in
> notificatio-11 XSD"
> I am doing more review
>
> Bert Wijnen
>
> > -----Oorspronkelijk bericht-----
> > Van: Sharon Chisholm [mailto:[email-masked]]
> > Verzonden: dinsdag 19 februari 2008 22:20
> > Aan: Bert Wijnen - IETF
> > Onderwerp: RE: Notification Pre-release of -12 (take 2)
> >
> >
> > Hi
> >
> > Attached. I generally don't make this one available to the list since it
> > might get confused with the real -12.
> >
> > Sharon
> >
> > -----Original Message-----
> > From: Bert Wijnen - IETF [mailto:[email-masked]]
> > Sent: Tuesday, February 19, 2008 4:16 PM
> > To: Chisholm, Sharon (CAR:ZZ00)
> > Subject: RE: Notification Pre-release of -12 (take 2)
> >
> > Could you send me also the plain text (withoput the change-vars or
> > changes.
> > Just the draft as you would submit it?
> >
> > Bert Wijnen
> >
> > > -----Oorspronkelijk bericht-----
> > > Van: [email-masked]
> > > [mailto:[email-masked]]Namens Sharon Chisholm
> > > Verzonden: maandag 18 februari 2008 19:32
> > > Aan: Netconf
> > > Onderwerp: Notification Pre-release of -12 (take 2)
> > >
> > >
> > > Hi
> > >
> > > Based on some feedback from Bert, I have modified the IANA
> > > considerations section a bit. See attached.
> > >
> > > Sharon Chisholm
> > > Nortel
> > > Ottawa, Ontario
> > > Canada
> > >
> >
>

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: "Sharon Chisholm" <[email-masked]>
Date: Sun, 24 Feb 2008 18:56:09 -0500

Hi

The netconf.xsd stuff is just the schemaLocation value. I don't think we
really need to talk about it. It is defined in the Schema in section
3.4.

Sharon 

-----Original Message-----
From: Bert Wijnen - IETF [mailto:[email-masked]] 
Sent: Wednesday, February 20, 2008 10:27 AM
To: Chisholm, Sharon (CAR:ZZ00); Hector Trevino (htrevino)
Cc: Netconf
Subject: Notification Pre-release of -12 (take 2)

I admit that for the netconf.xsd (appendix B of RFC4741) the situation
is the same (or maybe even worse, because the string netconf.xsd does
not occur in RFC4741 at all; only schema:netconf exists, but only in the
IANA considerations section, nowhere else.)

I find it a bit strange if this is the way to find out where an an XSD
of a specific name is defined.

I also note that I do not find the string schema:notification in the
ntotications draft....

I guess I am just totally lost/confused ... sure it shows how bad my
XML/XSD skills are. Sorry for that.

Bert Wijnen

>    |                    | notification:1.0
|
>    |                    |
|
>    |                    | interleave:1.0
|
> > Attached. I generally don't make this one available to the list 
> > since it might get confused with the real -12.
> >
> > Sharon
> >