Subject: Re: [Netconf] FW: DISCUSS and COMMENT: draft-ietf-netconf-notification

From: "tom.petch" <[email-masked]>
Date: Thu, 10 Apr 2008 14:58:58 +0200

Bottom posting
Tom Petch

----- Original Message -----
From: "Bert Wijnen - IETF" <[email-masked]>
To: "Sharon Chisholm" <[email-masked]>; "Hector Trevino (htrevino)"
<[email-masked]>
Cc: "Netconf" <[email-masked]>
Sent: Friday, March 28, 2008 1:18 AM
Subject: [Netconf] FW: DISCUSS and COMMENT: draft-ietf-netconf-notification

> OK, so I propose this is one thing to be fixed by the authors
> (together with the otehr things that need fixing).
>
> Bert Wijnen
>
> -----Oorspronkelijk bericht-----
> Van: Romascanu, Dan (Dan) [mailto:[email-masked]]
> Verzonden: donderdag 27 maart 2008 20:55
> Aan: Sharon Chisholm; Pasi Eronen; [email-masked]
> CC: [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Onderwerp: RE: DISCUSS and COMMENT: draft-ietf-netconf-notification
>
>
> From the argumentation that Pasi made in the telechat, it looks like the
> practice of referring schemas with URLs is not used in RFCs, as it leads
> to potentially high traffic on servers. Specifically Pasi wrote the
> following:
>
> ------------------
>
> To give more background: a very long time ago, W3C decided to use http
> URIs for HTML DTD/schema names; today, they're seeing "up to 130 million
> requests per day, with periods of sustained bandwidth usage of 350Mbps":
>
> http://www.w3.org/blog/systeam/2008/02/08/w3c_s_excessive_dtd_traffic
>
> In the case of netconf-notification, there's doesn't seem to be any
> advantage in using http URIs (compared to the "urn:ietf:params:xml:..."
> URNs that all current RFCs
> use): no valid NETCONF implementation will ever need to download the
> schema from IANA. Therefore, I don't think we should take a risk by
> trying something totally new here.
>
>
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] On
> > Behalf Of Sharon Chisholm
> > Sent: Thursday, March 27, 2008 9:45 PM
> > To: Pasi Eronen; [email-masked]
> > Cc: [email-masked];
> > [email-masked];
> > [email-masked]; [email-masked]
> > Subject: RE: DISCUSS and COMMENT: draft-ietf-netconf-notification
> >
> > Hi
> >
> > I assume you are referring to the following:
> >
> >      <!-- import base netconf definitions -->
> >      <xs:import namespace="urn:ietf:params:xml:ns:netconf:base:1.0"
> >        schemaLocation=
> >
> > "http://www.iana.org/assignments/xml-registry/schema/netconf.xsd"/>
> >
> >
> > Is there a specific issue with this? The link works.
> >

This has seriously challenged my understanding of XSD:-(

If this is the fragment that Pasi(?) is referring to, then the namespace name is
a urn:, not a http:.  schemaLocation is not the namespace name but a hint as to
its location, which should be dereferencable so that ftp: or tftp: or ?telnet:
would do but the use of urn: seems odd (although that is what EPP, ipfix and
IRIS use while ForCES uses http:).

Or is he referring to
    xmlns="http://example.com/event/1.0"
just higher up in the I-D?  It's an example!

Neither make sense to me.

And at least the Apps ADs should know that there has been a substantial
discussion about http: namespace names leading to
 draft-duerst-iana-namespace-00.txt
which seemed well received and, in the course of discussing which, the question
of traffic generated came up, to which Tim Bray responded
"Yeah, it's true and it's potentially a problem.  In the case of the
W3C it's not XML namespace URIs, it's XML DTD system identifiers in the
<!DOCTYPE of HTML files... certain moronic software authors, for reasons best
known to themselves, issue a GET on the stupid thing (which is *large*) every
time they process an HTML instance.    I haven't heard reports of this happening
on XML namespace names though."

I have great respect for the knowledge of the IESG but on this occasion, I
remain puzzled.

Tom Petch

> > For expressing the restrictions on stopTime/startTime in the
> > XSD, can you propose specific syntax?
> >
> > Sharon
> >
> > -----Original Message-----
> > From: Pasi Eronen [mailto:[email-masked]]
> > Sent: Thursday, March 27, 2008 9:48 AM
> > To: [email-masked]
> > Cc: [email-masked];
> > [email-masked]; Chisholm,
> > Sharon (CAR:ZZ00); [email-masked]; [email-masked]
> > Subject: DISCUSS and COMMENT: draft-ietf-netconf-notification
> >
> > Discuss:
> > The schema "import" statements have HTTP URLs pointing to
> > www.iana.org.
> > I don't think any IETF XML schema has done this before?
> >
> > Comment:
> > The restrictions "[replayLogCreationTime] MUST be present if
> > replay is supported" could be expressed in XML schema,
> > instead of just documentation. Ditto for "[stopTime] must be
> > used with startTime".
> >
> >
>
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf

_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

---

From: "tom.petch" <[email-masked]>
Date: Thu, 10 Apr 2008 14:58:58 +0200

Bottom posting
Tom Petch

----- Original Message -----
From: "Bert Wijnen - IETF" <[email-masked]>
To: "Sharon Chisholm" <[email-masked]>; "Hector Trevino (htrevino)"
<[email-masked]>

Or is he referring to

Tom Petch

---

From: Phil Shafer <[email-masked]>
Date: Thu, 10 Apr 2008 22:48:46 -0400

>> to potentially high traffic on servers. Specifically Pasi wrote the

Pasi is mixing two different issues.  The w3 issues was DTDs, which
are concrete things and should be retrievable.  Moronic application
fetching the xhtml dtd east w3c bandwidth.

Namespace URI are not concrete things, are not retrievable and
won't eat bandwidth.  There is no risk here.

Not that there's any strong reaons for this to diverge from
the URN style we used in the original NETCONF spec.  Mixing
the two seems strange.

Thanks,
 Phil

---

From: Phil Shafer <[email-masked]>
Date: Thu, 10 Apr 2008 22:48:46 -0400

Thanks,
 Phil