Subject: [Netconf] overlapping nodes within a lock

From: Andy Bierman <[email-masked]>
Date: Fri, 30 Jan 2009 10:37:02 -0800

Hi,

I don't think the draft is clear on how
nested nodes are handled.  Full XPath is
not even required:

   <select>/foo/bar</select>
   <select>/foo</select>
   <select>/foo/bar/leaf</select>

I'm not sure what it means to properly process
this request.  Is it OK if an implementation prunes
overlapping nodes in the request?  So the response
(and internal lock) will look like this:

   <locked-node>/foo</locked-node>

Since this is all part of 1 lock, it should be OK.

Andy

_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

---

From: WashamFan <[email-masked]>
Date: Sat, 31 Jan 2009 19:17:58 +0800

Hi,
> Since this is all part of 1 lock, it should be OK.
IMO, it should be OK, since all <select>s are granted a single lock-id, when we unlock, we unlock all of them. So the returned nodes is AND of all <select>s.

washam

---

From: WashamFan <[email-masked]>
Date: Sat, 31 Jan 2009 19:17:58 +0800

Hi,

washam