Subject: [Netconf] Does NetConf require to have an XML declaration in the script?

From: Vladlen Kot <[email-masked]>
Date: Mon, 19 Jan 2009 10:09:29 -0800

Hello there,

I just want to confirm if XML declaration
        <?xml version="1.0" encoding="UTF-8"?>
is a Required (MUST be) part when sending NetConf message OR is it an Optional?

I can not find anything that says: "It's a MUST to be" (in the NetConf docs) but one of our guys raising it as a High priority Issue.

Thanks,
Vlad

Hello there,

I just want to confirm if XML declaration
        <?xml version="1.0" encoding="UTF-8"?>
is a Required (MUST be) part when sending NetConf message OR is it an Optional?

I can not find anything that says: "It's a MUST to be" (in the NetConf docs) but one of our guys raising it as a High priority Issue.

Thanks,
Vlad

_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

---

From: "James Balestriere (jbalestr)" <[email-masked]>
Date: Tue, 20 Jan 2009 07:27:19 +0800

Hi Vlad,
 
If I recall the discussion we had on this alias a few months ago
correctly, Netconf does not have an explicit requirement,
but, hidden in the XML language spec is something which implies it is
optional. So I think the implication for NETCONF is
that the declaration is optional.
 
James.

________________________________

From: [email-masked] [mailto:[email-masked]] On
Behalf Of Vladlen Kot
Sent: Tuesday, January 20, 2009 5:09 AM
To: [email-masked]
Subject: [Netconf] Does NetConf require to have an XML declaration in
thescript?

Hello there,

is a Required (MUST be) part when sending NetConf message OR is it an
Optional? 

I can not find anything that says: "It's a MUST to be" (in the NetConf
docs) but one of our guys raising it as a High priority Issue.

Thanks,

Vlad