Subject: [Netconf] partial lock errors

From: Andy Bierman <[email-masked]>
Date: Tue, 27 Jan 2009 05:08:15 -0800

Hi,

the draft says that an error will be returned
if any select parameter is not a node-set.
This is good.  It also says that it is an error
if a select parameter is an empty node set.

IMO, it should only be an error if the entire request
yields an empty node-set.

(A)

   <select>/a | /bogus</select>

(B)

   <select>/a</select>
   <select>/bogus</select>

Assuming that /a exists and /bogus does not,
it would be nice if both requests (A) and (B)
succeeded, instead of just (A).

Andy

_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

---

From: Martin Bjorklund <[email-masked]>
Date: Tue, 27 Jan 2009 15:00:52 +0100 (CET)

> yields an empty node-set.

I agree.

/martin

---

From: Martin Bjorklund <[email-masked]>
Date: Tue, 27 Jan 2009 15:00:52 +0100 (CET)

I agree.

/martin

---

From: Andy Bierman <[email-masked]>
Date: Tue, 27 Jan 2009 15:54:02 -0800

>> yields an empty node-set.

OK.  Can you also add a comment to stress that config=false
nodes are not part of the database.  I know 1 sentence says it,
but maybe an example that shows select(/a | /counter | /bogus)
or something like it to stress that read-only and non-existent
nodes are not errors.  They just don't contribute to the result
node-set.

Andy

---

From: Andy Bierman <[email-masked]>
Date: Tue, 27 Jan 2009 15:54:02 -0800

Andy

---

From: Balazs Lengyel <[email-masked]>
Date: Fri, 30 Jan 2009 17:28:12 +0100

Andy Bierman wrote:
> nodes are not part of the database.  

BALAZS: OK, will do

---

From: Balazs Lengyel <[email-masked]>
Date: Fri, 30 Jan 2009 17:28:12 +0100

BALAZS: OK, will do

---

From: Balazs Lengyel <[email-masked]>
Date: Fri, 30 Jan 2009 17:28:53 +0100

Hello,

> yields an empty node-set.

BALAZS: The drafts already says what you are asking for:
"If all the select expressions return an empty node set, the <error-
    tag> is 'operation-failed', and the <error-app-tag> is 'no-matches'."

The word "all" is included.

Balazs

---

From: Balazs Lengyel <[email-masked]>
Date: Fri, 30 Jan 2009 17:28:53 +0100

Hello,

Balazs

---

From: Balazs Lengyel <[email-masked]>
Date: Fri, 30 Jan 2009 18:12:07 +0100

>> nodes are not part of the database.  

On second reading I found this sentence in the draft:

"Partial locking only affects configuration data."

So I assume that addresses your concern.

Balazs

---

From: Balazs Lengyel <[email-masked]>
Date: Fri, 30 Jan 2009 18:12:07 +0100

Balazs