Subject: [Netconf] Draft Agenda for IETF #74 NETCONF Session

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Mon, 2 Mar 2009 15:27:11 +0100

Dear NETCONF WG, 

below is the draft agenda for the NETCONF WG session 
at the IETF #74. Our session will be on Tuesday after 
the lunch break at 1300-1500.

Our main focus in the session will be as usual on open issue 
discussion but we have a few additional topics.
Please send us your comments and requests concerning 
the agenda. 

The duration of the slots is not final and subject to change.
Presenters please confirm your slot.

BTW: As usual we need to organize the scribes and minute 
takers _before_ the meeting. Please help us to start the 
session on time and send us a note if you volunteer. 

Bert & Mehmet 

___________________________________________________

** Draft - 020309 **

NETCONF WG 
IETF 74, San Francisco, CA, USA

TUESDAY, March 24, 2009, 1300-1500 

   WG Chairs:
   Bert Wijnen <[email-masked]>
   Mehmet Ersue <[email-masked]>

   Scribes (IF no_volunteers THEN wait_forever) 
   Agenda bashing (2 minutes) 
   WG status review (5 minutes) 

   Chartered items:

      1. NETCONF Monitoring Schema - Mark Scott (15 minutes)  
          draft-ietf-netconf-monitoring
      2. Partial Lock RPC for NETCONF - Balazs Lengyel (15 minutes) 
         draft-ietf-netconf-partial-lock 
      3. 4741bis-draft - M. Bjorklund/J. Schönwälder (20 minutes)
          draft-ietf-netconf-4741bis
      4. With-defaults capability for NETCONF - B. Lengyel (20 minutes)
          draft-bierman-netconf-with-defaults

   Non-Chartered items:

      1. Robust Configuration Management within NETCONF - R. Cole/D. Romascanu (15 minutes)  
          draft-cole-netconf-robust-config-00

   Open mike 
      Generic solution for the message identity issue (10 minutes)
      Any other topics to discuss? 

   AOB

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Mon, 2 Mar 2009 17:14:36 +0100

Dear All,
 
please find an update of the NETCONF session agenda.
 
PS: The duration of the slots is subject to change. 
Presenters please confirm your slot. 
 
Mehmet 
________________________________________
 
** Draft - 020309 **
 
NETCONF WG 

   WG Chairs:

   Chartered items:
 
      1. Partial Lock RPC for NETCONF - Balazs Lengyel (5 minutes) 
         draft-ietf-netconf-partial-lock 
      2. NETCONF Monitoring Schema - Mark Scott (15 minutes)  
          draft-ietf-netconf-monitoring
      3. With-defaults capability for NETCONF - A. Bierman/B. Lengyel (20 minutes)
          draft-ietf-netconf-with-defaults
      4. 4741bis-draft - M. Bjorklund/J. Schönwälder (20 minutes)
          draft-ietf-netconf-4741bis
 
   Non-Chartered items:
 
      1. Generic solution for the message integrity issue (10 minutes)
      2. Robust Configuration Management within NETCONF - R. Cole/D. Romascanu (15 minutes)  
          draft-cole-netconf-robust-config-00
 
   Open mike 
 
   AOB

________________________________

	From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Ersue, Mehmet (NSN - DE/Munich)
	Sent: Monday, March 02, 2009 3:27 PM
	To: Netconf
	Subject: [Netconf] Draft Agenda for IETF #74 NETCONF Session

	Dear NETCONF WG, 

	Bert & Mehmet 

	** Draft - 020309 ** 

	NETCONF WG 

	   WG Chairs: 

	   Chartered items: 

	   Non-Chartered items: 

	   Open mike 

	   AOB

---

From: Andy Bierman <[email-masked]>
Date: Mon, 02 Mar 2009 08:30:34 -0800

> Presenters please confirm your slot.

I requested a short time slot to discuss
draft-bierman-netconf-module-00.txt.
In general, the WG needs to deal with the emergence
of YANG and DSDL, and the pervasiveness of XSD.

How will the NETCONF protocol operations be augmented to
support with-defaults or any other extension in the future?
The WG should have a plan going forward to deal with all 3 formats.
It appears that the WG is going to continue to use XSD
for normative syntax, YANG for non-normative syntax, and
unclear what role DSDL has at all.

> Mehmet

Andy

>    Bert Wijnen <[email-masked] <mailto:[email-masked]>>
>    Mehmet Ersue <[email-masked] <mailto:[email-masked]>>
>  
>     ------------------------------------------------------------------------
>     *From:* [email-masked] [mailto:[email-masked]]
>     *On Behalf Of *ext Ersue, Mehmet (NSN - DE/Munich)
>     *Sent:* Monday, March 02, 2009 3:27 PM
>     *To:* Netconf
>     *Subject:* [Netconf] Draft Agenda for IETF #74 NETCONF Session
> 
> 
>     Dear NETCONF WG,
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf

---

From: Ladislav Lhotka <[email-masked]>
Date: Mon, 02 Mar 2009 18:04:12 +0100

> of YANG and DSDL, and the pervasiveness of XSD.

I don't agree that XSD is pervasive, in the XML world the discussion
about XSD versus RELAX NG is essentially over - in favor of the latter.
Also, both XSD and RNG are designed to express only grammar and datatype
constraints, so Schematron will be needed for all kinds of semantic
rules. Here I see a clear advantage of DSDL as a coordinated set of
standards.

> unclear what role DSDL has at all.

Data modeling: It may be argued that XSD is better than RNG for this
purpose, but we have YANG.

Validation of XML instance data: XSD by itself is no match for DSDL.

Lada

-- 
Ladislav Lhotka, CESNET
PGP Key ID: E74E8C0C

---

From: Andy Bierman <[email-masked]>
Date: Mon, 02 Mar 2009 09:48:57 -0800

> Validation of XML instance data: XSD by itself is no match for DSDL.

I am not debating that RNG has better validation features than XSD,
or whether the "XML world" prefers RNG over XSD.  I am not taking
a position one way or the other on that.  (DSDL is more than RNG, BTW.)

I am pointing out that in the OPS-NM area of the IETF, XSD
is still quite prevalent.  It also appears from my ad-hoc selection
of I-Ds to read off the IETF-announce list, that XSD is still the
language used to define XML syntax for protocols (operations and data).

Either none of these people got the memo on the evils of XSD,
or XSD suites their needs, they already know XSD, and see no reason
to change right now.

It seems to me that the IETF needs to recognize that simply
mandating use of DSDL (by writing some charter text) is not
going to work.  I'm waiting to hear Plan B.

Andy

---

From: Martin Bjorklund <[email-masked]>
Date: Mon, 02 Mar 2009 20:36:31 +0100 (CET)

> unclear what role DSDL has at all.

I think we have no other options right now - XSD must be normative,
but hopefully YANG will be normative for future extensions.  The DSDL
schemas fall out of the YANG modules.

I also think that the XSD in 4741 tries to be somewhat extensible, but
it's not extensible enough to handle all our current capabilities.

I think a solution to this could be that we state - in text - that the
XSD defines the 4741 schema only, and new capabilities are free to
extend this in any way they like.

The alternative of making the XSD open enough (to handle at least all
current capabilities) would make it very complex, and we might not
even succeed.

/martin

---

From: Ladislav Lhotka <[email-masked]>
Date: Mon, 02 Mar 2009 20:54:12 +0100

> schemas fall out of the YANG modules.

IMO, the NETCONF protocol and RPC vocabulary is outside the scope of
YANG. For example, YANG doesn't allow to model XML attributes.

> current capabilities) would make it very complex, and we might not

The schemas in draft-lhotka-netconf-relaxng-00 do exactly that.

Lada

-- 
Ladislav Lhotka, CESNET
PGP Key ID: E74E8C0C

---

From: Andy Bierman <[email-masked]>
Date: Mon, 02 Mar 2009 12:06:34 -0800

> schemas fall out of the YANG modules.

this is good; is this the official OPS-NM area policy,
a NETCONF/NETMOD policy, just a NETMOD policy,
or just wish-full thinking?

> current capabilities) would make it very complex, and we might not

One obvious solution to the 'role of DSDL' question
is to start including non-normative DSDL in addition
to all the non-normative YANG, for all NETCONF/NETMOD documents.

However, this assumes there is enough expertise to write
these modules, and to review them.  Simply trusting the
pyang conversion of YANG to DSDL might be good enough
for now, but not in the long run.  But nobody is going
to learn DSDL if they never see it.

At this point, YANG and DSDL are both merely implementation
choices, and XSD is not.  Although I favor the YANG
implementation choice, I think DSDL and YANG should both
be included in all NETCONF/NETMOD documents.

Andy

---

From: Ladislav Lhotka <[email-masked]>
Date: Mon, 02 Mar 2009 21:37:27 +0100

> these modules, and to review them.  Simply trusting the

As much as I like DSDL, it won't IMO have much sense to include it as
non-normative, perhaps except special cases like datatype libraries.
Hancrafted schemas may be in conflict with the normative YANG module and
those automatically generated will be too long and not very readable for
anything but trivial modules. Someone wanting to do validation should be
able take the YANG module and translate it automatically to the
validation schemas. This is possible now for RELAX NG and will be soon
for Schematron and DSRL.

> be included in all NETCONF/NETMOD documents.

I think DSDL should be ultimately used as normative for NETCONF and YANG
for NETMOD.

Lada

-- 
Ladislav Lhotka, CESNET
PGP Key ID: E74E8C0C

---

From: Andy Bierman <[email-masked]>
Date: Mon, 02 Mar 2009 13:26:18 -0800

> I think DSDL should be ultimately used as normative for NETCONF and YANG

I don't see how that could ever happen unless DSDL
works its way into the skill sets of the IETF community.

Going from no DSDL anywhere to only DSDL everywhere
(for normative XML) is not realistic.

Andy

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Tue, 3 Mar 2009 16:10:16 +0100

Hi Andy,

I don't have any issues to have a slot for the I-D 
draft-bierman-netmod-netconf-module-00.txt.

As far as I can see the draft defines the NETCONF 
model in YANG. The questions you are raising below 
are not discussed in the document in detail.

I think we should have some more discussion on 
the document content to measure the interest of 
the WG.

Though IMO we should avoid a new discussion on 
"which language is better". I think we had already 
sufficient discussion on this during NETMOD 
preparation with some conclusion.

Mehmet

> -----Original Message-----
> From: ext Andy Bierman [mailto:[email-masked]] 
> Sent: Monday, March 02, 2009 5:31 PM
> To: Ersue, Mehmet (NSN - DE/Munich)
> Cc: Netconf
> Subject: Re: [Netconf] Draft Agenda for IETF #74 NETCONF Session
> 
> >       3. With-defaults capability for NETCONF - A. 
> Bierman/B. Lengyel 
> > (20 minutes)
> >       2. Robust Configuration Management within NETCONF - 
> R. Cole/D. 
> > Romascanu (15 minutes) 
> >           1. Robust Configuration Management within NETCONF 
> - R. Cole/D.
> >     Romascanu (15 minutes)

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Tue, 3 Mar 2009 16:11:53 +0100

> >> be included in all NETCONF/NETMOD documents.

Would this mean we will have 3 models with different 
languages in each document? I'm not in favor of trying 
to get 3 models consistent and matching to each other.
We had already issues with two languages in one document.

> (for normative XML) is not realistic.

IIRC we decided in different meetings to keep XSD as 
normative until YANG v1.0 gets published. This is a 
policy I can support.

Although DSDL seems to be beneficial for validation
I personally see many advantages for having one 
modeling language for NETCONF and NETMOD
documents. IMO we need such a strategy to increase 
the acceptance of our documents outside of IETF.

Cheers,
Mehmet

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 3 Mar 2009 16:44:50 +0100

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Andy Bierman

> this is good; is this the official OPS-NM area policy, a 
> NETCONF/NETMOD policy, just a NETMOD policy, or just 
> wish-full thinking?

Not a policy, but this is what we had in mind by the time NETMOD charter
was discussed and approved. For this reason we included in the NETMOD
charter 'standard mapping rules from YANG to the DSDL data modeling
framework (ISO/IEC 19757) with additional annotations to preserve
semantics'. 

At this point in time however, only XSD is normative and MUST be used.
If people want to include DSDL and YANG in NETCONF/NETMOD documents. for
extensions they can do it, but this is optional by now. 

Dan

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 3 Mar 2009 16:47:13 +0100

> [mailto:[email-masked]] On Behalf Of Ersue, Mehmet 

> normative until YANG v1.0 gets published. This is a policy I 
> can support.
> 

No other 'policy' is possible at this moment. 

Does anybody disagree? 

Dan

---

From: Andy Bierman <[email-masked]>
Date: Tue, 03 Mar 2009 08:07:42 -0800

> the acceptance of our documents outside of IETF.

So what is the role of DSDL in NETCONF?  None?
It is just an unrelated charter item of the NETMOD WG
to produce YANG 2 DSDL mappings?

Andy

---

From: Andy Bierman <[email-masked]>
Date: Tue, 03 Mar 2009 08:12:54 -0800

> preparation with some conclusion.

I assume the with-defaults draft will be remain on the agenda,
so the issue of how to publish the updated syntax will come up.
What are your thoughts on this subject?
How do the WG co-Chairs think the issues related to
augmentation of the NETCONF protocol should be solved?

Andy

---

From: "Bert Wijnen \(IETF\)" <[email-masked]>
Date: Tue, 3 Mar 2009 17:25:35 +0100

The role of DSDL in NETCONF is non-existent I think.

Bert
  ----- Original Message ----- 
  From: Andy Bierman 
  To: Ersue, Mehmet (NSN - DE/Munich) 
  Cc: [email-masked] 
  Sent: Tuesday, March 03, 2009 5:07 PM
  Subject: Re: [Netconf] Draft Agenda for IETF #74 NETCONF Session

  Andy

---

From: "Bert Wijnen \(IETF\)" <[email-masked]>
Date: Tue, 3 Mar 2009 17:24:54 +0100

I would think that any "updated syntax" would be in XSD.
Unfortunately... I am not sure how you do that in XSD.
Write a complete new XSD? If so, then so be it
(that is my personal view).

However... if any of those updates/extensions to NetConf will get
published AFTER we have YANG as PS (which we expect in 
September, right?) then we would do YANG I would think. 
Again, personal opinion.

Bert
  ----- Original Message ----- 
  From: Andy Bierman 
  To: Ersue, Mehmet (NSN - DE/Munich) 
  Cc: Netconf 
  Sent: Tuesday, March 03, 2009 5:12 PM
  Subject: Re: [Netconf] Draft Agenda for IETF #74 NETCONF Session

  Andy

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 3 Mar 2009 17:34:10 +0100

So, what is the exact proposal?
 
1. do YANG only betting on YANG timing with the risks of following a work-in-progress syntax, and of getting stuck because of the normative dependencies? 
2. do both XSD and YANG, maybe in separate sections, with YANG staying informative if YANG gets delayed? 
 
Dan

From: [email-masked] [mailto:[email-masked]] On Behalf Of Bert Wijnen (IETF)
Sent: Tuesday, March 03, 2009 6:25 PM
To: Andy Bierman; Ersue, Mehmet (NSN - DE/Munich)
Cc: Netconf
Subject: Re: [Netconf] Draft Agenda for IETF #74 NETCONF Session

	 
	Bert

		----- Original Message ----- 
		From: Andy Bierman <mailto:[email-masked]>  
		To: Ersue, Mehmet (NSN - DE/Munich) <mailto:[email-masked]>  
		Cc: Netconf <mailto:[email-masked]>  
		Sent: Tuesday, March 03, 2009 5:12 PM
		Subject: Re: [Netconf] Draft Agenda for IETF #74 NETCONF Session

		
		Andy

---

From: Andy Bierman <[email-masked]>
Date: Tue, 03 Mar 2009 08:38:24 -0800

> (that is my personal view).

The current XSD would need to be edited,
but of course this makes 'with-defaults'
part of 4741-bis, not a separate document.
Not a show-stopper of course, but not
what the WG wanted to do.

XSD has awful 'augment' capabilities.
You have to know in advance exactly what you are
going to need to augment, and plan for it in advance.
Or you take the pyang and yangdump approach and put
'augment points', in the form of abstract elements,
everywhere an augment could ever be used.

Neither solution is very satisfactory.

The sooner we can use YANG instead of XSD, the better.

> September, right?) then we would do YANG I would think.

I would think other documents at PS could do that,
but not a DS or Full Standard RFC.  (Not a big problem.
We have no YANG module RFCs at all, so they will
have to start out at PS anyway.)

Andy

>     *From:* Andy Bierman <mailto:[email-masked]>
>     *To:* Ersue, Mehmet (NSN - DE/Munich) <mailto:[email-masked]>
>     *Cc:* Netconf <mailto:[email-masked]>
>     *Sent:* Tuesday, March 03, 2009 5:12 PM
>     *Subject:* Re: [Netconf] Draft Agenda for IETF #74 NETCONF Session
> 
>      >>>    Bert Wijnen <[email-masked]
>     <mailto:[email-masked]> <mailto:[email-masked]>>
>      >>>    Mehmet Ersue <[email-masked]
>     <mailto:[email-masked]> <mailto:[email-masked]>>
>      >>> 
>      >>>     *From:* [email-masked]
>     <mailto:[email-masked]>
>      >> [mailto:[email-masked]]
>      >>> [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>

---

From: "Bert Wijnen \(IETF\)" <[email-masked]>
Date: Tue, 3 Mar 2009 17:55:08 +0100

For now... if people want to do XSD only, then I am fine with that.
If they want to do YANG in addition (separate section, non-normative for now), 
I am fine with that.

Bert
  ----- Original Message ----- 
  From: Romascanu, Dan (Dan) 
  To: Bert Wijnen (IETF) ; Andy Bierman ; Ersue, Mehmet (NSN - DE/Munich) 
  Cc: Netconf 
  Sent: Tuesday, March 03, 2009 5:34 PM
  Subject: RE: [Netconf] Draft Agenda for IETF #74 NETCONF Session

  Dan

------------------------------------------------------------------------------

    Bert
      ----- Original Message ----- 
      From: Andy Bierman 
      To: Ersue, Mehmet (NSN - DE/Munich) 
      Cc: Netconf 
      Sent: Tuesday, March 03, 2009 5:12 PM
      Subject: Re: [Netconf] Draft Agenda for IETF #74 NETCONF Session

      Andy

---

From: Andy Bierman <[email-masked]>
Date: Tue, 03 Mar 2009 08:57:49 -0800

Romascanu, Dan (Dan) wrote:
> */So, what is the exact proposal?/*
>  
> */1. do YANG only betting on YANG timing with the risks of following a 
> work-in-progress syntax, and of getting stuck because of the normative 
> dependencies? /*
> */2. do /**/both XSD and YANG, maybe in separate sections, with YANG 
> staying informative if YANG gets delayed? /*

IMO - (2)

There is a 3rd XSD option I didn't mention before,
which is to add 'augment points' to each of
the RPC operations in 4741-bis.  This allows
for any 'with-defaults' type of extension, forever.
Very limited augments, but easy to do, and will permit
independent document publication of the extensions.

I prefer a base document + extension RFCs, only
because of the way the IETF standards track works.
A monolithic document can cycle at Proposed Standard
status forever.

> *//* 
> */Dan/*
> *//* 

Andy

> *From:* [email-masked] [mailto:[email-masked]] *On 
> Behalf Of *Bert Wijnen (IETF)
> *Sent:* Tuesday, March 03, 2009 6:25 PM
> *To:* Andy Bierman; Ersue, Mehmet (NSN - DE/Munich)
> *Cc:* Netconf
>         <mailto:[email-masked]>>
>         <mailto:[email-masked]>>
>          >>>

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Tue, 3 Mar 2009 19:09:27 +0100

Hi All,
 
I agree with Bert. Also Martin stated the 
same a bit earlier:
 
> schemas fall out of the YANG modules.
 
Everything else would be too much effort. I 
can think on three options:
A) do XSD-only 
B) do both XSD (normative) and YANG 
C) wait on YANG
 
My preferences are A) or B) for fast publication 
of documents. The author should be allowed 
to decide whether he/she supports YANG 
model additionally. He/she might also get 
some support from YANG guys.
 
I strongly support the use of one modeling 
language in NETCONF _and_ NETMOD documents 
'in the future'. 
IMO this has different benefits, e.g. avoiding 
complexity for translations or augmentations, 
avoiding inconsistencies with two languages 
in one document, faster learning curve, 
increasing acceptance outside of IETF.

Cheers,
Mehmet 

	From: ext Romascanu, Dan (Dan) [mailto:[email-masked]] 
	Sent: Tuesday, March 03, 2009 5:34 PM
	To: Bert Wijnen (IETF); Andy Bierman; Ersue, Mehmet (NSN - DE/Munich)
	Cc: Netconf
	Subject: RE: [Netconf] Draft Agenda for IETF #74 NETCONF Session

	 
	Dan

		 
		 
		Bert

			----- Original Message ----- 
			From: Andy Bierman <mailto:[email-masked]>  
			To: Ersue, Mehmet (NSN - DE/Munich) <mailto:[email-masked]>  
			Cc: Netconf <mailto:[email-masked]>  
			Sent: Tuesday, March 03, 2009 5:12 PM
			Subject: Re: [Netconf] Draft Agenda for IETF #74 NETCONF Session

			
			Andy

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Tue, 3 Mar 2009 19:21:18 +0100

> I assume the with-defaults draft will be remain on the agenda,

Yes. with-defaults draft is a WG item and we are keen 
of hearing the status and discussing issues.

> so the issue of how to publish the updated syntax will come up.

We can have additional discussion on this during open 
mic or earlier. Let us define it later based on the results 
of the maillist discussion.

> augmentation of the NETCONF protocol should be solved?
See parallel mail.

Cheers,
Mehmet

---

From: Martin Bjorklund <[email-masked]>
Date: Tue, 03 Mar 2009 20:44:44 +0100 (CET)

Andy Bierman <[email-masked]> wrote:
> >  *work-in-progress syntax, and of getting stuck because of the normative
> >  *dependencies? /*
> > */2. do /**/both XSD and YANG, maybe in separate sections, with YANG staying
> > *informative if YANG gets delayed? /*
> 
> IMO - (2)

Suppose we do (2) - we already do that for partial locking and
monitoring, let's say we do it for 4741bis as well.

In some future, YANG becomes PS.  Now we have all those documents with
non-normative YANG models.  Do we have to re-publish them all with
normative YANG?  If not, how can a new YANG PS model reuse/extend any
of those non-normative models?

/martin

---

From: Martin Bjorklund <[email-masked]>
Date: Tue, 03 Mar 2009 20:54:08 +0100 (CET)

> going to need to augment, and plan for it in advance.

Another option could be to not use the formal XSD ways of extending
schemas at all.  Instead, we could use XSD to describe the current
schema, with no substitutionGroups etc.  And we describe this clearly
in text, i.e. we state that new capabilities may extend this schema by
informal text.  Next, when we need to define a new capability, text is
added that describes how the base _XML_ is extended.

This is the approach taken by Andy and Balazs already in the
with-defaults draft.  I think this is fine.

/martin

---

From: Andy Bierman <[email-masked]>
Date: Tue, 03 Mar 2009 12:01:35 -0800

> of those non-normative models?

You are suggesting that (in the long run) we are better
off with only normative YANG.

This implies that XSD would not be normative, and only
the YANG version would be in any NETCONF/NETMOD RFC.
Or would XSD become the non-normative appendix?

Sounds OK to me.
It may be just what we need to stop tinkering with YANG
and get it in the IESG queue already.

Andy

---

From: Andy Bierman <[email-masked]>
Date: Tue, 03 Mar 2009 12:07:56 -0800

> with-defaults draft.  I think this is fine.

This was the only part of the draft I wanted to change
(besides the scope issue raised by Phil).

I don't want every NETCONF user to be forced
to maintain their own 'doctored' version of
the schema (XSD, YANG, or DSDL).

An acceptable work-around would be if IANA or the WG
maintained online versions of the up-to-date schema.
Then (at least) everyone has the opportunity to use
the same doctored version.

Andy

---

From: Ladislav Lhotka <[email-masked]>
Date: Tue, 03 Mar 2009 21:19:43 +0100

> off with only normative YANG.

What about the XML attributes such as message-id that are turned to
elements in your YANG module for NETCONF?

> Or would XSD become the non-normative appendix?

IMO this would be only confusing and/or error-prone. If YANG is
normative, it should suffice.

> and get it in the IESG queue already.

+1

Lada

-- 
Ladislav Lhotka, CESNET
PGP Key ID: E74E8C0C

---

From: Andy Bierman <[email-masked]>
Date: Tue, 03 Mar 2009 12:41:40 -0800

> elements in your YANG module for NETCONF?

Actually, I just meant the YANG data models that
do not use XML attributes.

I think the XSD in RFC 4741 should still be normative
for the protocol itself.

IMO, using XML attributes was a mistake.
The <filter> element is a disaster, from a schema validation POV.

Andy

---

From: Ladislav Lhotka <[email-masked]>
Date: Tue, 03 Mar 2009 21:59:08 +0100

> do not use XML attributes.

I had the impression that most contributors to this thread assumed YANG
will replace the XSD in RFC 4741 and all extensions as well.

> I think the XSD in RFC 4741 should still be normative

The schema is broken, so I am very sceptical about its so called
normativeness. It happily validates PDUs that are in fact invalid
according to the text.

Lada

-- 
Ladislav Lhotka, CESNET
PGP Key ID: E74E8C0C

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Mon, 9 Mar 2009 16:42:54 +0100

Hi All,
 
I uploaded the attached draft agenda to the meeting 
material site. 
http://www.ietf.org/proceedings/09mar/agenda/netconf.txt
 
PS: As usual we need to organize the scribes and minute 
takers _before_ the meeting. Please help us to start the 
session on time and send us a note if you volunteer. 
PS2: The sequence and duration of the slots might change. 

Cheers,
Mehmet 

	From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Ersue, Mehmet (NSN - DE/Munich)
	Sent: Monday, March 02, 2009 5:15 PM
	To: Netconf
	Subject: Re: [Netconf] Draft Agenda for IETF #74 NETCONF Session

	Dear All,

	 
	Mehmet 
	 
	** Draft - 020309 **
	 
	NETCONF WG 

	   WG Chairs:

	   Chartered items:

	   Non-Chartered items:

	   Open mike 
	 
	   AOB

		Dear NETCONF WG, 

		Bert & Mehmet 

		** Draft - 020309 ** 

		NETCONF WG 

		   WG Chairs: 

		   Chartered items: 

		   Non-Chartered items: 

		   Open mike 

		   AOB

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Mon, 16 Mar 2009 20:08:09 +0100

Hi All,
 
we uploaded the agenda for the IETF #74 NETCONF 
session to the Meeting Materials site:
http://www.ietf.org/proceedings/09mar/agenda/netconf.txt
 
Cheers,
Mehmet 
 
NETCONF WG 

   WG Chairs:

   Chartered items:

      3. With-defaults capability for NETCONF - B. Lengyel (20 minutes)

   Non-Chartered items:

      1. Generic solution for the message integrity issue (15 minutes)
      2. Robust Configuration Management within NETCONF - R. Cole/D. Romascanu (15 minutes)  
         draft-cole-netconf-robust-config-00

   Open mike (15 minutes)
      Augmenting NETCONF protocol operations
      Any other topics to discuss? 

   AOB