Subject: [Netconf] Non-Netconf lock monitoring

From: WashamFan <[email-masked]>
Date: Sat, 28 Mar 2009 04:11:10 +0800

Hi,

When multiple NM protocols are supported by a device, all locks acquired via all supported protocols should be monitored in a consistent way.

We should identify each lock whatever protocol is used to control the lock. If I understand correctly, lockId is used to differentiate all locks including both Netconf and non-Netconf ones. That is good, but maybe not enough.

We still should provide some information which is expected to be used for releasing a lock by force. sessionId is used to release a Netconf lock via <kill-session>, but IIRC, 
sessionId=0 for all non-Netconf sessions. Please refer to another thread discussing
sessionId issue.

I co-author a mib draft to model multiplex protocols supported locks monitoring,, I think it 
is of value to this issue. And I want to ask if Netconf WG is a suitable place to accommodate the draft.

washam

---

From: Balazs Lengyel <[email-masked]>
Date: Mon, 30 Mar 2009 17:04:05 +0200

Hello Washam,
I agree, that the netconf monitoring draft should include both non-netconf locks, and 
non-netconf sessions.

If you write such a MIB, it should have the same structure and content as the relevant part of 
the netconf-monitoring YAM.

Balazs

WashamFan wrote:
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
> 

-- 
Balazs Lengyel                       Ericsson Hungary Ltd.
TSP System Manager
ECN: 831 7320                        Fax: +36 1 4377792
Tel: +36-1-437-7320     email: [email-masked]