Subject: [Netconf] Comment to 4741bis

From: Balazs Lengyel <[email-masked]>
Date: Fri, 13 Mar 2009 17:19:56 +0100

8.8.5.1.  <edit-config>

    The :url capability modifies the <edit-config> operation to accept
    the <url> element as an alternative to the <config> parameter.  If
    the <url> element is specified, then it should identify a local
    configuration file.

This states that the URL may identify an external location. Is this correct? Should this be 
clarified?

There is a similar - the url should identify a local file - statement for delete-config, but 
not for copy-config or for validate. Is this correct?

Balazs

---

From: Martin Bjorklund <[email-masked]>
Date: Mon, 16 Mar 2009 22:06:15 +0100 (CET)

>     the <url> element is specified, then it should identify a local

The same text is also present in 7.2, where you also find this:

      This
      operation allows the new configuration to be expressed in several
      ways, such as using a local file, a remote file, or inline.

Note the phrase "remote file".

I think the sentence "If the <url> element is specified, then it
should identify a local configuration file." should be removed.

> There is a similar - the url should identify a local file - statement for
> delete-config, but not for copy-config or for validate. Is this correct?

delete-config is different - IMO we should say that for delete-config,
the url MUST identify a local file (i.e. have url scheme 'file').  I
don't think it makes sense for NETCONF to function as a file deletion
proxy...

/martin

---

From: Balazs Lengyel <[email-masked]>
Date: Tue, 17 Mar 2009 11:07:13 +0100

I would only allow copy config towards files where either the source or target is a real 
datastore.

"I don't think it makes sense for NETCONF to function as a file deletion
proxy..."

You could make the same argument against a text-editor proxy or a file copy proxy.

The question is really do we want to support file based (URL based) datastores. If yes all I 
need is a flat file and Confd :-) Edit/Delete/Validate/Copy will work towards a flat XML file 
as well.

You could also ask the question, do we want to support, or at least allow support for such file 
based datastores?

Balazs

-- 
Balazs Lengyel                       Ericsson Hungary Ltd.
TSP System Manager
ECN: 831 7320                        Fax: +36 1 4377792
Tel: +36-1-437-7320     email: [email-masked]

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 17 Mar 2009 12:25:28 +0100

On Tue, Mar 17, 2009 at 11:07:13AM +0100, Balazs Lengyel wrote:
 
> The question is really do we want to support file based (URL based)
> datastores. If yes all I need is a flat file and Confd :-)
> Edit/Delete/Validate/Copy will work towards a flat XML file as well.
>
> You could also ask the question, do we want to support, or at least
> allow support for such file based datastores?

I find this part of RFC 4741 somewhat unclear and in particular I
think we need to clarify (i) where URLs are allowed and make sense and
(ii) where URLs are restricted to "local" file: URLs and where we like
to see support for arbitrary "remote" URLs. And I think supporting
remote URLs has some security implications that likely need to be
discussed in the security considerations.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>