Subject: [Netconf] sessionId issue

From: WashamFan <[email-masked]>
Date: Sat, 28 Mar 2009 04:09:12 +0800

Hi,

There were 2 issues:
1) sessionId=0 for all non-netconf sessions.
2) lockId is unique for all netconf locks.

After clarification wrt/ 2), now
2*) lockId is unique for all locks (including both netconf and non-netconf locks).

But, how about 1)?

sec2.1.4, monitoring-04:

   Session data pertaining to the NETCONF server.  Includes data
   for NETCONF and non-NETCONF management sessions.

sessionId is used as the key amongst sessions, but it can't be the key based on 1).

washam

---

From: Balazs Lengyel <[email-masked]>
Date: Mon, 30 Mar 2009 17:06:39 +0200

I would rather have the sessionId unique for ALL sessions as well. What to do with SNMP and 
alike that doesn't really have a session just a UDP packet is an interesting issue?
Balazs

WashamFan wrote:
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
> 

-- 
Balazs Lengyel                       Ericsson Hungary Ltd.
TSP System Manager
ECN: 831 7320                        Fax: +36 1 4377792
Tel: +36-1-437-7320     email: [email-masked]