Subject: [Netconf] comments on netconf-monitoring-04

From: Andy Bierman <[email-masked]>
Date: Wed, 11 Mar 2009 11:01:41 -0700

Hi,

There are several bugs introduced in this draft.

  - ToC IDs do not match real name (netconf-state vs. ietf-netconf-state)
  - typo in 1.1
  - def. of username: s/likely be/likely to be/
  - statistics diagram shows 'managementStatistics' as a
    child node; It is just the complexType name for the 'statistics' node
  - examples wrong (netconf-state vs. ietf-netconf-state)
  - YANG module has 'container netconf' (not ietf-netconf-state)

Comments:

  - Abstract says what this data model module provides, but
    no mention why anybody should want to retrieve it.
    (e.g., is it for debugging NETCONF protocol errors?)

  - Introduction:  says a NETCONF agent can change capabilities
    in the middle of a session.  IMO, 4741-bis needs to define
    this behavior, not netconf-monitoring.  It is not clear at
    all that this should be supported.

  - sec. 3.1 should mention that the <get-schema> operation
    is optional, and only supported if the :schema-retrieval
    capability is advertised by the agent.

  - :netconf-monitoring capability:
    Are we going to have a generic module capability AND a
    YANG module capability for every NETCONF data model?
    Can't we just use the YANG capability URI?
    The only YANG-ish detail is the 'deviations' parameter,
    which can be ignored if not used.

  - since many of my previous comments were not addressed,
    I can only assume this is the data model the WG wants
    and thinks is useful.  IMO these statistics are mostly
    useful for comparing subtree/xpath filtering behavior
    on different agents.  It is not clear to me what
    sort of protocol problems can be debugged with this data.
    (Keep in mind the session-id of the lock holder is returned
    in a failed <lock> reply, so don't count that one :-)

Andy

---

From: Andy Bierman <[email-masked]>
Date: Wed, 11 Mar 2009 11:52:32 -0700

> There are several bugs introduced in this draft.

add 1 more:
   - the new contact info in the YANG module got pasted
     inside the SessionId type-stmt, which breaks the module

> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
> 
>