Subject: [Netconf] 4741bis - error-severity

From: Martin Bjorklund <[email-masked]>
Date: Thu, 30 Apr 2009 16:02:26 +0200 (CEST)

Hi,

<error-severity> is defined to be 'error' or 'warning'.  In the list
of errors in Appendix A, 'warning' never occurs.

Also, according to the XSD, <ok> and <rpc-error> cannot be returned at
the same time, so there is no way to return <ok> and a warning at the
same time.

There are three alternatives:

   1.  remove warning

   2.  fix warning so that it works

   3.  keep warning but clarify that it doesn't work

Comments?

/martin

---

From: Andy Bierman <[email-masked]>
Date: Thu, 30 Apr 2009 08:25:24 -0700

>    3.  keep warning but clarify that it doesn't work

Does anybody actually implement any warnings?
If not, then (1) is good.

In order to choose (2), we would have to understand
what we mean by a 'warning', and write it down.
Maybe if we did that the first time, we would have
tossed this error-severity field.

> /martin

Andy