Subject: [Netconf] with-defaults-01

From: WashamFan <[email-masked]>
Date: Mon, 13 Apr 2009 14:10:59 +0800

Hi,

1) bullet 2, use cases for needing default values, sec1:

o  Some management applications might not have the capabilities to
    correctly parse and interpret formal data models.

IMO, the manager described above neither understands default values nor non-default values, does it? So how does this use case make sense?

2) para3, sec 2.3 & para2, sec2.5

If no 'supported' parameter is present, Does it mean the device only supports one behavior which is specified in 'basic' parameter or support all behaviors?
Since values of <with-default> are restricted to the behaviors the device supports, it should be clarified what the values that a device support for are.

washam

---

From: Andy Bierman <[email-masked]>
Date: Mon, 13 Apr 2009 04:59:57 -0700

> Since values of <with-default> are restricted to the behaviors the device supports, it should be clarified what the values that a device support for are.

This 'standard' is completely useless unless 'report-all'
is mandatory-to-implement.

> washam

Andy