Subject: [Netconf] remove partial-operation error-tag from 4741bis

From: Andy Bierman <[email-masked]>
Date: Sat, 23 May 2009 16:17:28 -0700

Hi,

I would like the 'partial-operation' error-tag
to be removed from NETCONF.  I am not sure if it
has been widely implemented, but IMO it is not
worth implementing.  The data type of the
parameters (QName) is totally wrong, as Martin
has already pointed out.

This error-tag is very CLI-centric and does not
really make sense in a NETCONF database, potentially
full of interconnected nodes.  It is very possible
that the XML PDUs will not be treated as a serialized
list of 'commands'.  Since NETCONF has no real
processing model, it is not clear if any agent
really has to implement this error-tag anyway.
(ARCH? We don't seem to need one of those ;-)

Either remove 'partial-operation' or fix it.
Fixing it means changing QName to instance-identifier
and clearly defining a PDU processing model for
arbitrary hierarchical data, such that every compliant
agent implementation can be expected to produce consistent
partial-operation error reports.

Andy

---

From: Martin Bjorklund <[email-masked]>
Date: Sun, 24 May 2009 16:42:48 +0200 (CEST)

Andy Bierman <[email-masked]> wrote:
> to be removed from NETCONF.

+1

I can see that it could have been useful, but if noone has implemented
it so far, I think it is evidence that it wasn't as useful as it was
thought to be.

/martin