Subject: [Netconf] FW: New Version Notification for draft-ietf-netconf-monitoring-05

From: "Mark Scott" <[email-masked]>
Date: Thu, 25 Jun 2009 11:05:13 -0400

Hello,

A new version (v5) of the NETCONF Monitoring Schema draft has been posted.

This version addresses action items from IETF74 and comments received on v4.  Changes include:
- updated statistics (and counter definitions) per offline discussion:
	- updated counter definitions
	- updated data types  (addition of ZeroBasedCounter32)
	- per session counters;  see section 2.1.4
	- global counters;  see section 2.1.5
- unique sessionId handling and WG consensus:
	- expected handling of NETCONF and non-NETCONF sessions defined
	- explicit exclusion of sessionId=0 added
	- see section 2.1.4
- removal of subscriptions subtree;  was sec 2.1.5 in v4
- revised XSD and YANG models

Thank you to all who provided comments and participated in the offline discussions.

Please direct all comments on this new version to the ML for further consideration.

cheers,
Mark

-----Original Message-----
From: IETF I-D Submission Tool [mailto:[email-masked]] 
Sent: Thursday, June 25, 2009 10:52 AM
To: Scott, Mark (CAR:2N00)
Cc: Chisholm, Sharon (CAR:ZZ00); [email-masked]
Subject: New Version Notification for draft-ietf-netconf-monitoring-05 

A new version of I-D, draft-ietf-netconf-monitoring-05.txt has been successfuly submitted by Mark Scott and posted to the IETF repository.

Filename:	 draft-ietf-netconf-monitoring
Revision:	 05
Title:		 NETCONF Monitoring Schema
Creation_date:	 2009-06-24
WG ID:		 netconf
Number_of_pages: 43

Abstract:
This document defines a NETCONF data model (in XML Schema) to be used
to monitor the NETCONF protocol.  The monitoring data model includes
information about NETCONF datastores, sessions, locks and statistics.
This data facilitates the management of a NETCONF server.  This
document also defines methods for NETCONF clients to discover data
models supported by a NETCONF server and defines a new NETCONF <get-
schema> operation to retrieve them.

The IETF Secretariat.

---

From: Balazs Lengyel <[email-masked]>
Date: Fri, 26 Jun 2009 18:27:54 +0200

Hello Mark,
Some comments:
General)
I think we should not exclude the possibility of monitoring non-netconf sessions in this schema.

2.1.2) "The /netconf-state/datastores subtree contains configuration data"
This seems to indicate it contains writable data. I know that was not your intention, so please 
reword.

Some changes to the paragraph starting with "For partial locks the list":
For partial locks the list of locked nodes and the select expressions originally used to 
request the lock are returned. The scope of the partial lock is defined by the list of locked 
nodes. This list might change during the lifetime of the lock.
The select expressions indicate the original intended scope of the lock.

Ch 2.1.3)
YIN should be added as a format.
s/One of more locations/Zero one of more locations/

2.1.4) in several places you use "a <rpc> message was expected"
Who expects it? Does the device know that an <edit-config> should be arriving at 7:00 PM? :-) 
Rather remove the expected part.

2.1.5) Please indicate if droppedSessions includes session closed due to parseErrors.

3.1)
- One XML error, search for ><
- negative response missing

3.2)
- s/schema may be supported in multiple locations/schema may be available in multiple locations/
- first paragraph last sentence is trivial, remove it.
- Why do you have a negative response section here? Does this belong to 3.1?

5) didn't check XSD. How about generating it automatically from YANG? That would more or less 
remove the need to review it.

9) Include non-normative references for yang and yang-types

Appendix)
- location should be a leaf-list not a leaf
- get-schema output: if we have a YANG schema will it will be a string not any XML
- the level of descriptions is uneven in this YAM

Balazs

Mark Scott wrote:
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
> 

-- 
Balazs Lengyel                       Ericsson Hungary Ltd.
System Manager
ECN: 831 7320                        Fax: +36 1 4377792
Tel: +36-1-437-7320                  email: [email-masked]

---

From: WashamFan <[email-masked]>
Date: Sat, 27 Jun 2009 10:02:17 +0800

Hi,

>  The select expressions indicate the original intended scope of the lock.

How to understand "This list might change during the lifetime of the lock."?
What the list herein refer to? IMO, the list of locked nodes to which 
the original XPath expressions evaluate at the first time WONT change.
But the list of nodes to which the original XPath expressions evaluate
during the lifetime of the lock MIGHT change. I think we should spell
out it.

washam

---

From: Balazs Lengyel <[email-masked]>
Date: Mon, 29 Jun 2009 11:51:35 +0200

Ok, lets make it even more explicit.
The __list of locked nodes__ might change as indicated in partial-lock chapter 1.1 and also 2.4.1.
Balazs