Subject: [Netconf] FW: I-D Action:draft-ietf-netconf-monitoring-06.txt

From: "Mark Scott" <[email-masked]>
Date: Mon, 13 Jul 2009 10:22:39 -0400

Hello,

A new version (v6) of the NETCONF Monitoring Schema draft has been
posted.

Changes include:
- replaced references to 'schema-retrieval capability' with
'<get-schema> operation'	
- upper/lowercase alignment on references to 'format' in text and models
- changed negative response for <get-schema> to 'data-missing'
- ML comments on v05 which required changes in the draft:
  o 2.1.2:  reworded to avoid suggestion that configurable data was
contained in the sub-tree (per Balazs' request)
  o 2.1.2:  reworded paragraph partial lock and select statements (per
Balazs' suggested text)
  o Fixed examples in 3.1 and added negative response (per Balazs'
comment)
  o YANG:  location changed to leaf-list (per Balazs' comment)
  o added non-normative references to yang and yang-types (per Balazs'
comment)
  o 2.1.3:  added YIN and RNC to format 'enums' text and models
- other comments discussed/answered on ML

Thank you to all who provided comments.

Please direct comments on this version to the ML for further
consideration.

cheers,
Mark

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of [email-masked]
Sent: Monday, July 13, 2009 10:15 AM
To: [email-masked]
Cc: [email-masked]
Subject: [Netconf] I-D Action:draft-ietf-netconf-monitoring-06.txt

A New Internet-Draft is available from the on-line Internet-Drafts
directories.
This draft is a work item of the Network Configuration Working Group of
the IETF.

	Title           : NETCONF Monitoring Schema
	Author(s)       : M. Scott, et al.
	Filename        : draft-ietf-netconf-monitoring-06.txt
	Pages           : 42
	Date            : 2009-07-13

This document defines a NETCONF data model (in XML Schema) to be used to
monitor the NETCONF protocol.  The monitoring data model includes
information about NETCONF datastores, sessions, locks and statistics.
This data facilitates the management of a NETCONF server.  This document
also defines methods for NETCONF clients to discover data models
supported by a NETCONF server and defines a new NETCONF <get-
schema> operation to retrieve them.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-netconf-monitoring-06.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Balazs Lengyel <[email-masked]>
Date: Mon, 13 Jul 2009 20:20:33 +0200

Hello Mark, Martin,

4.2.)
  <rpc-reply message-id="102"
     xmlns="urn:ietf:params:xml:ns:netconf:base:1.0">
     <data xmlns="urn:ietf:params:xml:ns:netconf:state">
       <xs:schema>
         <!-- bar version 2008-06-01 yang module would be
         returned here -->
        </xs:schema>
     </data>
   </rpc-reply>

This is invalid XML as the prefix xs is not defined.
I also strongly think that "xs:schema" is a very misleading container for a YANG module, or 
anything other then a true XML Schema. So please remove the xs:schema tags. The yang module 
should be placed immediately inside <data>

Balazs

---

From: Andy Bierman <[email-masked]>
Date: Mon, 13 Jul 2009 11:40:54 -0700

>         <!-- bar version 2008-06-01 yang module would be

This is also incorrect wrt/ YANG encoding.
There is no <xs:schema> node inside the <data> node.

   <data>
     module bar {

     }
   </data>

The <xs:schema> node would be the top-level node
of the content if the format was XSD, not YANG.

> I also strongly think that "xs:schema" is a very misleading container
> for a YANG module, or anything other then a true XML Schema. So please
> remove the xs:schema tags. The yang module should be placed immediately
> inside <data>
> 
> 
> Balazs

Andy

---

From: "Mark Scott" <[email-masked]>
Date: Mon, 13 Jul 2009 14:47:48 -0400

Agreed - the YANG example will be corrected.

Suggest we remove the top-level node completely and rely on the contents
of <data> solely.  I.e. XML Schema will include the <xs:schema> anyway,
YANG will include module, etc.

Unless anyone can articulate the need for a generic top-level <schema>
(minus xs:) node for all formats.

Comments?

Mark

-----Original Message-----
From: Andy Bierman [mailto:[email-masked]] 
Sent: Monday, July 13, 2009 2:41 PM
To: Balazs Lengyel
Cc: Scott, Mark (CAR:2N00); Martin Bjorklund; [email-masked]
Subject: Re: [Netconf] FW: I-D
Action:draft-ietf-netconf-monitoring-06.txt

   <data>
     module bar {

     }
   </data>

Andy

---

From: Martin Bjorklund <[email-masked]>
Date: Mon, 13 Jul 2009 21:53:34 +0200 (CEST)

> Agreed - the YANG example will be corrected.

There are two faulty examples in 4.2; 2.b and 3.a.

> YANG will include module, etc.

Yes, that is what the XSD and YANG module specifies today, it is just
the YANG examples that are wrong.

/martin

---

From: Martin Bjorklund <[email-masked]>
Date: Mon, 13 Jul 2009 21:58:47 +0200 (CEST)

> the YANG examples that are wrong.

Aha, ok, the XSD should use xs:any, not xs:anytype as it does
today.

/martin

---

From: Martin Bjorklund <[email-masked]>
Date: Mon, 13 Jul 2009 23:16:28 +0200 (CEST)

> Aha, ok, the XSD should use xs:any, not xs:anytype as it does

Maybe I am confused.  When I use the current definition,

  <xs:element name="data" type="xs:anyType" />

xmllint accepts  both:

   <data>
     <xs:schema>
       ...
     </xs:schema>
   </data>

and

  <data>
    module foo {
      ...
    }
  </data>

So, either the current XSD is fine, or xmllint is wrong.

/martin

---

From: "Mark Scott" <[email-masked]>
Date: Mon, 13 Jul 2009 17:39:26 -0400

I've seen conflicting information stating xs:AnyType restricts to known
W3C types and other suggesting that any freeform XML/text is allowed.

So honestly I don't know which is most correct here but my preference is
to stick with xs:anyType (current definition).

I'm updating v7 accordingly with new YANG examples but leaving the XSD
as is.

Mark

-----Original Message-----
From: Martin Bjorklund [mailto:[email-masked]] 
Sent: Monday, July 13, 2009 5:16 PM
To: Scott, Mark (CAR:2N00)
Cc: [email-masked]
Subject: Re: [Netconf] FW: I-D

xmllint accepts  both:

   <data>
     <xs:schema>
       ...
     </xs:schema>
   </data>

and

  <data>
    module foo {
      ...
    }
  </data>

/martin