Subject: [Netconf] with-defaults clarification

From: Andy Bierman <[email-masked]>
Date: Thu, 30 Jul 2009 10:05:45 -0700

Hi,

I think the with-defaults draft should be clarified to
indicate that the <with-defaults> parameter is ignored
for <copy-config> if the target of the copy operation
is the candidate or running databases.

Andy

---

From: Phil Shafer <[email-masked]>
Date: Thu, 30 Jul 2009 13:00:59 -0400

>is the candidate or running databases.

Doesn't it say the opposite, that it's only legal for files/urls?

Thanks,
 Phil

---

From: Andy Bierman <[email-masked]>
Date: Thu, 30 Jul 2009 10:33:42 -0700

> Doesn't it say the opposite, that it's only legal for files/urls?

oops

   <copy-config> is only affected if the target of the operation is a
   URL.  If the target is a NETCONF datastore (running, candidate or
   startup) the capability has no effect.

I allow <with-defaults> for copy-config from running to startup.
It has a real impact.  If the operator really wants
the 'explicit' filtered view, then saving running to startup
will affect that.  Everything that gets saved in startup
its tagged as 'explicitly-set' the next time the agent boots.

So the operator may want to control how defaults are saved to NV-storage.

Andy

---

From: Phil Shafer <[email-masked]>
Date: Thu, 30 Jul 2009 19:36:57 -0400

>So the operator may want to control how defaults are saved to NV-storage.

I view it as an unlikely scenario that an operator will want to
waste precious nv ram on default values.   Also since readability
in config scales with the volume, a large config is more problematic
to understand, maintain, and debug.  It's a lose/lose scenario.

Thanks,
 Phil

---

From: Andy Bierman <[email-masked]>
Date: Fri, 31 Jul 2009 07:41:23 -0700

> to understand, maintain, and debug.  It's a lose/lose scenario.

I think 10 years ago, in a really router-centric world, the "precious NVRAM"
argument would be good enough.  But NV-storage is not expensive on every device,
and it should be up to the operator to decide how to use resources anyway.

If the manager wants the agent to use 'explicit' instead
or 'trim', and the agent supports both, then the
<with-defaults> parameter is the only way for the
operator to make the NV-store consistent with the
preferred view of defaults.

Another issue is the "new image reboot" scenario.
Router vendors like to claim that when they change the
default value for some parameter from 1 SW release to
the next, that it is always OK, nothing to worry about.

But an operator may want to insure that no defaults change
by not using any defaults.  This would be a debugging mode.
What if the new image doesn't work right when the box boots
with the trimmed NV-store?  Does it work better when it
boots with with the full set of values, and not the new defaults?

Andy