Subject: [Netconf] WGLC: draft-ietf-netconf-with-defaults-02

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Mon, 3 Aug 2009 23:41:33 +0200

Dear NETCONF WG, 

we had a good progress on the draft "With-defaults capability 
for NETCONF". In the NETCONF session at IETF we decided to 
bring the draft to WGLC to initiate additional discussion.

With this mail we start a WGLC for the "With-defaults capability 
for NETCONF" draft, which is planned to publish as a Proposed 
Standard RFC. The WGLC will run until August 21, 2009. 

Everybody on the NETCONF WG maillist PLEASE REVIEW the 
draft and send your comments to the NETCONF maillist. 
(http://tools.ietf.org/html/draft-ietf-netconf-with-defaults-02) 

Thank you and looking forward for your comments. 

Cheers, 
Mehmet

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Thu, 6 Aug 2009 22:48:37 +0200

[splitting the thread into two parts]

> From: ext Juergen Schoenwaelder Thursday, August 06, 2009 9:15 PM
> 
> On Thu, Aug 06, 2009 at 05:55:26PM +0200, Ersue, Mehmet (NSN 
> - DE/Munich) wrote:
>  
... 
> > I agree that if the default is '3' and the value is '3', it is
> > considered to contain the default, regardless of how it
> > was created.
> 
> This is one interpretation, but not all systems have this
> interpretation.
> 
> > The draft does not specify explicitly set (default) data
> > clearly.
> 
> This is the interpretation where 3 is the default value but there was
> an explicit management operation to set the value to 3 and thus this
> value now becomes part of the config (because it was explicitely set,
> not because of the value itself).
> 
> > How do we handle non-default values which have been
> > set explicitely, where the default is '3' but the value is
> > _not_ '3' ? Are they suppressed too?
> 
> In this model, everything explicitly set is config data - the value
> does not matter. It matters that the value was explicitely set.

Exactly. But in Chapter 1.1.2. the definition of the term 
"Explicitly set default data" focuses only on: "Data that 
is explicitly set by the NETCONF client to its default value."

I would rather add here what you are saying: 
"Everything explicitly set is config data independently of the 
fact whether it's value matches the default value or not."

The statement "Some servers MAY treat explicitly 
set default data as simple default data, as they may 
not be able to differentiate between them." is somehow 
misleading.

To get it free of confusion I would add to the definition
of the basic mode "explicit" in chapter 1.2.: 
"An agent which supports the basic mode "explicit" MUST 
support the recognition of explicitly defined data."

Mehmet

> We probably need some more text plus an example to describe these
> three models more clearly.
>
> 
> /js
> 
> -- 
> Juergen Schoenwaelder           Jacobs University Bremen gGmbH
> Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
> Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>
>