Subject: [Netconf] Database Architecture OK or NOT-OK?

From: "Bert Wijnen \(IETF\)" <[email-masked]>
Date: Sat, 1 Aug 2009 15:51:54 +0200

We (as WG chairs) have not seen much reaction to the email from Andy in which
he stated
       I wish we had time to work on the NETCONF database architecture,
       because it isn't very good.
I did respond... but noone else.

As WG chairs, we ask ALL WG participants to SPEAK UP NOW if they think we
should spend some time on this topic. If not, then we will drop it from our list
of things to do (at least for the forseeable future).

Bert and Mehmet

----- Original Message ----- 
  From: Bert (IETF) Wijnen 
  To: Andy Bierman 
  Cc: [email-masked] 
  Sent: Sunday, July 26, 2009 3:00 PM
  Subject: Re: [Netconf] Comments :draft-ietf-netconf-4741bis-01.txt

  Andy wrote:
  > I wish we had time to work on the NETCONF database architecture,
  > because it isn't very good.
  >   
  > Andy
  >   

  I wonder if others (many) feel the same?
  Because if we do believe that the db architecture is not good enough, 
  then we better think about a possible better architecture now.... 
  before we start adding all sorts of new/other things.

  speaking as a contributer
  Bert

---

From: Ladislav Lhotka <[email-masked]>
Date: Sat, 01 Aug 2009 17:23:04 +0200

Hi Bert,

I do think some time should be spent on this. To start with, it would be
useful to agree on a definition of the term "configuration datastore".
The definition in 4741bis (sec. 5.1)

"A configuration datastore is defined as the complete set of
configuration data that is required to get a device from its initial
default state into a desired operational state."

is hardly satisfactory because it depends on the notion of 'initial
default state' which is not defined and allows multiple interpretations.

I understand implementations use slightly different approaches but IMO
we can hardly talk about database architecture if the base information
set is not properly defined.

Lada

Bert Wijnen (IETF) píše v So 01. 08. 2009 v 15:51 +0200:
>         Subject: Re: [Netconf]
>         Comments :draft-ietf-netconf-4741bis-01.txt
>         
>         
>         Andy wrote:
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
-- 
Ladislav Lhotka, CESNET
PGP Key ID: E74E8C0C

---

From: Andy Bierman <[email-masked]>
Date: Sat, 01 Aug 2009 09:11:21 -0700

> I did respond... but noone else.

I regret using the over-loaded term 'architecture'.

I don't mind just focusing on details.
That's what this WG knows how to do best.

I suppose 'ad-hoc' counts as an design approach.
It's been working so well for CLI all these years.

Andy

>     *From:* Bert (IETF) Wijnen <mailto:[email-masked]>
>     *To:* Andy Bierman <mailto:[email-masked]>
>     *Cc:* [email-masked] <mailto:[email-masked]>
>     *Sent:* Sunday, July 26, 2009 3:00 PM
>     *Subject:* Re: [Netconf] Comments :draft-ietf-netconf-4741bis-01.txt
> 
>     Andy wrote:
> ------------------------------------------------------------------------
>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Sat, 1 Aug 2009 19:00:49 +0200

On Sat, Aug 01, 2009 at 03:51:54PM +0200, Bert Wijnen (IETF) wrote:

> As WG chairs, we ask ALL WG participants to SPEAK UP NOW if they
> think we should spend some time on this topic. If not, then we will
> drop it from our list of things to do (at least for the forseeable
> future).

A statement like "it isn't very good" is a bit too vague to react on
and this is why there is likely so little reaction.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Andy Bierman <[email-masked]>
Date: Sat, 01 Aug 2009 10:44:34 -0700

> and this is why there is likely so little reaction.

Yes -- in my defense it was taken out of a long email
filled with issues, some of which are still unresolved.

IMO, the FTP-mode of NETCONF is a throwback to the
CLI world, that does not fit at all with the
edit-config/commit/discard-changes model.
It is really just CLI with angle brackets.
Why would an operator bother using this 'brute force' manual
mode of NETCONF, instead of the native CLI?

Andy

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Sat, 1 Aug 2009 19:59:52 +0200

> mode of NETCONF, instead of the native CLI?

FTP-mode? I am puzzled. I am even further away from understanding the
issue.

/js

---

From: Andy Bierman <[email-masked]>
Date: Sat, 01 Aug 2009 11:43:03 -0700

> FTP-mode? I am puzzled. I am even further away from understanding the

copy-config into running and candidate are just file copy operations.
The agent is supposed to figure out what changed and only alter
those device features.  Worst case, the agent is allowed to
blow away the entire config and re-initialize every feature
with its cut-and-pasted config replacement (XML subtree).  The manager has
no idea what will really happen from agent to agent.

IMO this is not nearly as clean as the edit-config operation,
which, if used correctly, can clearly state the intent and scope
of the desired config changes.

It is just my opinion, so I don't think there are any WG issues
to resolve.

Andy

---

From: "David B Harrington" <[email-masked]>
Date: Sun, 2 Aug 2009 11:47:27 +0200

Hi,
 
You have taken a comment out of context, and have not identified the
original email where Andy made this remark.
Can you identify the original message so readers can see what Andy had
to say?
 
dbh

  _____  

From: [email-masked] [mailto:[email-masked]] On
Behalf Of Bert Wijnen (IETF)
Sent: Saturday, August 01, 2009 3:52 PM
To: [email-masked]
Subject: [Netconf] Database Architecture OK or NOT-OK?

We (as WG chairs) have not seen much reaction to the email from Andy
in which
he stated
       I wish we had time to work on the NETCONF database
architecture,
       because it isn't very good.
I did respond... but noone else.
 
As WG chairs, we ask ALL WG participants to SPEAK UP NOW if they think
we
should spend some time on this topic. If not, then we will drop it
from our list
of things to do (at least for the forseeable future).

Bert and Mehmet
 
----- Original Message ----- 

From: Bert (IETF)  <mailto:[email-masked]> Wijnen 
To: Andy Bierman <mailto:[email-masked]>  
Cc: [email-masked] 
Sent: Sunday, July 26, 2009 3:00 PM
Subject: Re: [Netconf] Comments :draft-ietf-netconf-4741bis-01.txt