Subject: [Netconf] Draft minutes for IETF #75 NETCONF session

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Thu, 6 Aug 2009 22:47:19 +0200

Dear NETCONF WG,

attached are the draft minutes for the NETCONF session 
at IETF #75.

Many thanks to Lada and Juergen for taking the minutes 
and David P for scribing and channeling the jabber room!

Please review the minutes and let us know your change 
requests or comments by August 12, 2009 EOB. Thanks.

 <<Draft_IETF 75_NETCONF Minutes.txt>> 
Mehmet & Bert

---

From: Martin Bjorklund <[email-masked]>
Date: Tue, 11 Aug 2009 11:13:31 +0200 (CEST)

Hi,

"Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]> wrote:
> ** 014: capability changes
> 
>   - AB says that the base capability version must be increase when adding new
>     error-app-tags, otherwise the existing managers will break.

I believe Andy said 'error-tag' not 'error-app-tag'.

> ** 010: namespace wildcarding
> 
>   - MB is in favour of treating no namespace as a wildcard
>   - BL says this wildcarding is often used and he likes it
>   - MB disagrees.
>   - AB says this does break XML

I believe my disagreement was with Andy's comment, i.e. switch the
last two lines.

/martin

---

From: Andy Bierman <[email-masked]>
Date: Tue, 11 Aug 2009 05:24:40 -0700

> I believe my disagreement was with Andy's comment, i.e. switch the

I no longer object to this wildcarding.
Turns out I already implemented it ;-)

I checked my code and it does the same thing
as Martin is suggesting.  I don't even care if you declare
the NULL namespace prefix or not:

  <nc:rpc xmlns:nc="netconf-base">
    <nc:get>
       <nc:filter type="subtree">
          <interfaces>
            <interface>
              <name>eth0</name>
            </interface>
          </interfaces>
       </nc:filter>
     </nc:get>
  </nc:rpc>

This XML above does not break the libxml2 parser, so I was wrong
in my comment on jabber.

  <nc:rpc xmlns:nc="netconf-base">
    <nc:get>
       <nc:filter type="xpath"
           select="/interfaces/interface[name='eth0']"/>
    </nc:get>
  </nc:rpc>

If there is a way to make life easier on the operator,
then I don't care if it's standard or not, so the NETCONF
namespace can be left out too:

  <rpc>
    <get>
       <filter type="xpath"
           select="/interfaces/interface[name='eth0']"/>
    </get>
  </rpc>

But if namespaces are used, they must be correct.

> /martin

Andy