Subject: [Netconf] with-defaults: wait for YANG/4741bis

From: Balazs Lengyel <[email-masked]>
Date: Tue, 01 Dec 2009 18:00:14 +0100

Hello,
During the last IETF the question was asked about the with-defaults draft:

Shall we wait for YANG and the 4741bis so we can make YANG normative?

The proposal accepted by the room in Hiroshima is:

Don't wait.
with-defaults will try to keep it's YAM up to date with the YANG draft and 4741bis as long as 
possible, but it will not wait for the other two drafts to become rfcs. The with-defaults YAng 
Module will be informative only.

Balazs

---

From: Phil Shafer <[email-masked]>
Date: Tue, 1 Dec 2009 12:20:44 -0500

>The proposal accepted by the room in Hiroshima is:

I vote to wait, to make the YANG normative and to help YANG take
root by using it ourselves.  The benefits of publishing w-d before
YANG do not outweigh the benefits of having it use YANG and for
the YANG module to be normative.

Thanks,
 Phil

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Tue, 1 Dec 2009 18:47:14 +0100

There are no obvious issues, like the inconsistencies we had 
in the monitoring draft, which force us to use YANG immediately.
This is the reason why we don't want to delay the W-D draft.

Cheers,
Mehmet

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of ext Phil Shafer
> Sent: Tuesday, December 01, 2009 6:21 PM
> To: Balazs Lengyel
> Cc: netconf mailing list
> Subject: Re: [Netconf] with-defaults: wait for YANG/4741bis
> 
> Balazs Lengyel writes:
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>

---

From: Phil Shafer <[email-masked]>
Date: Tue, 1 Dec 2009 12:38:03 -0500

>This is the reason why we don't want to delay the W-D draft.

What is the benefit of publishing now instead of waiting to use
YANG, that hot new incredible network modeling language the NETMOD
group has been working on?  I hear it's the bee's knees.

Thanks,
 Phil

---

From: Balazs Lengyel <[email-masked]>
Date: Wed, 02 Dec 2009 15:21:08 +0100

Advantages:
- Some people could implement with-defaults earlier.
-  Clarify some defaults related issues earlier.
Balazs

-- 
Balazs Lengyel                       Ericsson Hungary Ltd.
System Manager
ECN: 831 7320                        Fax: +36 1 4377792
Tel: +36-1-437-7320                  email: [email-masked]

---

From: Phil Shafer <[email-masked]>
Date: Fri, 4 Dec 2009 11:34:57 -0500

>-  Clarify some defaults related issues earlier.

I don't see either of these as important, let alone sufficiently
important to have w-d avoid use of YANG as normative.  Implementors
can always (and have always) implement the draft, and publicatio
of w-d will do little to clarify the defaults related issues.

Thanks,
 Phil

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Fri, 4 Dec 2009 18:37:14 +0100

Phil,

WG chairs and the WG are usually keen of keeping 
their deadlines and avoiding unnecessary delay.

If there are no obvious issues, like the 
inconsistencies we had in the monitoring draft, 
then there is no sufficient reason to delay the 
W-D draft.

Mehmet

> From: ext Phil Shafer [mailto:[email-masked]] 
> Sent: Friday, December 04, 2009 5:35 PM
> To: Balazs Lengyel
> Cc: Ersue, Mehmet (NSN - DE/Munich); netconf mailing list

---

From: Phil Shafer <[email-masked]>
Date: Fri, 4 Dec 2009 12:40:05 -0500

>then there is no sufficient reason to delay the 

I guess I'm surprised there's not more interest in making the YANG
module normative.  It's a minor point for the draft, but a bigger
one for the NETCONF/YANG effort.

But as the lone voice, I'll drop it.

Thanks,
 Phil

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 4 Dec 2009 19:51:03 +0100

> then there is no sufficient reason to delay the 

Both documents are in last call and I am going to read them both.  I
do not see the timing issue but then I do not have customers that
can't work with NETCONF because of W-D not yet having an RFC number
and a stable namespace.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>