Subject: Re: [Netconf] warnings

From: Kent Watsen <[email-masked]>
Date: Tue, 8 Dec 2009 11:45:15 -0800

Andy Bierman writes:
> I don't think the standard will ever use warnings.
> Even the use-case above is not a real warning.   It is just
> part of the object behavior, as defined in the description-stmt.
> A warning is needed when something not defined in the YANG module
> happens during the server response.

I want to use warnings in the rpc-reply for <edit-config>/<commit> to indicate when (and maybe where) implicit changes occurred.  This is the suggestion I made when we were discussing system-creatable flag on the NETMOD list...

Kent

---

From: Andy Bierman <[email-masked]>
Date: Tue, 08 Dec 2009 12:56:03 -0800

> I want to use warnings in the rpc-reply for <edit-config>/<commit> to indicate when (and maybe where) implicit changes occurred.  This is the suggestion I made when we were discussing system-creata…

I strongly object to any change in the server responses to
the client without changing the NETCONF base protocol version.
Any change at all in <rpc-reply> is a break in the contract
implied by the RFC4741 base capability.

> Kent

Andy