Subject: [Netconf] with-defaults basic mode configurable

From: Balazs Lengyel <[email-masked]>
Date: Tue, 01 Dec 2009 17:43:44 +0100

Hello,
During the last IETF the question was asked:

Should the basic-mode of with-defaults be configurable?
A number of implementations have it as configurable per session.

The proposal is:

The basic-mode of with-defaults is seen as configurable. This is a 
property of the specific NETCONF session.
The current value can always be fetched as part of the with-defaults 
capability from the netconf-monitoring data module.
How the value is set is left implementation specific, as this is not 
seen as an essential feature just a convenience item.
No changes will be made to the with-defaults draft due to this issue.

Balazs

---

From: Andy Bierman <[email-masked]>
Date: Tue, 01 Dec 2009 09:19:28 -0800

> capability from the netconf-monitoring data module.

Not quite right -- the data returned for a <get> request
is global data.  All sessions see the exact same instances
(modulo access control).

Under no circumstances should a NETCONF server
ever return session-specific values from
the conceptual database.  (Think 'SNMP context'
and run away! :-)

Instead, an RPC operation must be used,
or a per-session data structure in the database.

> No changes will be made to the with-defaults draft due to this issue.

Andy

---

From: WashamFan <[email-masked]>
Date: Wed, 02 Dec 2009 14:45:39 +0800

Hi,

My understanding is, basic-mode of defaults is for the server and would 
be automatically applied to all sessions handled by the server. If the client
(via a session) want to retrieve in a different defaults mode, it should 
specify it explicitly along with the RPC. 

Are you guys saying the client can change the basic-mode for a session
without impact on other sessions? How could we do that without no
change to the current with-defaults I-D?

Thanks,
washam

----- Original Message -----
From: Andy Bierman <[email-masked]>
Date: Wednesday, December 2, 2009 1:19 am
Subject: Re: [Netconf] with-defaults basic mode configurable
To: Balazs Lengyel <[email-masked]>
Cc: netconf mailing list <[email-masked]>

>  _______________________________________________
>  Netconf mailing list
>  [email-masked]
>  https://www.ietf.org/mailman/listinfo/netconf
>