Subject: [Netconf] WGLC for draft-ietf-netconf-monitoring-10

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Wed, 2 Dec 2009 20:23:09 +0100

Dear NETCONF WG, 
 
we think the draft Mark submitted solves the issues 
raised on the maillist recently. 

This is just to be sure the WG has the chance for a 
final review and approves the document before it goes 
to AD review. This WGLC ends on Dec 16, 2009.

The document is intended to go for standards track. 
http://tools.ietf.org/html/draft-ietf-netconf-monitoring-10

Mehmet

---

From: Andy Bierman <[email-masked]>
Date: Wed, 02 Dec 2009 12:12:50 -0800

> http://tools.ietf.org/html/draft-ietf-netconf-monitoring-10

There sure were a lot of changes from -09 to -10:

// old: ietf-netconf-state (2009-06-16) ietf-netconf-state.yang
// new: ietf-netconf-monitoring (2009-11-20) ietf-netconf-monitoring.yang

M module
M namespace
M contact
M description
D revision '2009-06-16'
A revision '2009-11-20'
M identity transport
   M description
M identity netconf-ssh
   M reference
M identity netconf-soap-over-beep
   M reference
M identity netconf-soap-over-https
   M reference
M identity netconf-beep
   M reference
M identity netconf-tls
   M reference
M identity xsd
   M reference
M identity rng
   M reference
M identity yang
   M reference
M identity yin
   M reference
M identity rnc
   M reference
D typedef SessionId
A typedef session-id
D grouping NETCONFDatastoreType
D grouping CommonCounters
A grouping netconf-datastore-type
A grouping common-counters
M container netconf-state
   A description 'The /netconf-state s...'
   M container capabilities
      M description
      M child node order
   M container datastores
      M list datastore
         M container name
            M choice datastore
               M case running
                  M child node order
               M case candidate
                  M child node order
               M case startup
                  M child node order
         M container locks
            M description
            D grouping LockInfo
            A grouping lock-info
            D choice lockType
            A choice lock-type
   M container schemas
      M list schema
         M leaf identifier
            M description
         M leaf version
            M description
         M leaf format
            M description
         M leaf namespace
            M description
         M leaf-list location
            M description
   M container sessions
      M description
      M list session
         M key from 'sessionId' to 'session-id'
         A description 'Unique identifier fo...'
         D leaf sessionId
         M leaf transport
            M mandatory from 'false' to 'true'
            A description 'Identifies the trans...'
         M leaf username
            A description 'If present, the user...'
         D leaf sourceHost
         D leaf loginTime
         D leaf inRpcs
         D leaf inBadRpcs
         D leaf outRpcErrors
         D leaf outNotifications
         A leaf session-id
         A leaf source-host
         A leaf login-time
         A leaf in-rpcs
         A leaf in-bad-rpcs
         A leaf out-rpc-errors
         A leaf out-notifications
   M container statistics
      D leaf netconfStartTime
      D leaf inBadHellos
      D leaf inSessions
      D leaf droppedSessions
      D leaf inRpcs
      D leaf inBadRpcs
      D leaf outRpcErrors
      D leaf outNotifications
      A leaf netconf-start-time
      A leaf in-bad-hellos
      A leaf in-sessions
      A leaf dropped-sessions
      A leaf in-rpcs
      A leaf in-bad-rpcs
      A leaf out-rpc-errors
      A leaf out-notifications
M rpc get-schema
   A description 'This operation is us...'
   M container input
      M leaf identifier
         A description 'Identifier for the s...'
      M leaf version
         M mandatory from 'true' to 'false'
         A description 'Version of the schem...'
      M leaf format
         M mandatory from 'true' to 'false'
         A description 'The data modeling la...'
   M container output
      M child node order

Is the WG done making gratuitous name changes to
every possible identifier in the document? I hope so.

So camelCase is out and dashes are in?
IMO, this does not help readability.
The preference for all-lowercase-and-dashes is rather subjective.

> Mehmet

Andy

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 3 Dec 2009 00:42:39 +0100

> So camelCase is out and dashes are in?

yes

> The preference for all-lowercase-and-dashes is rather subjective.

The real value of a common coding style in software projects is
consistency across groups of programmers, not so much the format
itself. I believe the same applies to YANG artefacts.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>