Subject: [Netconf] [Technical Errata Reported] RFC5717 (1978)

From: RFC Errata System <[email-masked]>
Date: Mon, 28 Dec 2009 02:53:05 -0800 (PST)

The following errata report has been submitted for RFC5717,
"Partial Lock Remote Procedure Call (RPC) for NETCONF".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=5717&eid=1978

--------------------------------------
Type: Technical
Reported by: Alfred Hoenes <[email-masked]>

Section: App. A, p.16

Original Text
-------------
    <!-- reply to <partial-lock> -->

    <xs:complexType name="contentPartInPartialLockReplyType">
        <xs:annotation>
            <xs:documentation>
                The content of the reply to a successful
                partial-lock request MUST conform to this complex type.
            </xs:documentation>
        </xs:annotation>
        <xs:sequence>
            <xs:element name="lock-id" type="lock-id-type">
              <xs:annotation>
                <xs:documentation>
|                 Identifies the lock to be released.  Must be the value
|                 received in the response to a partial-lock operation.
                </xs:documentation>
              </xs:annotation>
            </xs:element>
            [...]

Corrected Text
--------------
    <!-- reply to <partial-lock> -->

    <xs:complexType name="contentPartInPartialLockReplyType">
        <xs:annotation>
            <xs:documentation>
                The content of the reply to a successful
                partial-lock request MUST conform to this complex type.
            </xs:documentation>
        </xs:annotation>
        <xs:sequence>
            <xs:element name="lock-id" type="lock-id-type">
              <xs:annotation>
                <xs:documentation>
|                 Identifies the lock, if granted.  This lock-id must
|                 be used in the partial-unlock operation.
                </xs:documentation>
              </xs:annotation>
            </xs:element>
            [...]

Notes
-----
Rationale:
  The clause in the RFC apparently has been copied from page 15
  (bottom part), where the partialUnLockType is getting defined,
  without the necessary changes in semantics for the context of
  the reply to a partial-lock operation.
  The replacement text has been crafted in the spirit of the
  corresponding description in the YANG module in Appendix B.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5717 (draft-ietf-netconf-partial-lock-11)
--------------------------------------
Title               : Partial Lock Remote Procedure Call (RPC) for NETCONF
Publication Date    : December 2009
Author(s)           : B. Lengyel, M. Bjorklund
Category            : PROPOSED STANDARD
Source              : Network Configuration
Area                : Operations and Management
Stream              : IETF
Verifying Party     : IESG

---

From: "Bert Wijnen \(IETF\)" <[email-masked]>
Date: Mon, 28 Dec 2009 13:30:04 +0100

Balzs and Martin,

it seems to me that Alfred is correct in having found a problem.
It also seems that his suggested fix is correct.

If you agree, pls confirm on our mailing list, and then we (WG chairs) will
ask our AD to approve the errata and fix.

That will then be formally registered on the Errata pages, and you can
make the fix in your source .xml files, so that if we ever do a -bis version
that it will be inclued.

Bert

  ----- Original Message ----- 
  From: RFC Errata System 
  To: [email-masked] ; [email-masked] ; [email-masked] ; [email-masked] ; [email-masked] ; [email-masked] 
  Cc: [email-masked] ; [email-masked] ; [email-masked] 
  Sent: Monday, December 28, 2009 11:53 AM
  Subject: [Technical Errata Reported] RFC5717 (1978)

  Section: App. A, p.16

  Original Text
  -------------

  Corrected Text
  --------------

  Notes
  -----
  Rationale:

  Instructions:
  -------------

------------------------------------------------------------------------------

  Geen virus gevonden in het binnenkomende-bericht.
  Gecontroleerd door AVG - www.avg.com 
  Versie: 9.0.722 / Virusdatabase: 270.14.121/2589 - datum van uitgifte: 12/27/09 10:18:00

---

From: Martin Bjorklund <[email-masked]>
Date: Mon, 28 Dec 2009 13:41:27 +0100 (CET)

> ask our AD to approve the errata and fix.

I agree, his suggested fix is correct.

(The YANG description should be exactly the same as the XSD
description as well...)

/martin