Subject: [Netconf] Netconf Implementations - as reported on our netconf twiki page

From: "Bert (IETF) Wijnen" <[email-masked]>
Date: Thu, 15 Apr 2010 10:04:50 +0200

Dear WG participants, on our NETCONF TWIKI, we have various
pointers to additional NetConf and YANG related materials.
The page is at:

    http://trac.tools.ietf.org/wg/netconf/trac/wiki

Over the years we (as current and past WG chairs) have collected
information. However, you as the community need to help us to keep
this up to date.

Yesterday we got a report that various links were broken.
We have fixed those that we could quickly track down.

There are a few that we cannot (yet) track down.
If you have pointers them, pls do let us know.
If we cannot find the pointers in the next few weeks,
we plan to disable the links... maybe even better to
remove the item completely.

Also it seems some companies have merged or been bought?
So we appologize if the data is not 100% correct. It is
only the owners of the pages that can keep us informed and
up to date.

Bert and Mehmet

Below is a list of changes made and still open problems:

> Regarding the Wiki:
>
> http://trac.tools.ietf.org/wg/netconf/trac/wiki
>
> I think it’s a great idea to have a list of tool vendors. Some changes 
> are recommended for this section of the Wiki:
>
> embeddedMIND™ <http://embeddedmind.com/mindagentnetconf> from 
> Silicon&Software Systems (S3) now has an extensible Netconf agent with 
> integrated configuration store and CLI, SNMP and Web interfaces.
>
> -> Looks like S3 was bought by GoAhead Software.
>
Fixed the ptr.
Also added ??Now GoAhead?? Hope the owners can tell us more.
>
> XML Based Device Management 
> <http://www.wipro.com/webpages/prodesign/reusableframeworks/ip/xml.htm> 
> by Wipro, including an agent written in C and a manager in Java
>
> -> This URL doesn’t work anymore.
>
Can't find info for it anymore

> Applied Informatics' C++-based NetConf implementation 
> <http://www.appinf.com/poco/wiki/tiki-index.php?page=NetConf> based on 
> the POCO framework ( Howto 
> <http://www.appinf.com/poco/wiki/tiki-index.php?page=NetConf>).
>
> -> This URL doesn’t work anymore.
>
Same

> XMS (eXtensible Management System) 
> <http://www.6wind.com/Network.html>, written in C, by 6WIND
>
> -> This URL doesn’t work anymore.
>
Same

> Another implementation written in C by 
> http://www.postech.ac.kr/Postech in Korea
>
> -> This URL doesn’t work anymore.
>
Same... but I may be able to track it down with a few emails in the next
few days
>
> Also, the Ncclient module is now located at 
> http://oss.schmizz.net/ncclient/.
>
> · NANOG28 (June 2003): Panel on XML Router Configs - Progress and 
> Predictions <http://www.nanog.org/mtg-0306/xml.html>
>
> · NANOG28 (June 2003) BOF on XML-based Network Management Tools 
> <http://www.nanog.org/mtg-0306/enns.html>
>
> -> These links have moved as well.
>

fixed

---

From: Tomasz Mikolajczyk <[email-masked]>
Date: Mon, 26 Apr 2010 15:20:56 +0200

Hi,

To answer your inline query at
http://trac.tools.ietf.org/wg/netconf/trac/wiki

embeddedMIND is now a GoAhead Software product.

Further information at:
http://goahead.com/products/embeddedmind/default.aspx

Regards,
Tomasz Mikolajczyk

On 04/15/2010 10:04 AM, Bert (IETF) Wijnen wrote:
>> <http://www.wipro.com/webpages/prodesign/reusableframeworks/ip/xml.htm> by
>> Wipro, including an agent written in C and a manager in Java
>>
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>