Subject: Re: [Netconf] FW: Lars Eggert's Discuss on draft-ietf-netconf-4741bis-09: (with DISCUSS)

From: "Bert (IETF) Wijnen" <[email-masked]>
Date: Tue, 01 Mar 2011 15:55:27 +0100

Lars,

I find the text that you requires a bit heavy. I would claim, that any document that describes
a transport (NETCONF or OTHER) must indeed comply with RFC2914. Such has been the case for
many years. And RFC2914 is there to make sure all such documents indeed do address
congestion control issues.

I do not see why RFC4741bis would have to REPEAT the 2914 language.
Whatever new NETCONF transport document ever will come out, it will have to pass
the requirements of RFC2914, no?

If you (or better the IETF) is ever going to revise RFC2914, would we then also have
to revise our text again?

So why are you asking this?

Bert

On 3/1/11 2:21 PM, Romascanu, Dan (Dan) wrote:
>   Hi,
>
> Please address the issue raised by Lars in his DISCUSS.
>
> Thanks and Regards,
>
> Dan
>
>
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Lars Eggert
> Sent: Tuesday, March 01, 2011 3:01 PM
> To: The IESG
> Cc: [email-masked];
> [email-masked]
> Subject: Lars Eggert's Discuss on draft-ietf-netconf-4741bis-09: (with
> DISCUSS)
>
> Lars Eggert has entered the following ballot position for
> draft-ietf-netconf-4741bis-09: Discuss
>
> When responding, please keep the subject line intact and reply to all
> email addresses included in the To and CC lines. (Feel free to cut this
> introductory paragraph, however.)
>
> Please refer to http://www.ietf.org/iesg/statement/discuss-criteria.html
> for more information about IESG DISCUSS and COMMENT positions.
>
>
>
> ----------------------------------------------------------------------
> DISCUSS:
> ----------------------------------------------------------------------
>
> Section 2 should have a requirement that NETCONF transport that are to
> be used over the Internet MUST implement congestion control, in
> accordance with RFC2914. It can also simply note that all NETCONF
> transports that use TCP (such as the SSH transport) automatically
> fulfill this requirement.
>
> (This really is a no-brainer. I just want to prevent a future argument
> when someone wants to do a "lightweight" NETCONF transport over UDP...)
>
>
>
>

---

From: Lars Eggert <[email-masked]>
Date: Wed, 2 Mar 2011 09:56:09 +0200

Hi,

> So why are you asking this?

as I said in the discuss, my only motivation is to prevent a potential future argument for new NETCONF transport types.

You are of course right that 2914 applies anyway. I simply thought a reminder of that would make sense here.

I'll change this from a discuss to a comment.

Lars