Subject: Re: [Netconf] Finished WG Last Call for draft-ietf-netconf-system-notifications-04.txt

From: Martin Bjorklund <[email-masked]>
Date: Mon, 26 Sep 2011 20:52:00 +0200 (CEST)

Hi,

Andy Bierman <[email-masked]> wrote:
> A new version (-05) has been posted:
> http://www.ietf.org/id/draft-ietf-netconf-system-notifications-05.txt
> 
> Please verify that the disputed text has been adjusted correctly.

The new version is fine with regards to my comments.  But it has one
change that I do not think should be there:

OLD:
     leaf killed-by {
       when "../termination-reason = 'killed' and .";

The "and ." is confusing.  It should be:

NEW:
     leaf killed-by {
       when "../termination-reason = 'killed'";

On a purely editorial note, so far all our published modules has
followed the (stylistic) guideline to have the YANG statements in a
consistent order (the canonical order).  I suggest this module follows
this style.

/martin

---

From: Andy Bierman <[email-masked]>
Date: Mon, 26 Sep 2011 12:12:31 -0700

If the 'when-stmt' is changed then the data type has to be changed
to allow 0 instead of a session-id.  I think there was consensus
that a server should be able to send this notification even if the
server knew the session was killed by some external source,
but there is no NETCONF session tracking for that external session.

IMO, since a client has to deal with session-id=0 in some cases already,
then it is better to continue using zero consistently for new things.

I will reorder the YANG statements in canonical order.

The other issue has to be resolved by first deciding
what to do if termination-reason='killed' and no killed-by 
session ID is available.

1) come up with a different termination-reason enum and don't use 'killed'
OR
2) adjust the <killed-by> leaf definition to either
   3) be allowed to exist with a value of 0
   OR
   4) not be instantiated unless the value is non-zero
       (what the current when-stmt says and what Phil wanted)

Straw poll? Survey says? ...

Andy

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Martin Bjorklund
Sent: Monday, September 26, 2011 11:52 AM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Netconf] Finished WG Last Call for draft-ietf-netconf-system-notifications-04.txt

Hi,

OLD:
     leaf killed-by {

NEW:
     leaf killed-by {

/martin
_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

---

From: Martin Bjorklund <[email-masked]>
Date: Mon, 26 Sep 2011 22:04:18 +0200 (CEST)

Andy Bierman <[email-masked]> wrote:
> to allow 0 instead of a session-id.

No... why?  

The when expression says that the leaf "killed-by" is valid when
termination-reason equals 'killed' and the leaf "killed-by" exists.
The last part is confusing b/c it is redundant.  The when statement
now says that if the leaf doesn't exist, it can't exist, and if it
exists, it can exist (!)

> I think there was consensus

Yes, and that's fine; it is not mandatory.

If you do a new version, you may want to:

s/Summarizes each edit being reported/
  Summarizes the edits that have been detected/

s/an YANG data model/a YANG data model/

/martin