Subject: [Netconf] netconf java implementation

From: Pau Minoves <[email-masked]>
Date: Wed, 7 Sep 2011 16:30:50 +0200

Dear all,

This mail is just to let you know about a netconf client implementation that
we maintain. We were developing it internally in a research project, so we
decided to release it standalone as open source about a year ago.

You can find it here:

http://code.google.com/p/netconf4j/

It is java, low dependency and OSGI-ready. Of course we welcome any users,
feedback or contributions.

Also, we have seen that there are a couple of implementation lists here:

http://www.ops.ietf.org/netconf/
http://trac.tools.ietf.org/wg/netconf/trac/wiki

I'm just assuming that the maintainers are in this list, but, could it be
possible to add our implementation there too?

Thanks.

Best regards,
Pau

-- 
Distributed Applications and Networks Area (DANA)
Fundació i2CAT, Internet i Innovació Digital a Catalunya
C/ Gran Capità 2-4, Nexus I building, 1st floor, office 109
08034 Barcelona, Spain
T: +34 935 679 927

---

From: Simon Leinen <[email-masked]>
Date: Sun, 11 Sep 2011 21:27:29 +0200

> possible to add our implementation there too?

Done for the first page, please review.  The second is a Wiki, so you
should be able to add suitable text yourself.
-- 
Simon.

---

From: Pau Minoves <[email-masked]>
Date: Mon, 12 Sep 2011 10:26:28 +0200

Great, Thanks.

I added it too to the second page.

---

From: Matjaz Vrecko <[email-masked]>
Date: Thu, 22 Sep 2011 14:58:01 +0200

Hello Simon, Pau,

We would appreciate if you could be so kind and extend the contents
of the http://www.ops.ietf.org/netconf/ page, by adding also the
following two entries to the "Implementations" section:

MG-SOFT NETCONF Browser, a user friendly NETCONF GUI client/manager, based
on MG-SOFT's own NETCONF V1 and V1.1 protocols. Application is implemented
in Java.
(http://www.mg-soft.com/mgNetConfBrowser.html)

MG-SOFT Visual YANG Designer, a user friendly YANG file designer (creator,
editor, modeler, builder), based on MG-SOFT's own YANG compiler. Application
is implemented in Java.
(http://www.mg-soft.com/mgYangDesigner.html)

Please let me know if you need any additional information.

Thank you very much and best regards,

Matjaz

-- 
Matjaz Vrecko
MG-SOFT Corporation, Strma ulica 8, SI-2000 Maribor, Slovenia
Internet: http://www.mg-soft.si/  E-mail: <[email-masked]>
Phone: +386 2 2506565, Fax: +386 2 2506566

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Fri, 23 Sep 2011 18:16:51 +0200

Hi All,

before everybody begins editing the (official) NETCONF Wiki page at
ietf.org:
Please read the introduction part of
http://trac.tools.ietf.org/wg/netconf/trac/wiki.

"Please send any suggestions or NETCONF related information you would
like to see on this Wiki to NETCONF WG chairs
([email-masked]), e.g. links to NETCONF implementations,
presentations or tutorials." 

We would like to please you to stick to this rule.

Regards,
Mehmet & Bert
Co-chairs of NETCONF WG

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
Behalf Of
> ext Matjaz Vrecko
> Sent: Thursday, September 22, 2011 2:58 PM
> To: Simon Leinen
> Cc: [email-masked]
> Subject: Re: [Netconf] netconf java implementation
> 
> Hello Simon, Pau,
> 
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf