Subject: [Netconf] advertising submodules

From: Martin Bjorklund <[email-masked]>
Date: Tue, 15 Nov 2011 11:32:53 +0100 (CET)

Hi,

I just wanted to clarify what I meant re. advertising submodules.

*If* we need to change this, that would be an update to YANG, not to
NETCONF.  NETCONF has this notion of capabilities, but it doesn't
specify exactly what should go in them.

YANG defines that each *module* is advertised, with revision, module
name, features etc.

If we also want to advertise submdoules, the natural place to specify
how to do that would be in YANG.  So we could say that each submodule
is advertised as a separate NETCONF cpaability.  No need to change
NETCONF to do this.

/martin

---

From: Andy Bierman <[email-masked]>
Date: Tue, 15 Nov 2011 06:04:39 -0800

> is advertised as a separate NETCONF cpaability.  No need to change

Of course.
NETCONF just requires a URI as capability content.

A new document called 'YANG Submodule Capability for NETCONF' could
be done without touching the RFC 6020.

> /martin

Andy

---

From: Ladislav Lhotka <[email-masked]>
Date: Tue, 15 Nov 2011 22:07:49 +0800

> be done without touching the RFC 6020.

Does it mean this new capability will be optional?

Lada

> 
>> /martin
> 
> Andy
> 
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf

--
Ladislav Lhotka, CESNET
PGP Key ID: E74E8C0C

---

From: Martin Bjorklund <[email-masked]>
Date: Tue, 15 Nov 2011 15:11:32 +0100 (CET)

> be done without touching the RFC 6020.

Right.  It could Update 6020.

But before we do this, we need to make sure that this is the right
solution to the original problem...  And we need to switch ML.

/martin