Subject: [Netconf] Fwd: I-D Action: draft-bierman-netconf-restconf-00.txt

From: Andy Bierman <[email-masked]>
Date: Wed, 4 Sep 2013 17:03:46 -0700

FYI,

The initial RESTCONF protocol draft has been published.
Support for notifications has not been added yet.
See the change log for a summary of the updates
since the yang-api-01 draft.

Andy

---------- Forwarded message ----------
From: <[email-masked]>
Date: Wed, Sep 4, 2013 at 4:59 PM
Subject: I-D Action: draft-bierman-netconf-restconf-00.txt
To: [email-masked]

A New Internet-Draft is available from the on-line Internet-Drafts
directories.

        Title           : RESTCONF Protocol
        Author(s)       : Andy Bierman
                          Martin Bjorklund
                          Kent Watsen
                          Rex Fernando
        Filename        : draft-bierman-netconf-restconf-00.txt
        Pages           : 93
        Date            : 2013-09-04

Abstract:
   This document describes a RESTful protocol that provides a
   programmatic interface over HTTP for accessing data defined in YANG,
   using the datastores defined in NETCONF.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-bierman-netconf-restconf

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-bierman-netconf-restconf-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 5 Sep 2013 07:24:26 +0200

Hi,

I am wondering whether the authors did consider approaches that do not
require to construct complex URIs. See for example this I-D that
provides some warnings:

   http://tools.ietf.org/html/draft-nottingham-uri-get-off-my-lawn-02

Is .well-known really intended to be the root of a complex URI
namespace for applications like RESTCONF? For example, RFC 5785
says:

   However, in keeping with the Architecture of the World-
   Wide Web [W3C.REC-webarch-20041215], well-known URIs are not intended
   for general information retrieval or establishment of large URI
   namespaces on the Web.

Does it make sense to run this proposal through some application area
experts for early review and comment?

/js

> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Andy Bierman <[email-masked]>
Date: Thu, 5 Sep 2013 06:07:51 -0700

>    http://tools.ietf.org/html/draft-nottingham-uri-get-off-my-lawn-02

It is a tradeoff whether the YANG-derived text is in the URI
or in the message body.  I do not agree that using a URI for this
purpose is a problem, any more than using YANG at all
is a problem.  Schema-based applications need stable (static) URIs.
Discovering the entire set of URIs on a device each session is
too inefficient.

> experts for early review and comment?

Probably -- we added .well-known because we thought it was needed.
If not, that saves 12 useless characters in every request.

Andy

---

From: Kent Watsen <[email-masked]>
Date: Thu, 5 Sep 2013 17:48:52 +0000

> If not, that saves 12 useless characters in every request.

[Ooops, sorry, there was a misunderstanding.  The .well-known (RFC 5785)
is good, but it was only intended to retrieve the host-meta resource (RFC
6415), which is defined to be an extensible resource descriptor (XRD)
[http://docs.oasis-open.org/xri/xrd/v1.0/xrd-1.0.html], which itself
contains types defined in RFC 5988.  For instance:

    Request
    -------
    GET /.well-known/host-meta users HTTP/1.1
    Accept: application/xrd+xml

    Response
    --------
    HTTP/1.1 200 OK
    Content-Type: application/xrd+xml
    Content-Length: nnn
    <XRD xmlns='http://docs.oasis-open.org/ns/xri/xrd-1.0'>
        <Link rel='restconf' href='/api'/>
    </XRD>

>From this, the client then knows that the entire RESTCONF URL-space is
under /api.

Per RFC 5988, we just need to register "restconf" in IANA's Link Relation
Types registry 
(http://www.iana.org/assignments/link-relations/link-relations.xhtml).

Thanks,
Kent