Subject: [Netconf] Draft charter after consensus call

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Wed, 11 Dec 2013 13:56:40 +0000

Dear NETCONF WG,

we had two consensus calls ended on December 4, 2013.

−       Verifing session consensus with the maillist on RFC5539bis new port and YANG module separation
   http://www.ietf.org/mail-archive/web/netconf/current/msg08445.html
−       Verifing session consensus on RESTCONF as WG item with the maillist
http://www.ietf.org/mail-archive/web/netconf/current/msg08444.html

The co-chairs think that there was support for the action points and no objections to the consensus from the Vancouver NETCONF session.
We think we can go one step further. The co-chairs agreed to have Reverse SSH as a separate document for the time being.

Below is the relevant part of the draft charter. Please comment by December 20, 2013 EOB PT.
We will then pass it on to our AD for approval by IESG.

Bert & Mehmet

---------------

  In the current phase of NETCONF's incremental development the workgroup
  will focus on following items:

  1. Develop the call home mechanism for the mandatory SSH binding (Reverse
  SSH) providing a server-initiated session establishment.

  2. Advance NETCONF over TLS to be in-line with NETCONF 1.1 (i.e., update
  RFC 5539) and add the call home mechanism to provide a server-initiated
  session establishment.

  3. Combine the server configuration data models from Reverse SSH and
  RFC5539bis drafts in a separate YANG module.

  4. Develop a RESTful protocol (RESTCONF) that provides a programmatic
  interface for accessing data defined in YANG, using the datastores
  defined in NETCONF. The two parts concerning RESTCONF protocol over
  HTTP and the YANG patch operation will be prepared in separate drafts.

Goals and Milestones:
  Jan 2014 - Submit initial WG drafts for RESTCONF as WG item
  Apr 2014 - WGLC for RFC5539bis
  Apr 2014 - WGLC for Reverse SSH
  Apr 2014 - WGLC for NETCONF server configuration data model
  May 2014 - Submit Reverse SSH to AD/IESG for consideration as Proposed Standard
  May 2014 - Submit RFC5539bis to AD/IESG for consideration as Proposed Standard
  Jun 2014 - WGLC for RESTCONF
  Aug 2014 - Submit RESTCONF to AD/IESG for consideration as Proposed Standard

---

From: "Bert Wijnen (IETF)" <[email-masked]>
Date: Wed, 18 Dec 2013 11:39:48 +0100

We've had many emails on our WG mailing list, so maybe this one
did escape your attention. Please let us (WG hcairs) know if you
have any issues with this draft new WG charter. If we do not hear
any by Dec 20th, we will pss it to our AD for approval by th IESG.

It is always nice to hear that WG participants do agree too!

Bert and Mehmet

On 12/11/13 2:56 PM, Ersue, Mehmet (NSN - DE/Munich) wrote:
>   * Verifing session consensus with the maillist on RFC5539bis new port and YANG module separation
>     _http://www.ietf.org/mail-archive/web/netconf/current/msg08445.html_
>   * Verifing session consensus on RESTCONF as WG item with the maillist
>     _http://www.ietf.org/mail-archive/web/netconf/current/msg08444.html_
>
> We think we can go one step further.The co-chairs agreed to have Reverse SSH as a separate document for the time being.
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 18 Dec 2013 14:17:34 +0000

Hi,

I raised questions in Vancouver about the wisdom of doing RESTCONF in the same WG as NETCONF. I still think that RESTCONF is a different protocol, and that doing two protocols - the continuation of the development of NETCONF and a new protocol RESTCONF - in the same WG called NETCONF may be confusing for people who are not part of this community, and create doubts about the status and stability of NETCONF. I acknowledge that I am on the rough part of the consensus. 

Regards,

Dan

> -----Original Message-----
> From: Netconf [mailto:[email-masked]] On Behalf Of Bert Wijnen
> (IETF)
> Sent: Wednesday, December 18, 2013 12:40 PM
> To: Netconf
> Subject: [Netconf] Reminder: Action by Dec 20th 2013 PLEASE: Draft
> charter after consensus call
> 
> We've had many emails on our WG mailing list, so maybe this one did
> escape your attention. Please let us (WG hcairs) know if you have any
> issues with this draft new WG charter. If we do not hear any by Dec
> 20th, we will pss it to our AD for approval by th IESG.
> 
> >     _http://www.ietf.org/mail-
> archive/web/netconf/current/msg08445.html_
> > The co-chairs think that there was support for the action points and
> no objections to the consensus from the Vancouver NETCONF session.
> > We think we can go one step further.The co-chairs agreed to have
> Reverse SSH as a separate document for the time being.

---

From: "ietfdbh" <[email-masked]>
Date: Wed, 18 Dec 2013 12:41:26 -0500

Hi,

I agree with Dan that starting a RESTCONF effort in the same WG could be
destabilizing.
I think it might be better to do this work in a separate WG that works
closely with NETCONF.

David Harrington
[email-masked]
+1-603-828-1401

> From: Netconf [mailto:[email-masked]] On Behalf Of Romascanu,
> Dan (Dan)
> Sent: Wednesday, December 18, 2013 9:18 AM
> To: Bert Wijnen (IETF); Netconf
> Subject: Re: [Netconf] Reminder: Action by Dec 20th 2013 PLEASE: Draft
> I raised questions in Vancouver about the wisdom of doing RESTCONF in the
> same WG as NETCONF. I still think that RESTCONF is a different protocol,
and
> that doing two protocols - the continuation of the development of NETCONF
> and a new protocol RESTCONF - in the same WG called NETCONF may be
> confusing for people who are not part of this community, and create doubts
> about the status and stability of NETCONF. I acknowledge that I am on the
> rough part of the consensus.
> 
> Regards,
> 
> Dan
> 
> 
> 
> 
> archive/web/netconf/current/msg08444.html_
> > >

---

From: "Reinaldo Penno (repenno)" <[email-masked]>
Date: Wed, 18 Dec 2013 17:51:51 +0000

I would prefer that RESTconf is done in Netconf since there is where Netconf knowledge resides. Although RESTconf uses HTTP as transport, the protocol contract is almost the same as Netconf.

If we go to another WG, we would need Netconf folks to attend that other group as well. 

We had a similar discussion in Netmod: Should we standardize Yang models for, say, ACLs in Netmod or the Internet area WG? If we go to Internet Area, Netconf/yang folks would need to attend, if we stay in Netmod, router folks would need to attend.

________________________________________
From: Netconf [[email-masked]] on behalf of ietfdbh [[email-masked]]
Sent: Wednesday, December 18, 2013 9:41 AM
To: 'Romascanu, Dan (Dan)'; 'Bert Wijnen (IETF)'; 'Netconf'
Subject: Re: [Netconf] Reminder: Action by Dec 20th 2013 PLEASE: Draft  charter after consensus call

Hi,

David Harrington
[email-masked]
+1-603-828-1401

and

---

From: Ladislav Lhotka <[email-masked]>
Date: Wed, 18 Dec 2013 20:37:10 +0100

Hi,

> I raised questions in Vancouver about the wisdom of doing RESTCONF in the same WG as NETCONF. I still think that RESTCONF is a different protocol, and that doing two protocols - the continuation of…

I support the current charter proposal, i.e. developing RESTCONF in NETCONF. 

>From my previous experience, people that don't closely follow NETCONF and NETMOD are often confused by the split between these two WGs. Having three groups with significantly overlapping topics and active participants, separate mailing lists etc., would make things worse.

Also, RESTCONF in fact is not a new protocol, it is, for the most part, an application of existing and well-established stuff: HTTP plus REST principles, plus of course YANG.

Lada

-- 
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 18 Dec 2013 19:56:01 +0000

Hi Lada,

As I said, I do not mind being on the rough side of the consensus. I believe that RESTCONF is important work, and it is more important that it's done than where it's done. 

However, as you used the argument - what does the scope below has with NETCONF? If at all, it has more to do with NETMOD. 

Regards,

Dan
  
________________________________________
From: Ladislav Lhotka [[email-masked]]

Lada

---

From: Ladislav Lhotka <[email-masked]>
Date: Wed, 18 Dec 2013 21:47:11 +0100

> As I said, I do not mind being on the rough side of the consensus. I believe that RESTCONF is important work, and it is more important that it's done than where it's done.

Absolutely, and it is also important to do it soon, otherwise it will be done sort of over our heads.

> However, as you used the argument - what does the scope below has with NETCONF? If at all, it has more to do with NETMOD.

Well, the expanded title of NETCONF WG is “Network Configuration”. :-)

Lada

---

From: Andy Bierman <[email-masked]>
Date: Wed, 18 Dec 2013 13:15:02 -0800

On Wed, Dec 18, 2013 at 9:51 AM, Reinaldo Penno (repenno) <[email-masked]
> wrote:

> I would prefer that RESTconf is done in Netconf since there is where
> Netconf knowledge resides. Although RESTconf uses HTTP as transport, the
> protocol contract is almost the same as Netconf.
>
>

I do not have a strong opinion on this topic, so mild +1.
I think RESTCONF is visible on the radar and the interested people
will show up no matter where it is hosted.

> We had a similar discussion in Netmod: Should we standardize Yang models
> for, say, ACLs in Netmod or the Internet area WG? If we go to Internet
> Area, Netconf/yang folks would need to attend, if we stay in Netmod, router
> folks would need to attend.
>
>

This is a different issue -- is YANG mature enough to let individual WGs
manage
their own YANG development?  IMO, yes.  It should be done on a case-by-case
basis.
E.g., The ACL module might be done in NETMOD rather than spin up a WG just
for that.
But Topology might end up being done in I2RS because they are already
chartered
to work on topology.

Andy

> > > >    Aug 2014 - Submit RESTCONF to AD/IESG for consideration as
> Proposed
> > > > Standard
> > > >
> > > >

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Wed, 18 Dec 2013 21:30:03 +0000

Hi Dan, All,

speaking as a technical contributor, I see a huge value in it, if RESTCONF gets developed in NETCONF WG.

Some might see RESTCONF as a new protocol but it isn't. Looking at it from configuration management pov. RESTCONF builds on and uses the mechanisms NETCONF introduced.

That said I don't want RESTCONF to compete with NETCONF, which most likely will happen, if it is developed independent of NETCONF.

It is rather in the interest of NETCONF developers and users, if the two protocols are aligned and kept aligned over the time.
This parallel development and continuous alignment of the two sister protocols can only be done appropriately, if they are developed in the same WG.

Regards, 
Mehmet 

> From: Netconf [mailto:[email-masked]] On Behalf Of ext Ladislav Lhotka
> Sent: Wednesday, December 18, 2013 8:37 PM
> To: Romascanu, Dan (Dan); Bert Wijnen (IETF); Netconf
> > I raised questions in Vancouver about the wisdom of doing RESTCONF in the same
> WG as NETCONF. I still think that RESTCONF is a different protocol, and that doing two
> protocols - the continuation of the development of NETCONF and a new protocol
> RESTCONF - in the same WG called NETCONF may be confusing for people who are not
> part of this community, and create doubts about the status and stability of NETCONF. I
> acknowledge that I am on the rough part of the consensus.
> 
> From my previous experience, people that don't closely follow NETCONF and NETMOD
> are often confused by the split between these two WGs. Having three groups with
> significantly overlapping topics and active participants, separate mailing lists etc., would
> make things worse.
> 
> Also, RESTCONF in fact is not a new protocol, it is, for the most part, an application of
> existing and well-established stuff: HTTP plus REST principles, plus of course YANG.
> 
> Lada
> 
> >
> > Regards,
> >
> > Dan
> >
> >
> >
> >

---

From: "Reinaldo Penno (repenno)" <[email-masked]>
Date: Wed, 18 Dec 2013 22:03:26 +0000

I see as the same issue, different name.

If somebody wants to use some other transport besides HTTP should the work be done on some other WG or in Netconf?  If Netconf was mature enough it could be done in the other WG, otherwise in Netconf.
At this point I believe Netconf is the proper home for RESTconf.

Thanks,

Reinaldo

From: Andy Bierman <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, December 18, 2013 at 1:15 PM
To: Cisco Employee <[email-masked]<mailto:[email-masked]>>
Cc: ietfdbh <[email-masked]<mailto:[email-masked]>>, "Romascanu, Dan (Dan)" <[email-masked]<mailto:[email-masked]>>, "Bert Wijnen (IETF)" <[email-masked]<mailto:[email-masked]>>, Netconf <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Netconf] Reminder: Action by Dec 20th 2013 PLEASE: Draft charter after consensus call

This is a different issue -- is YANG mature enough to let individual WGs manage
their own YANG development?  IMO, yes.  It should be done on a case-by-case basis.
E.g., The ACL module might be done in NETMOD rather than spin up a WG just for that.
But Topology might end up being done in I2RS because they are already chartered
to work on topology.

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 19 Dec 2013 15:53:20 +0100

> I think it might be better to do this work in a separate WG that works

While RESTCONF may be seen as a competitor to NETCONF by some, I think
it does not matter at all where it is done in the IETF. In fact, I
could easily find reasons why a separate WG could be seen even more as
developing a competitor to NETCONF. To ensure that NETCONF and
RESTCONF stay aligned and since to a large extend the same people are
involved, I think doing RESTCONF in the NETCONF WG makes a lot of
sense.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Alexander Clemm (alex)" <[email-masked]>
Date: Thu, 19 Dec 2013 19:49:42 +0000

To Bert's original question, I support this charter.

IMHO I think it is fine for RESTCONF and NETCONF be in the same working group.  If it causes confusion, perhaps a change in name for the working group can be considered (Protocols and transports for YANG datamodels in Netconf datastores).  I also think the wording of point 4 could be slightly improved, but this is a minor item ("4. Develop a RESTful protocol (RESTCONF) that provides a programmatic interface for accessing data defined in YANG, using the datastores  defined in NETCONF. " - I find the blurring between "programmatic interface" and "protocol" not very clear; isn't the goal not really a programmatic interface per se but to simply provide REST developers with a simple access to Netconf datastores for applications that do not require many of the richer services that are provided through Netconf?)

Thanks
--- Alex

-----Original Message-----
From: Netconf [mailto:[email-masked]] On Behalf Of Juergen Schoenwaelder
Sent: Thursday, December 19, 2013 6:53 AM
To: ietfdbh
Cc: 'Netconf'
Subject: Re: [Netconf] Reminder: Action by Dec 20th 2013 PLEASE: Draft charter after consensus call

On Wed, Dec 18, 2013 at 12:41:26PM -0500, ietfdbh wrote:
> Hi,
> 
> I agree with Dan that starting a RESTCONF effort in the same WG could 
> be destabilizing.

While RESTCONF may be seen as a competitor to NETCONF by some, I think it does not matter at all where it is done in the IETF. In fact, I could easily find reasons why a separate WG could be seen even more as developing a competitor to NETCONF. To ensure that NETCONF and RESTCONF stay aligned and since to a large extend the same people are involved, I think doing RESTCONF in the NETCONF WG makes a lot of sense.

/js

---

From: "Lisa Huang (yihuan)" <[email-masked]>
Date: Thu, 19 Dec 2013 20:21:36 +0000

I support this charter.

Here is my opinion on item 4: I believe the goal is not to provide
programmatic interface, but a set of standards about how to relate restful
path with yang path and how to simplify RESTful application to access
Netconf datastore, etc.

On 12/18/13 2:39 AM, "Bert Wijnen (IETF)" <[email-masked]> wrote:

>> The co-chairs think that there was support for the action points and no
>>objections to the consensus from the Vancouver NETCONF session.