Subject: [Netconf] Entity tag (ETag) question

From: Bartosz Bąk <[email-masked]>
Date: Wed, 30 Jul 2014 14:56:33 +0200

Hi all,
I'm working on a database-backed YANG datastore with RESTCONF API.
Currently I'm dealing with entity tag feature and I have a problem with 
spec interpretation in this area.
Let me explain my concerns on a below example:
Suppose I have the following model:

module leafrefs {
   namespace "http://com/example/A";
   prefix test;
   list A {
    leaf a-key {type string;}
    leaf a-property {type string;}
    key a-key;
    container Test {
        leaf test {type string;}
        leaf test2 {type string;}
        leaf test3 {type string;}
    }
    leaf
    list B {
      leaf b-key {type string;}
      leaf b-property {type string;}
      key b;
    }
   }
}

So my question is whether there should by only single ETag assigned to 
the whole data tree instance (to each "A" root element) and then each 
data modification to that tree, like :
a). modifying A.a-property,
b). Modifying container property A.Test.test
c). Adding new B  to the A.b list,
d). Patching existing A.B element.
e). removing existing A.B element.
changes the entity tag to the new unique value?

Or maybe system should maintain separate entity tags  for every A and B 
elements and patching existing A.B element should not change entity tag 
of the parent A element, instead given B child element should get new 
value of it's own Etag.

Thank you in advance for the answers
-- 
Regards,
Bartek

---

From: Andy Bierman <[email-masked]>
Date: Wed, 30 Jul 2014 06:53:12 -0700

Hi,

In our implementation, the server simply updates the changed node and
all its ancestors, including the <config> root.  The draft only requires
that the etag be maintained for the config root. Anything else is optional
and up to the developer.

Andy

On Wed, Jul 30, 2014 at 5:56 AM, Bartosz Bąk <[email-masked]>
wrote:

> So my question is whether there should by only single ETag assigned to the
> whole data tree instance (to each "A" root element) and then each data
> modification to that tree, like :
> elements and patching existing A.B element should not change entity tag of
> the parent A element, instead given B child element should get new value of
> it's own Etag.
>
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>