Subject: Re: [Netconf] edit-config operation inconsistency

From: Martin Bjorklund <[email-masked]>
Date: Mon, 04 Aug 2014 08:03:23 +0200 (CEST)

Hi,

Andy Bierman <[email-masked]> wrote:
> The text on page 37 needs to be updated somehow (as errata).

> I don't think we agree on the text yet, but here is an attempt
> 
> RFC 6241, sec 7.2, para 6:
> 
> OLD:
> 
>          If the "operation" attribute is not specified, the
>          configuration is merged into the configuration datastore.
> 
> 
> 
> NEW:
> 
>          If the "operation" attribute is not specified, then
>          the operation applied to the parent data node of the configuration
>          is used. If no parent data node is available, then the
> 'default-operation' value is used.

Ok.  Minor tweak to match the rest of the text, and re-adding the last
part from the original sentence.

NEW:

          If the "operation" attribute is not specified, then
          the operation applied to the parent data node of the configuration
          is used. If no parent data node is available, then the
          value of the <default-operation> parameter is used.  If the
          <default-operation> parameter is not given, the
          configuration is merged into the configuration datastore.

/martin

---

From: Andy Bierman <[email-masked]>
Date: Sat, 9 Aug 2014 11:49:00 -0700

> part from the original sentence.

I don't mind, but I thought since the YANG default for this leaf is 'merge',
the last sentence is somewhat redundant.

>           configuration is merged into the configuration datastore.

Andy

---

From: Martin Bjorklund <[email-masked]>
Date: Sun, 10 Aug 2014 20:06:53 +0200 (CEST)

> the last sentence is somewhat redundant.

Agree it is redundant, but since it it there in the original, I think
it is better to keep it.

/martin