Subject: [Netconf] draft minutes/notes of our Virtual Interim Meeting on 8 Sept 2014

From: "Bert Wijnen (IETF)" <[email-masked]>
Date: Tue, 09 Sep 2014 13:34:05 +0200

Dear WG participants, we had our first virtual interim meeting yesterday.
here are the draft minutes (thanks to Kent for taking notes, amended/merged
with my own notes):

The meetings run from 8 Sept - 3 Nov 2014. Biweekly on Mondays from 7pm-9pm
CET (Berlin, Amsterdam, Paris). That is 17:00-19:00 UTC. They are webex based
meetings. We have decided last night to record the meetings. But the WG chair(s)
will ensure at the start of every meeting that everyone is aware and that
nobody objects. The recording of yesterdays meeting is here:

    <recording URL> <Bert needs to obtain the URL from secretariat>

- The main objective of the call is to help us (WG) move faster on our
   chartered work items. RESTCONF is a big piece of that. Whatever we want
   to decide must be verified on the WG mailing list. Of course some discussion
   end up in changes to a document, which will always be presented to the WG
   mailing list and which will eventually be Last Called, so everyone has a say.

- We had 10 participants on the call

- Kent presented GitHub, which is used to track issues and which also
   is used by various editors to work together on the documents
   * DECISION: We will NOT forward all changes in GITHUB to the WG
               mailing list.
   * Pull-requests for editorial changes are OK,
   * but more substantial issues (in fact all issues) should be discussed
     on our NETCONF WG mailing list. We can use github to keep track of the
     status and to record summaries, proposed solutions and the final
     resolution.

- Andy presented RESTCONF issues
   see: https://github.com/netconf-wg/restconf/issues
   We discussed them in reverse order (will try to get them properly
   discussed in order next time). I (Bert) have added all issues,
   also those that were created new as a result o the virtual meeting and
   those that were not discussed. If you want to comment or voice an
   opinion on any issue (that would be VERY GOOD and HELPFUL), then pls
   set the subject line to the issue number plus issue title.

   * issue # 10: Naming convention for Query Parameters
       o opened by Bert as a result of our first virual meeting
       o split ioff from issue # 6
   * issue # 9: Define how authentication is performed
       o opened by Andy as a result of our first virtual meeting
   * issue #7: Mandatory-to-implement encoding
       o WG chairs did a poll on the WG list for opinions:
         see: http://www.ietf.org/mail-archive/web/netconf/current/msg09218.html
         It runs till Sept 18, so those who have not expressed an opinion yet
         are encouraged to do so.
       o For now, "Optional" encoding (choice d) got more votes than "XML mandatory"
         (choice a).
       o Martin mentions technical motivations were expressed with choice 'a'
       o Bert reminded that STANDARDIZATION means making choices and making interoperability
         easy. From that point of view, choice a seems more appropriate.
       o ACTION: Bert will send reminder to collect more opinions (done)
   * issue #6: how to identify query parameters supported by the server
       o No prefix for ietf-defined (this is naming, see new issue #10)
       o We basically have 2 issues, one is Naming,the other is discovery of which
         parameters are supported by the server. So issue #6 stays as is,
         issue #10 opened by Bert for Naming conventions
       o Capability encoding in the air: Lada is thinking a json object
       o Proposal to collapse into a single URI string
       o Opinions of other WG participants are welcome! Please speak up
   * issue #5: protocol capability URIs
       o was not discussed on this call
       o Toronto consensus: Add protocol capabilities somehow
       o so we need to see new text in a revision of the draft
   *issue #4: Defaults handling
       o Mapping to RESTCONF straight forward
       o the server MUST report what basic-mode it supports
       o Question: Should full support of with-defaults RFC be added to base RESTCONF?
         Please speak up and express opinions?
   * issue #3: add collection resource
       o Put collections media-type and query-parameters into main draft, but?
       o There seems to be consensus to put collections resource in another document.
       o Need to deal with GET on a list with no keys given:
           GET /restconf/data/interfaces/interface
           --> Maybe this will be an error unless collection resource requested
       o Need text proposals on mailing list.
   * issue #2 Netconf state monitoring
       o Need to create an issue for authentication
         (done by Andy, that is issue #9
       o Do we need to have a 6022-bis document or can RESTCONF just update the text
         in order to support non-NETCONF sessions.
       o An idea is to let this doc "update" RFC 6022
   * issue #1: Select parameter
       o What syntax should be used for the "select" query parameter? The
         current choices are "XPath" and "path-expr". Perhaps an
         additional parameter to identify the select string format is
         needed to allow extensibility?
       o Martin's proposal stands...issue seems closed
       o WG participants, please speak up if you cannot live with
         Martin's proposal, see
           https://github.com/netconf-wg/restconf/issues/1

- A question was raised by Mahesh, regarding CLI type uses as ping and traceroute.
   He was asked to post the problem statement to the WG list, which he has done now
   see: http://www.ietf.org/mail-archive/web/netconf/current/msg09254.html

- Next time we will discuss restconf issues again, but also: call-home.
   It seems like a good idea to then have the accompanying documents updated as well,
   so:
   o ACTION: Juergen should update 5539bis
   0 ACTION: Kent to submit server-model

Bert Wijnen, with special thanks to Kent and Andy.

---

From: "Bert Wijnen (IETF)" <[email-masked]>
Date: Tue, 09 Sep 2014 13:50:13 +0200

I found at: http://www.ietf.org/iesg/statement/interim-meetings.html

     The minutes, including a list of attendees, must be sent to
     [email-masked] within 10 days after the meeting, conference
     call or jabber session concludes.

So I will add this list of participants (speak up if you think I missed somone):
I intend send the complete set to processdings by the end of this week.

Meeting start:  8 Sept 2014, 17:00 UTC
Meeting end:    8 Sept 2014, 19:05 UTC

Chair:     Bert Wijnen
Attendees: Juergen Schoenwaelder
            Ladislav Lhotka
            Martin Bjorklund
            Kent Watsen
            Andy Bierman
            Michael Scharf
            Mahesh Jethanandi
            Alberto Gonzalez Priedro
            Benoit CLaise (AD)

Regrets:   Mehmet Ersue (vacation)

On 09/09/14 13:34, Bert Wijnen (IETF) wrote:
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>

---

From: "Bert Wijnen (IETF)" <[email-masked]>
Date: Fri, 12 Sep 2014 09:40:13 +0200

Here are the proceeding materials for our NETCONF virtual meeting (webex) on 8 Sept 2014

Meeting start:  8 Sept 2014, 17:11 UTC
Meeting end:    8 Sept 2014, 19:05 UTC

Chair:     Bert Wijnen
            Mahesh Jethanandani
            Alberto Gonzalez Prieto
            Benoit CLaise (AD)

Regrets:   Mehmet Ersue (co-chair, vacation)

> Streaming recording link:
>    https://ietf.webex.com/ietf/ldr.php?RCID=2fd2a151d4ef7ebe95f310880f92fdad
> Download recording link:
>    https://ietf.webex.com/ietf/lsr.php?RCID=b57f37cff1571be1061b1963a16bd472
>
>        o split off from issue # 6