Subject: Re: [Netconf] Action by August 1st: WG call for consensus to have ONE netconf-callhome document

From: t.petch <[email-masked]>
Date: Fri, 19 Sep 2014 15:16:25 +0100

Bert

I never saw a follow up to this - I say more in my e-mail to Mehmet.

Tom Petch

----- Original Message -----
From: "Bert Wijnen" <[email-masked]>
To: "Netconf" <[email-masked]>
Sent: Thursday, July 24, 2014 8:16 PM
Subject: [Netconf] Action by August 1st: WG call for consensus to have
ONE netconf-callhome document

WG participants, during our IET90 session, Kent presented
and we discussed reverse ssh this issue:

    Asymmetric document structure
    5539bis vs RFC6242 + reverse-ssh  -> 6242bis instead?

    Placement for generic content, Including:
      Section 3: "Benefits to Device Management”
      Section 5: "SSH Server Identification and Verification”

    Best if moved to a common “Call Home” draft
    A “6242bis” wouldn’t work after all…

    Proposal:
    Have a single “NETCONF Call Home” (draft-ietf-netconf-call-home)
    draft that is equally valid for all NETCONF transports
    rename this draft and move 5539bis content into it

We did a hum in the room and there was overwhelming support to accept
the proposal. No-one hummed against or abstained.

So we're confirming this consensus on the WG mailing list.

Please speak up by Friday August 1st if you disagree.

Bert and Mehmet

_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 19 Sep 2014 20:58:41 +0200

Tom,

there is

https://tools.ietf.org/html/draft-ietf-netconf-call-home-00

and there is an update of 5539bis pending that removes call home
from it. And then there is the NC server configuration model

https://tools.ietf.org/html/draft-ietf-netconf-server-model-02

I think we are doing exactly what was discussed in Toronto.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Kent Watsen <[email-masked]>
Date: Fri, 19 Sep 2014 20:14:56 +0000

But to Tom's point, the reverse-ssh is still listed as an "Active" draft
and the charter has not yet been updated.

Kent

On 9/19/14, 2:58 PM, "Juergen Schoenwaelder"
<[email-masked]> wrote:

>>       Section 3: "Benefits to Device Management²
>>       Section 5: "SSH Server Identification and Verification²
>> 
>>     Best if moved to a common ³Call Home² draft
>>     A ³6242bis² wouldn¹t work after allŠ
>> 
>>     Proposal:
>>     Have a single ³NETCONF Call Home² (draft-ietf-netconf-call-home)

---

From: t.petch <[email-masked]>
Date: Sun, 21 Sep 2014 09:45:56 +0100

----- Original Message -----
From: "Juergen Schoenwaelder" <[email-masked]>
To: "t. petch" <[email-masked]>
Cc: "Bert Wijnen" <[email-masked]>; "Netconf" <[email-masked]>
Sent: Friday, September 19, 2014 7:58 PM

> I think we are doing exactly what was discussed in Toronto.

Yes, but I was hoping for a confirmation on the list, as being the usual
way to proceed (and which the report from Toronto says will happen).

And if we are taking a chunk out of A to form A' and adding a chunk to B
to form B', then I want to see both A' and B' together, to see that they
fit together, do not have gaps left, do not contradict each other and so
on.

I was asked to look at call-home (!:-( before Monday and decided that I
could not adequately do that without the corresponding update to
5539bis.  I still think that.  After that, it would make sense to me to
look at server-model.

Tom Petch
> > .de/>

---

From: Bert Wijnen <[email-masked]>
Date: Mon, 22 Sep 2014 09:51:18 +0200

Tom, others,

We (WG chairs directly or on mlist) did not receive any
objections to the consensus call on the mailing list that we used
to verify the f2f consensus. We should have (as promised and as you say)
re-confirmed that on the list. I guess our vacations got us somewhat out of
focus.

We believe we now have wg consensus on merging the callhome material.

You are correct that it would be good to have all related documents
(with changes because of this) available at the same time.

Juergen was busy however with his NETMOD interim in NY and so he was
unable to deliver the 5539bis revision sofar. I am sure he will do so
as soon as he gets a chance.

Hope this helps,
Bert