Subject: [Netconf] NETCONF- read-write objects retrieval

From: vathsala narayanan <[email-masked]>
Date: Wed, 10 Sep 2014 23:11:03 +0530

Hi all,

I'm currently working on a NETCONF research project. To understand the
working of NETCONF, I have taken the mib objects  (from std IP mib)
ipForwarding and ipDefaultTTL as example.

 I have used a tool which generates a yang module that maps to this MIB and
provide a new rpc function to configure values(say set-ipmib). My
configuration  is a success as I can see a rpc-reply from the server. But
I'm looking for a way to retrieve the configured values. When I do a
get/xget, I am able to see only the read-only objects getting listed. Is
there  a way to retrieve read-write objects through netconf?

Best Regards,
Vathsala

---

From: Rohit pobbathi <[email-masked]>
Date: Thu, 11 Sep 2014 09:13:00 +0000

You can use get-config operation of NETCONF to retrieve config data.

From: Netconf [mailto:[email-masked]] On Behalf Of vathsala narayanan
Sent: 2014年9月11日 1:41
To: [email-masked]
Subject: [Netconf] NETCONF- read-write objects retrieval

Hi all,

I'm currently working on a NETCONF research project. To understand the working of NETCONF, I have taken the mib objects  (from std IP mib) ipForwarding and ipDefaultTTL as example.

 I have used a tool which generates a yang module that maps to this MIB and provide a new rpc function to configure values(say set-ipmib). My configuration  is a success as I can see a rpc-reply from the server. But I'm looking for a way to retrieve the configured values. When I do a get/xget, I am able to see only the read-only objects getting listed. Is there  a way to retrieve read-write objects through netconf?

Best Regards,
Vathsala

---

From: vathsala narayanan <[email-masked]>
Date: Thu, 11 Sep 2014 16:17:33 +0530

Hi,

When I try to use  get-config after configuring a mib object, I get only
the container name listed in the output. I am not able to see the
configured mib objects.
Am I missing something ?

Please find snippet of logs below:

yangcli root@localhost> set-ip ipDefaultTTL=1 ipForwarding=2

RPC OK Reply 28 for session 1:

yangcli root@localhost> get-config source=running

RPC Data Reply 31 for session 1:

rpc-reply {
  data {
    ip {
>>>>>>>>object display missing here .
    }
}
}

Regards,
Vathsala

On Thu, Sep 11, 2014 at 2:43 PM, Rohit pobbathi <[email-masked]>
wrote:

> *From:* Netconf [mailto:[email-masked]] *On Behalf Of *vathsala
> narayanan
> *Sent:* 2014年9月11日 1:41
> *To:* [email-masked]
> *Subject:* [Netconf] NETCONF- read-write objects retrieval
>
>
>
> Hi all,
>
>
>
>  I have used a tool which generates a yang module that maps to this MIB
> and provide a new rpc function to configure values(say set-ipmib). My

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 11 Sep 2014 13:17:53 +0200

Hi,

I do not think we can solve implementation issue here.

/js

> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Andy Bierman <[email-masked]>
Date: Thu, 11 Sep 2014 10:17:19 -0700

> the container name listed in the output. I am not able to see the
Lots. #1 is that this question should go to the OpenYuma mailing list, not
this one.

> yangcli root@localhost> set-ip ipDefaultTTL=1 ipForwarding=2

I assume the "set-ip"  command is a custom RPC provided by the server?
It is not a yangcli command. Or is it a yangcli alias?

Normal NETCONF usage would be to define "ip" as data and use <edit-config>
to edit it, instead of a custom RPC that does the same thing. Using a
"set-ip" custom
command is strongly discouraged.

> >>>>>>>>object display missing here .

Where is the "ip" config=true data node defined?
If there is none, then it cannot possibly be returned in a <get-config>
response.

Are you sure you committed this data and it is not sitting in
the candidate datastore?

}
> Vathsala

Andy

>
> On Thu, Sep 11, 2014 at 2:43 PM, Rohit pobbathi <[email-masked]
> > wrote:
>