Subject: [Netconf] L2 topology discovery with NETCONF

From: Jing Zhao <[email-masked]>
Date: Wed, 10 Sep 2014 11:13:43 +0800

Hi all,

I'm working on a NETCONF research project hoping to find out a way to 
build layer 2 network topology. There are some open algorithms to build 
topology based on the information read from switch MIB.

For example, each switch port has one entry in MIB dot1dStpPortTable which 
includes designated switch id, designated port, the root switch, etc.

But I'm looking for a way to use NETCONF to read the MIB from switches. 
What I can expect is that switches implement some special YANG module 
which maps to this MIB and provides a new RPC function like, e.g., 
get-stp-table.

I think this should be a normal use case for NETCONF. It's actually listed 
as one issue here.

But I cannot find anything related on the Web. The most I can get is 
ietf-routing.yang draft listing at www.netconfcentral.org. So is there any 
IETF RFC or draft defining something pertaining to layer 2 topology 
discovery using NETCONF?

Thanks!

Best regards,
Eric

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 10 Sep 2014 13:34:16 +0200

Hi,

you can turn a MIB module into a read-only YANG model following RFC
6643. While L2 discovery via MIB modules may work in certain
situations, using something like LLDP and an interface to extract
information from stations speaking LLDP may be an alternative to
consider.

/js

On Wed, Sep 10, 2014 at 11:13:43AM +0800, Jing Zhao wrote:
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "ietfdbh" <[email-masked]>
Date: Wed, 10 Sep 2014 11:06:24 -0400

To expand on Juergen's response,

See http://en.wikipedia.org/wiki/Link_Layer_Discovery_Protocol
And RFC2922

David Harrington
[email-masked]
+1-603-828-1401

> -----Original Message-----
> From: Netconf [mailto:[email-masked]] On Behalf Of Juergen
> Schoenwaelder
> Sent: Wednesday, September 10, 2014 7:34 AM
> To: Jing Zhao
> Cc: [email-masked]
> Subject: Re: [Netconf] L2 topology discovery with NETCONF
> 
> Hi,
>

---

From: Jing Zhao <[email-masked]>
Date: Thu, 11 Sep 2014 09:46:41 +0800

Thanks guys.

Yes, LLDP is an alternative in my research. Either way, I guess we need 
some way to fetch those distributed info from switches, in order to build 
the topology. In the case of NETCONF, those switches must announce and 
support an extra capability of a read-only YANG module translated from the 
according MIB.

What I'm worried about is the lack of a standard-defined YANG module for 
this purpose. Different vendors may implement their own YANG modules if 
they ever have one. It's thus hard to discover the network topology when 
there are switches from different vendors, or at least not scalable.

To me, missing a standard module may limit the usage of NETCONF in this 
area. People will have to fall back and use SNMP to read MIB on different 
switches.

So I want to know if there is something defined in NETCONF standard 
pertaining to L2 topology discovery. If not, is there any plan for that?

Best regards,
Eric

Juergen Schoenwaelder <[email-masked]> wrote on 
2014/09/10 19:34:16:

> From: Juergen Schoenwaelder <[email-masked]>
> To: Jing Zhao <[email-masked]>, 
> Cc: [email-masked]
> Date: 2014/09/10 19:34

---

From: "ietfdbh" <[email-masked]>
Date: Thu, 11 Sep 2014 00:02:37 -0400

Hi,

I don't understand why you think the lack of a standard YANG module is a
problem for discovering network topology.

There are standard MIB modules supporting LLDP, and for discovering the
network topology, they can be read using NETCONF, for those who want to use
NETCONF, and they can be read using SNMP for those who want to use SNMP.

That actually follows the original intention of having a standard MIB that
could be accessed using different protocols.

The only place where the MIB is inadequate is for configuring the read-write
objects in the RFC2922 ptopoConfigGroup and the LLDP-MIB lldpConfiguration
groups.

But since most SNMP deployments don't support SNMP SETs, these MIB objects
probably aren't used directly anyway.

If they are used, but configured via CLI commands or other mechanisms, then
a YANG module to configure them might be helpful.

David Harrington

 <mailto:[email-masked]> [email-masked]

+1-603-828-1401

From: Jing Zhao [mailto:[email-masked]] 
Sent: Wednesday, September 10, 2014 9:47 PM
To: Juergen Schoenwaelder
Cc: [email-masked]; ietfdbh
Subject: Re: [Netconf] L2 topology discovery with NETCONF

Thanks guys. 

Yes, LLDP is an alternative in my research. Either way, I guess we need some
way to fetch those distributed info from switches, in order to build the
topology. In the case of NETCONF, those switches must announce and support
an extra capability of a read-only YANG module translated from the according
MIB. 

What I'm worried about is the lack of a standard-defined YANG module for
this purpose. Different vendors may implement their own YANG modules if they
ever have one. It's thus hard to discover the network topology when there
are switches from different vendors, or at least not scalable. 

Best regards, 
Eric 

2014/09/10 19:34:16:

> >  <https://www.ietf.org/mailman/listinfo/netconf>
> Fax:   +49 421 200 3103         < <http://www.jacobs-university.de/>
http://www.jacobs-university.de/>

---

From: Jing Zhao <[email-masked]>
Date: Thu, 11 Sep 2014 12:56:21 +0800

Thanks.

My concern is that not all switches allow access to that MIB via NETCONF. 
But yes, adding a standard model doesn't help whatsoever.

Then should I use SNMP instead of NETCONF? My understanding is that as 
long as SNMP is enabled on a switch, we can access that MIB via SNMP. But 
even if NETCONF is enabled, we still may not access that MIB via NETCONF, 
because that switch vendor may not translate that MIB to a YANG module. 
Will this be a real problem?

So according to your experience, when there are switches from different 
vendors in a subnet, which protocol should I use to fetch the MIB from 
those switches?

Best regards,
Eric

"ietfdbh" <[email-masked]> wrote on 2014/09/11 12:02:37:

> From: "ietfdbh" <[email-masked]>
> To: "'Jing Zhao'" <[email-masked]>, "'Juergen Schoenwaelder'" 
> <[email-masked]>, 
> Cc: <[email-masked]>
> Date: 2014/09/11 12:02
> Subject: RE: [Netconf] L2 topology discovery with NETCONF
> 
> Hi,
> 
> I don’t understand why you think the lack of a standard YANG module 
> is a problem for discovering network topology.
> There are standard MIB modules supporting LLDP, and for discovering 
> the network topology, they can be read using NETCONF, for those who 
> want to use NETCONF, and they can be read using SNMP for those who 
> want to use SNMP.
> That actually follows the original intention of having a standard 
> MIB that could be accessed using different protocols.
> 
> The only place where the MIB is inadequate is for configuring the 
> read-write objects in the RFC2922 ptopoConfigGroup and the LLDP-MIB 
> lldpConfiguration groups.
> But since most SNMP deployments don’t support SNMP SETs, these MIB 
> objects probably aren’t used directly anyway.
> If they are used, but configured via CLI commands or other 
> mechanisms, then a YANG module to configure them might be helpful.
> 
> David Harrington
> [email-masked]
> +1-603-828-1401
> Yes, LLDP is an alternative in my research. Either way, I guess we 
> need some way to fetch those distributed info from switches, in 
> order to build the topology. In the case of NETCONF, those switches 
> must announce and support an extra capability of a read-only YANG 
> module translated from the according MIB. 
> 
> What I'm worried about is the lack of a standard-defined YANG module
> for this purpose. Different vendors may implement their own YANG 
> modules if they ever have one. It's thus hard to discover the 
> network topology when there are switches from different vendors, or 
> at least not scalable. 
> 
> To me, missing a standard module may limit the usage of NETCONF in 
> this area. People will have to fall back and use SNMP to read MIB on
> different switches. 
> 

> 
> Best regards, 
> Eric 
> 
> Juergen Schoenwaelder <[email-masked]> wrote 
> on 2014/09/10 19:34:16:
> 

> > > ietf-routing.yang draft listing at www.netconfcentral.org. So 
isthere any

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 11 Sep 2014 08:10:50 +0000

I would strongly recommend using the MIB module defined in IEEE 802.1AB rather than RFC 2922.

Regards,

Dan

From: Netconf [mailto:[email-masked]] On Behalf Of ietfdbh
Sent: Thursday, September 11, 2014 7:03 AM
To: 'Jing Zhao'; 'Juergen Schoenwaelder'
Cc: [email-masked]
Subject: Re: [Netconf] L2 topology discovery with NETCONF

Hi,

I don't understand why you think the lack of a standard YANG module is a problem for discovering network topology.
There are standard MIB modules supporting LLDP, and for discovering the network topology, they can be read using NETCONF, for those who want to use NETCONF, and they can be read using SNMP for those who want to use SNMP.
That actually follows the original intention of having a standard MIB that could be accessed using different protocols.

The only place where the MIB is inadequate is for configuring the read-write objects in the RFC2922 ptopoConfigGroup and the LLDP-MIB lldpConfiguration groups.
But since most SNMP deployments don't support SNMP SETs, these MIB objects probably aren't used directly anyway.
If they are used, but configured via CLI commands or other mechanisms, then a YANG module to configure them might be helpful.

David Harrington
[email-masked]<mailto:[email-masked]>
+1-603-828-1401
From: Jing Zhao [mailto:[email-masked]]
Sent: Wednesday, September 10, 2014 9:47 PM
To: Juergen Schoenwaelder
Cc: [email-masked]<mailto:[email-masked]>; ietfdbh
Subject: Re: [Netconf] L2 topology discovery with NETCONF

Thanks guys.

Yes, LLDP is an alternative in my research. Either way, I guess we need some way to fetch those distributed info from switches, in order to build the topology. In the case of NETCONF, those switches must announce and support an extra capability of a read-only YANG module translated from the according MIB.

What I'm worried about is the lack of a standard-defined YANG module for this purpose. Different vendors may implement their own YANG modules if they ever have one. It's thus hard to discover the network topology when there are switches from different vendors, or at least not scalable.

To me, missing a standard module may limit the usage of NETCONF in this area. People will have to fall back and use SNMP to read MIB on different switches.

So I want to know if there is something defined in NETCONF standard pertaining to L2 topology discovery. If not, is there any plan for that?

Best regards,
Eric

Juergen Schoenwaelder <[email-masked]<mailto:[email-masked]>> wrote on 2014/09/10 19:34:16:

> From: Juergen Schoenwaelder <[email-masked]<mailto:[email-masked]>>
> To: Jing Zhao <[email-masked]<mailto:[email-masked]>>,
> Cc: [email-masked]<mailto:[email-masked]>
> Date: 2014/09/10 19:34
> > [email-masked]<mailto:[email-masked]>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 11 Sep 2014 08:16:30 +0000

Hi,

Development of MIB modules for L2 bridging, including topology discovery was transferred from the IETF to the IEEE 802.1 Working Group. By now they develop only SMIv2 MIB modules, including the one that supports IEEE 802.1AB, which is an evolution of the IETF ptopo MIB supporting LLDP. The IEEE 802 started a process of evolution towards YANG (they had a tutorial in July, started discussions about YANG support in new projects) but it's hard to estimate when and how these discussions will end. However, I do not believe that the NETCONF WG (or other IETF WG) should re-enter the business of developing data models for non-IETF technologies, so such questions may better be directed to the IEEE 802.1 WG - they may actually help them understand the need and accelerate their transition to NETCONF/YANG.

Regards,

Dan

From: Netconf [mailto:[email-masked]] On Behalf Of Jing Zhao
Sent: Thursday, September 11, 2014 4:47 AM
To: Juergen Schoenwaelder
Cc: [email-masked]
Subject: Re: [Netconf] L2 topology discovery with NETCONF

Thanks guys.

Best regards,
Eric

---

From: "ietfdbh" <[email-masked]>
Date: Thu, 11 Sep 2014 11:00:30 -0400

+1

David Harrington

+1-603-828-1401

From: Netconf [mailto:[email-masked]] On Behalf Of Romascanu, Dan
(Dan)
Sent: Thursday, September 11, 2014 4:17 AM
To: Jing Zhao; Juergen Schoenwaelder
Cc: [email-masked]
Subject: Re: [Netconf] L2 topology discovery with NETCONF

Hi,

Development of MIB modules for L2 bridging, including topology discovery was
transferred from the IETF to the IEEE 802.1 Working Group. By now they
develop only SMIv2 MIB modules, including the one that supports IEEE
802.1AB, which is an evolution of the IETF ptopo MIB supporting LLDP. The
IEEE 802 started a process of evolution towards YANG (they had a tutorial in
July, started discussions about YANG support in new projects) but it's hard
to estimate when and how these discussions will end. However, I do not
believe that the NETCONF WG (or other IETF WG) should re-enter the business
of developing data models for non-IETF technologies, so such questions may
better be directed to the IEEE 802.1 WG - they may actually help them
understand the need and accelerate their transition to NETCONF/YANG. 

Regards,

Dan

Thanks guys. 

Best regards, 
Eric

---

From: Jing Zhao <[email-masked]>
Date: Fri, 12 Sep 2014 07:41:05 +0800

I get it, and thanks!

Best regards,
Eric

"Romascanu, Dan (Dan)" <[email-masked]> wrote on 2014/09/11 16:16:30:

> From: "Romascanu, Dan (Dan)" <[email-masked]>
> To: Jing Zhao <[email-masked]>, Juergen Schoenwaelder 
> Cc: "[email-masked]" <[email-masked]>
> Date: 2014/09/11 16:16
> Development of MIB modules for L2 bridging, including topology 
> discovery was transferred from the IETF to the IEEE 802.1 Working 
> Group. By now they develop only SMIv2 MIB modules, including the one
> that supports IEEE 802.1AB, which is an evolution of the IETF ptopo 
> MIB supporting LLDP. The IEEE 802 started a process of evolution 
> towards YANG (they had a tutorial in July, started discussions about
> YANG support in new projects) but it’s hard to estimate when and how
> these discussions will end. However, I do not believe that the 
> NETCONF WG (or other IETF WG) should re-enter the business of 
> developing data models for non-IETF technologies, so such questions 
> may better be directed to the IEEE 802.1 WG – they may actually help
> them understand the need and accelerate their transition to 
NETCONF/YANG. 

isthere any