Subject: [Netconf] Fwd: [Technical Errata Reported] RFC6241 (4066)

From: Benoit Claise <[email-masked]>
Date: Mon, 22 Sep 2014 14:44:24 +0200

Dear all,

Should this reported technical errata be accepted?

Regards, Beonit

-------- Original Message --------
Subject: 	[Technical Errata Reported] RFC6241 (4066)
Date: 	Wed, 30 Jul 2014 08:16:36 -0700
From: 	RFC Errata System <[email-masked]>
To: 	<[email-masked]>, <[email-masked]>, 
<[email-masked]>, <[email-masked]>, 
<[email-masked]>, <[email-masked]>, <[email-masked]>, 
<[email-masked]>
CC: 	<[email-masked]>, <[email-masked]>, <[email-masked]>

The following errata report has been submitted for RFC6241,
"Network Configuration Protocol (NETCONF)".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=6241&eid=4066

--------------------------------------
Type: Technical
Reported by: Andy Bierman <[email-masked]>

Section: 7.2

Original Text
-------------
If the "operation" attribute is not specified, the
configuration is merged into the configuration datastore.

Corrected Text
--------------
If the "operation" attribute is not specified, then the operation
applied to the parent data node of the configuration is used.
If no parent data node is available, then the "default-operation"
value is used.

Notes
-----
sentence in para 6 is not correct.
The default-operation value is used, not the value "merge".

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary.

--------------------------------------
RFC6241 (draft-ietf-netconf-4741bis-10)
--------------------------------------
Title               : Network Configuration Protocol (NETCONF)
Publication Date    : June 2011
Author(s)           : R. Enns, Ed., M. Bjorklund, Ed., J. Schoenwaelder, Ed., A. Bierman, Ed.
Category            : PROPOSED STANDARD
Source              : Network Configuration
Area                : Operations and Management
Stream              : IETF
Verifying Party     : IESG

.

---

From: Martin Bjorklund <[email-masked]>
Date: Mon, 22 Sep 2014 14:54:40 +0200 (CEST)

> Should this reported technical errata be accepted?

I suggested a variant of the proposed text in:

http://www.ietf.org/mail-archive/web/netconf/current/msg09169.html

/martin

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 22 Sep 2014 14:57:37 +0200

> http://www.ietf.org/mail-archive/web/netconf/current/msg09169.html

I like Martin's text.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Bert Wijnen (IETF)" <[email-masked]>
Date: Mon, 22 Sep 2014 15:00:31 +0200

>> http://www.ietf.org/mail-archive/web/netconf/current/msg09169.html

same here, Bert

---

From: "Alberto Gonzalez Prieto (albertgo)" <[email-masked]>
Date: Mon, 22 Sep 2014 17:58:02 +0000

+1

On 9/22/14, 6:00 AM, "Bert Wijnen (IETF)" <[email-masked]> wrote:

>_______________________________________________
>Netconf mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/netconf

---

From: "Sterne, Jason (Jason)" <[email-masked]>
Date: Mon, 22 Sep 2014 18:10:15 +0000

+1 on Martin's.

-----Original Message-----
From: Netconf [mailto:[email-masked]] On Behalf Of Bert Wijnen (IETF)
Sent: Monday, September 22, 2014 9:01 AM
To: Martin Bjorklund; [email-masked]; [email-masked]
Subject: Re: [Netconf] Fwd: [Technical Errata Reported] RFC6241 (4066)

same here, Bert