Subject: [Netconf] regarding my action items from today's meeting

From: Kent Watsen <[email-masked]>
Date: Mon, 22 Sep 2014 22:05:01 +0000

*** ACTION: Kent to lookup who raised the call-hone [sic] enable knobs
    (bwijnen, 18:46:57)

This regards https://github.com/netconf-wg/server-model/issues/7.

I traced this comment to the Open Issues section in the original
netconf-server draft (it was NOT posted to the mailing list).  Juergen had
added it to the Open Issues section (via revision 3991 on his SVN server),
but it was more an open-ended question rather than an assertion of any
kind.   Juergen further clarified on today's call that he wouldn't push
for it, and Andy/Kent are against it, so it seems that we could close this
issue with resolution of not adding "enable[d]" knobs to the draft...

Anybody disagree?

PS: my plan is to resurrect the conditional-enablement draft so that
metadata (e.g., XML attributes) can be used to enable/disable subtrees.

*** ACTION: Kent to check what Junos allows  (kwatsen_, 18:54:05)

This regards https://github.com/netconf-wg/server-model/issues/8.

The JUNOS model looks like this:

   +--rw configuration!
      +--rw system
         +--rw services!
            +--rw netconf
               +--rw ssh!
                  +--rw apply-advanced
                  +--rw connection-limit?   uint32
                  +--rw rate-limit?         uint32
                  +--rw port?               int32

Or in YANG:

       container netconf {
         description "Allow NETCONF connections";
         container ssh {
           presence "enable ssh";
           description "Allow NETCONF over SSH";
           leaf connection-limit {
             description "Maximum number of allowed connections";
             default 75;
             type uint32 {
               range "1 .. 250";
             }
           }
           leaf rate-limit {
             description "Maximum number of connections per minute";
             default 150;
             type uint32 {
               range "1 .. 250";
             }
           }
           leaf port {
             description "Service port number";
             type int32 {
               range "1 .. 65535";
             }
           }
         }

Cheers,
Kent

---

From: "Bert Wijnen (IETF)" <[email-masked]>
Date: Tue, 23 Sep 2014 09:59:20 +0200

W.r.t.

> issue with resolution of not adding "enable[d]" knobs to the draft...

Please speak up ASAP (by Okt 1st at the latest) if you believe that we
do need those "enable[d]" knobs. If we hear no strong objections, then we
will do as suggested by Kent, "do not add those knobs".

Bert and Mehmet

> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>