Subject: [Netconf] Details about the Bi-weekly NETCONF Virtual Interim on October 20, 2014, 17:00-19:00 UTC

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Thu, 16 Oct 2014 18:53:50 +0000

Dear NETCONF WG,

our next NETCONF virtual interim meeting will take place on Monday, October 20th, 17:00-19:00 UTC (19-21 Amsterdam, Berlin time).
Below is the agenda and the issue list we plan to discuss.

@All: Please read the issue descriptions in github and state your opinion concerning the possible solution as well as the way forward on the ML before the meeting.
@Draft authors: Please raise a discussion on concerning open issues and feedback you would like to have. You may also extend the agenda below as necessary.

The co-chairs would also like to invite all people on NETCONF ML, but especially 

    Tom Petch, Martin Bjorklund, Mahesh Jethhanandani, Alan Luchuk, and Lada Lothka

to join the virtual interim meeting and to contribute to the issue discussion.
Your participation is required and greatly appreciated. 
Thank You!

Agenda of the virtual interim meeting on October 20, 2014 1700-1900 UTC
-----------------------------------------------------------------------------------

- 5 min chair intro - recording the meeting?, scribe, agenda bashing

- 50 min restconf open issues (Andy)
   See https://github.com/netconf-wg/restconf/issues

   RESTCONF #3: add collection resource
   https://github.com/netconf-wg/restconf/issues/3
   http://www.ietf.org/mail-archive/web/netconf/current/msg09365.html

   RESTCONF #12:   target resource list or leaf-list keys required for GET
   https://github.com/netconf-wg/restconf/issues/12

   Not on the tracker yet:
   - ietf-yang-library.yang in RESTCONF-02: Should this be in a separate RFC?
   - ietf-restconf-monitoring.yang in RESTCONF-02: Is this complete for release 1?

- 40 min netconf-server model open issues  (Kent)
   see: https://github.com/netconf-wg/server-model/issues

   Issue #4: How to configure NETCONF server's SSH host-keys or TLS certificates
   Issue #8: what other server config knobs are needed?
   Issue #13: enable indirect Issuer authentications?
   Issue #15: Should the "listen" and "call-home" lists have parent containers?

- 20 min netconf-call-home open issues  (Kent)

   Issue #3: Extend to support RESTCONF as well?
   Issue #4:  Have a call-home port?

- 5 min AOB other topics

Please let the co-chairs know ASAP if you have comments or requests concerning the agenda.

Following is the webex+audio info for the meeting:

    To JOIN WEBEX MEETING
    https://ietf.webex.com/ietf/j.php?MTID=m9f461ea30a23d08e29f45c40c0814e7d
    Meeting number: 649 602 794
    Meeting password: restconf

    JOIN BY PHONE
    1-650-479-3208 Call-in toll number (US/Canada)
    Access code: 649 602 794

    Can't join the meeting? Contact support here:
    https://ietf.webex.com/ietf/mc

Mehmet and Bert

---

From: t.petch <[email-masked]>
Date: Fri, 17 Oct 2014 11:21:12 +0100

----- Original Message -----
From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
To: "netconf" <[email-masked]>
Sent: Thursday, October 16, 2014 7:53 PM
> Dear NETCONF WG,
>
> our next NETCONF virtual interim meeting will take place on Monday,
October 20th, 17:00-19:00 UTC (19-21 Amsterdam, Berlin time).
> @All: Please read the issue descriptions in github and state your
opinion concerning the possible solution as well as the way forward on
the ML before the meeting.
> @Draft authors: Please raise a discussion on concerning open issues
and feedback you would like to have. You may also extend the agenda
below as necessary.
>   Tom Petch, Martin Bjorklund, Mahesh Jethhanandani, Alan Luchuk, and
Lada Lothka

Mehmet,

I  hear you; trouble is, the agenda is not very appealing.

I am a simple-minded man, who likes to progress in small steps and
scope, or requirements, comes early on.  Currently, I am unclear about
how a NETCONF user will be authenticated, especially with TLS; once that
is determined, I will feel able to comment more on 5539bis.  After
which, I can move on to the second half of call-home, which in turn
determines what goes, or does not go, into server-model; while RESTCONF
is not yet on my radar (I note that in Apps, there is some debate about
RESTful and whether or not it is well-enough defined to talk about
meaningfully).

So when I see 50 minutes of RESTCONF followed by 50 minutes of
server-model, I think that that is two hours of sitting and listening
for me:-(

Tom Petch

---

From: Andy Bierman <[email-masked]>
Date: Fri, 17 Oct 2014 08:55:14 -0700

> server-model, I think that that is two hours of sitting and listening
How about if your issues were first?
RESTCONF does not have to go first each time.

> Tom Petch
Andy

> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Fri, 17 Oct 2014 16:15:30 +0000

Hi Tom,

we can for sure put 5539bis issues onto the agenda.

@Juergen: Please jump in.

Cheers,
Mehmet

From: ext Andy Bierman [mailto:[email-masked]]
Sent: Friday, October 17, 2014 5:55 PM
To: t.petch
Cc: Ersue, Mehmet (NSN - DE/Munich); netconf
Subject: Re: [Netconf] Details about the Bi-weekly NETCONF Virtual Interim on October 20, 2014, 17:00-19:00 UTC

On Fri, Oct 17, 2014 at 3:21 AM, t.petch <[email-masked]<mailto:[email-masked]>> wrote:
----- Original Message -----
From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]<mailto:[email-masked]>>
To: "netconf" <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, October 16, 2014 7:53 PM

Mehmet,

Tom Petch

Andy

_______________________________________________
Netconf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netconf

---

From: t.petch <[email-masked]>
Date: Fri, 17 Oct 2014 17:46:32 +0100

Mehmet

My sense is that we are heading towards X.509 certificates for client
and server authentication with NETCONF over TLS and that what it needs
is a consensus call to effect that.  I don't think there is anything to
discuss, ar at least, not worth putting on the Agenda of a Virtual
Interim.  And if, in a week or two, we have that consensus, then it is a
question of updating the three I-Ds to reflect that and seeing what
comes next.  May be how to extract a user id will be then worth
discussing.

So it is probably right that the Virtual Interim focuses on RESTCONF
because I suspect that that is the area where discussions will be most
fruitful, just that I don't see anything I can contribute there at this
time.

Tom  Petch

----- Original Message -----
From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
To: "ext Andy Bierman" <[email-masked]>; "t.petch"
<[email-masked]>
Cc: "netconf" <[email-masked]>
Sent: Friday, October 17, 2014 5:15 PM
Subject: RE: [Netconf] Details about the Bi-weekly NETCONF Virtual
Interim on October 20, 2014, 17:00-19:00 UTC

Hi Tom,

Cheers,
Mehmet

From: ext Andy Bierman [mailto:[email-masked]]
Sent: Friday, October 17, 2014 5:55 PM
To: t.petch
Cc: Ersue, Mehmet (NSN - DE/Munich); netconf
Subject: Re: [Netconf] Details about the Bi-weekly NETCONF Virtual
Interim on October 20, 2014, 17:00-19:00 UTC

On Fri, Oct 17, 2014 at 3:21 AM, t.petch
<[email-masked]<mailto:[email-masked]>> wrote:
----- Original Message -----
From: "Ersue, Mehmet (NSN - DE/Munich)"
<[email-masked]<mailto:[email-masked]>>
To: "netconf" <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, October 16, 2014 7:53 PM

Mehmet,

Tom Petch

Andy

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Sun, 19 Oct 2014 18:50:36 +0000

Agree basically. Though I think a discussion on X.509 usage in the interim meeting will be valuable.

BR,
Mehmet 

> -----Original Message-----
> From: ext t.petch [mailto:[email-masked]]
> Sent: Friday, October 17, 2014 6:47 PM
> To: Ersue, Mehmet (NSN - DE/Munich)
> Cc: netconf; Juergen Schoenwaelder