Subject: Re: [Netconf] Draft Minutes of the NETCONF session in IETF 91

From: Kent Watsen <[email-masked]>
Date: Mon, 24 Nov 2014 23:48:20 +0000

Hi Mehmet, Mahesh,

Today is the 24th and no comments to the minutes have been raised.  Can we now state that WG consensus to the decisions captured in the minutes have been confirmed on the list?

If so, then I'll proceed updating my drafts as follows:

  * draft-ietf-netconf-call-home
         - will be updated to include RESTCONF  (separate ports)

  * draft-ietf-netconf-server-model
         -  will also be updated to include RESTCONF (to support above edit)
         - remove YANG 1.1 if-feature statements
         - add support for configuring client certs for SSH also
         - remove read-only listing of keys/certs supported by server
         - add if-feature statement to the new global config options
         - clean up IANA section (andy's comment)

  * draft-ietf-netconf-zerotouch
         - clarify bootstrapping sequence diagram
         - (post-meeting) see if there a solution that doesn't entail vendor-tracking

Thanks,
Kent

From: <Ersue>, "Mehmet (NSN - DE/Munich)" <[email-masked]<mailto:[email-masked]>>
Date: Sunday, November 16, 2014 at 2:23 AM
To: NetConf <[email-masked]<mailto:[email-masked]>>
Subject: [Netconf] Draft Minutes of the NETCONF session in IETF 91

Dear NETCONF WG,

please find below the draft minutes of the NETCONF session in IETF 91:
http://www.ietf.org/proceedings/91/minutes/minutes-91-netconf

Please send your comments to the co-chairs by November 24, 2014 EOB PT.

Cheers,
Mehmet

---

From: Martin Bjorklund <[email-masked]>
Date: Tue, 25 Nov 2014 09:45:50 +0100 (CET)

Kent Watsen <[email-masked]> wrote:
> Hi Mehmet, Mahesh,
> 
> Today is the 24th and no comments to the minutes have been raised.
> Can we now state that WG consensus to the decisions captured in the
> minutes have been confirmed on the list?

I hope not!  I interpreted Mehmet's email to mean that we could
provide comments on *the draft minutes* until the 24th.

/martin

>          - (post-meeting) see if there a solution that doesn't entail
>          - vendor-tracking
> 
> 
> Thanks,
> Kent
> 
> 
> From: <Ersue>, "Mehmet (NSN - DE/Munich)"
> <[email-masked]<mailto:[email-masked]>>

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Tue, 25 Nov 2014 11:22:15 +0000

Hi All,

I started the verification of IETF 91 WG session results with the attached mail. 
As there was no objection to the session results the draft authors will implement the solutions as agreed.

Cheers, 
Mehmet 

> -----Original Message-----
> From: ext Martin Bjorklund [mailto:[email-masked]]
> Sent: Tuesday, November 25, 2014 9:46 AM
> To: [email-masked]
> Cc: Ersue, Mehmet (NSN - DE/Munich); [email-masked]; [email-masked]
> Subject: Re: [Netconf] Draft Minutes of the NETCONF session in IETF 91
> 

Subject: [Netconf] Summary of and AIs from the NETCONF Session in IETF #91
From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
To: ext Benoit Claise <[email-masked]>, netconf <[email-masked]>
Date: Thu, 13 Nov 2014 05:07:41 +0000
List-Id: Network Configuration WG mailing list <netconf.ietf.org>

Hi Benoit, NETCONF WG,

below is a summary and action items from the NETCONF WG session on November 11, 2014, Honolulu, Hawaii.
A short version of this summary will be made available at OPS area Wiki soon (at http://trac.tools.ietf.org/area/ops/trac/wiki/IETF91summary).

- We had approx. 85+ participants in the 2 hour NETCONF session,
- We reviewed the status of the WG,
- We had a discussion on all 6 chartered documents.
- Note takers were: Lada Lhotka and Balazs Lengyel. The Jabber scribe was Rolf Winter.
Many thanks to the note takers and jabber scribe for volunteering.

The session agenda is available at: http://www.ietf.org/proceedings/91/agenda/agenda-91-netconf
NETCONF co-chairs will ask for a room for 100 for the next meeting.

Following are the decisions taken per humming in the NETCONF session.
If there is no strong objection we will implement as proposed.

RESTCONF Call home support:
   - humming supported this approach, and the WG wants to do it now.

Separate ports for callhome for SSH, TLS, RESTCONF
   - The WG supports with a large humm multiple/separate ports.

Focus on the use of X.509 for TLS (rfc5539bis)
   - supported by a large humm

Describe algorithm for extracting a user name out of the X509 attributes
   - loud humm in favor

Use if-feature for server-model instead of waiting for an YANG 1.1 solution
   - loud humm in favor, certainly we do not want to wait

Should we generate ssh host keys/509-certificates via a yang model or generate
them out of band.
   -  big humm for yes, i.e. we postpone and do it later.

Report hostkeys/certificates via yang data model
   - Humm to take them out and not report them via a data model

RESTCONF state monitoring would require RESTCONF sessions
   - ACTION item: Andy will take the issue to list

RESTCONF Default handling:
   - ACTION item: Andy will take it to the list

SHOULD or MUST use HTTP 1.1
   - humm in favor of SHOULD

The issue on the I2RS ephemeral state has been summarized by the I2RS co-chair Jeff Haas.
The discussion will be continued in NETCONF virtual meetings.

The two drafts on fragmentation support will be merged and provided to NETCONF maillist.
The aim should be to raise a discussion and to get the support of NETCONF WG memebers.

Virtual Meetings:
   - The WG will continue with virtual meetings.
   - In the first meeting we will discuss I2RS ephemeral state.
   - Action item: Mehmet to send out a new doodle poll to chose the best time for all.

Potential requirements on zerotouch from ANIMA WG:
   - Action item: WG chairs to communicate with ANIMA WG co-chairs that they must agree on
     requirements and provide with a draft to NETCONF WG.

Cheers,
Mehmet

_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

---

From: t.petch <[email-masked]>
Date: Tue, 25 Nov 2014 11:27:11 +0000

Kent

I made two comments, seeking clarification as to what the two hums were
about, one of which was where the algorithm for extracting a user name
out of the X.509 attributes would go (something I got the sense that
Juergen had wanted more clarity on).

For me, netconf-server is the right place but I have seen nothing that I
would call consensus (or lack thereof) on this item.

Tom Petch

----- Original Message -----
From: "Kent Watsen" <[email-masked]>
To: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>; "Mahesh
Jethanandani" <[email-masked]>
Cc: "NETCONF" <[email-masked]>
Sent: Monday, November 24, 2014 11:48 PM
Subject: Re: [Netconf] Draft Minutes of the NETCONF session in IETF 91

Hi Mehmet, Mahesh,

Today is the 24th and no comments to the minutes have been raised.  Can
we now state that WG consensus to the decisions captured in the minutes
have been confirmed on the list?

         -  will also be updated to include RESTCONF (to support above
edit)

vendor-tracking

Thanks,
Kent

Dear NETCONF WG,

Cheers,
Mehmet

------------------------------------------------------------------------
--------

---

From: Kent Watsen <[email-masked]>
Date: Tue, 25 Nov 2014 15:59:30 +0000

>would call consensus (or lack thereof) on this item.

Fair point, the server-model draft has a dependency on 5539bis, also noted
during the IETF 91 meeting.  The expected impact of the 5539bis update
onto the server-model draft will likely be only to add explicit references
to 5539bis sections, in order to tie the two drafts together.

I'll move forward making the other edits now, and make the needed
adjustments for 5539bis, as soon as it's updated.

Thanks,
Kent