Subject: [Netconf] Summary of and AIs from the NETCONF Session in IETF #91

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Thu, 13 Nov 2014 05:07:41 +0000

Hi Benoit, NETCONF WG,

below is a summary and action items from the NETCONF WG session on November 11, 2014, Honolulu, Hawaii. 
A short version of this summary will be made available at OPS area Wiki soon (at http://trac.tools.ietf.org/area/ops/trac/wiki/IETF91summary).
 
- We had approx. 85+ participants in the 2 hour NETCONF session,
- We reviewed the status of the WG,
- We had a discussion on all 6 chartered documents.
- Note takers were: Lada Lhotka and Balazs Lengyel. The Jabber scribe was Rolf Winter.
Many thanks to the note takers and jabber scribe for volunteering.
 
The session agenda is available at: http://www.ietf.org/proceedings/91/agenda/agenda-91-netconf  
NETCONF co-chairs will ask for a room for 100 for the next meeting.

Following are the decisions taken per humming in the NETCONF session.
If there is no strong objection we will implement as proposed.

RESTCONF Call home support:
   - humming supported this approach, and the WG wants to do it now.

Separate ports for callhome for SSH, TLS, RESTCONF
   - The WG supports with a large humm multiple/separate ports.

Focus on the use of X.509 for TLS (rfc5539bis)
   - supported by a large humm

Describe algorithm for extracting a user name out of the X509 attributes
   - loud humm in favor

Use if-feature for server-model instead of waiting for an YANG 1.1 solution
   - loud humm in favor, certainly we do not want to wait

Should we generate ssh host keys/509-certificates via a yang model or generate
them out of band.
   -  big humm for yes, i.e. we postpone and do it later.

Report hostkeys/certificates via yang data model
   - Humm to take them out and not report them via a data model

RESTCONF state monitoring would require RESTCONF sessions
   - ACTION item: Andy will take the issue to list

RESTCONF Default handling:
   - ACTION item: Andy will take it to the list

SHOULD or MUST use HTTP 1.1
   - humm in favor of SHOULD

The issue on the I2RS ephemeral state has been summarized by the I2RS co-chair Jeff Haas.
The discussion will be continued in NETCONF virtual meetings.

The two drafts on fragmentation support will be merged and provided to NETCONF maillist.
The aim should be to raise a discussion and to get the support of NETCONF WG memebers.

Virtual Meetings:
   - The WG will continue with virtual meetings.
   - In the first meeting we will discuss I2RS ephemeral state.
   - Action item: Mehmet to send out a new doodle poll to chose the best time for all.

Potential requirements on zerotouch from ANIMA WG:
   - Action item: WG chairs to communicate with ANIMA WG co-chairs that they must agree on
     requirements and provide with a draft to NETCONF WG.

Cheers,
Mehmet

---

From: t.petch <[email-masked]>
Date: Thu, 13 Nov 2014 10:31:15 +0000

----- Original Message -----
From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
To: "ext Benoit Claise" <[email-masked]>; "netconf"
<[email-masked]>
Sent: Thursday, November 13, 2014 5:07 AM
Subject: [Netconf] Summary of and AIs from the NETCONF Session in IETF
#91

> A short version of this summary will be made available at OPS area
Wiki soon (at
http://trac.tools.ietf.org/area/ops/trac/wiki/IETF91summary).
> The session agenda is available at:
http://www.ietf.org/proceedings/91/agenda/agenda-91-netconf
> If there is no strong objection we will implement as proposed.

<snip>

>    - supported by a large humm

A clarification - does this mean that we re-title rfc5539bis as being
only about the use of TLS leaving those wanting other forms of security
to write their own I-Ds?

Tom Petch

> >
> Cheers,
> Mehmet
>
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf

---

From: t.petch <[email-masked]>
Date: Thu, 13 Nov 2014 10:34:15 +0000

----- Original Message -----
From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
To: "ext Benoit Claise" <[email-masked]>; "netconf"
<[email-masked]>

Wiki soon (at

<snip>

> Describe algorithm for extracting a user name out of the X509
attributes

A clarification - does this mean that this algorithm goes in
netconf-server?

Tom Petch

<snip>