Subject: [Netconf] RESTCONF/YANG Patch Status for Jan. 5 Virtual Interim meeting

From: Andy Bierman <[email-masked]>
Date: Sun, 4 Jan 2015 11:11:40 -0800

Hi,

There are no RESTCONF or YANG Patch issues that
really need discussion at this time.

RESTCONF Issues:
https://github.com/netconf-wg/restconf/issues

YANG Patch Issues:
https://github.com/netconf-wg/yang-patch/issues

Most RESTCONF issues have some sort of
resolution and do not need to be discussed until the
next draft is reviewed. These include:

   #1: select parameter
   Resolution: rename select to fields

   #2: netconf-state monitoring support
   Resolution: do not add any session monitoring

   #3:collection resource
   Resolution: split all collection resource details out into
   a new WG draft that will be called
   draft-ietf-netconf-restconf-collection-00

   #4: defaults handling
   Resolution: add 2 capabilities as proposed

   #9: Define how authentication is performed
   Resolution: Security section text has been updated

   #14: define module name prefix rules
   Resolution: Will accept YANG JSON encoding rules
   (SHOULD use prefix)

   #15: use of groupings in ietf-restconf.yang
   Resolution: Use restconf-resource extension solution to
   bind namespace and module-name to a RESTCONF resource

   #16: content parameter should be mandatory to implement
   Resolution: make content parameter mandatory

The following issue depends on the NETMOD WG resolution
of Y45:

   #13: ietf-yang-library: which RFC should contain this module

There are 2 open issues for YANG Patch that have resolution
proposals.

    #1:  structure of edit value anyxml
    Resolution: require child value to contain child node representing
    the edit content

     #2: parsing QNames in value parameter anyxml
     Resolution: this is an implementation detail. It is expected
     that the edit content will be validated against the YANG
     schema for the indicated object somehow

Future Discussion items:
    RESTCONF #3:  Query parameters and other mechanisms
    needed for needed for management and retrieval of collection resources.
    There are no concrete proposals for extended selection and sorting support
    at this time. This discussion is expected to occur for the new
collection draft.

Andy

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Mon, 5 Jan 2015 14:29:15 +0000

Hi All,

the resolution and the way forward for the Restconf issues #14 and #16 have been now updated on Github. 
We are going to implement as described.

Please speak up by January 8 if you have any strong objections.

Mehmet 

> -----Original Message-----
> From: Netconf [mailto:[email-masked]] On Behalf Of ext Andy Bierman
> Sent: Sunday, January 04, 2015 8:12 PM
> To: Netconf
> Subject: [Netconf] RESTCONF/YANG Patch Status for Jan. 5 Virtual Interim meeting
> 
> Hi,
> 
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf