Subject: [Netconf] Agenda of the NETCONF Virtual Interim Meeting on January 19, 2015 1700-1900 UTC

From: Mahesh Jethanandani <[email-masked]>
Date: Thu, 15 Jan 2015 22:27:41 -0800

NETCONF WG,

Please find below the agenda of the NETCONF virtual interim meeting on January 19, 2015 1700-1900 UTC and the access information for the meeting.

I would like to invite all WG members to participate in the meeting and discuss the open issues. Based on the results of that discussion and agreement reached, we will start the WGLC for some of the WG items.

Agenda of the virtual interim meeting on January 19, 2015 1700-1900 UTC
-------------------------------------------------------------------------------------
Agenda is also available at: 
http://www.ietf.org/proceedings/interim/2015/01/19/netconf/agenda/agenda-interim-2015-netconf-2

- 5 min chair intro, scribe, agenda bashing
 The notes will be taken on: http://beta.etherpad.org/p/netconf-Jan19 <http://beta.etherpad.org/p/netconf-Jan19>  

- 15 minutes. Discussion around use of GitHub as an issue tracker and the different states. One of the suggestions from Kent is represented in the following diagram:

               GitHub Status
   +----------------+----------------+
   |      Open      |     Closed     |
   |                |                |
   |                |                |
   |                |                |
   |      New -----------> Dead      |
   |       |        |                |
   |       V        |                |
   |      Open      |                |
   |       |        |                |
   |       V        |                |
   |     Verify     |                |
   |       |        |                |
   |       V        |                |
   |      Edit      |                |
   |       |        |                |
   |       V        |                |
   |     Review --------> Done       |
   |                |                |
   |                |                |
   |                |                |
   |   Editorial -------> Editorial  |
   |                |                |
   |                |                |
   +----------------+————————+

where the states are (borrowed from NETMOD GitHub) and are defined as follows:

- NEW :: A submitted issue starts in the NEW state. Note that issues
         were collected in Spring 2014. Since then, we are adding new
         issues only in special cases (e.g., new YANG bugs identified
         or splitting issues into several smaller issues).
- OPEN :: A first discussion of the issue took place and it was
          accepted to be in scope of the YANG 1.1 effort.
- DEAD :: The issue was declared dead, e.g., because it is considered
          outside of the scope of YANG 1.1 or the issue does not seem
          to require a solution.
- VRFY :: The issue was discussed and a resolution emerged that needs
          to be verified on the mailing list.
- EDIT :: The issue is waiting for the document editor to make the
          corresponding changes.
- REVIEW :: The edits have been done and the changes in the I-D need
            to be reviewed.
- DONE :: The edits have been reviewed an the issue has been resolved.

- Call Home (Kent) (10min)
            Updated draft posted. 
            Currently 2 open issues in review state
 See https://github.com/netconf-wg/call-home/issues <https://github.com/netconf-wg/call-home/issues>  

- Server Model (Kent) (20min)
 Currently 4 open issues. Two in verify, 1 dead and 1 edit.
 See https://github.com/netconf-wg/server-model/issues <https://github.com/netconf-wg/server-model/issues>
         - Restconf (Andy) (20min) (Is Andy attending?)
           Currently 9 open issues, 4 of them are enhancement
           https://github.com/netconf-wg/restconf/issues <https://github.com/netconf-wg/restconf/issues>   

        - Zerotouch (Kent) (10min)
          Currently 2 open issues.
          See https://github.com/netconf-wg/zero-touch/issues <https://github.com/netconf-wg/yang-patch/issues>
       - Update from i2rs WG (Jeffrey Haas/Susan Hares)
          i2rs requirements on NETCONF.

       - 5 min AOB other topics

Cheers
Mahesh and Mehmet

--------------------------------------------------------------------------------------------------------------------------------------------------------------------------
NETCONF Virtual Meetings
Every 2 weeks on Monday, from Monday, January 19, 2015, to Monday, March 2, 2015
6:00 pm  |  Europe Time (Berlin, GMT+01:00)  |  2 hr 45 min
 
Join WebEx meeting <https://ietf.webex.com/ietf/j.php?MTID=mb7c42dd2a2944005f5fd0a8624dac056>
Meeting number:	640 672 878
Meeting password:	nc2015
 
Join by phone
1-877-668-4493 Call-in toll free number (US/Canada)
1-650-479-3208 Call-in toll number (US/Canada)
Access code: 640 672 878
Toll-free calling restrictions <http://www.webex.com/pdf/tollfree_restrictions.pdf>
 
Add this meeting <https://ietf.webex.com/ietf/j.php?MTID=md940f58ed7f75f984c4936323a8a32c5> to your calendar.
 
Can't join the meeting? Contact support. <https://ietf.webex.com/ietf/mc>
 
IMPORTANT NOTICE: Please note that this WebEx service allows audio and other information sent during the session to be recorded, which may be discoverable in a legal matter. By joining this session, you automatically consent to such recordings. If you do not consent to being recorded, discuss your concerns with the host or do not join the session.

---

From: Andy Bierman <[email-masked]>
Date: Fri, 16 Jan 2015 07:37:53 -0800

Hi,

Monday, Jan. 19th is a national holiday in the US (MLK day) so I will
not be attending the interim.  Perhaps somebody else can present
the RESTCONF status.

Andy

On Thu, Jan 15, 2015 at 10:27 PM, Mahesh Jethanandani <
[email-masked]> wrote:

> NETCONF WG,
>
> Please find below the agenda of the NETCONF virtual interim meeting on
> January 19, 2015 1700-1900 UTC and the access information for the meeting.
>
> I would like to invite all WG members to participate in the meeting and
> discuss the open issues. Based on the results of that discussion and
> agreement reached, we will start the WGLC for some of the WG items.
>
>
>  The notes will be taken on: http://beta.etherpad.org/p/netconf-Jan19
>
> - 15 minutes. Discussion around use of GitHub as an issue tracker and the
> different states. One of the suggestions from Kent is represented in the
> following diagram:
>
>                GitHub Status
>  See https://github.com/netconf-wg/call-home/issues
>
>  See https://github.com/netconf-wg/server-model/issues
>
>            https://github.com/netconf-wg/restconf/issues
>
>           See https://github.com/netconf-wg/zero-touch/issues
> <https://github.com/netconf-wg/yang-patch/issues>
>
> *NETCONF Virtual Meetings*Every 2 weeks on Monday, from Monday, January
> 19, 2015, to Monday, March 2, 20156:00 pm  |  Europe Time (Berlin,
> GMT+01:00)  |  2 hr 45 min *Join WebEx meeting*
> <https://ietf.webex.com/ietf/j.php?MTID=mb7c42dd2a2944005f5fd0a8624dac056>Meeting
> number:640 672 878Meeting password:nc2015 *Join by phone**1-877-668-4493* Call-in
> toll free number (US/Canada)*1-650-479-3208* Call-in toll number
> (US/Canada)Access code: 640 672 878Toll-free calling restrictions
> <http://www.webex.com/pdf/tollfree_restrictions.pdf> Add this meeting
> <https://ietf.webex.com/ietf/j.php?MTID=md940f58ed7f75f984c4936323a8a32c5> to
> your calendar. Can't join the meeting? Contact support.
> <https://ietf.webex.com/ietf/mc> IMPORTANT NOTICE: Please note that this
> WebEx service allows audio and other information sent during the session to
> be recorded, which may be discoverable in a legal matter. By joining this
> session, you automatically consent to such recordings. If you do not
> consent to being recorded, discuss your concerns with the host or do not
> join the session.
>
>
>
>
>
>
>
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>
>