Subject: Re: [Netconf] NACM update for YANG 1.1

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 13 Feb 2015 21:51:21 +0100

Mehmet,

may I assume that a NACM update can made? Please confirm so that we can
move forward with Y58 (and perhaps Y36).

/js

On Thu, Jan 08, 2015 at 03:20:28PM +0000, Ersue, Mehmet (NSN - DE/Munich) wrote:
> Hi Juergen,
> 
> thanks for sharing the issue description and the background.
> I personally believe we should extend RFC 6536 to support the usage of actions.
> 
> @All: Please comment by January 22, 2015, whether you have any objections to addressing the issue with a rfc6536bis document.
> 
> Regards,
> Mehmet 
> 
> -----Original Message-----
> From: ext Juergen Schoenwaelder [mailto:[email-masked]] 
> Sent: Thursday, January 08, 2015 12:19 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: NACM update for YANG 1.1
> 
> Hi,
> 
> the YANG 1.1 work going on in NETMOD has two issues that interact with
> the NETCONF access control model (NACM) defined in RFC 6536.  YANG 1.1
> issue Y58 provides a mechanism to associate an action with a data
> node. (Similarily, Y36 provides a mechanism to associate a
> notification with a data node.)
> 
> To fully support Y58 (and perhaps Y36), a minor modification of NACM
> would be needed so that access control rights can be associated with
> actions. The change is expected to be minor and the editors of RFC
> 6536 indicated to be willing to do the work.
> 
> The question now is if NETCONF is willing to do this update if say Y58
> makes it into YANG 1.1. (While there seems to be good support for Y58,
> some people raised a concern that we should not have an incomplete
> solution where standard access control cannot be configured for
> actions.)
> 
> The YANG 1.1 issues list can be found here:
> 
>      http://svn.tools.ietf.org/svn/wg/netmod/yang-1.1/
> 
> /js
> 
> -- 
> Juergen Schoenwaelder           Jacobs University Bremen gGmbH
> Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
> Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Fri, 13 Feb 2015 21:16:56 +0000

Juergen,

there were no objections against NACM by the call deadline. 
Also offline discussion with different draft authors showed that there is a need.

So we may assume there is interest to address NACM as described in your original 
mail below.

Cheers, 
Mehmet 

-----Original Message-----
From: ext Juergen Schoenwaelder [mailto:[email-masked]] 
Sent: Friday, February 13, 2015 9:51 PM
To: Ersue, Mehmet (NSN - DE/Munich)
Cc: [email-masked]
Subject: Re: NACM update for YANG 1.1

Mehmet,

/js