Subject: [Netconf] Library #2: should multi-protocol information be added?

From: Andy Bierman <[email-masked]>
Date: Thu, 5 Feb 2015 09:08:45 -0800

Hi,

The following issue has been added to the github tracker:

https://github.com/netconf-wg/yang-library/issues/2

Should information be added to identify which protocols use each module or
should each protocol define their own augmentations?

Andy

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 5 Feb 2015 18:19:35 +0100

> should each protocol define their own augmentations?

Are you saying we envision servers supporting both NETCONF and
RESTCONF that expose different module sets over NETCONF and RESTCONF?

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Andy Bierman <[email-masked]>
Date: Thu, 5 Feb 2015 09:31:35 -0800

> RESTCONF that expose different module sets over NETCONF and RESTCONF?

It is already happening. Not all RESTCONF servers are going
to support the ietf-netconf RPCs (as operation resources).
Martin and I agree that this does not really work
for operations that assume NETCONF sessions are being used.

Perhaps I2RS modules will not be intended for NETCONF or RESTCONF,
but only a new I2RS protocol?

There are also the modules like ietf-restconf that only have extensions
visible just so they will be invisible to NETCONF.  This sort of clumsy
multi-protocol support is unsustainable.

Andy