Subject: [Netconf] server-model #45: how do interval-secs and count-max work for reconnect-strategy if an endpoint resolves to multiple IP addresses?

From: Kent Watsen <[email-masked]>
Date: Sun, 29 Mar 2015 20:27:37 +0000

This issue (see subject line and/or link below) was discussed during the Dallas meeting with an agreement simply document that hostname expansions occur in-line.  That is, if an application has two configured endpoints ("name1" and "name2") and each expands into two IP addresses ({ip1.1, ip1.2, ip1.3}, {ip2.1, ip2.2, ip2.3}), then treat them as if the IP addresses had been configured explicitly (ip1.1, ip1.2, ip1.3, ip2.1, ip2.2, ip2.3).

The issue is hence moved to the VERIFY state.  The issue will move to the EDIT state If no objection is raised by April 6th.

Reference: https://github.com/netconf-wg/server-model/issues/45

Thanks,
Kent

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 30 Mar 2015 09:32:45 +0200

> Reference: https://github.com/netconf-wg/server-model/issues/45

Do we keep interval-secs and count-max in the reconnect-strategy
container? If not, then I would say that we can also be silent about
this. It is good practice to iterate over the list getaddrinfo()
returns and I think it is fine if we stay out of the timing and
iteration details.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>