Subject: [Netconf] server-model #47: introduce a 2nd timeout for periodic connections for when there's data to send?

From: Kent Watsen <[email-masked]>
Date: Sun, 29 Mar 2015 22:43:41 +0000

This issue (see subject line and/or link below) was discussed during the
Dallas meeting with an agreement to change the "should" to a "may", that
the server *may* connect sooner than its periodic timeout would have it do.

OLD:

                  For messages the NETCONF server wants to send to
                  to the NETCONF client, the NETCONF server should
                  proactively connect to the NETCONF client, if
                  not already, to send the messages immediately.";

NEW

                  For messages the NETCONF server wants to send to
                  to the NETCONF client, the NETCONF server may
                  proactively connect to the NETCONF client, if
                  not already, to send its messages sooner than
                  its periodic timeout would have it do.";

This issue is hence moved to the VERIFY state.  The issue will move to the
EDIT state if no objection is raised by April 6th.

Reference: https://github.com/netconf-wg/server-model/issues/47

Thanks,
Kent

---

From: Randy Presuhn <[email-masked]>
Date: Mon, 30 Mar 2015 13:19:06 -0700 (GMT-07:00)

Hi -

>From: Kent Watsen <[email-masked]>
>Sent: Mar 29, 2015 3:43 PM
>To: "[email-masked]" <[email-masked]>
>Subject: [Netconf] server-model #47: introduce a 2nd timeout for periodic connections for when there's data to send?
>
>

The English is broken.
   s/, if not already,/ (if it is not already connected)/

The English is awkward.
   s/its periodic timeout would have it do/specified by its periodic timeout/

Anthropomorphisms are annoying:
   s/the NETCONF server wants to send/to be sent by the NETCONF server/

Randy