Subject: Re: [Netconf] [netmod] Is it possible to change a list enty's key/keys?

From: Randy Presuhn <[email-masked]>
Date: Mon, 16 Mar 2015 13:58:45 -0700 (GMT-07:00)

Hi -

>From: Ladislav Lhotka <[email-masked]>
>Sent: Mar 16, 2015 7:58 AM
>To: Randy Presuhn <[email-masked]>, Netconf <[email-masked]>
>Subject: Re: [Netconf] [netmod] Is it possible to change a list enty's key/keys?
>
>Randy Presuhn <[email-masked]> writes:
>
>> Hi -
>>
>>>From: Ladislav Lhotka <[email-masked]>
>>>Sent: Mar 11, 2015 2:43 AM
>>>To: Martin Björklund <[email-masked]>
>>>Cc: Netconf <[email-masked]>
>>>Subject: Re: [Netconf] [netmod] Is it possible to change a list enty's key/keys?
>> ...
>>>Robust management applications should be prepared to deal
>>>with e.g. interfaces being renamed at run time because that’s
>>>a fact of life.
>>
>> What are your expectations of managed systems' ability
>> to maintain referential integrity (of, e.g., logs,
>> alarms, and configuration data) across rename events?
>
>If an interface changes its name, then all references to it in the
>configuration have to be updated. I think Junos has such a procedure.
>
>You may remember that I advocated using opaque keys that don't have any
>meaning outside configuration and thus are not affected by external side
>effects.
>
>As for logs, I think the only solution is to log an entry about the name
>change, and then use the new name afterwards.

And alarms?  (Think about alarm aggregation and
trouble ticket systems.)

Randy

Randy

---

From: Ladislav Lhotka <[email-masked]>
Date: Tue, 17 Mar 2015 10:00:24 +0100

> On 16 Mar 2015, at 21:58, Randy Presuhn <[email-masked]> wrote:
> 
> Hi -
> 

I have no experience with such systems but I assume they have to be notified about the change and act accordingly. My point was just that a system-wide interface name can change, either at run time or after a reboot.

Lada

> 
> Randy
> 
> Randy
> 
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C