Subject: Re: [Netconf] rename operation for YANG Patch

From: Randy Presuhn <[email-masked]>
Date: Thu, 2 Apr 2015 09:20:14 -0700 (GMT-07:00)

Hi -

Care to be more specific about referential integrity,
both within the managed system and external references
to the entry in question?

Randy

-----Original Message-----
>From: Andy Bierman <[email-masked]>
>Sent: Apr 2, 2015 8:00 AM
>To: Netconf <[email-masked]>
>Subject: [Netconf] rename operation for YANG Patch
>
>Hi,
>
>It would be very easy to add a "rename" operation to the YANG Patch
>draft.  This would allow an operator to efficiently change the value
>of list keys without deleting and re-creating entries.
>
>Since deletion and re-creation will cause a disruption in network
>services, IMO it is important that this is fixed in RESTCONF.
>Unlike NETCONF (which has a multi-step procedure with
>locking and candidate config) there is no way to efficiently
>rename an entry in RESTCONF.
>
>The 'move' operation almost does a 'rename', but it is not expected
>to have a payload.  A 'rename' operation would be similar to 'move'
>except the keys that are changing would be specified.
>
>
>Is there support to add this operation to YANG Patch?
>
>
>Andy
>
>_______________________________________________
>Netconf mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/netconf

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 2 Apr 2015 18:55:39 +0200

I expect that the configuration datastore must validate as usual and
this implies that all leafrefs etc. are valid. There is no difference
between 'delete foo; create bar' and 'rename foo to bar' in this
respect.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Andy Bierman <[email-masked]>
Date: Thu, 2 Apr 2015 09:56:30 -0700

> to the entry in question?

Actually, this is the only solution proposal that is explicit about
renaming list instances.  If the entry is renamed by deleting
and re-creating it, then there is no way for an application
to correlate the old name and new name.  The server does not even
know there is any correlation between the old name and the new name.

But if there is a notification for a "rename event" then the applications
would have something to use for an automatic mapping.

Andy

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 2 Apr 2015 18:57:07 +0200

The other possible interpretation would be rename foo to bar and
update all references in the datastore accordingly. I am not sure this
is what Andy had in mind.