Subject: [Netconf] RESTCONF event notification question

From: Tao Deng <[email-masked]>
Date: Thu, 16 Apr 2015 00:13:52 +0000

Dear RESTCONF Experts,

I am reading the IETF RESTCONF draft revision 4 (here<https://tools.ietf.org/html/draft-ietf-netconf-restconf-04>) and have a question regarding the following text in Section 6.3 regarding asynchronous event notification from the server:

The server will treat the connection as an event stream, using the Server Sent Events [W3C.CR-eventsource-20121211<https://tools.ietf.org/html/draft-ietf-netconf-restconf-04#ref-W3C.CR-eventsource-20121211>] transport strategy.

Could you please help advise if WebSocket qualifies as the above mentioned strategy for asynchronous event notification? I see ODL uses WebSocket for that purpose. Or do we have to use a technology as specified by that W3C link?

Many thanks,
Tao

---

From: Martin Bjorklund <[email-masked]>
Date: Thu, 16 Apr 2015 22:12:25 +0200 (CEST)

Hi,

Tao Deng <[email-masked]> wrote:
> Dear RESTCONF Experts,
> 
> I am reading the IETF RESTCONF draft revision 4
> (here<https://tools.ietf.org/html/draft-ietf-netconf-restconf-04>) and
> have a question regarding the following text in Section 6.3 regarding
> asynchronous event notification from the server:
> 
> 
> The server will treat the connection as an event stream, using the
> Server Sent Events
> [W3C.CR-eventsource-20121211<https://tools.ietf.org/html/draft-ietf-netconf-restconf-04#ref-W3C.CR-eventsource-20121211>]
> transport strategy.
> 
> Could you please help advise if WebSocket qualifies as the above
> mentioned strategy for asynchronous event notification? I see ODL uses
> WebSocket for that purpose. Or do we have to use a technology as
> specified by that W3C link?

Are you saying that the current specification is not clear, or are you
asking for changing RESTCONF to use WebSockets instead of Server Sent
Events?

/martin

---

From: Tao Deng <[email-masked]>
Date: Thu, 16 Apr 2015 20:21:21 +0000

Hi Martin,

Thanks for your response. Let me clarify my question. The RESTCONF draft is very specific about what technology to use for the asynchronous event notification: Server Sent Event. I meant to ask, are other similar technologies (such as WebSocket) allowed to be used for this purpose?

Open Daylight SDN controller uses WebSocket for their implementation of a RESTCONF server. By doing so, is this a non-conformance to the standard draft?

Thanks,
Tao

-----Original Message-----
From: Martin Bjorklund [mailto:[email-masked]] 
Sent: Thursday, April 16, 2015 1:12 PM
To: Tao Deng
Cc: [email-masked]
Subject: Re: [Netconf] RESTCONF event notification question

Hi,

Tao Deng <[email-masked]> wrote:
> [W3C.CR-eventsource-20121211<https://tools.ietf.org/html/draft-ietf-ne
> tconf-restconf-04#ref-W3C.CR-eventsource-20121211>]
> transport strategy.
> 

Are you saying that the current specification is not clear, or are you asking for changing RESTCONF to use WebSockets instead of Server Sent Events?

/martin

---

From: Kent Watsen <[email-masked]>
Date: Fri, 17 Apr 2015 18:58:07 +0000

RESTCONF does not prevent alternate notification mechanisms from being
used, and a RESTCONF server is not required to support RESTCONF
notifications (see Section 6.1).  At this point, it's a bit late to
consider altering the draft much in this area, unless you want to raise it
for WG discussion.

Thanks,
Kent

On 4/16/15, 4:21 PM, "Tao Deng" <[email-masked]> wrote:

>Hi Martin,
>
>Thanks for your response. Let me clarify my question. The RESTCONF draft
>is very specific about what technology to use for the asynchronous event
>notification: Server Sent Event. I meant to ask, are other similar
>technologies (such as WebSocket) allowed to be used for this purpose?
>
>Open Daylight SDN controller uses WebSocket for their implementation of a
>RESTCONF server. By doing so, is this a non-conformance to the standard
>draft?
>
>Thanks,
>Tao
>
>_______________________________________________
>Netconf mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/netconf

---

From: Tao Deng <[email-masked]>
Date: Fri, 17 Apr 2015 20:36:13 +0000

Thanks a lot Kent for clarifying that it is allowed to use alternate notification mechanisms. That's all what I wanted to confirm. 

It might be good to put a statement in Section 6.3 of the draft that other notification mechanisms may be used for notification purposes besides Server Sent Event. However, I'll leave it up to you and other authors to decide what's best for the draft.

Thanks again!
Tao 

-----Original Message-----
From: Kent Watsen [mailto:[email-masked]] 
Sent: Friday, April 17, 2015 11:58 AM
To: Tao Deng; Martin Bjorklund
Cc: GNS SDN Engineering (Moffett Towers); [email-masked]
Subject: Re: [Netconf] RESTCONF event notification question

RESTCONF does not prevent alternate notification mechanisms from being used, and a RESTCONF server is not required to support RESTCONF notifications (see Section 6.1).  At this point, it's a bit late to consider altering the draft much in this area, unless you want to raise it for WG discussion.

Thanks,
Kent

On 4/16/15, 4:21 PM, "Tao Deng" <[email-masked]> wrote:

>Hi Martin,
>
>Thanks for your response. Let me clarify my question. The RESTCONF 
>draft is very specific about what technology to use for the 
>asynchronous event
>Open Daylight SDN controller uses WebSocket for their implementation of 
>a RESTCONF server. By doing so, is this a non-conformance to the 
>standard draft?
>
>Thanks,
>Tao
>
>> (here<https://tools.ietf.org/html/draft-ietf-netconf-restconf-04>) 
>> and have a question regarding the following text in Section 6.3 
>> regarding asynchronous event notification from the server:
>> 
>> 
>> [W3C.CR-eventsource-20121211<https://tools.ietf.org/html/draft-ietf-n
>> e tconf-restconf-04#ref-W3C.CR-eventsource-20121211>]
>> transport strategy.
>> 
>> mentioned strategy for asynchronous event notification? I see ODL 
>> uses WebSocket for that purpose. Or do we have to use a technology as

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 17 Apr 2015 23:00:12 +0200

Hi,

you are always free to implement whatever you want. However, if you
want to claim compliance to a standard and be interoperable, you have
to implement what the standard says. Writing into a standard that
people can implement something else is IMHO kind of pointless.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Andy Bierman <[email-masked]>
Date: Fri, 17 Apr 2015 14:16:02 -0700

> people can implement something else is IMHO kind of pointless.

+1

To be clear, the stream resources in RESTCONF must be SSE.
It says so in several places.  You can add non-standard mechanisms
and ignore RESTCONF streams.

> /js

Andy