Subject: Re: [Netconf] server-model #49: combine trusted-ca-certs and trusted-client-certs for ssh/tls?

From: Kent Watsen <[email-masked]>
Date: Mon, 18 May 2015 22:14:31 +0000

Hi Tom,

Yes, if server-model uses YANG 1.1 syntax, than both the clients and
servers will need to  support YANG 1.1 in order to support the
server-model YANG module.

Thanks,
Kent

On 3/31/15, 4:05 AM, "t.petch" <[email-masked]> wrote:

>----- Original Message -----
>From: "Kent Watsen" <[email-masked]>
>To: <[email-masked]>
>Sent: Monday, March 30, 2015 12:06 AM
>
>This issue (see subject line and/or link below) was discussed during the
>Dallas meeting with an agreement to combine the configuration for
>trusted CA-certs and client-certs into one container for both SSH and
>TLS.  The new container would use the following YANG 1.1 if-feature
>statement (assuming the WG adopts that resolution):
>
><tp>
>
>Does this mean that unless and until the clients and servers are
>upgraded to support YANG 1.1, then there will be no YANG server model
>that they could use?
>
>Tom Petch
>
>
>    if-feature "(ssh-x509-certs or tls)";
>
>This issue is hence moved to the VERIFY state.  The issue will move to
>the EDIT state if no objection is raised by April 6th.
>
>Reference: https://github.com/netconf-wg/server-model/issues/49
>
>Thanks,
>Kent
>
>
>
>
>------------------------------------------------------------------------
>--------
>
>
>> _______________________________________________
>> Netconf mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/netconf
>>
>

---

From: Kent Watsen <[email-masked]>
Date: Mon, 18 May 2015 22:15:32 +0000

The solution described below is now considered verified.

Thanks,
Kent

From: Kent Watsen <[email-masked]<mailto:[email-masked]>>
Date: Sunday, March 29, 2015 at 7:06 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [Netconf] server-model #49: combine trusted-ca-certs and trusted-client-certs for ssh/tls?

This issue (see subject line and/or link below) was discussed during the Dallas meeting with an agreement to combine the configuration for trusted CA-certs and client-certs into one container for both SSH and TLS.  The new container would use the following YANG 1.1 if-feature statement (assuming the WG adopts that resolution):

This issue is hence moved to the VERIFY state.  The issue will move to the EDIT state if no objection is raised by April 6th.

Thanks,
Kent