Subject: Re: [Netconf] server-model #47: introduce a 2nd timeout for periodic connections for when there's data to send?

From: Randy Presuhn <[email-masked]>
Date: Mon, 18 May 2015 15:48:42 -0700 (GMT-07:00)

Hi -

>From: Kent Watsen <[email-masked]>
>Sent: May 18, 2015 3:09 PM
>To: Randy Presuhn <[email-masked]>, "[email-masked]" <[email-masked]>
>Subject: Re: [Netconf] server-model #47: introduce a 2nd timeout for periodic connections for when there's data to send?
>
>
>
>>>OLD:
>>>
>>>                  For messages the NETCONF server wants to send to
>>>                  to the NETCONF client, the NETCONF server should
>>>                  proactively connect to the NETCONF client, if
>>>                  not already, to send the messages immediately.";
>>>
>>>NEW
>>>
>>>                  For messages the NETCONF server wants to send to
>>>                  to the NETCONF client, the NETCONF server may
>>>                  proactively connect to the NETCONF client, if
>>>                  not already, to send its messages sooner than
>>>                  its periodic timeout would have it do.";
>>
>>The English is broken.
>>   s/, if not already,/ (if it is not already connected)/
>>
>>The English is awkward.
>>   s/its periodic timeout would have it do/specified by its periodic
>>timeout/
>>
>>Anthropomorphisms are annoying:
>>   s/the NETCONF server wants to send/to be sent by the NETCONF server/
>
>
>Taking Randy's comments into account, and trimming it down to a more
>direct statement:
>
>   For messages to be sent by the NETCONF server
>   to the NETCONF client, the NETCONF server may
>   proactively connect to the NETCONF client
>   sooner than specified by its periodic timeout.

Works for me, though I think the new wording makes it
clear that the "For messages to be sent by the NETCONF
server to the NETCONF client" is really superfluous,
and that the "may" should be a "MAY".

Randy

---

From: Kent Watsen <[email-masked]>
Date: Mon, 18 May 2015 23:22:42 +0000

>and that the "may" should be a "MAY".

Good point, is this better?

   The NETCONF server MAY connect to the NETCONF client
   sooner than specified by its periodic timeout for

   any reason (e.g., to send a message).

Thanks again,
Kent