Subject: [Netconf] A tool to convert yang file to many extensions

From: Said Malah <[email-masked]>
Date: Thu, 11 Jun 2015 09:35:13 +0200

Hi,

I wish if I can have a tool other that "pyang" that can make an xml file from yang file.

Thank you.

_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

---

From: Ladislav Lhotka <[email-masked]>
Date: Thu, 11 Jun 2015 09:38:43 +0200

> On 11 Jun 2015, at 09:35, Said Malah <[email-masked]> wrote:
> 
> Hi,
> 

Do you mean something like the sample-xml-skeleton plugin in pyang? I am not aware of any other tool that does this.

Lada

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: Said Malah <[email-masked]>
Date: Thu, 11 Jun 2015 09:40:35 +0200

Yes, something like that because the Pyang version didn't get an update since a while. So I wish if I can find a other tool that can do the same.

-----Original Message-----
From: Ladislav Lhotka [mailto:[email-masked]] 
Sent: jeudi 11 juin 2015 09:39
To: Said Malah
Cc: Netconf
Subject: Re: [Netconf] A tool to convert yang file to many extensions

Lada

---

From: Douglas Hubler <[email-masked]>
Date: Thu, 11 Jun 2015 13:44:01 +0000

Are you looking to create YIN, or custom XML?  If custom, you're looking
for python API to walk yang tree?

On Thu, Jun 11, 2015 at 3:41 AM Said Malah <[email-masked]> wrote:

> Yes, something like that because the Pyang version didn't get an update
> since a while. So I wish if I can find a other tool that can do the same.
>
> Do you mean something like the sample-xml-skeleton plugin in pyang? I am
> not aware of any other tool that does this.
>
> Lada
>
> >
> > Thank you.
> >

---

From: Said Malah <[email-masked]>
Date: Thu, 11 Jun 2015 16:38:53 +0200

To be accurate, I’m looking for a tool that can make the same output as Pyang for xml so a custom XML.
But why there is just a Python API for that ?
I did many research in vain actually to find a way to convert !! nothing !

From: Douglas Hubler [mailto:[email-masked]]
Sent: jeudi 11 juin 2015 15:44
To: Said Malah; Ladislav Lhotka
Cc: Netconf
Subject: Re: [Netconf] A tool to convert yang file to many extensions

Are you looking to create YIN, or custom XML?  If custom, you're looking for python API to walk yang tree?

On Thu, Jun 11, 2015 at 3:41 AM Said Malah <[email-masked]<mailto:[email-masked]>> wrote:
Yes, something like that because the Pyang version didn't get an update since a while. So I wish if I can find a other tool that can do the same.

-----Original Message-----
From: Ladislav Lhotka [mailto:[email-masked]<mailto:[email-masked]>]
Sent: jeudi 11 juin 2015 09:39
To: Said Malah
Cc: Netconf
Subject: Re: [Netconf] A tool to convert yang file to many extensions

> On 11 Jun 2015, at 09:35, Said Malah <[email-masked]<mailto:[email-masked]>> wrote:
>
> Hi,
>

Lada

> [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>

_______________________________________________
Netconf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netconf

---

From: Ladislav Lhotka <[email-masked]>
Date: Thu, 11 Jun 2015 17:28:30 +0200

> On 11 Jun 2015, at 15:44, Douglas Hubler <[email-masked]> wrote:
> 

sample-xml-skeleton plugin is available in the stable 1.5 version of pyang, so I don’t understand why you can’t use it.

Lada