Subject: Re: [Netconf] server-model #54: move idle-timeout from global "session-options" to the "listen" tree?

From: Mahesh Jethanandani <[email-masked]>
Date: Wed, 1 Jul 2015 13:53:23 -0700

[Chair hat off]

Kent,

> On Jun 1, 2015, at 5:38 PM, Kent Watsen <[email-masked]> wrote:
> 
> For periodic connections, the idle-timeout is way too course (default 1 hour). We use to have a "linger-timeout" for this purpose (default 30 secs), but a side meeting in Dallas concluded that it was unneeded, as the client would close the connection as and when it was ready. Still, the intent is that the connection wouldn't stay open anywhere close to the periodic interval (default 5 mins). An idle-timeout here is nearly useless.

I am assuming, that moving the idle-timeout to the listen tree allows you to time connections out that connect, but do not progress. I am thinking DOS scenario, where somebody opens connections but decides not to make progress.

Mahesh Jethanandani
[email-masked]

---

From: Kent Watsen <[email-masked]>
Date: Wed, 1 Jul 2015 21:20:38 +0000

> I am assuming, that moving the idle-timeout to the listen tree allows
> you to time connections out that connect, but do not progress. I am
> thinking DOS scenario, where somebody opens connections but
> decides not to make progress.

Yes, exactly the purpose here!

Cheers,
Kent