Subject: [Netconf] Mandatory statement for the use of XML in Restconf

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Thu, 23 Jul 2015 12:15:08 +0000

Team,

I wanted to express my concern about making XML the mandatory encoding for the Restconf (draft-ietf-netconf-restconf-07).

There are use cases where Restconf may be used in CPEs or constrained devices where multiple encoding are just not possible. In fact JSON will most likely be the more popular option. As such I would remove the wording to state XML is mandatory.

BR,
Tim

---

From: "Scharf, Michael (Michael)" <[email-masked]>
Date: Thu, 23 Jul 2015 12:25:22 +0000

Hi all,

... and in other potential use cases of RESTCONF JSON will also most likely the more popular option, e.g., on certain NBIs that will clearly be JSON-based. Supporting both encodings there just creates needless overhead, AFAIKT. Note that this use case is entirely disjoint to Tim's one.

Michael

From: Netconf [mailto:[email-masked]] On Behalf Of Carey, Timothy (Timothy)
Sent: Thursday, July 23, 2015 2:15 PM
To: [email-masked]
Subject: [Netconf] Mandatory statement for the use of XML in Restconf

Team,

BR,
Tim

---

From: "Jonathan Hansford" <[email-masked]>
Date: Thu, 23 Jul 2015 13:30:30 +0100

Tim,
This has been discussed before (see the [Netconf] Suggestion for
RESTCONF section 5.3 [1] thread). 

Jonathan

----- Original Message -----
From: "Carey Timothy (Timothy)" 
To:"[email-masked]" 
Cc:
Sent:Thu, 23 Jul 2015 12:15:08 +0000
Subject:[Netconf] Mandatory statement for the use of XML in Restconf

	Team,

	I wanted to express my concern about making XML the mandatory
encoding for the Restconf (draft-ietf-netconf-restconf-07).

	There are use cases where Restconf may be used in CPEs or constrained
devices where multiple encoding are just not possible. In fact JSON
will most likely be the more popular option. As such I would remove
the wording to state XML is mandatory.

	BR,

	Tim

Links:
------
[1]
https://mailarchive.ietf.org/arch/msg/netconf/osCW_tb7P7DvkwoXyPmAjQsJJ4g

---

From: Robert Wilton <[email-masked]>
Date: Thu, 23 Jul 2015 15:04:19 +0100

I also agree with Tim: I don't think that RESTCONF should require XML as 
a mandatory encoding.

I would suggest that both client and server can decide whether they want 
to support JSON and/or XML.

To make a server with maximal interoperability then it should support 
both protoocols. Likewise for the client.  But if there isn't consensus 
on a mandatory default encoding then surely it is better to have no 
default encoding at all, and just leave it to the implementers to decide 
what they want to support.

Cheers,
Rob

On 23/07/2015 13:30, Jonathan Hansford wrote:
> RESTCONF section 5.3 
> <https://mailarchive.ietf.org/arch/msg/netconf/osCW_tb7P7DvkwoXyPmAjQsJJ4g> 
> thread).
>
> Jonathan
>
>
>     From:
>     "Carey Timothy (Timothy)" <[email-masked]>
>
>     To:
>     "[email-masked]" <[email-masked]>
>     Cc:
>
>     Sent:
>     Subject:
>     [Netconf] Mandatory statement for the use of XML in Restconf
>
>
>     Team,
>
>     There are use cases where Restconf may be used in CPEs or
>     constrained devices where multiple encoding are just not possible.
>     In fact JSON will most likely be the more popular option. As such
>     I would remove the wording to state XML is mandatory.
>
>     BR,
>
>     Tim
>
>
>
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf