Subject: [Netconf] yang library issues

From: Jeffrey Haas <[email-masked]>
Date: Thu, 23 Jul 2015 14:04:50 +0200

The comment I was unable to make at the mic is that work ongoing in IETF to structure yang modules is potentially proceeding with a fallacy.  That fallacy is that the location of a module is effectively "known ahead of time".  Thus, if your device supports BGP, you will potentially have a routing/ietf-bgp module.

The presence of modules is conveyed in the protocol HELLO.

The use of the library to help provide a manifest of actual implementations seems quite important.  I am endeavoring to help the participants of the rtg-yang-architecture group and also members of openconfig that they should not depend location of a module and consequences if they do.

-- Jeff

---

From: Andy Bierman <[email-masked]>
Date: Thu, 23 Jul 2015 05:12:34 -0700

Hi,

YANG modules do not have locations.
I think you mean a YANG module that has data nodes
places those data nodes in a specific location relative
to the document root.

Any YANG compiler knows what top-level data nodes are defined
in a module, so I do not understand your comments.

Module names have a flat namespace.
There are naming conventions like ietf-foo vs. example-foo.
There is no layering like routing/ietf-routing.

Andy

On Thu, Jul 23, 2015 at 5:04 AM, Jeffrey Haas <[email-masked]> wrote:

> The comment I was unable to make at the mic is that work ongoing in IETF
> to structure yang modules is potentially proceeding with a fallacy.  That
> fallacy is that the location of a module is effectively "known ahead of
> time".  Thus, if your device supports BGP, you will potentially have a
> routing/ietf-bgp module.
>
> The use of the library to help provide a manifest of actual
> implementations seems quite important.  I am endeavoring to help the
> participants of the rtg-yang-architecture group and also members of
> openconfig that they should not depend location of a module and
> consequences if they do.
>
> -- Jeff
>
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>