Subject: [Netconf] Summary and AIs from the NETCONF Session in IETF #93

From: "Ersue, Mehmet (Nokia - DE/Munich)" <[email-masked]>
Date: Sat, 25 Jul 2015 11:04:44 +0000

Dear Benoit, NETCONF WG,

below is a summary and action items from the NETCONF WG session on July 23, 2015 in Prague, Czech Republic.

- We had approx. 65+ participants in the 2 hour NETCONF session,
- We reviewed the status of the WG,
- We had a discussion on 7 chartered documents.

- Many thanks to the note takers: ext Radek Krejci and Mike Leske and the jabber scribe: Juergen Schoenwaelder.

The session agenda is available at: https://www.ietf.org/proceedings/93/agenda/agenda-93-netconf

Following is a summary of the discussion and the decisions taken per show-hands.

This mail is at the same time to verify the discussion result and decisions from the IETF 93 NETCONF session.
If there is no strong objection we will implement as discussed.

- After WG LC Call Home will go to AD review. Write-up will be provided by the shepherd (Mahesh).

- Server Model: The duplication of data in server model has been discussed with 4 optional solutions. Option 4 based on key chains has been proposed. Many WG member are in favor. Nobody against.
This option requires a delay of the work and some part needs to be done in Security area.
Kent to provide a proposal for the way forward describing how to address option 4 with key chains and the work split with SEC area.

- Restconf issues have been discussed. Agreed to use the current YANG 1.1 draft instead of YANG 1.0 and finalize issues in Restconf with this basis. The goal is to go to LC with this basis asap.
- Different folks would like to have JSON as additional encoding. This discussion has been separated in the sake of time usage and will be brought to the maillist.

- Remaining YANG Patch and YANG Library issues will be solved soon and WG LC is the next step.

- Pub/Sub Solution draft.
WG supports adoption, no objections. ADs recommended to not wait. The co-chairs support the adoption. It'll be verified on the maillist.

- I2RS requirements have been discussed. Issues have been clarified in two steps first in NETCONF and then in I2RS session.

Regards,
Mehmet & Mahesh

---

From: Ladislav Lhotka <[email-masked]>
Date: Wed, 29 Jul 2015 10:55:12 +0200

"Ersue, Mehmet (Nokia - DE/Munich)" <[email-masked]> writes:

> - Different folks would like to have JSON as additional encoding. This
> discussion has been separated in the sake of time usage and will be
> brought to the maillist.

I think the real issue here is that support for XML should not be
mandatory.

Lada

> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf

-- 
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C