Subject: [Netconf] About grouping changed-by-parms definition in RFC6470

From: Mandy Liu <[email-masked]>
Date: Wed, 1 Jul 2015 09:23:14 +0000

Hi Andy and NETCONF WG,

The grouping "changed-by-parms" is defined in RFC 6470 below. Per my understanding there should be a case "by-server" in the choice "server-or-user". What is the intention that "leaf server" is used in it?

grouping changed-by-parms {
       description
         "Common parameters to identify the source
          of a change event, such as a configuration
          or capability change.";

       container changed-by {
         description
           "Indicates the source of the change.
            If caused by internal action, then the
            empty leaf 'server' will be present.
            If caused by a management session, then
            the name, remote host address, and session ID
            of the session that made the change will be reported.";
         choice server-or-user {
           mandatory true;
           leaf server {
             type empty;
             description
               "If present, the change was caused
                by the server.";
           }

           case by-user {
             uses common-session-parms;
           }
         } // choice server-or-user
       } // container changed-by-parms
     }

Thanks,
Mandy

---

From: Phil Shafer <[email-masked]>
Date: Wed, 1 Jul 2015 11:07:06 -0400

Mandy Liu writes:
>The grouping "changed-by-parms" is defined in RFC 6470 below. Per my unders=
>tanding there should be a case "by-server" in the choice "server-or-user". =

Also "parms" seems like an odd terminology to use.  "nodes" or "data"
might be less odd.

Thanks,
 Phil

---

From: Per Hedeland <[email-masked]>
Date: Wed, 01 Jul 2015 17:21:59 +0200

>> tanding there should be a case "by-server" in the choice "server-or-user". =

The 'server' leaf implies a case called 'server' per the shorthand rule
in RFC 6020 sect 7.9.2. Wrapping it in a redundant 'case by-server { }'
would perhaps be a bit more symmetric, but it is irrelevant for the
actual interface. (I.e. the 'changed-by' container will have either the
'server' leaf or the 'username', 'session-id', and 'source-host' leafs.)

> Also "parms" seems like an odd terminology to use.  "nodes" or "data"

The grouping description says

- and that's what it is. The actually changed nodes are not part of this
grouping.

--Per Hedeland

---

From: Mandy Liu <[email-masked]>
Date: Thu, 2 Jul 2015 00:40:10 +0000

Ok, got it. Thanks for your replies, Per!

Regards,
Mandy

-----Original Message-----
From: Per Hedeland [mailto:[email-masked]] 
Sent: Wednesday, July 01, 2015 11:22 PM
To: Phil Shafer
Cc: Mandy Liu; Adrian Pan; Harry Huang; Qifeng Zhang; [email-masked]; Wei Luo S
Subject: Re: [Netconf] About grouping changed-by-parms definition in RFC6470

On 2015-07-01 17:07, Phil Shafer wrote:
> Mandy Liu writes:
>> The grouping "changed-by-parms" is defined in RFC 6470 below. Per my 
>> unders= tanding there should be a case "by-server" in the choice 
>> "server-or-user". =

The 'server' leaf implies a case called 'server' per the shorthand rule in RFC 6020 sect 7.9.2. Wrapping it in a redundant 'case by-server { }'
would perhaps be a bit more symmetric, but it is irrelevant for the actual interface. (I.e. the 'changed-by' container will have either the 'server' leaf or the 'username', 'session-id', and 'source-host' leafs.)

- and that's what it is. The actually changed nodes are not part of this grouping.

--Per Hedeland