Subject: [Netconf] Opinion poll for the support of draft-mm-netconf-time-capability

From: "Ersue, Mehmet (Nokia - DE/Munich)" <[email-masked]>
Date: Tue, 7 Jul 2015 22:05:02 +0000

Dear NETCONF WG,

draft-mm-netconf-time-capability has been discussed in Netconf WG in different IETF meetings. There was only cautious support.
As recently the authors asked for support on the maillist no single person spoke for this draft.

However, after the draft has been brought to IETF LC as AD supported draft, there were diverse people supporting strongly and proposed to publish the document in NETCONF WG.

Just to be sure we develop the right documents in Netconf WG, we would like to ask the same question again.
Based on the support on Netconf maillist draft-mm-netconf-time-capability may be adopted as a new WG item.

- If anybody thinks draft-mm-netconf-time-capability does fit the focus of Netconf WG and should be developed as Netconf WG item please state your opinion on the maillist within one week (July 15, 2015 EOB PT).

- If anybody thinks that this is not the right approach to develop in Netconf WG please state it as well.

- We also would like to know whether anybody did or is planning to implement draft-mm-netconf-time-capability.

Best Regards,
Mehmet Ersue
Netconf WG Co-chair

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 8 Jul 2015 08:53:39 +0000

Hi,

I was one of the individuals who commented at the IETF LC that this work seems to be useful and seems to be within the scope of the Netconf WG. There were discussions whether the solution proposed in draft-mm-netconf-time-capability is 'the right approach', and also questions about extending this solution to Restconf.

Regards,

Dan

From: Netconf [mailto:[email-masked]] On Behalf Of Ersue, Mehmet (Nokia - DE/Munich)
Sent: Wednesday, July 08, 2015 1:05 AM
To: [email-masked]
Subject: [Netconf] Opinion poll for the support of draft-mm-netconf-time-capability

Dear NETCONF WG,

Best Regards,
Mehmet Ersue
Netconf WG Co-chair

---

From: "Ersue, Mehmet (Nokia - DE/Munich)" <[email-masked]>
Date: Wed, 8 Jul 2015 16:55:19 +0000

Thanks Dan!

Others please comment no later than July 15th indicating your support or non-support.

Cheers,
Mehmet

From: ext Romascanu, Dan (Dan) [mailto:[email-masked]]
Sent: Wednesday, July 08, 2015 10:54 AM
To: Ersue, Mehmet (Nokia - DE/Munich); [email-masked]
Subject: RE: [Netconf] Opinion poll for the support of draft-mm-netconf-time-capability

Hi,

Regards,

Dan

From: Netconf [mailto:[email-masked]] On Behalf Of Ersue, Mehmet (Nokia - DE/Munich)
Sent: Wednesday, July 08, 2015 1:05 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [Netconf] Opinion poll for the support of draft-mm-netconf-time-capability

Dear NETCONF WG,

Best Regards,
Mehmet Ersue
Netconf WG Co-chair

---

From: Andy Bierman <[email-masked]>
Date: Wed, 8 Jul 2015 11:43:10 -0700

Hi,

I don't support this draft because it is a general computing platform
feature,
and NETCONF is a configuration management protocol.
The draft does not provide any way to examine or edit pending RPC calls.

Andy

On Wed, Jul 8, 2015 at 9:55 AM, Ersue, Mehmet (Nokia - DE/Munich) <
[email-masked]> wrote:

> *From:* ext Romascanu, Dan (Dan) [mailto:[email-masked]]
> *Sent:* Wednesday, July 08, 2015 10:54 AM
> *To:* Ersue, Mehmet (Nokia - DE/Munich); [email-masked]
> *Subject:* RE: [Netconf] Opinion poll for the support of
> draft-mm-netconf-time-capability
>
>
>
> Hi,
>
>
>
> I was one of the individuals who commented at the IETF LC that this work
> seems to be useful and seems to be within the scope of the Netconf WG.
> There were discussions whether the solution proposed in
> draft-mm-netconf-time-capability is ‘the right approach’, and also
> questions about extending this solution to Restconf.
>
>
>
> Regards,
>
>
>
> Dan
>
>
>
>
>
> *From:* Netconf [mailto:[email-masked]
> <[email-masked]>] *On Behalf Of *Ersue, Mehmet (Nokia -
> DE/Munich)
> *Sent:* Wednesday, July 08, 2015 1:05 AM
> *To:* [email-masked]
> *Subject:* [Netconf] Opinion poll for the support of
> draft-mm-netconf-time-capability
>
>
>
> Dear NETCONF WG,
>
>
>
> draft-mm-netconf-time-capability has been discussed in Netconf WG in
> different IETF meetings. There was only cautious support.
>
> However, after the draft has been brought to IETF LC as AD supported
> draft, there were diverse people supporting strongly and proposed to
> publish the document in NETCONF WG.
>
>
>
> - If anybody thinks draft-mm-netconf-time-capability does fit the focus of
> Netconf WG and should be developed as Netconf WG item please state your
> opinion on the maillist within one week (July 15, 2015 EOB PT).
>
>
>
> - We also would like to know whether anybody did or is planning to
> implement draft-mm-netconf-time-capability.
>
>
>
> Best Regards,
> Mehmet Ersue
>
> Netconf WG Co-chair
>
>
>
>
>
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>
>

---

From: Andy Bierman <[email-masked]>
Date: Wed, 8 Jul 2015 12:00:01 -0700

Hi,

The draft does not say what happens if the session that requests the
scheduled RFC is dropped.  Are the scheduled tasks dropped?
If not, how does the server send the "real" reply?

Clients are designed so that a request is completed when the
response with the proper message-id is received.

   <rpc message-id="1">
      <get  schedule=5-days-from-now />
   </rpc>

   <rpc-reply message-id="1"><ok/><rpc-reply>   >>> sent immediately

  <rpc-reply message-id="1">
    <data> .... </data>
  <rpc-reply>   >>> sent 5 days from now

This breaks the NETCONF design which expects that only
one <rpc-reply> is sent for each <rpc> request.

Andy

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 8 Jul 2015 21:45:37 +0200

> - We also would like to know whether anybody did or is planning to implement draft-mm-netconf-time-capability.

I think the key questions are:

a) Is the problem a real-world problem operators using NETCONF are
   facing? Is there any operational evidence that the current features
   NETCONF has to run network wide transactions are not sufficient?

b) If a) is confirmed, does the solution proposed in the I-D provide a
   good starting point for a standardized solution?

c) If a) and b), do we have a sufficient number of people to work on
   this? If perhaps not, what is the priority of addressing this given
   all the other things the active contributors have on their plate?

I personally can't answer a). Concerning b), I do have some technical
concerns (but then such an I-D is a starting point). My main concern
is actually c). Our resources are finite and taking on work that than
takes >3 years to finish is not helpful.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Martin Bjorklund <[email-masked]>
Date: Wed, 08 Jul 2015 22:33:17 +0200 (CEST)

Hi,

> I think the key questions are:

This is a good summary of the issues.

>    NETCONF has to run network wide transactions are not sufficient?

I don't know the answer to this one.  I do know that the current
NETCONF mechanisms are sufficient for the deployments we have done.

>    good starting point for a standardized solution?

I have some concerns.  The proposed solution is fragile b/c it relies
on augmenting every rpc with additional parameters, instead of trying
to find a generic mechanism.

> takes >3 years to finish is not helpful.

/martin

---

From: Andy Bierman <[email-masked]>
Date: Wed, 8 Jul 2015 16:13:05 -0700

> one <rpc-reply> is sent for each <rpc> request.
I misread the latest version.
The original <get> will not have an immediate response.
Instead a notification is sent indicating the RPC was scheduled.
Only 1 rpc-reply is sent at the end.

Andy

>> - If anybody thinks draft-mm-netconf-time-capability does fit the focus
>> of Netconf WG and should be developed as Netconf WG item please state your

---

From: "Ersue, Mehmet (Nokia - DE/Munich)" <[email-masked]>
Date: Fri, 17 Jul 2015 21:31:03 +0000

Dear Netconf WG,

as far as the co-chairs can see, there was no sufficient support to enable the
adoption of draft-mm-netconf-time-capability as WG item.

We have seen support from one person on the mailing list, but at the same
time there were plenty of challenging questions from different WG member.

Mehmet

From: ext Andy Bierman [mailto:[email-masked]]
Sent: Thursday, July 09, 2015 1:13 AM
To: Ersue, Mehmet (Nokia - DE/Munich)
Cc: ext Romascanu, Dan (Dan); [email-masked]
Subject: Re: [Netconf] Opinion poll for the support of draft-mm-netconf-time-capability

On Wed, Jul 8, 2015 at 12:00 PM, Andy Bierman <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

   <rpc message-id="1">

Andy

Andy

On Wed, Jul 8, 2015 at 9:55 AM, Ersue, Mehmet (Nokia - DE/Munich) <[email-masked]<mailto:[email-masked]>> wrote:
Thanks Dan!

Cheers,
Mehmet

From: ext Romascanu, Dan (Dan) [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Wednesday, July 08, 2015 10:54 AM
To: Ersue, Mehmet (Nokia - DE/Munich); [email-masked]<mailto:[email-masked]>
Subject: RE: [Netconf] Opinion poll for the support of draft-mm-netconf-time-capability

Hi,

I was one of the individuals who commented at the IETF LC that this work seems to be useful and seems to be within the scope of the Netconf WG. There were discussions whether the solution proposed in draft-mm-netconf-time-capability is ‘the right approach’, and also questions about extending this solution to Restconf.

Regards,

Dan

Dear NETCONF WG,

Best Regards,
Mehmet Ersue
Netconf WG Co-chair

_______________________________________________
Netconf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netconf