Subject: [Netconf] Opinion poll for the RESTCONF encoding

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Thu, 6 Aug 2015 22:09:20 +0000

I believe it should be "x+j"

The text already says Content is encoded in either JSON or XML format so we have constrained RESTconf to those protocols already.

We can use the Accept-encoding feature to negotiate as Mehmet suggests BTW: We may have an issue with "If there was no request input, then the default output encoding is XML".

BR,
Tim

---

From: Ladislav Lhotka <[email-masked]>
Date: Fri, 7 Aug 2015 10:01:56 +0200

> On 07 Aug 2015, at 00:09, Carey, Timothy (Timothy) <[email-masked]> wrote:
> 
> I believe it should be “x+j”
> 
> 
> We can use the Accept-encoding feature to negotiate as Mehmet suggests BTW: We may have an issue with “If there was no request input, then the default output encoding is XML”.

RFC 7231 says: “A request without any Accept header field implies that the user agent will accept any media type in response.”

In our case the server may send either XML or JSON.

Lada

> 
> BR,
> Tim
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C