Subject: Re: [Netconf] RESTCONF #24:mandatory encoding revisited

From: Ladislav Lhotka <[email-masked]>
Date: Sat, 1 Aug 2015 17:45:07 +0200

Hi Mehmet,

> On 01 Aug 2015, at 03:03, Ersue, Mehmet (Nokia - DE/Munich) <[email-masked]> wrote:
> 
> Hi Lada,
> 
> you might be also interested to read: 
> https://mailarchive.ietf.org/arch/msg/netconf/YSEbLd-nnI0dlkeiIeGW-z6JqDg 
> 
> In the sake of progress Bert and I declared at that time consensus.

Yes, it was declared consensus rather than rough consensus. So here we go.

> 
> As far as I understand peoples interest and opinions changed since last October.
> It makes sense to repeat the opinion poll.

Agreed.

Lada

> 
> Mehmet 
> 
> -----Original Message-----
> From: Netconf [mailto:[email-masked]] On Behalf Of ext Ladislav Lhotka
> Sent: Wednesday, July 29, 2015 11:14 AM
> To: Andy Bierman; Netconf
> Subject: Re: [Netconf] RESTCONF #24:mandatory encoding revisited
> 
> Andy Bierman <[email-masked]> writes:
> 
>> Hi,
>> 
>> It would be good if we could close this issue soon.
>> I am not in favor of changing the previous consensus call.
> 
> I am in favor of changing it. The consensus call that was done before
> Honolulu meeting was IMO very problematic and I had strong objections
> against it - the opinions were 10:7 in favor of making XML mandatory.
> 
> See this thread:
> 
> https://mailarchive.ietf.org/arch/search/?email_list=netconf&gbt=1&index=8EhIVndveGw2QrHTefsYsADPC6Y
> 
> Recently, other people expressed their preference, and explained
> technical reasons, for NOT doing so.
> 
>> 
>> At first I thought JSON would be good for RESTCONF,
>> until I implemented it.  It is not appropriate for streaming servers.
>> The complexity and memory required and just as bad or worse
>> than XML, especially once namespaces and attributes are
>> added.
> 
> Not all servers need to stream data.
> 
>> 
>> JSON is fine if the entire document is in memory,
>> but that's not how NETCONF/RESTCONF servers work.
> 
> You probably mean your NETCONF/RESTCONF servers. Small devices have
> configurations that easily fit into memory, and small devices are
> exactly those for which XML support is a considerable burden.
> 
> Lada
> 
>> 
>> 
>> Andy
>> _______________________________________________
>> Netconf mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/netconf
> 
> -- 
> Ladislav Lhotka, CZ.NIC Labs
> PGP Key ID: E74E8C0C
> 
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
> <Mail Attachment.eml>

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: Andy Bierman <[email-masked]>
Date: Mon, 3 Aug 2015 12:07:21 -0700

Hi,

Just removing the sentence about 'XML is mandatory'
is not what was proposed before.  Instead it would say
that implementation of XML or JSON is mandatory.
This is not the same as (d) because the same requirement
applies to clients (JSON or XML, not JSON and XML
like it says in (d)).

I do not want the standard to support an implementation
that uses completely proprietary message encoding.
Either XML or JSON has to be supported.  Maybe that will
be inappropriate in the future.  If so, a new protocol
revision can declare a different set of encoding formats.

Andy

---

From: Ashesh Mishra <[email-masked]>
Date: Mon, 3 Aug 2015 14:56:38 -0700

I agree with Andy. "XML or JSON is mandatory" makes much more sense at this time (and for the foreseeable future). 

--
Ashesh

Sent from my iPhone

> On Aug 3, 2015, at 12:07 PM, Andy Bierman <[email-masked]> wrote:
> 
> Hi,
>

---

From: Mahesh Jethanandani <[email-masked]>
Date: Mon, 3 Aug 2015 17:03:13 -0700

Andy,

Can you update the GitHub with the proposal so we are clear?

Also, is there a need to be able to discover which encoding the server supports? If so, do we have a proposal for how the encoding will be discovered?

> On Sat, Aug 1, 2015 at 8:45 AM, Ladislav Lhotka <[email-masked] <mailto:[email-masked]>> wrote:
> Hi Mehmet,
> 
> > On 01 Aug 2015, at 03:03, Ersue, Mehmet (Nokia - DE/Munich) <[email-masked] <mailto:[email-masked]>> wrote:
> >
> > Hi Lada,
> >
> > https://mailarchive.ietf.org/arch/msg/netconf/YSEbLd-nnI0dlkeiIeGW-z6JqDg <https://mailarchive.ietf.org/arch/msg/netconf/YSEbLd-nnI0dlkeiIeGW-z6JqDg>
> >
> > From: Netconf [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of ext Ladislav Lhotka
> > Andy Bierman <[email-masked] <mailto:[email-masked]>> writes:
> >
> >> Hi,
> >>
> > https://mailarchive.ietf.org/arch/search/?email_list=netconf&gbt=1&index=8EhIVndveGw2QrHTefsYsADPC6Y <https://mailarchive.ietf.org/arch/search/?email_list=netconf&gbt=1&index=8EhIVndveGw2QrHTefsYsADPC6Y>
> >
> >> [email-masked] <mailto:[email-masked]>
> >> https://www.ietf.org/mailman/listinfo/netconf <https://www.ietf.org/mailman/listinfo/netconf>
> >
> > --
> > [email-masked] <mailto:[email-masked]>
> > https://www.ietf.org/mailman/listinfo/netconf <https://www.ietf.org/mailman/listinfo/netconf>
> > <Mail Attachment.eml>
> 
> --

Mahesh Jethanandani
[email-masked]