Subject: [Netconf] Opinion poll for the RESTCONF encoding

From: "Ersue, Mehmet (Nokia - DE/Munich)" <[email-masked]>
Date: Thu, 6 Aug 2015 20:18:23 +0000

Dear NETCONF WG,

last October we had an opinion poll on the RESTCONF encoding, which ended with a close consensus in favor of XML as mandatory.
See https://mailarchive.ietf.org/arch/msg/netconf/YSEbLd-nnI0dlkeiIeGW-z6JqDg
Based on the recent discussion on this topic and opinions against mandatory statements in RESTCONF, NETCONF WG co-chairs would like to start a new opinion poll.

As stated in the mail for the previous poll, the result of the poll depends on the count of people voting.
So, all interested NETCONF WG members, please speak up so that we get a better data to judge on WG (rough) consensus.
If the voting result is again close, the WG co-chairs will (again) declare consensus in the sake of progress, based on the "dominant view" determined by the co-chairs and AD.

Please do state your opinion with short and concrete reasoning, by August 19, 2015 18:00 PST about the following options:

x) XML is mandatory, JSON optional,
j) JSON is mandatory, XML optional,
x&j) XML and JSON are both mandatory,
x+j) Either XML or JSON is mandatory the other one is optional,
nm) Both XML and JSON are optional and _not_ mandatory.

For "x+j" and "nm" please provide a solution for a successful negotiation or determination of the encoding to be used between server and client.
For the solution discussion a separate thread will be started and can be finalized also after the poll deadline.

You may think that one or the other option is useless from your pov. In this case please ignore it.

Looking forward to counting your votes and reading your reasoning.
Thank you.

Best Regards,
Mehmet  & Mahesh

---

From: Andy Bierman <[email-masked]>
Date: Thu, 6 Aug 2015 13:45:34 -0700

Hi,

I prefer x+j. HTTP does not require hard-wired mandatory encoding
formats.  Quite the opposite.  Let the market decide where XML-only,
JSON-only, or XML and JSON servers are appropriate.

Andy

On Thu, Aug 6, 2015 at 1:18 PM, Ersue, Mehmet (Nokia - DE/Munich) <
[email-masked]> wrote:

> Dear NETCONF WG,
>
> last October we had an opinion poll on the RESTCONF encoding, which ended
> with a close consensus in favor of XML as mandatory.
> See
> *https://mailarchive.ietf.org/arch/msg/netconf/YSEbLd-nnI0dlkeiIeGW-z6JqDg*
> <https://mailarchive.ietf.org/arch/msg/netconf/YSEbLd-nnI0dlkeiIeGW-z6JqDg>
> Based on the recent discussion on this topic and opinions against
> mandatory statements in RESTCONF, NETCONF WG co-chairs would like to start
> a new opinion poll.
>
> So, all interested NETCONF WG members, please speak up so that we get a
> better data to judge on WG (rough) consensus.
> If the voting result is again close, the WG co-chairs will (again) declare
> consensus in the sake of progress, based on the “dominant view” determined
> by the co-chairs and AD.
>
> Please do state your opinion with short and concrete reasoning, by August
> 19, 2015 18:00 PST about the following options:
>
> nm) Both XML and JSON are optional and _*not*_ mandatory.
>
> For “x+j” and “nm” please provide a solution for a successful negotiation
> or determination of the encoding to be used between server and client.
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>
>

---

From: Ladislav Lhotka <[email-masked]>
Date: Thu, 6 Aug 2015 22:58:09 +0200

x+j

Lada

> On 06 Aug 2015, at 22:18, Ersue, Mehmet (Nokia - DE/Munich) <[email-masked]> wrote:
> 
> Dear NETCONF WG,
> 
> If the voting result is again close, the WG co-chairs will (again) declare consensus in the sake of progress, based on the “dominant view” determined by the co-chairs and AD.
>  
> For “x+j” and “nm” please provide a solution for a successful negotiation or determination of the encoding to be used between server and client.

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: "Ersue, Mehmet (Nokia - DE/Munich)" <[email-masked]>
Date: Thu, 6 Aug 2015 21:04:35 +0000

Hi Lada, All,

please provide some reasoning and explanation for your choice.

In case of x+j, please provide also a solution for the negotiation or determination (aka. discovery) of the encoding.

If there is a discussion necessary we will use the other thread under "Discovery of the Encoding Format".

Thanks.

Mehmet 

-----Original Message-----
From: ext Ladislav Lhotka [mailto:[email-masked]] 
Sent: Thursday, August 06, 2015 10:58 PM
To: Ersue, Mehmet (Nokia - DE/Munich)
Cc: Netconf
Subject: Re: [Netconf] Opinion poll for the RESTCONF encoding

x+j

Lada

---

From: Andy Bierman <[email-masked]>
Date: Thu, 6 Aug 2015 14:12:53 -0700

On Thu, Aug 6, 2015 at 2:04 PM, Ersue, Mehmet (Nokia - DE/Munich) <
[email-masked]> wrote:

> In case of x+j, please provide also a solution for the negotiation or
> determination (aka. discovery) of the encoding.
>

I updated the github issue tracker
https://github.com/netconf-wg/restconf/issues/24

HTTP already provides the Accept header for this purpose.
This is already mandatory to implement for RESTCONF.
The server returns 406 Not Acceptable if the Accept header
does not request an encoding format that the server supports.

I don't think we need to do anything else for encoding discovery.

Andy

> > last October we had an opinion poll on the RESTCONF encoding, which
> ended with a close consensus in favor of XML as mandatory.
> > See
> https://mailarchive.ietf.org/arch/msg/netconf/YSEbLd-nnI0dlkeiIeGW-z6JqDg
> > If the voting result is again close, the WG co-chairs will (again)
> declare consensus in the sake of progress, based on the “dominant view”
> determined by the co-chairs and AD.
> >
> > Please do state your opinion with short and concrete reasoning, by
> August 19, 2015 18:00 PST about the following options:
> >
> > For “x+j” and “nm” please provide a solution for a successful
> negotiation or determination of the encoding to be used between server and
> client.

---

From: "Ersue, Mehmet (Nokia - DE/Munich)" <[email-masked]>
Date: Thu, 6 Aug 2015 21:47:31 +0000

[co-chair hat off]

Limiting the choices to XML or JSON mandatory enforces interoperability.

x+j is, in my opinion the right solution to choose.
This gives to the implementer the freedom to choose which of them to implement (XML or JSON).
 
So this is my vote.

Mehmet

-----Original Message-----
From: Netconf [mailto:[email-masked]] On Behalf Of ext Ersue, Mehmet (Nokia - DE/Munich)
Sent: Thursday, August 06, 2015 11:05 PM
To: ext Ladislav Lhotka
Cc: Netconf
Subject: Re: [Netconf] Opinion poll for the RESTCONF encoding

Hi Lada, All,

Thanks.

Mehmet 

-----Original Message-----
From: ext Ladislav Lhotka [mailto:[email-masked]] 
Sent: Thursday, August 06, 2015 10:58 PM
To: Ersue, Mehmet (Nokia - DE/Munich)
Cc: Netconf
Subject: Re: [Netconf] Opinion poll for the RESTCONF encoding

x+j

Lada

---

From: Joe Clarke <[email-masked]>
Date: Thu, 6 Aug 2015 18:39:32 -0400

On 8/6/15 16:18, Ersue, Mehmet (Nokia - DE/Munich) wrote:
> _https://mailarchive.ietf.org/arch/msg/netconf/YSEbLd-nnI0dlkeiIeGW-z6JqDg_
> mandatory statements in RESTCONF, NETCONF WG co-chairs would like to
> start a new opinion poll.
> nm) Both XML and JSON are optional and _/not/_ mandatory.
> negotiation or determination of the encoding to be used between server
> and client.

j is mandatory, x optional

Joe

---

From: t.petch <[email-masked]>
Date: Fri, 7 Aug 2015 12:23:45 +0100

----- Original Message -----
From: "Ersue, Mehmet (Nokia - DE/Munich)"  [email-masked]>

Sent: Thursday, August 06, 2015 9:18 PM

https://mailarchive.ietf.org/arch/msg/netconf/YSEbLd-nnI0dlkeiIeGW-z6JqD
g

As stated in the mail for the previous poll, the result of the poll
depends on the count of people voting.
So, all interested NETCONF WG members, please speak up so that we get a
better data to judge on WG (rough) consensus.
If the voting result is again close, the WG co-chairs will (again)
declare consensus in the sake of progress, based on the "dominant view"
determined by the co-chairs and AD.

<tp>

x

offers the best chance of interoperability at this point in time.

Tom Petch

For "x+j" and "nm" please provide a solution for a successful
negotiation or determination of the encoding to be used between server
and client.
For the solution discussion a separate thread will be started and can be
finalized also after the poll deadline.

You may think that one or the other option is useless from your pov. In
this case please ignore it.

Best Regards,
Mehmet  & Mahesh

------------------------------------------------------------------------
--------

---

From: Rodney Cummings <[email-masked]>
Date: Fri, 7 Aug 2015 11:31:38 -0500

I vote for:
        x+j

My reasoning is that there are RESTful web servers in the field today that 
chose to implement XML, or JSON, but not both. In order to transition 
these products to RESTCONF, it is important for RESTCONF's mandates to be 
analogous.

As the "x+j" solution proceeds through the market, I think it is likely 
that most if not all clients will implement both XML and JSON, in order to 
provide interoperability with all RESTCONF servers. I don't think that we 
necessarily need to mandate this client-side "x&j" in RESTCONF itself, 
because I am confident that the market can work that out on its own.

As for the negotiation of the encoding, I agree with other comments that 
the existing HTTP mechanisms can be leveraged.

----------------------------
Rodney Cummings
Principal Software Architect, Industrial/Embedded Networks
National Instruments
Tel: (512) 683-8544
Fax: (512) 683-8661
Email: [email-masked]

From:   "Ersue, Mehmet (Nokia - DE/Munich)" <[email-masked]>
To:     Netconf <[email-masked]>, 
Date:   08/06/2015 03:18 PM
Subject:        [Netconf] Opinion poll for the RESTCONF encoding
Sent by:        "Netconf" <[email-masked]>

Dear NETCONF WG,

 

 

Best Regards, 
Mehmet & Mahesh

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 7 Aug 2015 18:42:47 +0200

+1 (thanks Rodney for making my vote easier)

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Mahesh Jethanandani <[email-masked]>
Date: Fri, 7 Aug 2015 09:57:17 -0700

[Co-char hat off]

I agree and vote for x+j).

x+j) on the server will let the market decide whether the client supports x&j) or x+j).

> On Aug 7, 2015, at 9:31 AM, Rodney Cummings <[email-masked]> wrote:
> 
> I vote for: 
>         x+j 
> 
> My reasoning is that there are RESTful web servers in the field today that chose to implement XML, or JSON, but not both. In order to transition these products to RESTCONF, it is important for RESTCONF's mandates to be analogous. 
> 
> As the "x+j" solution proceeds through the market, I think it is likely that most if not all clients will implement both XML and JSON, in order to provide interoperability with all RESTCONF servers. I don't think that we necessarily need to mandate this client-side "x&j" in RESTCONF itself, because I am confident that the market can work that out on its own. 
> 
> As for the negotiation of the encoding, I agree with other comments that the existing HTTP mechanisms can be leveraged. 
> 
> See https://mailarchive.ietf.org/arch/msg/netconf/YSEbLd-nnI0dlkeiIeGW-z6JqDg <https://mailarchive.ietf.org/arch/msg/netconf/YSEbLd-nnI0dlkeiIeGW-z6JqDg> 
> https://www.ietf.org/mailman/listinfo/netconf <https://www.ietf.org/mailman/listinfo/netconf>
> 

Mahesh Jethanandani
[email-masked]

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Fri, 7 Aug 2015 18:55:48 +0000

Agree:  x+j

From: Mahesh Jethanandani, August 07, 2015 12:57 PM

[Co-char hat off]

On Aug 7, 2015, at 9:31 AM, Rodney Cummings <[email-masked]<mailto:[email-masked]>> wrote:

I vote for:
        x+j

----------------------------
Rodney Cummings
Principal Software Architect, Industrial/Embedded Networks
National Instruments
Tel: (512) 683-8544
Fax: (512) 683-8661
Email: [email-masked]<mailto:[email-masked]>

From:        "Ersue, Mehmet (Nokia - DE/Munich)" <[email-masked]<mailto:[email-masked]>>
To:        Netconf <[email-masked]<mailto:[email-masked]>>,
Date:        08/06/2015 03:18 PM
Subject:        [Netconf] Opinion poll for the RESTCONF encoding
Sent by:        "Netconf" <[email-masked]<mailto:[email-masked]>>
________________________________

Dear NETCONF WG,

Best Regards,
Mehmet & Mahesh

 _______________________________________________
Netconf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netconf

_______________________________________________
Netconf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netconf

Mahesh Jethanandani
[email-masked]<mailto:[email-masked]>

---

From: "Rudy Klecka (rklecka)" <[email-masked]>
Date: Fri, 7 Aug 2015 22:19:59 +0000

Agree: x+j

From: Netconf <[email-masked]<mailto:[email-masked]>> on behalf of "Eric Voit (evoit)" <[email-masked]<mailto:[email-masked]>>
Date: Friday, August 7, 2015 at 1:55 PM
To: Mahesh Jethanandani <[email-masked]<mailto:[email-masked]>>
Cc: Netconf <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Netconf] Opinion poll for the RESTCONF encoding

Agree:  x+j

[Co-char hat off]

I vote for:
        x+j

Dear NETCONF WG,

Best Regards,
Mehmet & Mahesh

Mahesh Jethanandani

---

From: "Russ White" <[email-masked]>
Date: Sat, 8 Aug 2015 06:55:05 -0400

> nm) Both XML and JSON are optional and _not_ mandatory.

It might be profitable to split this into two problems -- what is mandatory
on the server side, and what is mandatory on the client side. I would argue
the server should be required to support both (x&j) and the client should
conform to x+j to provide the widest degree of flexibility and
interoperability. The negotiation, as noted elsewhere, is already included
in HTTP.

If they must be considered together, then I would argue for XML mandatory,
JSON optional (x), because that is likely to produce the most widely
deployed interoperable solutions.

:-)

Russ

---

From: Ambika Tripathy <[email-masked]>
Date: Sun, 9 Aug 2015 12:26:40 +0530

I would like to vote for X+J.

br,
Ambika Prasad Tripathy

-- 
Ambika Prasad Tripathy
Cell @+91 9437547730/8553070866
Alt email: [email-masked]
[email-masked]
skype:ambika_nethawk

---

From: "Einar Nilsen-Nygaard (einarnn)" <[email-masked]>
Date: Sun, 9 Aug 2015 10:29:52 +0000

x+j

Cheers,

Einar

On Aug 6, 2015, at 9:18 PM, Ersue, Mehmet (Nokia - DE/Munich) <[email-masked]<mailto:[email-masked]>> wrote:

Dear NETCONF WG,

Best Regards,
Mehmet & Mahesh

---

From: KARAN VERMA <[email-masked]>
Date: Mon, 10 Aug 2015 12:27:54 +0530

hi,

My vote also given

x+j

On Mon, Aug 10, 2015 at 12:26 PM, KARAN VERMA <[email-masked]>
wrote:

> Hello Einar,
>
>
> got it
>
> On Mon, Aug 10, 2015 at 12:19 PM, Einar Nilsen-Nygaard (einarnn) <
> [email-masked]> wrote:
>
>> Karan,
>>
>> Noticed that you just replied to me, not to Mehmet or the alias (unless
>> you bcc’d?). You may wish to re-reply with:
>>
>> [email-masked]
>> [email-masked]
>>
>> …on the "To" list if you want your vote registered!
>>
>> Cheers,
>>
>> Einar
>>
>>
>> On Aug 10, 2015, at 6:19 AM, KARAN VERMA <[email-masked]>
>> wrote:
>>
>> I think
>>
>> My vote also given
>>
>> x+j
>>
>> On Sun, Aug 9, 2015 at 3:59 PM, Einar Nilsen-Nygaard (einarnn) <
>> [email-masked]> wrote:
>>
>>> x+j
>>>
>>> Cheers,
>>>
>>> Einar
>>>
>>> On Aug 6, 2015, at 9:18 PM, Ersue, Mehmet (Nokia - DE/Munich) <
>> *Kind Regards, *
>> *Dr. Karan Verma *
>> *Research Scholar *
>> *UTP, Malaysia*
>> *Phone: +60-166245082 <%2B60-166245082>*
>>
>>
>>
>
>
> --
> *Kind Regards, *
>
> *Dr. Karan Verma *
> *Research Scholar *
> *UTP, Malaysia*
> *Phone: +60-166245082 <%2B60-166245082>*
>

-- 
*Kind Regards, *

*Karan Verma *
*Research Scholar *
*UTP, Malaysia*
*Phone: +60-166245082 <%2B60-166245082>*

---

From: Dean Bogdanovic <[email-masked]>
Date: Mon, 10 Aug 2015 10:31:47 +0200

x+j is fine for larger devices, but will run into problems with IoT, where resources are scarce. 

I vote for x+j, but we should keep constrained resource environments in mind

Dean

> On Aug 10, 2015, at 8:57 AM, KARAN VERMA <[email-masked]> wrote:
> 
> hi,
> 
> My vote also given 
> 
> x+j
> 
> On Mon, Aug 10, 2015 at 12:26 PM, KARAN VERMA <[email-masked] <mailto:[email-masked]>> wrote:
> Hello Einar,
> 
> 
> got it 
> 
> On Mon, Aug 10, 2015 at 12:19 PM, Einar Nilsen-Nygaard (einarnn) <[email-masked] <mailto:[email-masked]>> wrote:
> Karan,
> 
> Noticed that you just replied to me, not to Mehmet or the alias (unless you bcc’d?). You may wish to re-reply with:
> 
> [email-masked] <mailto:[email-masked]>
> [email-masked] <mailto:[email-masked]>
> 
>> On Aug 10, 2015, at 6:19 AM, KARAN VERMA <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> I think 
>> 
>> My vote also given 
>> 
>> x+j
>> 
>> On Sun, Aug 9, 2015 at 3:59 PM, Einar Nilsen-Nygaard (einarnn) <[email-masked] <mailto:[email-masked]>> wrote:
>> x+j
>> 
>> Cheers,
>> 
>> Einar
>> 
>>> On Aug 6, 2015, at 9:18 PM, Ersue, Mehmet (Nokia - DE/Munich) <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>> Dear NETCONF WG,
>>> 
>>> [email-masked] <mailto:[email-masked]>
>> [email-masked] <mailto:[email-masked]>
>> Kind Regards, 
>> Dr. Karan Verma 
>> Research Scholar 
>> UTP, Malaysia
>> Phone: +60-166245082 <tel:%2B60-166245082>
> 
> 
> 
> -- 
> Kind Regards, 
> 
> Dr. Karan Verma 
> Research Scholar 
> UTP, Malaysia
> Phone: +60-166245082 <tel:%2B60-166245082>
> 
> 
> -- 
> Kind Regards, 
> 
> Karan Verma 
> Research Scholar 
> UTP, Malaysia
> Phone: +60-166245082 <tel:%2B60-166245082>_______________________________________________
> Netconf mailing list
> [email-masked]

---

From: Ladislav Lhotka <[email-masked]>
Date: Mon, 10 Aug 2015 10:40:17 +0200

Hi Dean,

do you mean that IoT devices might need something else than JSON or XML?

Lada

> On 10 Aug 2015, at 10:31, Dean Bogdanovic <[email-masked]> wrote:
> 
>> On Mon, Aug 10, 2015 at 12:26 PM, KARAN VERMA <[email-masked]> wrote:
>> Hello Einar,
>> 
>> 
>> got it 
>> 
>> On Mon, Aug 10, 2015 at 12:19 PM, Einar Nilsen-Nygaard (einarnn) <[email-masked]> wrote:
>> Karan,
>> 
>>> On Aug 10, 2015, at 6:19 AM, KARAN VERMA <[email-masked]> wrote:
>>> 
>>> I think 
>>> 
>>> My vote also given 
>>> 
>>> x+j
>>> 
>>> On Sun, Aug 9, 2015 at 3:59 PM, Einar Nilsen-Nygaard (einarnn) <[email-masked]> wrote:
>>> x+j
>>> 
>>> Cheers,
>>> 
>>> Einar
>>> 
>>>> On Aug 6, 2015, at 9:18 PM, Ersue, Mehmet (Nokia - DE/Munich) <[email-masked]> wrote:
>>>> 
>>>> Dear NETCONF WG,
>>>> 
>>> Phone: +60-166245082
>> Phone: +60-166245082
>> Phone: +60-166245082

---

From: Radek Krejčí <[email-masked]>
Date: Mon, 10 Aug 2015 10:48:40 +0200

I agree and vote for x+j option

Radek Krejci

Dne 7.8.2015 v 18:31 Rodney Cummings napsal(a):
> ------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
>
>
>
> Dear NETCONF WG,
>
> See _https://mailarchive.ietf.org/arch/msg/netconf/YSEbLd-nnI0dlkeiIeGW-z6JqDg_

---

From: Dean Bogdanovic <[email-masked]>
Date: Mon, 10 Aug 2015 10:54:56 +0200

I meant that IoT might be able to support one or the other, not both.

Dean

> On Aug 10, 2015, at 10:40 AM, Ladislav Lhotka <[email-masked]> wrote:
> 
> Hi Dean,
>

---

From: Ladislav Lhotka <[email-masked]>
Date: Mon, 10 Aug 2015 11:00:52 +0200

> On 10 Aug 2015, at 10:54, Dean Bogdanovic <[email-masked]> wrote:
> 

Then I don’t understand your concerns because this is (I hope) exactly what x+j means: server implementors have to choose either JSON or XML. They can choose to support both but it isn’t required.

Lada

---

From: Dean Bogdanovic <[email-masked]>
Date: Mon, 10 Aug 2015 11:05:41 +0200

Yes, you are right. I misread x+j with x&j

Sorry for confusion

Dean

> On Aug 10, 2015, at 11:00 AM, Ladislav Lhotka <[email-masked]> wrote:
> 
>

---

From: Andy Bierman <[email-masked]>
Date: Mon, 10 Aug 2015 03:02:05 -0700

Hi,

The CoMI protocol proposed to the CORE WG uses CBOR encoding,
not XML or JSON.

Andy

On Mon, Aug 10, 2015 at 1:54 AM, Dean Bogdanovic <[email-masked]> wrote:

> >>> Noticed that you just replied to me, not to Mehmet or the alias
> (unless you bcc’d?). You may wish to re-reply with:
> >>>
> >>> [email-masked]
> >>> [email-masked]
> >>>
> >>>>> So, all interested NETCONF WG members, please speak up so that we
> get a better data to judge on WG (rough) consensus.
> >>>>> For the solution discussion a separate thread will be started and
> can be finalized also after the poll deadline.
> >>>>>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 10 Aug 2015 12:34:15 +0200

A device implementing CoMI is implementing CoMI and not RESTCONF so
this is no issue. If in the future another encoding becomes as popular
as JSON is today, a new RFC can be published that relaxes the
requirements further.

/js

---

From: t.petch <[email-masked]>
Date: Mon, 10 Aug 2015 11:42:23 +0100

----- Original Message -----
From: "Russ White" <[email-masked]>
To: "'Ersue, Mehmet (Nokia - DE/Munich)'" <[email-masked]>;
"'Netconf'" <[email-masked]>
Sent: Saturday, August 08, 2015 11:55 AM

Russ

Usually we have a small number of servers and a massive number of
clients, so clients are what they are and servers have to cope; there
are many such examples in and around HTML.

Here, the roles are reversed, it is servers that are the legion, clients
that are few and flexible.  So any client worth its salt will be x&j
regardless of what we say.

I was thinking of the server when I opted for x; still do, too many
standards have been constrained by the current technology and have
looked feeble a few years on when hardware capabilities have increased
by an order of magnitude.

Tom Petch

---

From: Ladislav Lhotka <[email-masked]>
Date: Mon, 10 Aug 2015 13:32:51 +0200

> On 10 Aug 2015, at 12:34, Juergen Schoenwaelder <[email-masked]> wrote:
> 

+1

Lada

---

From: "Alexander Clemm (alex)" <[email-masked]>
Date: Mon, 10 Aug 2015 18:00:13 +0000

+1 
(i.e. x+j)
--- Alex

-----Original Message-----
From: Netconf [mailto:[email-masked]] On Behalf Of Ladislav Lhotka
Sent: Monday, August 10, 2015 4:33 AM
To: Jürgen Schönwälder
Cc: Netconf
Subject: Re: [Netconf] Opinion poll for the RESTCONF encoding

+1

Lada

>> The CoMI protocol proposed to the CORE WG uses CBOR encoding, not XML 
>> or JSON.
>> 
>> Andy
>> 
>> 
>>>>> x+j is fine for larger devices, but will run into problems with 
>>>>> x+IoT,
>>> where resources are scarce.
>>>>> 
>>>>> I vote for x+j, but we should keep constrained resource 
>>>>> environments in
>>> mind
>>>>> 
>>>>> Dean
>>>>> 
>>>>>> On Aug 10, 2015, at 8:57 AM, KARAN VERMA 
>>>>>> <[email-masked]>
>>> wrote:
>>>>>> 
>>>>>> hi,
>>>>>> 
>>>>>> My vote also given
>>>>>> 
>>>>>> x+j
>>>>>> 
>>> negotiation or determination of the encoding to be used between 
>>> server and client.

---

From: Xiang Li <[email-masked]>
Date: Wed, 12 Aug 2015 09:51:44 -0500

>> x+j) Either XML or JSON is mandatory the other one is optional,

Considering the reasons behind this second poll I vote for x+j this 
time. I originally went with XML for best interoperability.

-Xiang Li

>> For the solution discussion a separate thread will be started and can 
>> be finalized also after the poll deadline.
>>
> [email-masked] <mailto:[email-masked]>
>
>
>
>
>
>
>

---

From: Kent Watsen <[email-masked]>
Date: Wed, 12 Aug 2015 17:57:34 +0000

Since I haven't voted yet, let the record show I'm for x+j"

>as JSON is today, a new RFC can be published that relaxes the

How would this relaxation be introduced?   Say there is new encoding 'a'
and we now want "x+j+a".  Would we latch it to the RESTCONF protocol
version?  - that is, RESTCONF v1 (what we're working on now) supports
"x+j" and RESTCONF v2 supports "x+j+a"?

The host-meta file could be updated from:

          <Link rel='restconf' href='/restconf'>

To something like:

          <Link rel='restconf' href='/restconf'>
          <Link rel='restconf-v2' href='/restconf-v2'>

But is this better than yesterday's proposal?

  <Link rel='restconf' href='/restconf'>
    <Property 
type="urn:ietf:params:xml:ns:yang:ietf-restconf/encoding>json</Property>
    <Property 
type="urn:ietf:params:xml:ns:yang:ietf-restconf/encoding>xml</Property>
  </Link>

Kent

---

From: Andy Bierman <[email-masked]>
Date: Wed, 12 Aug 2015 11:03:41 -0700

> type="urn:ietf:params:xml:ns:yang:ietf-restconf/encoding>xml</Property>

If notifications are supported then the "text/event-stream" encoding
be listed here as well?

IMO the value of these global properties is minimal because the
server can support a different set of encoding formats for each resource.
(So the Accept header needs to be sent anyway)

Andy

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 12 Aug 2015 21:37:30 +0200

> "x+j" and RESTCONF v2 supports "x+j+a"?

No, an encoding is just an encoding and not a new protocol version.
Anyway, this is a hypothetical discussion, so lets not waste cycles on
it before we even have published RESTCONF 1.0.

/js

---

From: Kent Watsen <[email-masked]>
Date: Thu, 13 Aug 2015 01:53:35 +0000

>No, an encoding is just an encoding and not a new protocol version.

I agree, which is why I was pointing out the silliness of keying off a
protocol version.

>it before we even have published RESTCONF 1.0.

I disagree - we should see our way clear to the end game with such things.

So a legacy client pointed at a new server only supporting the 'a'
encoding would learn that only from receiving back a 406 Not Acceptable?
Assuming the client passed both +xml and +json, would the user then jump
to ietf.org looking to see if there were a new encoding?  This could be so
much better if the 406 response body also included a message indicating
which content types are available for the resource.  Oooo, and so it can,
according to rfc7231, Section 6.5.6:

   The server SHOULD generate a payload containing a list of available
   representation characteristics and corresponding resource identifiers
   from which the user or user agent can choose the one most
   appropriate.

Works for me!

Kent

---

From: Andy Bierman <[email-masked]>
Date: Wed, 12 Aug 2015 19:41:22 -0700

> I disagree - we should see our way clear to the end game with such things.
yes

>    from which the user or user agent can choose the one most
me too

I have been asked several times about RESTCONF over CoAP
using CBOR encoding.  Some people do not like CoMI because
we took out some features to make it simpler for constrained devices.
RESTCONF without XML or JSON might happen sooner than you think.

Kent

Andy

---

From: "Scharf, Michael (Michael)" <[email-masked]>
Date: Thu, 13 Aug 2015 07:50:57 +0000

x+j and let the market decide

IMHO in some cases the encoding supported by the server will be simply known by out-of-band information and on-the-fly negotiation will not really be required. But I guess the REST-ish way to determine encodings is HTTP accept.

Michael

From: Netconf [mailto:[email-masked]] On Behalf Of Ersue, Mehmet (Nokia - DE/Munich)
Sent: Donnerstag, 6. August 2015 22:18
To: Netconf
Subject: [Netconf] Opinion poll for the RESTCONF encoding

Dear NETCONF WG,

Best Regards,
Mehmet & Mahesh

---

From: Ladislav Lhotka <[email-masked]>
Date: Thu, 13 Aug 2015 10:41:24 +0200

> On 13 Aug 2015, at 09:50, Scharf, Michael (Michael) <[email-masked]> wrote:
> 
> IMHO in some cases the encoding supported by the server will be simply known by out-of-band information and on-the-fly negotiation

Indeed, NM software is usually selected for a concrete network.

Lada

> will not really be required. But I guess the REST-ish way to determine encodings is HTTP accept.
>  
> Michael
>  
>

---

From: Robert Wilton <[email-masked]>
Date: Thu, 13 Aug 2015 09:58:00 +0100

> RESTCONF without XML or JSON might happen sooner than you think.

Then does it still make sense to mandate that all compliant RESTCONF 
server implementations have to support at least one of XML or JSON?

Cheers,
Rob

---

From: Robert Wilton <[email-masked]>
Date: Thu, 13 Aug 2015 10:31:51 +0100

I seem to be swimming against the tide, but my vote is for nm.

More precisely, I would write "A server SHOULD support either XML or 
JSON encoding.  For maximum interoperability it is RECOMMENDED that both 
client and servers support both XML and JSON".

Justification: Don't cause a server to be non compliant with RESTCONF if 
they have a specific reason for requiring a different encoding.

As for the client/server compatibility issue - I think that market 
forces will mean that this isn't an issue in practice.

Thanks,
Rob

On 06/08/2015 21:18, Ersue, Mehmet (Nokia - DE/Munich) wrote:
> So, all interested NETCONF WG members, please speak up so that we get 
> a better data to judge on WG (rough) consensus.
> declare consensus in the sake of progress, based on the “dominant 
> view” determined by the co-chairs and AD.

---

From: Kent Watsen <[email-masked]>
Date: Thu, 13 Aug 2015 19:03:16 +0000

I almost voted "nm" before for this reason and, with the recent info about 406 including supported encodings, I'm now even more open to the idea...

My only reservation is that I'm torn if interoperability is better achieved by mandate or market forces.  If it is outrageously onerous, the CoMI folks can always define "COMICONF" that is a one-line diff to RESTCONF  ;)

Kent

From: Robert Wilton <[email-masked]<mailto:[email-masked]>>
Date: Thursday, August 13, 2015 at 5:31 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Netconf] Opinion poll for the RESTCONF encoding

More precisely, I would write "A server SHOULD support either XML or JSON encoding.  For maximum interoperability it is RECOMMENDED that both client and servers support both XML and JSON".

Justification: Don't cause a server to be non compliant with RESTCONF if they have a specific reason for requiring a different encoding.

As for the client/server compatibility issue - I think that market forces will mean that this isn't an issue in practice.

Thanks,
Rob

Best Regards,
Mehmet & Mahesh

_______________________________________________
Netconf mailing list
[email-masked]<mailto:[email-masked]>https://www.ietf.org/mailman/listinfo/netconf

---

From: Robert Wilton <[email-masked]>
Date: Fri, 14 Aug 2015 12:17:33 +0100

On 13/08/2015 20:03, Kent Watsen wrote:
>
> I almost voted "nm" before for this reason and, with the recent info 
> about 406 including supported encodings, I'm now even more open to the 
> idea...
I guess that I'm not convinced that either XML or JSON will necessarily 
end up as the prevalent encoding longer term, I think that one of the 
more efficient binary encodings will eventually win out.

But if RESTCONF mandates XML or JSON now then it seems fairly unlikely 
that this requirement will be dropped any time in the near future 
because nobody likes to break backwards compatibility.

>
> My only reservation is that I'm torn if interoperability is better 
> achieved by mandate or market forces.
Yes, I can emphasise with that view.

>  If it is outrageously onerous, the CoMI folks can always define 
> "COMICONF" that is a one-line diff to RESTCONF  ;)
At the end of the day, I'm also OK with x+j, but felt that nm was 
slightly better.

I guess that what I have proposed really sits between x+j and nm, given 
that it is weaker than x+j but stronger than nm (i.e. RECOMMENDED rather 
than OPTIONAL).

Thanks,
Rob

>
> Kent
>
> From: Robert Wilton <[email-masked] <mailto:[email-masked]>>
> To: "[email-masked] <mailto:[email-masked]>" <[email-masked] 
> <mailto:[email-masked]>>
> JSON encoding.  For maximum interoperability it is RECOMMENDED that 
> both client and servers support both XML and JSON".
>
> Justification: Don't cause a server to be non compliant with RESTCONF 
> if they have a specific reason for requiring a different encoding.
>
>> [email-masked]://www.ietf.org/mailman/listinfo/netconf
>

---

From: Andy Bierman <[email-masked]>
Date: Fri, 14 Aug 2015 19:33:02 -0700

Hi,

I did not say the CORE WG is going to standardize RESTCONF over CoAP.
Their charter is being reviewed now. My preference is to keep CoMI as
lightweight as possible.

A RESTCONF-over-CoAP server would be non-standard.
IMO it is not unreasonable to expect the server to support JSON
to work with RESTCONF clients, to claim RESTCONF conformance.

If there was a standard mapping of RESTCONF to CoAP,
then the server would claim conformance to that RFC, not RESTCONF.

Andy

On Fri, Aug 14, 2015 at 4:17 AM, Robert Wilton <[email-masked]> wrote:

> I almost voted "nm" before for this reason and, with the recent info about
> 406 including supported encodings, I'm now even more open to the idea...
>
> end up as the prevalent encoding longer term, I think that one of the more
> efficient binary encodings will eventually win out.
>
> that this requirement will be dropped any time in the near future because
> nobody likes to break backwards compatibility.
>
>
> At the end of the day, I'm also OK with x+j, but felt that nm was slightly
> better.
>
> From: Robert Wilton <[email-masked]>
> To: " <[email-masked]>[email-masked]" <[email-masked]>
> More precisely, I would write "A server SHOULD support either XML or JSON
> encoding.  For maximum interoperability it is RECOMMENDED that both client
> and servers support both XML and JSON".
>
> As for the client/server compatibility issue - I think that market forces
> will mean that this isn't an issue in practice.
>
> Thanks,
> Rob
>
>
> Netconf mailing [email-masked]://www.ietf.org/mailman/listinfo/netconf
>
>
>
>