Subject: [Netconf] Revisit of HTTP2 and Restconf ?

From: "Eric Voit (evoit)" <[email-masked]>
Date: Wed, 5 Aug 2015 16:00:23 +0000

In January 2014, there was a thread on the relevance of HTTP 2.0 to Restconf.   At the time it was decided to treat HTTP1.1 & HTTP2.0 the same.
https://www.ietf.org/mail-archive/web/netconf/current/msg08579.html 

At some point, it might be worth reexamining that conclusion.  Below are some reasons why the benefits of HTTP2.0 might be useful to explicitly support within Restconf:

(1) Full stream multiplexing, stream prioritization and flow control

(2) Since TLS is underneath HTTP2, there is no need to establish multiple TLS connections to partially achieve goals of (1)

(3) TCP Session scale: No need for multiple TCP connections and bindings/distribution into these parallel connections

(4) Ride the performance/scale curve of current HTTP2 development

I have a vested interest here, as many YANG subscription updates can be pushed concurrently from a network device.  With such support, we can avoid head-of-line blocking issues.

That said, I have no desire to slow down Restconf work for the deltas necessary for HTTP2 parameter support.   But if people believe this is interesting, perhaps the community would welcome a draft defining the deltas beyond the Restconf.  

Thoughts?

Eric

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 5 Aug 2015 20:30:02 +0200

> That said, I have no desire to slow down Restconf work for the deltas necessary for HTTP2 parameter support.   But if people believe this is interesting, perhaps the community would welcome a draft…

I believe HTTP/2 is very interesting to look at, in particular also
whether the server push mechanism of HTTP/2 can provide a better way
to send notifications. While I support this initiative, I likely won't
be able to write a draft myself in the forseeable future.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>