Subject: Re: [Netconf] Opinion poll for the RESTCONF encoding

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 10 Aug 2015 09:22:53 +0000

Dear all;

In IoT space, JSON has a strong support, some device will definitely not support XML,  so mandating XML support in the server is not really constructive. So I agree with the general desire in that thread not to force XML everywhere.

nm seems like the right thing to me though I’m fine with x+j.
Rationale is that nm is probably more open to the future and x+j does not guarantee that your server will have the protocol a particular new device needs anyway since the only guarantee came from musting XML everywhere.

In the IoT space there’s always an additional standard like a ZigBeeIP that picks and chooses between acceptable things and restricts things to guarantee interop within that standard.

Cheers,

Pascal

From:        "Ersue, Mehmet (Nokia - DE/Munich)" <[email-masked]<mailto:[email-masked]>>
To:        Netconf <[email-masked]<mailto:[email-masked]>>,
Date:        08/06/2015 03:18 PM
Subject:        [Netconf] Opinion poll for the RESTCONF encoding
Sent by:        "Netconf" <[email-masked]<mailto:[email-masked]>>
________________________________

Dear NETCONF WG,

last October we had an opinion poll on the RESTCONF encoding, which ended with a close consensus in favor of XML as mandatory.
See https://mailarchive.ietf.org/arch/msg/netconf/YSEbLd-nnI0dlkeiIeGW-z6JqDg
Based on the recent discussion on this topic and opinions against mandatory statements in RESTCONF, NETCONF WG co-chairs would like to start a new opinion poll.

As stated in the mail for the previous poll, the result of the poll depends on the count of people voting.
So, all interested NETCONF WG members, please speak up so that we get a better data to judge on WG (rough) consensus.
If the voting result is again close, the WG co-chairs will (again) declare consensus in the sake of progress, based on the “dominant view” determined by the co-chairs and AD.

Please do state your opinion with short and concrete reasoning, by August 19, 2015 18:00 PST about the following options:

x) XML is mandatory, JSON optional,
j) JSON is mandatory, XML optional,
x&j) XML and JSON are both mandatory,
x+j) Either XML or JSON is mandatory the other one is optional,
nm) Both XML and JSON are optional and _not_ mandatory.

For “x+j” and “nm” please provide a solution for a successful negotiation or determination of the encoding to be used between server and client.
For the solution discussion a separate thread will be started and can be finalized also after the poll deadline.

You may think that one or the other option is useless from your pov. In this case please ignore it.

Looking forward to counting your votes and reading your reasoning.
Thank you.

Best Regards,
Mehmet & Mahesh

_______________________________________________
Netconf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netconf
_______________________________________________
Netconf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netconf

---

From: Alan Luchuk <[email-masked]>
Date: Mon, 10 Aug 2015 09:23:34 -0400 (EDT)

> x+j) Either XML or JSON is mandatory the other one is optional,

Regards,
--Alan