Subject: [Netconf] Spencer Dawkins' No Objection on draft-ietf-netconf-call-home-11: (with COMMENT)

From: "Spencer Dawkins" <[email-masked]>
Date: Tue, 20 Oct 2015 11:48:20 -0700

Spencer Dawkins has entered the following ballot position for
draft-ietf-netconf-call-home-11: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-netconf-call-home/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

In this text:

   C1  The NETCONF/RESTCONF client listens for TCP connection requests
       from NETCONF/RESTCONF servers.  The client SHOULD listen for
       connections on the IANA-assigned ports defined in section
       Section 5, but MAY be configured to use a non-standard port.
       
are SHOULD/MAY mutually exclusive here, or can you do both? I'd be
guessing if I said I knew, from this text. Could you provide "as well as"
or "instead of" guidance?

---

From: Mahesh Jethanandani <[email-masked]>
Date: Tue, 20 Oct 2015 21:47:18 -0700

Spencer,

> On Oct 20, 2015, at 11:48 AM, Spencer Dawkins <[email-masked]> wrote:
> 

As I read the content, I can see some implementations deciding to “as well as” while others deciding that they would have nothing but “instead of”. Could this be left up to implementors to decide?

Mahesh Jethanandani
[email-masked]

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Wed, 21 Oct 2015 12:33:59 -0500

Hi, Manesh,

On Tue, Oct 20, 2015 at 11:47 PM, Mahesh Jethanandani <
[email-masked]> wrote:

> As I read the content, I can see some implementations deciding to “as well
> as” while others deciding that they would have nothing but “instead of”.
> Could this be left up to implementors to decide?
>

Absolutely. My point was that it wasn't clear to me that implementors can
do either/both. If you think that's clear, that's fine.

Thanks for the quick response.

Spencer

---

From: Kent Watsen <[email-masked]>
Date: Wed, 21 Oct 2015 19:19:28 +0000

Hi Spencer,

Thank you for your review.

Based on this discussion, I will not plan to make any change to the draft.

Thanks again,
Kent

From: Spencer Dawkins at IETF <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, October 21, 2015 at 1:33 PM
To: Mahesh Jethanandani <[email-masked]<mailto:[email-masked]>>
Cc: The IESG <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: Spencer Dawkins' No Objection on draft-ietf-netconf-call-home-11: (with COMMENT)

Hi, Manesh,

On Tue, Oct 20, 2015 at 11:47 PM, Mahesh Jethanandani <[email-masked]<mailto:[email-masked]>> wrote:
Spencer,

On Oct 20, 2015, at 11:48 AM, Spencer Dawkins <[email-masked]<mailto:[email-masked]>> wrote:

In this text:

Absolutely. My point was that it wasn't clear to me that implementors can do either/both. If you think that's clear, that's fine.

Spencer