Subject: [Netconf] Consensus on draft-leiba-netmod-regpolicy-update-00 (was: Re: On the registration policy for the NETCONF Capability URNs registry)

From: Benoit Claise <[email-masked]>
Date: Thu, 5 Nov 2015 16:54:26 +0900

Dear all,

During the NETCONF meeting today, there was no objection to progressing 
the draft 
https://tools.ietf.org/html/draft-leiba-netmod-regpolicy-update-00.
I would like to confirm consensus on the list with this email.

The one sentence exec summary is: This document proposes that the 
registration policy for the NETCONF Capability URNs registry is lowered 
from Standards Action to IETF review, so that a document such as 
draft-mm-netconf-time-capability-09 
<http://datatracker.ietf.org/doc/draft-mm-netconf-time-capability/> can 
register a new entry.

The plan is to progress draft-leiba-netmod-regpolicy-update-00 as AD 
sponsor in 2 weeks from now.

Regards, Benoit

> Dear all,
>
> https://tools.ietf.org/html/draft-leiba-netmod-regpolicy-update-00
>
> This document, which updates the NETCONF Capability URNs registry 
> policy, requires the process defined in RFC 2026. This means that it 
> needs to be discussed, reviewed by the responsible AD, given an 
> IETF-wide last call, and reviewed and approved by the IESG.
>
> I hope that it can go fairly quickly, as it's a simple action. 
> Therefore, I propose to keep this document as an individual 
> submission, which I will AD sponsor.  However, neither Bary nor I are 
> going to push this ahead against the working group's opposition.
>
> So it's time to speak up if you disagree with that policy change.
> A final consensus call will be made during the NETCONF meeting in 
> Yokohama.
>
> Regards, Benoit (OPS AD)
>
>> For any who haven't followed it, we had a discussion about the
>> experimental document draft-mm-netconf-time-capability, which
>> registers a NETCONF capability URN.  Here's my last comment on the
>> point, after I cleared my DISCUSS ballot:
>>
>> ----------
>> The registration policy for the NETCONF Capability URNs registry is
>> Standards Action, and this document, with Experimental status, does
>> not meet the requirement that the registration come from a Standards
>> Track RFC.  This document cannot make that registration.
>>
>> After discussion about whether the IESG should make an exception in
>> this case and allow the registration, I agree that it's the right
>> thing to do for this document, so I've cleared my DISCUSS ballot on
>> that point.
>>
>> But at the same time, it seems that the registration policy is too
>> strict, and should be IETF Review, which allows the NETCONF working
>> group to make the decision by getting IETF consensus on the
>> registration -- there's no need to specifically require a Standards
>> Track RFC.  To that end, I've submitted an Internet draft,
>> draft-leiba-netmod-regpolicy-update, which I ask the Network
>> Operations AD to sponsor, in coordination with the NETCONF working
>> group.
>> ----------
>>
>> I typo'ed the filename (made it "-netmod-" rather than "-netconf-");
>> sorry about that.  In any case, the NETCONF working group should look
>> at it and comment.  It's straightforward, just changing the
>> registration policy and explaining why.  I don't expect there'll be
>> controversy with it, but please do give it a review and comment, and
>> let Benoît and Joel know if y'all think it's acceptable for one of
>> them to AD-sponsor:
>> https://datatracker.ietf.org/doc/draft-leiba-netmod-regpolicy-update/
>>
>> Please keep me on CC for any discussion, so I'll see the messages,
>> though I'll also keep an eye on the mailing list archive.
>>
>> Thanks,
>> Barry, ART AD
>> .
>>
>
> .
>

---

From: Ladislav Lhotka <[email-masked]>
Date: Thu, 5 Nov 2015 22:51:20 +0900

> On 05 Nov 2015, at 16:54, Benoit Claise <[email-masked]> wrote:
> 
> Dear all,
> 
> During the NETCONF meeting today, there was no objection to progressing the draft https://tools.ietf.org/html/draft-leiba-netmod-regpolicy-update-00.
> The one sentence exec summary is: This document proposes that the registration policy for the NETCONF Capability URNs registry is lowered from Standards Action to IETF review, so that a document such as draft-mm-netconf-time-capability-09 can register a new entry.
> 
> The plan is to progress draft-leiba-netmod-regpolicy-update-00 as AD sponsor in 2 weeks from now.

Support. Lada

>> This document, which updates the NETCONF Capability URNs registry policy, requires the process defined in RFC 2026. This means that it needs to be discussed, reviewed by the responsible AD, given an IETF-wide last call, and reviewed and approved by the IESG. 
>> 
>> I hope that it can go fairly quickly, as it's a simple action. Therefore, I propose to keep this document as an individual submission, which I will AD sponsor.  However, neither Bary nor I are going to push this ahead against the working group's opposition. 
>> 
>> A final consensus call will be made during the NETCONF meeting in Yokohama. 
>> 
>> Regards, Benoit (OPS AD) 
>> 
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: joel jaeggli <[email-masked]>
Date: Sun, 8 Nov 2015 08:06:40 +0900

Thanks,

With that I am going to allow the publication of draft-mm-netconf-time,
as our exception handling has been um unexceptional.

regards,
joel

---

From: Benoit Claise <[email-masked]>
Date: Mon, 23 Nov 2015 14:32:47 +0100

Dear all,

> Dear all,
>
> During the NETCONF meeting today, there was no objection to 
> progressing the draft 
> registration policy for the NETCONF Capability URNs registry is 
> lowered from Standards Action to IETF review, so that a document such 
> as draft-mm-netconf-time-capability-09 
> <http://datatracker.ietf.org/doc/draft-mm-netconf-time-capability/> 
> can register a new entry.
>
Which I'm doing right now.

Regards, Benoit