Subject: [Netconf] how to get the list data meet some filters via restconf

From: "fengchong (C)" <[email-masked]>
Date: Mon, 2 Nov 2015 01:44:29 +0000

Hi,
  YANG module is list below;
  List a {
Key name;
Leaf name {
…
}

Leaf b {
   …
}

Leaf c {
  …
}
  }

  How can I get all data of list a with b = 1 ?

/restconf/data/example:example /a?b=1

OR
/restconf/data/example:example /a?where=’b=1

BTW: where parameter is not clearly defined in
draft-ietf-netconf-restconf-collection-00.txt<https://tools.ietf.org/html/draft-ietf-netconf-restconf-collection-00.txt>
’
________________________________
冯冲
华为技术有限公司 Huawei Technologies Co., Ltd.
[Company_logo]

Phone:
Fax:
Mobile: 18519117316
Email: [email-masked]
地址：南京市软件大道101号华为南京基地 邮编：210001
Huawei Technologies Co., Ltd.

http://www.huawei.com
________________________________
本邮件及其附件含有华为公司的保密信息，仅限于发送给上面地址中列出的个人或群组。禁
止任何其他人以任何形式使用（包括但不限于全部或部分地泄露、复制、或散发）本邮件中
的信息。如果您错收了本邮件，请您立即电话或邮件通知发件人并删除本邮件！
This e-mail and its attachments contain confidential information from HUAWEI, which
is intended only for the person or entity whose address is listed above. Any use of the
information contained herein in any way (including, but not limited to, total or partial
disclosure, reproduction, or dissemination) by persons other than the intended
recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender by
phone or email immediately and delete it!

---

From: Andy Bierman <[email-masked]>
Date: Sun, 1 Nov 2015 17:48:18 -0800

> /restconf/data/example:example /a?b=1

You cannot do this in RESTCONF (yet)

> draft-ietf-netconf-restconf-collection-00.txt
> <https://tools.ietf.org/html/draft-ietf-netconf-restconf-collection-00.txt>
>

Yes -- this draft needs more work to be completed.
Please send review comments on this draft to the WG.

Andy

> ’
> ------------------------------
>
> 冯冲
> ------------------------------
>
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>
>