Subject: [Netconf] get/get-config with invalid filter elements

From: Keshava Krishna Bhat K <[email-masked]>
Date: Mon, 23 Nov 2015 20:47:37 +0530

​Hi,

What should be a NC server’s response when a get is done with valid and
invalid filters ?

For example:
<filter>
  <root xmlns="valid:namespace">
    <invalid-node xmlns="invalid:naespace"/> <!— invalid item -->
    <valid-level1-node/> <!— valid item -->
  </root>
</filter>

Now should the server reply with rpc-reply OR rpc-error (maybe
unknown-namespace) ?

Related question:
What should be the server's response to a get-config rpc which has a state
filter?

Regards,
Keshava.

---

From: Andy Bierman <[email-masked]>
Date: Tue, 24 Nov 2015 08:31:53 -0800

>     <valid-level1-node/> <!— valid item -->

Why does it have to be invalid?  It sould just be ietf-interfaces, but the
server does not have that module loaded.

> Now should the server reply with rpc-reply OR rpc-error (maybe

It just returns <root />.  That is all that matched in the filter.

> What should be the server's response to a get-config rpc which has a state

It will not match the filter so it is not returned.

I think the RFC is clear that selection nodes that do not match do
not result in an <rpc-error>.

> Keshava.

Andy

>
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>
>