Subject: [Netconf] FW: WG Last Call for draft-ietf-netconf-restconf-09, draft-ietf-netconf-yang-patch-07 and draft-ietf-netconf-yang-library-03

From: "Ersue, Mehmet (Nokia - DE/Munich)" <[email-masked]>
Date: Tue, 15 Dec 2015 21:17:22 +0000

The deadline is for sure January 22, 2016 EOB PT.

Mehmet

From: Ersue, Mehmet (Nokia - DE/Munich)
Sent: Tuesday, December 15, 2015 9:59 PM
To: [email-masked]
Cc: [email-masked]' <[email-masked]>; [email-masked]' <[email-masked]>; [email-masked]' <[email-masked]>; [email-masked]' <[email-masked]>
Subject: WG Last Call for draft-ietf-netconf-restconf-09, draft-ietf-netconf-yang-patch-07 and draft-ietf-netconf-yang-library-03

Dear NETCONF WG,

we hereby issue a WG Last Call for the drafts below:

http://tools.ietf.org/html/draft-ietf-netconf-restconf-09.txt
http://tools.ietf.org/html/draft-ietf-netconf-yang-patch-07.txt
http://tools.ietf.org/html/draft-ietf-netconf-yang-library-03.txt

Please review and send your comments to the NETCONF WG mailing list by January 22, 2015 EOB PT.

The drafts on RESTCONF, YANG patch and YANG library are planned to publish as standard track documents.

As RESTCONF is a major protocol we seek a detailed and thorough review within NETCONF WG but also by the related WGs before publishing.
Therefore the WGLC is planned to finalize on January 22th (covering the holiday time in between) and APP, INT and RTG area ADs will be informed as well as Core, I2RS, 6lo, and 6tisch WGs are invited to review.

Please take your time to review the documents and send your comments to the NETCONF maillist by the deadline.
Please state on NETCONF maillist also explicitly, whether you have read/reviewed and whether you support the publication.
Furthermore please indicate if you plan to implement or have already implementations for RESTCONF and its supplementary drafts.

Thank you for your review and kind help getting RESTCONF specifications stable.

Best Regards,
Mehmet and Mahesh

---

From: Qin Wu <[email-masked]>
Date: Thu, 24 Dec 2015 05:52:06 +0000

I have reviewed draft-ietf-netconf-restconf-09 and I have the following quick editorial comments:

1.      Section 3.6
In v-08, support for YANG 1.1 action statement is added, but look at section 3.6, it is not clear to me how rpc statement is used different from rpc statement? If there is some difference, it will be great to clarify this in the section 3.6.

2.      Section 3.6 said:
“
   An RPC operation is invoked as:

   POST {+restconf}/operations/<operation>
”
It looks {+restconf} stands for the RESTCONF API entry point
,I am wondering {+restconf} is different from “/restconf” in the example. Is “/restconf” an example of {+restconf}?

3． Section 5.1, 2nd paragraph

Would it be great to use an example to explain how RESTCONF operation is derived from the HTTP method and the request URI? E.g., you can reference the example in the Appendix to explain this?

4.       Section 5.1 said:
“
     <OP> /<restconf>/<path>?<query>#<fragment>

         ^       ^        ^       ^         ^
         |       |        |       |         |
       method  entry  resource  query    fragment

         M       M        O        O         I

       M=mandatory, O=optional, I=ignored

    <text> replaced by client with real values

”

It looks <text> does not appear in the above URI structure, is the <text> part of the above conceptual fields?

-Qin
发件人: Netconf [mailto:[email-masked]] 代表 Ersue, Mehmet (Nokia - DE/Munich)
发送时间: 2015年12月16日 5:17
收件人: [email-masked]
主题: [Netconf] FW: WG Last Call for draft-ietf-netconf-restconf-09, draft-ietf-netconf-yang-patch-07 and draft-ietf-netconf-yang-library-03

Mehmet

From: Ersue, Mehmet (Nokia - DE/Munich)
Sent: Tuesday, December 15, 2015 9:59 PM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]' <[email-masked]<mailto:[email-masked]>>; [email-masked]' <[email-masked]<mailto:[email-masked]>>; [email-masked]' <[email-masked]<mailto:[email-masked]>>; [email-masked]' <[email-masked]<mailto:[email-masked]>>
Subject: WG Last Call for draft-ietf-netconf-restconf-09, draft-ietf-netconf-yang-patch-07 and draft-ietf-netconf-yang-library-03

Dear NETCONF WG,

Best Regards,
Mehmet and Mahesh

________________________________

---

From: Andy Bierman <[email-masked]>
Date: Mon, 28 Dec 2015 18:55:00 -0800

On Wed, Dec 23, 2015 at 9:52 PM, Qin Wu <[email-masked]> wrote:

> In v-08, support for YANG 1.1 action statement is added, but look at
> section 3.6, it is not clear to me how rpc statement is used different from
> rpc statement? If there is some difference, it will be great to clarify
> this in the section 3.6.
>
> 2.      Section 3.6 said:
>
> “
>

This text in rfc6020bis-08 is the only explanation of the difference

   The difference between an action and an rpc is that an action is tied
   to a node in the datastore, whereas an rpc is not.  When an action is
   invoked, the node in the datastore is specified along with the name
   of the action and the input parameters.

As you can see on RESTCONF-09, pg 23, the /restconf/data entry point
is used, not /restconf/operations

   POST {+restconf}/data/<data-resource-identifier>/<operation>

   POST /restconf/data/module-A:interfaces/reset-all

Note that this is inconsistent with the NETCONF/XML encoding,
which uses the <action> element:

     <rpc message-id="101"
          xmlns="urn:ietf:params:xml:ns:netconf:base:1.0">
    *   <action xmlns="urn:ietf:params:xml:ns:yang:1">*
         <server xmlns="http://example.net/server-farm">
           <name>apache-1</name>
           <reset>
             <reset-at>2014-07-29T13:42:00Z</reset-at>
           </reset>
         </server>
       </action>
     </rpc>

The RESTCONF draft does not show an example of input or output parameters
for actions, but I think they are the same as for RPC.

The RESTCONF invocation would be:

   POST /restconf/data/server-farm:server=apache-1/reset

   { "server-farm:input" : {
        "reset-at" : "2014-07-29T13:42:00Z"
      }
   }

> ,I am wondering {+restconf} is different from “/restconf” in the example.
> Is “/restconf” an example of {+restconf}?
>

This is the convention used to indicate the entry point is not hard-wired.

> Would it be great to use an example to explain how RESTCONF operation is
> derived from the HTTP method and the request URI? E.g., you can reference
> the example in the Appendix to explain this?
>
>
Not sure what you mean.
Operations are explained in sec. 4

> part of the above conceptual fields?

No -- we will change this to indicate it is all the fields with
angle-brackets

> -Qin

Andy

> *发件人:* Netconf [mailto:[email-masked]] *代表 *Ersue, Mehmet
> (Nokia - DE/Munich)
> *发送时间:* 2015年12月16日 5:17
> *收件人:* [email-masked]
> *主题:* [Netconf] FW: WG Last Call for draft-ietf-netconf-restconf-09,
> draft-ietf-netconf-yang-patch-07 and draft-ietf-netconf-yang-library-03
>
>
>
> The deadline is for sure January 22, *2016* EOB PT.
>
>
>
> Mehmet
>
>
>
> *From:* Ersue, Mehmet (Nokia - DE/Munich)
> *Sent:* Tuesday, December 15, 2015 9:59 PM
> *To:* [email-masked]
> *Cc:* [email-masked]' <[email-masked]>; [email-masked]' <[email-masked]>; '
> [email-masked]' <[email-masked]>; [email-masked]' <[email-masked]>
> *Subject:* WG Last Call for draft-ietf-netconf-restconf-09,
> draft-ietf-netconf-yang-patch-07 and draft-ietf-netconf-yang-library-03
>
>
>
> Dear NETCONF WG,
>
>
>
> As RESTCONF is a major protocol we seek a detailed and thorough review
> within NETCONF WG but also by the related WGs before publishing.
>
> Therefore the WGLC is planned to finalize on January 22th (covering the
> holiday time in between) and APP, INT and RTG area ADs will be informed as
> well as Core, I2RS, 6lo, and 6tisch WGs are invited to review.
>
>
>
> Please state on NETCONF maillist also explicitly, whether you have
> read/reviewed and whether you support the publication.
>
> Furthermore please indicate if you plan to implement or have already
> implementations for RESTCONF and its supplementary drafts.
>
>
>
> ------------------------------
>
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>
>