Subject: [Netconf] WG Last Call for draft-ietf-netconf-restconf-09, draft-ietf-netconf-yang-patch-07 and draft-ietf-netconf-yang-library-03

From: "Ersue, Mehmet (Nokia - DE/Munich)" <[email-masked]>
Date: Tue, 15 Dec 2015 20:58:55 +0000

Dear NETCONF WG,

we hereby issue a WG Last Call for the drafts below:

http://tools.ietf.org/html/draft-ietf-netconf-restconf-09.txt
http://tools.ietf.org/html/draft-ietf-netconf-yang-patch-07.txt
http://tools.ietf.org/html/draft-ietf-netconf-yang-library-03.txt

Please review and send your comments to the NETCONF WG mailing list by January 22, 2015 EOB PT.

The drafts on RESTCONF, YANG patch and YANG library are planned to publish as standard track documents.

As RESTCONF is a major protocol we seek a detailed and thorough review within NETCONF WG but also by the related WGs before publishing.
Therefore the WGLC is planned to finalize on January 22th (covering the holiday time in between) and APP, INT and RTG area ADs will be informed as well as Core, I2RS, 6lo, and 6tisch WGs are invited to review.

Please take your time to review the documents and send your comments to the NETCONF maillist by the deadline.
Please state on NETCONF maillist also explicitly, whether you have read/reviewed and whether you support the publication.
Furthermore please indicate if you plan to implement or have already implementations for RESTCONF and its supplementary drafts.

Thank you for your review and kind help getting RESTCONF specifications stable.

Best Regards,
Mehmet and Mahesh

---

From: Athanasios Kyparlis <[email-masked]>
Date: Wed, 16 Dec 2015 16:28:27 +0000

This is a comment for draft-ietf-netconf-yang-library-03.txt:

The document should outline the relationship to schema subtree and get-schema operation defined in rfc6022.

Is the schema leaf defined in the draft equivalent to the schema 'location' defined in rfc6022? Are the two expected to have the same value?

It should also describe if the two capabilities (yang-library and rfc6022 schema) will be used in parallel or if systems are expected to switch to yang-library over rfc6022 or if there is going to be a prescribed preference [for example, should systems try to use yang-library for YANG and switch to rfc6022 schema only if the former is not present?].

Thanks,
Athanasios Kyparlis

From: i2rs [mailto:[email-masked]] On Behalf Of Ersue, Mehmet (Nokia - DE/Munich)
Sent: Tuesday, December 15, 2015 3:59 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: [i2rs] WG Last Call for draft-ietf-netconf-restconf-09, draft-ietf-netconf-yang-patch-07 and draft-ietf-netconf-yang-library-03

Dear NETCONF WG,

Best Regards,
Mehmet and Mahesh

---

From: Andy Bierman <[email-masked]>
Date: Wed, 16 Dec 2015 08:43:25 -0800

Hi,

The WG decided there was no relationship between the YANG library and the
netconf-state
schema list.

What should this draft say?  There is overlap, but not complete overlap.
The netconf-state list supports any schema language, not just YANG.

The YANG library is used by RESTCONF and YANG 1.1.
It has conformance info that does not exist in the schema list.

A client could use one or the other, or both of these lists.

Andy

On Wed, Dec 16, 2015 at 8:28 AM, Athanasios Kyparlis <
[email-masked]> wrote:

> Is the schema leaf defined in the draft equivalent to the schema
> ‘location’ defined in rfc6022? Are the two expected to have the same value?
>
>
>
> It should also describe if the two capabilities (yang-library and rfc6022
> schema) will be used in parallel or if systems are expected to switch to
> yang-library over rfc6022 or if there is going to be a prescribed
> preference [for example, should systems try to use yang-library for YANG
> and switch to rfc6022 schema only if the former is not present?].
>
>
>
> Thanks,
>
> Athanasios Kyparlis
>
>
>
> *From:* i2rs [mailto:[email-masked]] *On Behalf Of *Ersue, Mehmet
> (Nokia - DE/Munich)
> *Sent:* Tuesday, December 15, 2015 3:59 PM
> *To:* [email-masked]
> *Cc:* [email-masked]; [email-masked]; [email-masked]; [email-masked]
> *Subject:* [i2rs] WG Last Call for draft-ietf-netconf-restconf-09,
> draft-ietf-netconf-yang-patch-07 and draft-ietf-netconf-yang-library-03
>
>
>
> Dear NETCONF WG,
>
>
>
> As RESTCONF is a major protocol we seek a detailed and thorough review
> within NETCONF WG but also by the related WGs before publishing.
>
> Therefore the WGLC is planned to finalize on January 22th (covering the
> holiday time in between) and APP, INT and RTG area ADs will be informed as
> well as Core, I2RS, 6lo, and 6tisch WGs are invited to review.
>
>
>
> Please state on NETCONF maillist also explicitly, whether you have
> read/reviewed and whether you support the publication.
>
> Furthermore please indicate if you plan to implement or have already
> implementations for RESTCONF and its supplementary drafts.
>
>
>
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>
>

---

From: Athanasios Kyparlis <[email-masked]>
Date: Thu, 17 Dec 2015 02:33:39 +0000

Something to the effect of what you mention below should suffice.
Perhaps:
“The RFC6022 netconf-state list supports any schema language, not just YANG.
The YANG library SHOULD be used by RESTCONF and YANG 1.1. It has conformance info that does not exist in the RFC6022 schema list.

A client could use one or the other, or both of these lists, but the use of YANG-library should be preferred for YANG schemas.
In the case where both lists are supported, the information in each list MUST not contradict the other.”

Thanks,
AK

From: Andy Bierman [mailto:[email-masked]]
Sent: Wednesday, December 16, 2015 11:43 AM
To: Athanasios Kyparlis
Cc: [email-masked]
Subject: Re: [Netconf] WG Last Call for draft-ietf-netconf-restconf-09, draft-ietf-netconf-yang-patch-07 and draft-ietf-netconf-yang-library-03

Hi,

The WG decided there was no relationship between the YANG library and the netconf-state
schema list.

Andy

On Wed, Dec 16, 2015 at 8:28 AM, Athanasios Kyparlis <[email-masked]<mailto:[email-masked]>> wrote:
This is a comment for draft-ietf-netconf-yang-library-03.txt:

Is the schema leaf defined in the draft equivalent to the schema ‘location’ defined in rfc6022? Are the two expected to have the same value?

Thanks,
Athanasios Kyparlis

From: i2rs [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Ersue, Mehmet (Nokia - DE/Munich)
Sent: Tuesday, December 15, 2015 3:59 PM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: [i2rs] WG Last Call for draft-ietf-netconf-restconf-09, draft-ietf-netconf-yang-patch-07 and draft-ietf-netconf-yang-library-03

Dear NETCONF WG,

Best Regards,
Mehmet and Mahesh

_______________________________________________
Netconf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netconf

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 17 Dec 2015 08:11:47 +0100

> In the case where both lists are supported, the information in each list MUST not contradict the other.”

I do not think this text is helpful.

YANG 1.1 has several MUST statements referring to YANG library and
hence once an implementation implements YANG 1.1 modules, it will have
to support YANG library. So it would be misleading if we state SHOULD
here and in general it is desirable to avoid circular dependencies.
RESTCONF and YANG 1.1 both depend on YANG library and this is what
these documents say and I think this is sufficient.

In the long run, I expect that YANG library will be used where
functionality overlaps (but as Andy wrote, the overlap is not 1:1).

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>