Subject: [Netconf] A question about subtree filter

From: "fengchong (C)" <[email-masked]>
Date: Wed, 16 Dec 2015 02:54:52 +0000

Hi all,
   I have a question about subtree filter.
   In sec 6.2.5
       If all specified sibling content match nodes in a subtree filter
   expression are "true", then the filter output nodes are selected in
   the following manner:

   o  Each content match node in the sibling set is included in the
      filter output.

   o  If any containment nodes are present in the sibling set, then they
      are processed further and included if any nested filter criteria
      are also met.

   If a containement node is present in the sibling set, and if this containement node
   has a content node as its child. If this child content node is not met, then should this
   containement node be not selected or all the sibling set be not selected?

   For example:
   Data are listed below:
  <top>
         <a>
                   <a1>1</a1>
                   <a2>2</a2>
                   <a3>
                     <a31>1</a31>
                   </a3>
         </a>
         <a>
                   <a1>2</a1>
                   <a2>2</a2>
                   <a3>
                     <a31>2</a31>
                   </a3>
         </a>
</top>

And filter is :
<filter type= "subtree">
         <top>
                   <a>
                            <a1>1</a1>
                            <a2/>
                            <a3>
                                     <a31>2</a31>
                            </a3>
                   </a>
         </top>
</filter>

Then should return:
1.
  <data>
         <top>
                <a>
                   <a1>1</a1>
                   <a2>2</a2>
         </a>
         </top>
  </data>
Or
2.
<data/>

/frank

---

From: Andy Bierman <[email-masked]>
Date: Tue, 15 Dec 2015 19:18:22 -0800

>    containement node be not selected or all the sibling set be not

I think (1) is correct -- the <a31> content-match node filters out its
siblings
and the <a3> node.  It might be OK if an empty <a3 /> node was included.

> /frank
Andy

> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>
>