Subject: Re: [Netconf] LL review of yang-library-03

From: Martin Bjorklund <[email-masked]>
Date: Tue, 02 Feb 2016 12:55:36 +0100 (CET)

Hi,

Going through all comments on YANG library, I found this one, where no
decision has been made.

Andy Bierman <[email-masked]> wrote:
> On Thu, Dec 17, 2015 at 7:47 AM, Ladislav Lhotka <[email-masked]> wrote:
> 
> > Hi,
> >
> > I reviewed the draft and found several issues:

[...]

> >     - The name "conformance" seems to be a misnomer: the leaf gives
> >       information about how the module is used by the server. What
> >       about "role"?
> >
> 
> 
> Role is rather generic. How about conformance-role?

Since the description of this leaf already says:

          "Indicates the type of conformance the server is claiming
           for the YANG module identified by this entry.";

should the name be "conformance-type"?

/martin

---

From: Ladislav Lhotka <[email-masked]>
Date: Tue, 2 Feb 2016 13:07:16 +0100

> On 02 Feb 2016, at 12:55, Martin Bjorklund <[email-masked]> wrote:
> 
> Hi,
> 

I'd prefer conformance-role because "type" already has a diferrent meaning in YANG. Perhaps the description could be updated like this:       

    "Indicates the role in conformance the server is claiming
     for the YANG module identified by this entry.";

Lada

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: Martin Bjorklund <[email-masked]>
Date: Tue, 02 Feb 2016 14:11:16 +0100 (CET)

Ladislav Lhotka <[email-masked]> wrote:
> I'd prefer conformance-role because "type" already has a diferrent
> meaning in YANG.

If we following that logic, we cannot have interface type, no
routing-instance type etc.

To me "conformance role" sounds a bit weird, but maybe someone native
speaker can comment?

/martin

> Perhaps the description could be updated like this:
>

---

From: Ladislav Lhotka <[email-masked]>
Date: Tue, 2 Feb 2016 14:28:53 +0100

> On 02 Feb 2016, at 14:11, Martin Bjorklund <[email-masked]> wrote:
> 

Actually, is the way how the module is used in the data model related to conformance?

Lada