Subject: Re: [Netconf] [i2rs] FW: New Version Notification for draft-hares-i2rs-protocol-strawman-02.txt - 3.1.1

From: "jmh.direct" <[email-masked]>
Date: Tue, 10 May 2016 14:11:41 +0200

If the I2RS aren't is off then the system does not currently support this models.  This is just like any other optional YANG module.  If you are not currently prepared to use it, you don't claim to support it.
Caveat: The NetMod folks may have come up with a more nuanced mechanism.  
Yours,Joel

Sent via the Samsung Galaxy S® 6, an AT&T 4G LTE smartphone-------- Original message --------From: Susan Hares <[email-masked]> Date: 5/10/2016  1:25 PM  (GMT+01:00) To: "'Joel M. Halpern'" <[email-masked]>, 'Andy Bierman' <[email-masked]> Cc: [email-masked], 'Netconf' <[email-masked]> Subject: RE: [i2rs] FW: New Version Notification for draft-hares-i2rs-protocol-strawman-02.txt - 3.1.1 
Joel: 

What happens if the code supports the I2RS agent, but the I2RS agent is configured to be "off"?  Is this covered by the deviations or is this variable configuration? 

Sue 

-----Original Message-----
From: Joel M. Halpern [mailto:[email-masked]] 
Sent: Tuesday, May 10, 2016 1:34 AM
To: Susan Hares; Andy Bierman
Cc: [email-masked]; Netconf
Subject: Re: [i2rs] FW: New Version Notification for draft-hares-i2rs-protocol-strawman-02.txt - 3.1.1

As I understand it, if a model requires ephemeral elements, and the agent does not support ephemeral, then the agent can not claim to support the model.

Yes, deviations allow you to specify this, as Andy says.  But this is specifying a failure to conform.

I would go far as to say that such an agent is not an I2RS agent, but that is a step beyond the NetConf compliance definitions.

Yours,
Joel

On 5/9/16 6:09 PM, Susan Hares wrote:
> Andy and Joel:
>
> These are good points.
>
> What happens if the data model has some ephemeral sections and the 
> I2RS agent is not supported by the routing system.  The data model 
> would specify the ephemeral section, but there would be no support by i2rs.
>  Is the support of the ephemeral not a variable  condition to be 
> indicated in Yang module library?
>
> Sue
> Sent via the Samsung Galaxy Note5, an AT&T 4G LTE smartphone
> -------- Original message --------
> From: Andy Bierman <[email-masked]>
> Date: 5/7/2016 12:53 PM (GMT-05:00)
> To: "Joel M. Halpern" <[email-masked]>
> Cc: [email-masked], Netconf <[email-masked]>, Susan Hares 
> <[email-masked]>
> Subject: Re: [i2rs] FW: New Version Notification for 
> draft-hares-i2rs-protocol-strawman-02.txt - 3.1.1
>
>
>
> On Fri, May 6, 2016 at 8:51 AM, Joel M. Halpern <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Reading the latest revision, in section 3.1.1, the text in bullet 5
>     says that the data model indicates which portions are ephemeral.
>     That makes sense to me.
>
>     Then bullet 6 says that the management protocol needs to signal (in
>     its yang library) which parts are ephemeral.
>
>     Why the second requirement?  If the data model is supported, and the
>     data model states that certain items are ephemeral, what would it
>     mean if the signaling did not also say that.  Conversely, what would
>     it mean if the signaling said something was ephemeral that the model
>     does not define as ephemeral?
>
>     It may be that I am misreading bullet 6.  Please explain.
>
>
>
> I think you are correct that the YANG library does not need any 
> changes to identify ephemeral data.  Only the variable components of 
> YANG conformance are contained in the library.
>
>
>     Thank you,
>     Joel
>
>
>
> Andy
>
>
>     _______________________________________________
>     i2rs mailing list
>     [email-masked] <mailto:[email-masked]>
>     https://www.ietf.org/mailman/listinfo/i2rs
>
>

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 10 May 2016 10:54:28 -0400

Joel: 

See below.   Just trying to wrap up the discussion.

From: jmh.direct [mailto:[email-masked]] 
Sent: Tuesday, May 10, 2016 8:12 AM
To: Susan Hares; 'Joel M. Halpern'; 'Andy Bierman'
Cc: [email-masked]; 'Netconf'
Subject: RE: [i2rs] FW: New Version Notification for draft-hares-i2rs-protocol-strawman-02.txt - 3.1.1

Sue: I assume you desired to say…  if the I2RS is not on, then the system does not support this model.  

Sue: Do we need them to come up with mechanism that indicates I2RS is there but off? 

Yours,

Joel

Sent via the Samsung Galaxy S® 6, an AT&T 4G LTE smartphone

-------- Original message --------

From: Susan Hares <[email-masked]> 

Date: 5/10/2016 1:25 PM (GMT+01:00) 

To: "'Joel M. Halpern'" <[email-masked]>, 'Andy Bierman' <[email-masked]> 

Cc: [email-masked], 'Netconf' <[email-masked]> 

Subject: RE: [i2rs] FW: New Version Notification for draft-hares-i2rs-protocol-strawman-02.txt - 3.1.1 

Joel: 

Sue 

-----Original Message-----
From: Joel M. Halpern [mailto:[email-masked]] 
Sent: Tuesday, May 10, 2016 1:34 AM
To: Susan Hares; Andy Bierman
Cc: [email-masked]; Netconf
Subject: Re: [i2rs] FW: New Version Notification for draft-hares-i2rs-protocol-strawman-02.txt - 3.1.1

Yours,
Joel

On 5/9/16 6:09 PM, Susan Hares wrote:
> On Fri, May 6, 2016 at 8:51 AM, Joel M. Halpern <[email-masked]  <mailto:[email-masked]%20%0b>

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 10 May 2016 11:10:55 -0400

Yes, you interpreted my awful typing correctly.

I don't see any need for anything more, but was allowing that I am not 
fully current on the groups thinking.

Yours,
Joel

On 5/10/16 10:54 AM, Susan Hares wrote:
> *From:*jmh.direct [mailto:[email-masked]]
> *Sent:* Tuesday, May 10, 2016 8:12 AM
> *To:* Susan Hares; 'Joel M. Halpern'; 'Andy Bierman'
> *Cc:* [email-masked]; 'Netconf'
> *Subject:* RE: [i2rs] FW: New Version Notification for
> If the I2RS aren't is off then the system does not currently support
> this models.  This is just like any other optional YANG module.  If you
> are not currently prepared to use it, you don't claim to support it.
>
>
>
> From: Susan Hares <[email-masked] <mailto:[email-masked]>>
>
> To: "'Joel M. Halpern'" <[email-masked]
> <mailto:[email-masked]>>, 'Andy Bierman' <[email-masked]
> <mailto:[email-masked]>>
>
> Cc: [email-masked] <mailto:[email-masked]>, 'Netconf' <[email-masked]
> <mailto:[email-masked]>>
>
> Subject: RE: [i2rs] FW: New Version Notification for
> What happens if the code supports the I2RS agent, but the I2RS agent is
> configured to be "off"?  Is this covered by the deviations or is this
> variable configuration?
>
> Sue
>
> Cc: [email-masked] <mailto:[email-masked]>; Netconf
> As I understand it, if a model requires ephemeral elements, and the
> agent does not support ephemeral, then the agent can not claim to
> support the model.
>
> I would go far as to say that such an agent is not an I2RS agent, but
> that is a step beyond the NetConf compliance definitions.
>
> Yours,
> Joel
>
>> From: Andy Bierman <[email-masked] <mailto:[email-masked]>>
>> To: "Joel M. Halpern" <[email-masked] <mailto:[email-masked]>>
>> Cc: [email-masked] <mailto:[email-masked]>, Netconf <[email-masked]
> <mailto:[email-masked]>>, Susan Hares
>> <[email-masked] <mailto:[email-masked]>>
> <mailto:[email-masked]%20%0b>> <mailto:[email-masked]>> wrote:
>>
>>     [email-masked] <mailto:[email-masked]> <mailto:[email-masked]>