Subject: [Netconf] zerotouch/14: Removable storage details?

From: Kent Watsen <[email-masked]>
Date: Wed, 11 May 2016 23:41:13 +0000

https://github.com/netconf-wg/zero-touch/issues/14

The current draft says: "Details such as the format of file system and the naming of the files are left to the device's manufacturer to define",  but an on-list review recommends that the draft be more normative about this.

The above is essentially slide #12 from the IETF 95 presentation.  The minutes then capture the following dialog:

  - JH: storage formats have changed immensely over the years.  Fixing them in the model will likely just make the model obselete quickly . Maybe a registry ?
  - KW: What would be the motivation?
  - MCR: Not that we define them, we should just refer to them.
  - RT: what are we trying to achieve here ?  Just basic booting ?  or more ?

I think that there was/is a fundamental misunderstanding.  We're not here discussing the format of the filesystem for the device itself, that is completely out of scope.  Instead, we're just discussing the format of the filesystem for the removable storage device (e.g., a USB flash drive), and/or the names of the files that the device might look for on the storage device.

My view is that we should let each vendor decide for themselves.  If they want to support ext3, msdos, ntfs, hff+, or whatever - it's up to them to decide. Further, they should be allowed to define the file names and formats as well.   My thought its that there is little need to plug a specific removable storage device instance into more than one device, thus the multi-vendor aspect of this it not very strong, and so we should declare it as out-of-scope.

Thoughts?

Kent

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 12 May 2016 07:55:21 +0200

> My view is that we should let each vendor decide for themselves.  If they want to support ext3, msdos, ntfs, hff+, or whatever - it's up to them to decide. Further, they should be allowed to define…

I think it is useful to have a format that is readable and writable by
'regular' computers; if vendors start to produce storage sticks that
can't be read or copied using 'regular' computers, I would be somewhat
unhappy. That said, I am not sure a standard can really prevent this
from happening but giving some advice that using open formats is a
good thing may be useful. (An open format may allow me to create
combined boot sticks that can boot more than a single device type.)

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>