Subject: [Netconf] Open issues in draft-gonzalez-netconf-event-notifications-00

From: "Alberto Gonzalez Prieto (albertgo)" <[email-masked]>
Date: Tue, 28 Jun 2016 15:42:35 +0000

Hello,

draft-gonzalez-netconf-event-notifications-00 is one of the four drafts in the set "Event Notification + Yang-push "
Its scope is transporting Event Notifications over NETCONF.
The open issues we are currently focusing on are:
- configured subscriptions:
- How to realized configured subscription?
- The current line of work is based on call-home.
- Once a subscription is configured, the server would contact the receiver using call home. Once the NETCONF session is established, the server would send a <subscription-started>.
- From that point on, the server sends notifications to the receiver as per the subscription configuration.
- As for dynamic subscriptions, such a session could be used for multiple subscriptions. This would be controlled by the server
- Once the subscription is deleted, the server would send a <subscription-terminated> and drop the session.
- <create-subscription> and multiple subscriptions on a session
- Should multiple create-subscription's over a single NETCONF session be supported?
- The current thinking is to support multiple subscriptions over a single session only for establish-subscription's
- The rationale being to simplify implementations

If you have questions/input on these open issues or other aspects of the draft, we will be happy to discuss them.

Alberto Gonzalez
(on behalf of the draft authors and the NETCONF WG members attending the weekly calls)

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Tue, 28 Jun 2016 16:34:00 +0000

To help interpret the meaning of some of the open issues below, the subteam is evolving a terminology page at:
https://github.com/netconf-wg/yang-push/wiki/Terminology

Eric

From: Alberto Gonzalez Prieto, June 28, 2016 11:43 AM

Hello,

draft-gonzalez-netconf-event-notifications-00 is one
of the four drafts in the set "Event Notification + Yang-push "
Its scope is transporting Event Notifications over NETCONF.
The open issues we are currently focusing on are:
- configured subscriptions:
- How to realized configured subscription?
- The current line of work is based on call-home.
- Once a subscription is configured, the server would contact the receiver using call home. Once the NETCONF
session is established, the server would send a <subscription-started>.
- From that point on, the server sends notifications to the receiver as per the subscription configuration.
- As for dynamic subscriptions, such a session could be used for multiple subscriptions. This would be controlled
by the server
- Once the subscription is deleted, the server would send a <subscription-terminated>
and drop the session.
- <create-subscription> and multiple subscriptions on a session
- Should multiple create-subscription's over a single NETCONF session be supported?
- The current thinking is to support multiple subscriptions over a single session only for establish-subscription's
- The rationale being to simplify implementations

Alberto Gonzalez