Subject: Re: [Netconf] AUTH48 [DF][RV]: RFC 7895 <draft-ietf-netconf-yang-library-06.txt> NOW AVAILABLE

From: Mahesh Jethanandani <[email-masked]>
Date: Wed, 8 Jun 2016 18:20:15 -0700

The authors of draft-ietf-netconf-yang-library are making one more change to the module. See details below.

This begins a 1 week poll to address any concerns folks might have with this change. This is not a chance to review the whole document.

Thanks.

> On Jun 8, 2016, at 5:00 PM, Andy Bierman <[email-masked]> wrote:
> 
> Hi,
> 
> We decided to remove the submodules container:
> 
> 
> 1) YANG module: 
>    1.1) update revision date (also <CODE BEGINS> date
>    1.2) remove container submodules from grouping
> 
>      OLD:
> 
>       container submodules {
>         description
>           "Contains information about all the submodules used
>            by the parent module entry";
> 
>         list submodule {
>           key "name revision";
>           description
>             "Each entry represents one submodule within the
>              parent module.";
>           uses common-leafs;
>           uses schema-leaf;
>         }
>       }
> 
>       NEW:
> 
>       list submodule {
>         key "name revision";
>         description
>           "Each entry represents one submodule within the
>            parent module.";
>         uses common-leafs;
>         uses schema-leaf;
>       }
> 
>  2) YANG tree diagram
>      2.1 remove submodules
>      2.2 Should the notification be listed? If not, remove from NEW:
> 
> OLD:
> 
> 
>    +--ro modules-state
>       +--ro module-set-id    string
>       +--ro module* [name revision]
>          +--ro name                   yang:yang-identifier
>          +--ro revision               union
>          +--ro schema?                inet:uri
>          +--ro namespace              inet:uri
>          +--ro feature*               yang:yang-identifier
>          +--ro deviation* [name revision]
>          |  +--ro name        yang:yang-identifier
>          |  +--ro revision    union
>          +--ro conformance-type       enumeration
>          +--ro submodules
>             +--ro submodule* [name revision]
>                +--ro name        yang:yang-identifier
>                +--ro revision    union
>                +--ro schema?     inet:uri
> 
> NEW:
> 
>    +--ro modules-state
>       +--ro module-set-id    string
>       +--ro module* [name revision]
>          +--ro name                yang:yang-identifier
>          +--ro revision            union
>          +--ro schema?             inet:uri
>          +--ro namespace           inet:uri
>          +--ro feature*            yang:yang-identifier
>          +--ro deviation* [name revision]
>          |  +--ro name        yang:yang-identifier
>          |  +--ro revision    union
>          +--ro conformance-type    enumeration
>          +--ro submodule* [name revision]
>             +--ro name        yang:yang-identifier
>             +--ro revision    union
>             +--ro schema?     inet:uri
> notifications:
>    +---n yang-library-change
>       +--ro module-set-id    -> /modules-state/module-set-id
> 
> 
> Andy

Mahesh Jethanandani
[email-masked]

---

From: Andy Bierman <[email-masked]>
Date: Sat, 11 Jun 2016 11:27:04 -0700

Hi,

I noticed that the YANG library example in RESTCONF-13 does not
have the 'submodules' container

https://tools.ietf.org/html/draft-ietf-netconf-restconf-13#appendix-D.1.2

I think this was a missed edit in the ietf-yang-library module

Andy

On Wed, Jun 8, 2016 at 6:20 PM, Mahesh Jethanandani <[email-masked]
> wrote:

> This begins a 1 week poll to address any concerns folks might have with
> this change. This is not a chance to review the whole document.
>
> Thanks.
>

---

From: Mahesh Jethanandani <[email-masked]>
Date: Tue, 14 Jun 2016 17:14:28 -0700

This concludes the poll for the changes proposed by the authors.

The RFC Editors will go ahead and make the suggested changes.

Thanks.

> On Jun 8, 2016, at 6:20 PM, Mahesh Jethanandani <[email-masked]> wrote:
> 
>> On Jun 8, 2016, at 5:00 PM, Andy Bierman <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Hi,
>> 
> [email-masked] <mailto:[email-masked]>
> 
> 
> 
> 
> 

Mahesh Jethanandani
[email-masked]