Subject: [Netconf] Open issues in draft-gonzalez-netconf-event-notifications-00

From: "Ambika Prasad Tripathy (ambtripa)" <[email-masked]>
Date: Tue, 28 Jun 2016 17:22:27 +0000

Hi,

For Event Notification and YANG-PUSH drafts, on of the transport requirements is NetConf.
One of the open issue, I am currently focussing is the Subscription Priority and QoS over NetConf Transport

  *   We are enabling to create multiple create-subscription over a single netconf session.
  *   All subscription may not be of same priority. Say, out of multiple subscription request placed in a session, security related subscription may be of greater priority than counters.
  *   At publisher, there may be multiple session with multiple subscription.
  *   There should be a way to differentiate between subscription priority across the sessions at publisher and inside a session at subscriber.
  *   The Publisher should address high priority subscriptions across all the session before handling low priority subscription.
  *   What should be the right way to handle priority of subscriptions?

If you have questions/input on these open issues or other aspects of the draft, we will be happy to discuss them.

-
Br,
Ambika Prasad Tripathy
(on behalf of the draft authors and the NETCONF WG members attending the weekly calls)

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Tue, 28 Jun 2016 18:14:05 +0000

Hi Ambika,

I see this question broken in two:

(1) For NETCONF transport dequeuing, is there an issue with head-of-line blocking where we should pre-empt a lower priority update in favor of a higher priority one?  And if yes, is this an issue which is generic to NETCONF transport as a whole rather than being specific to subscriptions?

(2) Subscription priority has been defined as an augmentation in YANG-Push<https://datatracker.ietf.org/doc/draft-ietf-netconf-yang-push/?include_text=1>.  Priority is not available in the base RFC5277bis<https://datatracker.ietf.org/doc/draft-gonzalez-netconf-5277bis/?include_text=1> spec.  Independent of transport (e.g., NETCONF, Restconf, HTTP), is there anyone on this alias who has a requirement for subscription priority for generic event notifications?

Eric

From: Ambika Prasad Tripathy, June 28, 2016 1:22 PM

Hi,

-
Br,
Ambika Prasad Tripathy